source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 12549

Revision 12549, 13.0 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

ca-certificates-2021.2.46-1

tzdata-2021a-1

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2021a
5%define tzdata_version 2021a
6%define tzcode_version 2021a
7Release: 1%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: Public Domain
13URL: https://www.iana.org/time-zones
14# These are official upstream.
15Source0: https://data.iana.org/time-zones/releases/tzdata%{tzdata_version}.tar.gz
16Source1: https://data.iana.org/time-zones/releases/tzcode%{tzcode_version}.tar.gz
17Source2: javazic.tar.gz
18Source3: javazic-1.8-37392f2f5d59.tar.xz
19
20Patch002: 0002-Fix-have-snprintf-error.patch
21
22Patch100: javazic-fixup.patch
23Patch101: rebase-01.patch
24Patch102: rebase-02.patch
25Patch103: 7090844.patch
26Patch104: 7133138.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildArch: noarch
30BuildRequires: gawk, glibc, perl
31BuildRequires: java-1.8.0-openjdk-devel
32BuildRequires: glibc-common >= 2.5.90-7
33Conflicts: glibc-common <= 2.3.2-63
34
35%description
36This package contains data files with rules for various timezones around
37the world.
38
39%description -l ja
40このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
41
42
43%package java
44Summary: Timezone data for Java
45Group: system
46
47%description java
48This package contains timezone information for use by Java runtimes.
49
50
51%prep
52%setup -q -c -a 1
53
54%patch002 -p1
55
56# tzdata-2018g introduce 25:00 transition times.  This breaks OpenJDK.
57# Use rearguard for tzdata-2018g java
58mkdir rearguard
59make VERSION=%{version} tzdata%{version}-rearguard.tar.gz
60mv tzdata%{version}-rearguard.tar.gz rearguard
61pushd rearguard
62tar zxf tzdata%{version}-rearguard.tar.gz
63popd
64
65mkdir javazic
66tar zxf %{SOURCE2} -C javazic
67pushd javazic
68%patch100
69%patch101
70%patch102
71%patch103
72%patch104
73
74# Hack alert! sun.tools may be defined and installed in the
75# VM. In order to guarantee that we are using IcedTea/OpenJDK
76# for creating the zoneinfo files, rebase all the packages
77# from "sun." to "rht.". Unfortunately, gcj does not support
78# any of the -Xclasspath options, so we must go this route
79# to ensure the greatest compatibility.
80mv sun rht
81find . -type f -name '*.java' -print0 \
82    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
83                         -e 's:sun\.util\.:rht.util.:g'
84popd
85
86tar xf %{SOURCE3}
87
88echo "%{name}%{tzdata_version}" >> VERSION
89
90
91%build
92# Run make to create the tzdata.zi file
93rm tzdata.zi
94make tzdata.zi
95
96FILES="africa antarctica asia australasia europe northamerica southamerica
97       etcetera backward factory"
98
99mkdir zoneinfo/{,posix,right}
100zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
101zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
102zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
103
104# tzdata-2018g uses 25:00 which breaks java - use the rearguard files for java
105JAVA_FILES="rearguard/africa rearguard/antarctica rearguard/asia \
106      rearguard/australasia rearguard/europe rearguard/northamerica \
107      rearguard/southamerica rearguard/pacificnew rearguard/etcetera \
108      rearguard/backward"
109
110# Java 6/7 tzdata
111pushd javazic
112javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
113popd
114
115java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
116  -d javazi \
117  $JAVA_FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
118
119# Java 8 tzdata
120pushd javazic-1.8
121javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
122popd
123
124java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
125    -srcdir . -dstfile tzdb.dat \
126    -verbose \
127    $JAVA_FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
128
129
130%install
131rm -fr $RPM_BUILD_ROOT
132install -d $RPM_BUILD_ROOT%{_datadir}
133cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
134install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
135cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
136mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
137install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
138
139%clean
140rm -fr $RPM_BUILD_ROOT
141
142%files
143%defattr(-,root,root)
144%{_datadir}/zoneinfo
145%license LICENSE
146%doc README
147%doc theory.html
148%doc tz-link.html
149%doc tz-art.html
150
151%files java
152%defattr(-,root,root)
153%{_datadir}/javazi
154%{_datadir}/javazi-1.8
155
156%changelog
157* Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2021a-1
158- updated to 2021a.
159
160* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2019c-1
161- updated to 2019c.
162
163* Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2018i-1
164- updated to 2018i.
165
166* Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
167- update to 2017b
168
169* Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
170- updated to 2016j.
171
172* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
173- fixed changelog.
174- added Vendor and Distribution tag.
175
176* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
177- updated to 2016f.
178
179* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
180- updated to 2016e.
181- enabled java18 stuff.
182
183* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
184- updated to 2016d.
185
186* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
187- updated to 2015f.
188
189* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
190- updated to 2015e.
191
192* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
193- update to tzdata-2012c, tzcode-2012b
194
195* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
196- rebuilt with rpm-4.8.1-3
197
198* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
199- update to tzdata-2010l, tzcode-2010l
200- added java subpackage
201
202* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
203- update to tzdata-2009d, tzcode-2009d
204- spec in utf-8
205
206* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
207- update to tzdata-2008b, tzcode-2008a
208
209* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
210- initial build for VineSeed
211
212* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
213- Upstream 2007d
214  - Mongolia has abolished DST.
215  - Turkey will use EU rules this year, changing at 01:00 UTC rather
216    than 01:00 standard time.
217  - Cuba observed DST starting Sunday.
218  - Resolute, Nunavut switched from Central to Eastern time last
219    November.
220
221* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
222- Upstream 2007c
223  - Pulaski County, Indiana, switched back to eastern time.
224  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
225- Upstream 2007b
226  - Changes to the commentary in "leapseconds".
227- Upstream 2007a
228  - Updates to Bahamas, they will be in sync with 2007 US DST change
229  - New zone Australia/Eucla
230  - Africa/Asmera renamed to Africa/Asmara, link created
231  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
232
233* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
234- Upstream 2006p
235  - Covers changes from 2006m-2 and 2006m-3
236  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
237
238* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
239- Patch for Western Australia DST trial
240
241* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
242- Proposed upstream patch (#210058)
243  - Jordan will switch to winter time on October 27, not September 29
244  - Brazil's DST this year is the first Sunday in November to the last
245    Sunday in February.  (Thanks to Frederico A. C. Neves.)
246  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
247  - Commentary and past timestamps changes
248
249* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
250- Upstream 2006m:
251  - Adjustments for Egypt, Palestine, Uruguay
252  - Better description of `until' field in zic (8) manpage
253
254* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
255- Upstream 2006k, 2006l:
256  - Adjustments for Egypt, Palestine, Cuba, Honduras
257  - Documentation changes
258
259* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
260- Upstream 2006j
261  - Honduras stopped observing DST on Monday at 00:00
262  - America/Bermuda will follow the US's lead next year
263  - America/Moncton will use US-style rules next year
264  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
265    year
266  - New zone: America/Atikokan instead of America/Coral_Harbour
267  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
268  - Historical changes
269  - Commentary updates
270- Upstream 2006i
271  - localtime.c fixes
272- Upstream 2006h
273  - zic leapsecond fix
274
275* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
276- rebuild
277
278* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
279- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
280- Nicaragua updates
281
282* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
283- Upstream 2006f
284  - America/Guatemala observes DST between Apr/30 and Oct/1
285  - Historical changes for Nicaragua
286  - Update of America/Indiana/Vincennes in zone table
287
288* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
289- Upstream 2006d
290  - Haiti observes DST
291  - Sri Lanka change actually took effect Apr/15
292  - All Canada is now scheduled for 2007 US DST rules
293  - Some historical fixes
294
295* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
296- Upstream 2006c
297  - Time-related changes:
298    - dozens of historical and commentary changes
299    - Iran stopped observing DST
300    - Sri Lanka switches from UTC+6 to UTC+5:30
301    - America/Thule and America/Edmonton will adopt new US rules,
302      starting 2007
303    - Tunisia is adopting regular DST
304  - Code:
305    - asctime.c: Chages in format strings to silent gcc warnings
306    - removing K&R notation from function signatures
307    - few fixes across the code
308
309* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
310- Patch for Sri Lanka time zone change (#184514)
311
312* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
313- Upstream 2006b:
314  - using tz64code version, as 32 is legacy according to tzdata ML
315  - new manual pages for ctime, strftime, tzset
316  - some source code reorganizations
317  - no timezone/dst rule updates
318
319* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
320- Small changes in tst-timezone.c
321
322* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
323- Upstream 2006a:
324  - private.h(scheck): changing char* to char const*
325  - Rule changes for Palestine, zone changes for Indiana/US, both
326    changes for Canada.
327  - Many related doc changes.
328- Naming scheme in spec file doesn't use %%{name}, but tzdata.
329
330* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
331- 2005r-3
332  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
333    so that it won't clash across updates.
334
335* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
336- 2005r
337  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
338    northamerica to guard against old files with obsolete information
339    being left in the time zone binary directory.
340  - Changes for countries that are supposed to join 2007 US DST
341    change.  This includes most of Canada, however entries already in
342    the database (Alberta, British Columbia, Newfoundland, Northwest
343    Territories, and Yukon) were left alone for the time being.
344  - Fixes in zdump.c (abbrok): conditions are chained, and the string
345    is checked for emptiness.
346
347* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
348- 2005q
349  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
350  - SystemV timezone changes
351
352* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
353- 2005n
354  - changes for Kyrgyzstan and Uruguay
355- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
356  make check), update tst-timezone.c from glibc CVS (#172102)
357
358* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
359- 2005m
360  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
361    Australia, Kazakhstan
362  - historical timezone data changes for Japan, Poland, Northern Ireland and
363    Mali
364  - timezone name change for East Timor
365
366* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
367- 2005k
368  - leap seconds update
369
370* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
371- 2005i
372  - updates for Iran, Haiti and Nicaragua
373
374* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
375- 2005h
376  - fixes for Kazakhstan
377
378* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
379- 2005g
380  - fixes for Uruguay
381- include README and Theory from tzcode tarball in %{_docdir};
382  Theory includes a good summary of how the timezone data files
383  are supposed to be named
384
385* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
386- 2005f
387  - more updates for Israel, updates for Azerbaijan
388
389* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
390- 2005c
391  - updates for Israel and Paraguay
392
393* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
394- 2004g (#141107)
395  - updates for Cuba
396
397* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
398- 2004e (#135194)
399  - updates for Brazil, Uruguay and Argentina
400
401* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
402- 2004b
403
404* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
405- 2003d
406
407* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
408- 2003c
409- updates for Brazil (#104840)
410
411* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
412- rebuilt
413
414* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
415- initial package
Note: See TracBrowser for help on using the repository browser.