source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 6402

Revision 6402, 11.1 KB checked in by daisuke, 12 years ago (diff)

update to tzdata-2012c/tzcode-2012b

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2012c
5%define tzdata_version 2012c
6%define tzcode_version 2012b
7Release: 1%{?_dist_release}
8
9License: Public Domain
10Group: System Environment/Base
11URL: ftp://elsie.nci.nih.gov/pub/
12
13# The tzdata-base-0.tar.bz2 is a simple building infrastructure and
14# a test suite.  It is occasionally updated from glibc sources, and as
15# such is under LGPLv2+, but none of this ever gets to be part of
16# final zoneinfo files.
17Source0: tzdata-base-0.tar.bz2
18# These are official upstream.
19Source1: ftp://munnari.oz.au/pub/tzdata%{tzdata_version}.tar.gz
20Source2: ftp://munnari.oz.au/pub/tzcode%{tzcode_version}.tar.gz
21Source3: javazic.tar.gz
22
23Patch100: javazic-fixup.patch
24Patch101: javazic-exclusion-fix.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildArch: noarch
28BuildRequires: gawk, glibc, perl
29BuildRequires: java-devel
30BuildRequires: glibc-common >= 2.5.90-7
31Conflicts: glibc-common <= 2.3.2-63
32
33
34%description
35This package contains data files with rules for various timezones around
36the world.
37
38%description -l ja
39このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
40
41%package java
42Summary: Timezone data for Java
43Group: System Environment/Base
44
45%description java
46This package contains timezone information for use by Java runtimes.
47
48
49%prep
50%setup -n tzdata
51mkdir tzdata%{tzdata_version}
52tar xzf %{SOURCE1} -C tzdata%{tzdata_version}
53mkdir tzcode%{tzcode_version}
54tar xzf %{SOURCE2} -C tzcode%{tzcode_version}
55sed -e 's|@objpfx@|'`pwd`'/obj/|' \
56    -e 's|@datadir@|%{_datadir}|' \
57  Makeconfig.in > Makeconfig
58
59mkdir javazic
60tar zxf %{SOURCE3} -C javazic
61pushd javazic
62%patch100
63%patch101
64
65# Hack alert! sun.tools may be defined and installed in the
66# VM. In order to guarantee that we are using IcedTea/OpenJDK
67# for creating the zoneinfo files, rebase all the packages
68# from "sun." to "rht.". Unfortunately, gcj does not support
69# any of the -Xclasspath options, so we must go this route
70# to ensure the greatest compatibility.
71mv sun rht
72find . -type f -name '*.java' -print0 \
73    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
74                         -e 's:sun\.util\.:rht.util.:g'
75popd
76
77
78%build
79make
80grep -v tz-art.htm tzcode%{tzcode_version}/tz-link.htm > tzcode%{tzcode_version}/tz-link.html
81
82pushd javazic
83javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
84popd
85pushd tzdata%{tzdata_version}
86java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
87  -d ../zoneinfo/java \
88  africa antarctica asia australasia europe northamerica pacificnew \
89  southamerica backward etcetera solar87 solar88 solar89 systemv \
90  ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
91popd
92
93
94%install
95rm -fr $RPM_BUILD_ROOT
96sed -i 's|@install_root@|%{buildroot}|' Makeconfig
97make install
98
99cp -pr zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
100
101%check
102echo ====================TESTING=========================
103make check
104echo ====================TESTING END=====================
105
106
107%clean
108rm -fr $RPM_BUILD_ROOT
109
110
111%files
112%defattr(-,root,root)
113%{_datadir}/zoneinfo
114%doc tzcode%{tzcode_version}/README
115%doc tzcode%{tzcode_version}/Theory
116%doc tzcode%{tzcode_version}/tz-link.html
117
118%files java
119%defattr(-,root,root)
120%{_datadir}/javazi
121
122%changelog
123* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
124- update to tzdata-2012c, tzcode-2012b
125
126* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
127- rebuilt with rpm-4.8.1-3
128
129* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
130- update to tzdata-2010l, tzcode-2010l
131- added java subpackage
132
133* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
134- update to tzdata-2009d, tzcode-2009d
135- spec in utf-8
136
137* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
138- update to tzdata-2008b, tzcode-2008a
139
140* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
141- initial build for VineSeed
142
143* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
144- Upstream 2007d
145  - Mongolia has abolished DST.
146  - Turkey will use EU rules this year, changing at 01:00 UTC rather
147    than 01:00 standard time.
148  - Cuba observed DST starting Sunday.
149  - Resolute, Nunavut switched from Central to Eastern time last
150    November.
151
152* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
153- Upstream 2007c
154  - Pulaski County, Indiana, switched back to eastern time.
155  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
156- Upstream 2007b
157  - Changes to the commentary in "leapseconds".
158- Upstream 2007a
159  - Updates to Bahamas, they will be in sync with 2007 US DST change
160  - New zone Australia/Eucla
161  - Africa/Asmera renamed to Africa/Asmara, link created
162  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
163
164* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
165- Upstream 2006p
166  - Covers changes from 2006m-2 and 2006m-3
167  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
168
169* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
170- Patch for Western Australia DST trial
171
172* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
173- Proposed upstream patch (#210058)
174  - Jordan will switch to winter time on October 27, not September 29
175  - Brazil's DST this year is the first Sunday in November to the last
176    Sunday in February.  (Thanks to Frederico A. C. Neves.)
177  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
178  - Commentary and past timestamps changes
179
180* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
181- Upstream 2006m:
182  - Adjustments for Egypt, Palestine, Uruguay
183  - Better description of `until' field in zic (8) manpage
184
185* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
186- Upstream 2006k, 2006l:
187  - Adjustments for Egypt, Palestine, Cuba, Honduras
188  - Documentation changes
189
190* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
191- Upstream 2006j
192  - Honduras stopped observing DST on Monday at 00:00
193  - America/Bermuda will follow the US's lead next year
194  - America/Moncton will use US-style rules next year
195  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
196    year
197  - New zone: America/Atikokan instead of America/Coral_Harbour
198  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
199  - Historical changes
200  - Commentary updates
201- Upstream 2006i
202  - localtime.c fixes
203- Upstream 2006h
204  - zic leapsecond fix
205
206* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
207- rebuild
208
209* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
210- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
211- Nicaragua updates
212
213* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
214- Upstream 2006f
215  - America/Guatemala observes DST between Apr/30 and Oct/1
216  - Historical changes for Nicaragua
217  - Update of America/Indiana/Vincennes in zone table
218
219* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
220- Upstream 2006d
221  - Haiti observes DST
222  - Sri Lanka change actually took effect Apr/15
223  - All Canada is now scheduled for 2007 US DST rules
224  - Some historical fixes
225
226* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
227- Upstream 2006c
228  - Time-related changes:
229    - dozens of historical and commentary changes
230    - Iran stopped observing DST
231    - Sri Lanka switches from UTC+6 to UTC+5:30
232    - America/Thule and America/Edmonton will adopt new US rules,
233      starting 2007
234    - Tunisia is adopting regular DST
235  - Code:
236    - asctime.c: Chages in format strings to silent gcc warnings
237    - removing K&R notation from function signatures
238    - few fixes across the code
239
240* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
241- Patch for Sri Lanka time zone change (#184514)
242
243* Thu Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
244- Upstream 2006b:
245  - using tz64code version, as 32 is legacy according to tzdata ML
246  - new manual pages for ctime, strftime, tzset
247  - some source code reorganizations
248  - no timezone/dst rule updates
249
250* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
251- Small changes in tst-timezone.c
252
253* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
254- Upstream 2006a:
255  - private.h(scheck): changing char* to char const*
256  - Rule changes for Palestine, zone changes for Indiana/US, both
257    changes for Canada.
258  - Many related doc changes.
259- Naming scheme in spec file doesn't use %%{name}, but tzdata.
260
261* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
262- 2005r-3
263  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
264    so that it won't clash across updates.
265
266* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
267- 2005r
268  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
269    northamerica to guard against old files with obsolete information
270    being left in the time zone binary directory.
271  - Changes for countries that are supposed to join 2007 US DST
272    change.  This includes most of Canada, however entries already in
273    the database (Alberta, British Columbia, Newfoundland, Northwest
274    Territories, and Yukon) were left alone for the time being.
275  - Fixes in zdump.c (abbrok): conditions are chained, and the string
276    is checked for emptiness.
277
278* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
279- 2005q
280  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
281  - SystemV timezone changes
282
283* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
284- 2005n
285  - changes for Kyrgyzstan and Uruguay
286- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
287  make check), update tst-timezone.c from glibc CVS (#172102)
288
289* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
290- 2005m
291  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
292    Australia, Kazakhstan
293  - historical timezone data changes for Japan, Poland, Northern Ireland and
294    Mali
295  - timezone name change for East Timor
296
297* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
298- 2005k
299  - leap seconds update
300
301* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
302- 2005i
303  - updates for Iran, Haiti and Nicaragua
304
305* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
306- 2005h
307  - fixes for Kazakhstan
308
309* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
310- 2005g
311  - fixes for Uruguay
312- include README and Theory from tzcode tarball in %{_docdir};
313  Theory includes a good summary of how the timezone data files
314  are supposed to be named
315
316* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
317- 2005f
318  - more updates for Israel, updates for Azerbaijan
319
320* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
321- 2005c
322  - updates for Israel and Paraguay
323
324* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
325- 2004g (#141107)
326  - updates for Cuba
327
328* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
329- 2004e (#135194)
330  - updates for Brazil, Uruguay and Argentina
331
332* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
333- 2004b
334
335* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
336- 2003d
337
338* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
339- 2003c
340- updates for Brazil (#104840)
341
342* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
343- rebuilt
344
345* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
346- initial package
Note: See TracBrowser for help on using the repository browser.