source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 1759

Revision 1759, 10.8 KB checked in by inagaki, 14 years ago (diff)

update: tzdata
new: java-1.6.0-openjdk

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2010l
5%define tzdata_version 2010l
6%define tzcode_version 2010l
7Release: 1%{?_dist_release}
8
9License: Public Domain
10Group: System Environment/Base
11URL: ftp://elsie.nci.nih.gov/pub/
12
13# The tzdata-base-0.tar.bz2 is a simple building infrastructure and
14# a test suite.  It is occasionally updated from glibc sources, and as
15# such is under LGPLv2+, but none of this ever gets to be part of
16# final zoneinfo files.
17Source0: tzdata-base-0.tar.bz2
18# These are official upstream.
19Source1: ftp://elsie.nci.nih.gov/pub/tzdata%{tzdata_version}.tar.gz
20Source2: ftp://elsie.nci.nih.gov/pub/tzcode%{tzcode_version}.tar.gz
21Source3: javazic.tar.gz
22
23Patch0: javazic-fixup.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildArch: noarch
27BuildRequires: gawk, glibc, perl
28BuildRequires: java-devel
29BuildRequires: glibc-common >= 2.5.90-7
30Conflicts: glibc-common <= 2.3.2-63
31
32
33%description
34This package contains data files with rules for various timezones around
35the world.
36
37%description -l ja
38このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
39
40%package java
41Summary: Timezone data for Java
42Group: System Environment/Base
43
44%description java
45This package contains timezone information for use by Java runtimes.
46
47
48%prep
49%setup -n tzdata
50mkdir tzdata%{tzdata_version}
51tar xzf %{SOURCE1} -C tzdata%{tzdata_version}
52mkdir tzcode%{tzcode_version}
53tar xzf %{SOURCE2} -C tzcode%{tzcode_version}
54sed -e 's|@objpfx@|'`pwd`'/obj/|' \
55    -e 's|@datadir@|%{_datadir}|' \
56  Makeconfig.in > Makeconfig
57
58mkdir javazic
59tar zxf %{SOURCE3} -C javazic
60pushd javazic
61%patch0
62
63# Hack alert! sun.tools may be defined and installed in the
64# VM. In order to guarantee that we are using IcedTea/OpenJDK
65# for creating the zoneinfo files, rebase all the packages
66# from "sun." to "rht.". Unfortunately, gcj does not support
67# any of the -Xclasspath options, so we must go this route
68# to ensure the greatest compatibility.
69mv sun rht
70find . -type f -name '*.java' -print0 \
71    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
72                         -e 's:sun\.util\.:rht.util.:g'
73popd
74
75
76%build
77make
78grep -v tz-art.htm tzcode%{tzcode_version}/tz-link.htm > tzcode%{tzcode_version}/tz-link.html
79
80pushd javazic
81javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
82popd
83pushd tzdata%{tzdata_version}
84java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
85  -d ../zoneinfo/java \
86  africa antarctica asia australasia europe northamerica pacificnew \
87  southamerica backward etcetera solar87 solar88 solar89 systemv \
88  ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
89popd
90
91
92%install
93rm -fr $RPM_BUILD_ROOT
94sed -i 's|@install_root@|%{buildroot}|' Makeconfig
95make install
96
97cp -pr zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
98
99%check
100echo ====================TESTING=========================
101make check
102echo ====================TESTING END=====================
103
104
105%clean
106rm -fr $RPM_BUILD_ROOT
107
108
109%files
110%defattr(-,root,root)
111%{_datadir}/zoneinfo
112%doc tzcode%{tzcode_version}/README
113%doc tzcode%{tzcode_version}/Theory
114%doc tzcode%{tzcode_version}/tz-link.html
115
116%files java
117%defattr(-,root,root)
118%{_datadir}/javazi
119
120%changelog
121* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
122- update to tzdata-2010l, tzcode-2010l
123- added java subpackage
124
125* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
126- update to tzdata-2009d, tzcode-2009d
127- spec in utf-8
128
129* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
130- update to tzdata-2008b, tzcode-2008a
131
132* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
133- initial build for VineSeed
134
135* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
136- Upstream 2007d
137  - Mongolia has abolished DST.
138  - Turkey will use EU rules this year, changing at 01:00 UTC rather
139    than 01:00 standard time.
140  - Cuba observed DST starting Sunday.
141  - Resolute, Nunavut switched from Central to Eastern time last
142    November.
143
144* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
145- Upstream 2007c
146  - Pulaski County, Indiana, switched back to eastern time.
147  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
148- Upstream 2007b
149  - Changes to the commentary in "leapseconds".
150- Upstream 2007a
151  - Updates to Bahamas, they will be in sync with 2007 US DST change
152  - New zone Australia/Eucla
153  - Africa/Asmera renamed to Africa/Asmara, link created
154  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
155
156* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
157- Upstream 2006p
158  - Covers changes from 2006m-2 and 2006m-3
159  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
160
161* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
162- Patch for Western Australia DST trial
163
164* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
165- Proposed upstream patch (#210058)
166  - Jordan will switch to winter time on October 27, not September 29
167  - Brazil's DST this year is the first Sunday in November to the last
168    Sunday in February.  (Thanks to Frederico A. C. Neves.)
169  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
170  - Commentary and past timestamps changes
171
172* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
173- Upstream 2006m:
174  - Adjustments for Egypt, Palestine, Uruguay
175  - Better description of `until' field in zic (8) manpage
176
177* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
178- Upstream 2006k, 2006l:
179  - Adjustments for Egypt, Palestine, Cuba, Honduras
180  - Documentation changes
181
182* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
183- Upstream 2006j
184  - Honduras stopped observing DST on Monday at 00:00
185  - America/Bermuda will follow the US's lead next year
186  - America/Moncton will use US-style rules next year
187  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
188    year
189  - New zone: America/Atikokan instead of America/Coral_Harbour
190  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
191  - Historical changes
192  - Commentary updates
193- Upstream 2006i
194  - localtime.c fixes
195- Upstream 2006h
196  - zic leapsecond fix
197
198* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
199- rebuild
200
201* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
202- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
203- Nicaragua updates
204
205* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
206- Upstream 2006f
207  - America/Guatemala observes DST between Apr/30 and Oct/1
208  - Historical changes for Nicaragua
209  - Update of America/Indiana/Vincennes in zone table
210
211* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
212- Upstream 2006d
213  - Haiti observes DST
214  - Sri Lanka change actually took effect Apr/15
215  - All Canada is now scheduled for 2007 US DST rules
216  - Some historical fixes
217
218* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
219- Upstream 2006c
220  - Time-related changes:
221    - dozens of historical and commentary changes
222    - Iran stopped observing DST
223    - Sri Lanka switches from UTC+6 to UTC+5:30
224    - America/Thule and America/Edmonton will adopt new US rules,
225      starting 2007
226    - Tunisia is adopting regular DST
227  - Code:
228    - asctime.c: Chages in format strings to silent gcc warnings
229    - removing K&R notation from function signatures
230    - few fixes across the code
231
232* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
233- Patch for Sri Lanka time zone change (#184514)
234
235* Thu Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
236- Upstream 2006b:
237  - using tz64code version, as 32 is legacy according to tzdata ML
238  - new manual pages for ctime, strftime, tzset
239  - some source code reorganizations
240  - no timezone/dst rule updates
241
242* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
243- Small changes in tst-timezone.c
244
245* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
246- Upstream 2006a:
247  - private.h(scheck): changing char* to char const*
248  - Rule changes for Palestine, zone changes for Indiana/US, both
249    changes for Canada.
250  - Many related doc changes.
251- Naming scheme in spec file doesn't use %%{name}, but tzdata.
252
253* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
254- 2005r-3
255  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
256    so that it won't clash across updates.
257
258* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
259- 2005r
260  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
261    northamerica to guard against old files with obsolete information
262    being left in the time zone binary directory.
263  - Changes for countries that are supposed to join 2007 US DST
264    change.  This includes most of Canada, however entries already in
265    the database (Alberta, British Columbia, Newfoundland, Northwest
266    Territories, and Yukon) were left alone for the time being.
267  - Fixes in zdump.c (abbrok): conditions are chained, and the string
268    is checked for emptiness.
269
270* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
271- 2005q
272  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
273  - SystemV timezone changes
274
275* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
276- 2005n
277  - changes for Kyrgyzstan and Uruguay
278- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
279  make check), update tst-timezone.c from glibc CVS (#172102)
280
281* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
282- 2005m
283  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
284    Australia, Kazakhstan
285  - historical timezone data changes for Japan, Poland, Northern Ireland and
286    Mali
287  - timezone name change for East Timor
288
289* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
290- 2005k
291  - leap seconds update
292
293* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
294- 2005i
295  - updates for Iran, Haiti and Nicaragua
296
297* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
298- 2005h
299  - fixes for Kazakhstan
300
301* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
302- 2005g
303  - fixes for Uruguay
304- include README and Theory from tzcode tarball in %{_docdir};
305  Theory includes a good summary of how the timezone data files
306  are supposed to be named
307
308* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
309- 2005f
310  - more updates for Israel, updates for Azerbaijan
311
312* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
313- 2005c
314  - updates for Israel and Paraguay
315
316* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
317- 2004g (#141107)
318  - updates for Cuba
319
320* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
321- 2004e (#135194)
322  - updates for Brazil, Uruguay and Argentina
323
324* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
325- 2004b
326
327* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
328- 2003d
329
330* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
331- 2003c
332- updates for Brazil (#104840)
333
334* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
335- rebuilt
336
337* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
338- initial package
Note: See TracBrowser for help on using the repository browser.