source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 12346

Revision 12346, 13.0 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

ca-certificates-2020.2.40-1

dmidecode-3.2-1

dnsmasq-2.80-2

golang-1.14.1-1

gthumb-3.8.3-1

haveged-1.9.8-1

iw-5.4-1

liblockfile-1.14-6

libnl3-3.5.0-1

libvisio-0.1.7-2

mailx-8.1.2.20180807-1

strace-5.5-1

tzdata-2019c-1

zlib-1.2.11-2

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2019c
5%define tzdata_version 2019c
6%define tzcode_version 2019c
7Release: 1%{?_dist_release}
8Group: System Environment/Base
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: Public Domain
13URL: https://www.iana.org/time-zones
14# These are official upstream.
15Source0: https://data.iana.org/time-zones/releases/tzdata%{tzdata_version}.tar.gz
16Source1: https://data.iana.org/time-zones/releases/tzcode%{tzcode_version}.tar.gz
17Source2: javazic.tar.gz
18Source3: javazic-1.8-37392f2f5d59.tar.xz
19
20Patch002: 0002-Fix-have-snprintf-error.patch
21
22Patch100: javazic-fixup.patch
23Patch101: rebase-01.patch
24Patch102: rebase-02.patch
25Patch103: 7090844.patch
26Patch104: 7133138.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildArch: noarch
30BuildRequires: gawk, glibc, perl
31BuildRequires: java-1.8.0-openjdk-devel
32BuildRequires: glibc-common >= 2.5.90-7
33Conflicts: glibc-common <= 2.3.2-63
34
35
36%description
37This package contains data files with rules for various timezones around
38the world.
39
40%description -l ja
41このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
42
43%package java
44Summary: Timezone data for Java
45Group: System Environment/Base
46
47%description java
48This package contains timezone information for use by Java runtimes.
49
50
51%prep
52%setup -q -c -a 1
53
54%patch002 -p1
55
56# tzdata-2018g introduce 25:00 transition times.  This breaks OpenJDK.
57# Use rearguard for tzdata-2018g java
58mkdir rearguard
59make VERSION=%{version} tzdata%{version}-rearguard.tar.gz
60mv tzdata%{version}-rearguard.tar.gz rearguard
61pushd rearguard
62tar zxf tzdata%{version}-rearguard.tar.gz
63popd
64
65mkdir javazic
66tar zxf %{SOURCE2} -C javazic
67pushd javazic
68%patch100
69%patch101
70%patch102
71%patch103
72%patch104
73
74# Hack alert! sun.tools may be defined and installed in the
75# VM. In order to guarantee that we are using IcedTea/OpenJDK
76# for creating the zoneinfo files, rebase all the packages
77# from "sun." to "rht.". Unfortunately, gcj does not support
78# any of the -Xclasspath options, so we must go this route
79# to ensure the greatest compatibility.
80mv sun rht
81find . -type f -name '*.java' -print0 \
82    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
83                         -e 's:sun\.util\.:rht.util.:g'
84popd
85
86tar xf %{SOURCE3}
87
88echo "%{name}%{tzdata_version}" >> VERSION
89
90
91%build
92# Run make to create the tzdata.zi file
93make tzdata.zi
94
95FILES="africa antarctica asia australasia europe northamerica southamerica
96       pacificnew etcetera backward"
97
98mkdir zoneinfo/{,posix,right}
99zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
100zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
101zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
102
103# tzdata-2018g uses 25:00 which breaks java - use the rearguard files for java
104JAVA_FILES="rearguard/africa rearguard/antarctica rearguard/asia \
105      rearguard/australasia rearguard/europe rearguard/northamerica \
106      rearguard/southamerica rearguard/pacificnew rearguard/etcetera \
107      rearguard/backward"
108
109# Java 6/7 tzdata
110pushd javazic
111javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
112popd
113
114java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
115  -d javazi \
116  $JAVA_FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
117
118# Java 8 tzdata
119pushd javazic-1.8
120javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
121popd
122
123java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
124    -srcdir . -dstfile tzdb.dat \
125    -verbose \
126    $JAVA_FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
127
128
129%install
130rm -fr $RPM_BUILD_ROOT
131install -d $RPM_BUILD_ROOT%{_datadir}
132cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
133install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
134cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
135mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
136install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
137
138%clean
139rm -fr $RPM_BUILD_ROOT
140
141%files
142%defattr(-,root,root)
143%{_datadir}/zoneinfo
144%license LICENSE
145%doc README
146%doc theory.html
147%doc tz-link.html
148%doc tz-art.html
149
150%files java
151%defattr(-,root,root)
152%{_datadir}/javazi
153%{_datadir}/javazi-1.8
154
155%changelog
156* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2019c-1
157- updated to 2019c.
158
159* Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2018i-1
160- updated to 2018i.
161
162* Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
163- update to 2017b
164
165* Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
166- updated to 2016j.
167
168* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
169- fixed changelog.
170- added Vendor and Distribution tag.
171
172* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
173- updated to 2016f.
174
175* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
176- updated to 2016e.
177- enabled java18 stuff.
178
179* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
180- updated to 2016d.
181
182* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
183- updated to 2015f.
184
185* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
186- updated to 2015e.
187
188* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
189- update to tzdata-2012c, tzcode-2012b
190
191* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
192- rebuilt with rpm-4.8.1-3
193
194* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
195- update to tzdata-2010l, tzcode-2010l
196- added java subpackage
197
198* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
199- update to tzdata-2009d, tzcode-2009d
200- spec in utf-8
201
202* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
203- update to tzdata-2008b, tzcode-2008a
204
205* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
206- initial build for VineSeed
207
208* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
209- Upstream 2007d
210  - Mongolia has abolished DST.
211  - Turkey will use EU rules this year, changing at 01:00 UTC rather
212    than 01:00 standard time.
213  - Cuba observed DST starting Sunday.
214  - Resolute, Nunavut switched from Central to Eastern time last
215    November.
216
217* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
218- Upstream 2007c
219  - Pulaski County, Indiana, switched back to eastern time.
220  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
221- Upstream 2007b
222  - Changes to the commentary in "leapseconds".
223- Upstream 2007a
224  - Updates to Bahamas, they will be in sync with 2007 US DST change
225  - New zone Australia/Eucla
226  - Africa/Asmera renamed to Africa/Asmara, link created
227  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
228
229* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
230- Upstream 2006p
231  - Covers changes from 2006m-2 and 2006m-3
232  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
233
234* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
235- Patch for Western Australia DST trial
236
237* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
238- Proposed upstream patch (#210058)
239  - Jordan will switch to winter time on October 27, not September 29
240  - Brazil's DST this year is the first Sunday in November to the last
241    Sunday in February.  (Thanks to Frederico A. C. Neves.)
242  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
243  - Commentary and past timestamps changes
244
245* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
246- Upstream 2006m:
247  - Adjustments for Egypt, Palestine, Uruguay
248  - Better description of `until' field in zic (8) manpage
249
250* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
251- Upstream 2006k, 2006l:
252  - Adjustments for Egypt, Palestine, Cuba, Honduras
253  - Documentation changes
254
255* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
256- Upstream 2006j
257  - Honduras stopped observing DST on Monday at 00:00
258  - America/Bermuda will follow the US's lead next year
259  - America/Moncton will use US-style rules next year
260  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
261    year
262  - New zone: America/Atikokan instead of America/Coral_Harbour
263  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
264  - Historical changes
265  - Commentary updates
266- Upstream 2006i
267  - localtime.c fixes
268- Upstream 2006h
269  - zic leapsecond fix
270
271* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
272- rebuild
273
274* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
275- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
276- Nicaragua updates
277
278* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
279- Upstream 2006f
280  - America/Guatemala observes DST between Apr/30 and Oct/1
281  - Historical changes for Nicaragua
282  - Update of America/Indiana/Vincennes in zone table
283
284* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
285- Upstream 2006d
286  - Haiti observes DST
287  - Sri Lanka change actually took effect Apr/15
288  - All Canada is now scheduled for 2007 US DST rules
289  - Some historical fixes
290
291* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
292- Upstream 2006c
293  - Time-related changes:
294    - dozens of historical and commentary changes
295    - Iran stopped observing DST
296    - Sri Lanka switches from UTC+6 to UTC+5:30
297    - America/Thule and America/Edmonton will adopt new US rules,
298      starting 2007
299    - Tunisia is adopting regular DST
300  - Code:
301    - asctime.c: Chages in format strings to silent gcc warnings
302    - removing K&R notation from function signatures
303    - few fixes across the code
304
305* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
306- Patch for Sri Lanka time zone change (#184514)
307
308* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
309- Upstream 2006b:
310  - using tz64code version, as 32 is legacy according to tzdata ML
311  - new manual pages for ctime, strftime, tzset
312  - some source code reorganizations
313  - no timezone/dst rule updates
314
315* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
316- Small changes in tst-timezone.c
317
318* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
319- Upstream 2006a:
320  - private.h(scheck): changing char* to char const*
321  - Rule changes for Palestine, zone changes for Indiana/US, both
322    changes for Canada.
323  - Many related doc changes.
324- Naming scheme in spec file doesn't use %%{name}, but tzdata.
325
326* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
327- 2005r-3
328  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
329    so that it won't clash across updates.
330
331* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
332- 2005r
333  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
334    northamerica to guard against old files with obsolete information
335    being left in the time zone binary directory.
336  - Changes for countries that are supposed to join 2007 US DST
337    change.  This includes most of Canada, however entries already in
338    the database (Alberta, British Columbia, Newfoundland, Northwest
339    Territories, and Yukon) were left alone for the time being.
340  - Fixes in zdump.c (abbrok): conditions are chained, and the string
341    is checked for emptiness.
342
343* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
344- 2005q
345  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
346  - SystemV timezone changes
347
348* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
349- 2005n
350  - changes for Kyrgyzstan and Uruguay
351- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
352  make check), update tst-timezone.c from glibc CVS (#172102)
353
354* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
355- 2005m
356  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
357    Australia, Kazakhstan
358  - historical timezone data changes for Japan, Poland, Northern Ireland and
359    Mali
360  - timezone name change for East Timor
361
362* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
363- 2005k
364  - leap seconds update
365
366* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
367- 2005i
368  - updates for Iran, Haiti and Nicaragua
369
370* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
371- 2005h
372  - fixes for Kazakhstan
373
374* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
375- 2005g
376  - fixes for Uruguay
377- include README and Theory from tzcode tarball in %{_docdir};
378  Theory includes a good summary of how the timezone data files
379  are supposed to be named
380
381* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
382- 2005f
383  - more updates for Israel, updates for Azerbaijan
384
385* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
386- 2005c
387  - updates for Israel and Paraguay
388
389* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
390- 2004g (#141107)
391  - updates for Cuba
392
393* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
394- 2004e (#135194)
395  - updates for Brazil, Uruguay and Argentina
396
397* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
398- 2004b
399
400* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
401- 2003d
402
403* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
404- 2003c
405- updates for Brazil (#104840)
406
407* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
408- rebuilt
409
410* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
411- initial package
Note: See TracBrowser for help on using the repository browser.