source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 12011

Revision 12011, 12.9 KB checked in by tomop, 5 years ago (diff)

tzdata-2018i-1

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2018i
5%define tzdata_version 2018i
6%define tzcode_version 2018i
7Release: 1%{?_dist_release}
8
9License: Public Domain
10Group: System Environment/Base
11URL: https://www.iana.org/time-zones
12
13Vendor: Project Vine
14Distribution: Vine Linux
15
16# These are official upstream.
17Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
18Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
19Source2: javazic.tar.gz
20Source3: javazic-1.8-37392f2f5d59.tar.xz
21
22Patch002: 0002-Fix-have-snprintf-error.patch
23
24Patch100: javazic-fixup.patch
25Patch101: rebase-01.patch
26Patch102: rebase-02.patch
27Patch103: 7090844.patch
28Patch104: 7133138.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildArch: noarch
32BuildRequires: gawk, glibc, perl
33BuildRequires: java-1.8.0-openjdk-devel
34BuildRequires: glibc-common >= 2.5.90-7
35Conflicts: glibc-common <= 2.3.2-63
36
37
38%description
39This package contains data files with rules for various timezones around
40the world.
41
42%description -l ja
43このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
44
45%package java
46Summary: Timezone data for Java
47Group: System Environment/Base
48
49%description java
50This package contains timezone information for use by Java runtimes.
51
52
53%prep
54%setup -q -c -a 1
55
56%patch002 -p1
57
58# tzdata-2018g introduce 25:00 transition times.  This breaks OpenJDK.
59# Use rearguard for tzdata-2018g java
60mkdir rearguard
61make VERSION=%{version} tzdata%{version}-rearguard.tar.gz
62mv tzdata%{version}-rearguard.tar.gz rearguard
63pushd rearguard
64tar zxf tzdata%{version}-rearguard.tar.gz
65popd
66
67mkdir javazic
68tar zxf %{SOURCE2} -C javazic
69pushd javazic
70%patch100
71%patch101
72%patch102
73%patch103
74%patch104
75
76# Hack alert! sun.tools may be defined and installed in the
77# VM. In order to guarantee that we are using IcedTea/OpenJDK
78# for creating the zoneinfo files, rebase all the packages
79# from "sun." to "rht.". Unfortunately, gcj does not support
80# any of the -Xclasspath options, so we must go this route
81# to ensure the greatest compatibility.
82mv sun rht
83find . -type f -name '*.java' -print0 \
84    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
85                         -e 's:sun\.util\.:rht.util.:g'
86popd
87
88tar xf %{SOURCE3}
89
90echo "%{name}%{tzdata_version}" >> VERSION
91
92
93%build
94# Run make to create the tzdata.zi file
95make tzdata.zi
96
97FILES="africa antarctica asia australasia europe northamerica southamerica
98       pacificnew etcetera backward"
99
100mkdir zoneinfo/{,posix,right}
101zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
102zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
103zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
104
105# tzdata-2018g uses 25:00 which breaks java - use the rearguard files for java
106JAVA_FILES="rearguard/africa rearguard/antarctica rearguard/asia \
107      rearguard/australasia rearguard/europe rearguard/northamerica \
108      rearguard/southamerica rearguard/pacificnew rearguard/etcetera \
109      rearguard/backward"
110
111# Java 6/7 tzdata
112pushd javazic
113javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
114popd
115
116java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
117  -d javazi \
118  $JAVA_FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
119
120# Java 8 tzdata
121pushd javazic-1.8
122javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
123popd
124
125java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
126    -srcdir . -dstfile tzdb.dat \
127    -verbose \
128    $JAVA_FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
129
130
131%install
132rm -fr $RPM_BUILD_ROOT
133install -d $RPM_BUILD_ROOT%{_datadir}
134cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
135install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
136cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
137mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
138install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
139
140%clean
141rm -fr $RPM_BUILD_ROOT
142
143%files
144%defattr(-,root,root)
145%{_datadir}/zoneinfo
146%license LICENSE
147%doc README
148%doc theory.html
149%doc tz-link.html
150%doc tz-art.html
151
152%files java
153%defattr(-,root,root)
154%{_datadir}/javazi
155%{_datadir}/javazi-1.8
156
157%changelog
158* Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2018i-1
159- updated to 2018i.
160
161* Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
162- update to 2017b
163
164* Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
165- updated to 2016j.
166
167* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
168- fixed changelog.
169- added Vendor and Distribution tag.
170
171* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
172- updated to 2016f.
173
174* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
175- updated to 2016e.
176- enabled java18 stuff.
177
178* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
179- updated to 2016d.
180
181* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
182- updated to 2015f.
183
184* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
185- updated to 2015e.
186
187* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
188- update to tzdata-2012c, tzcode-2012b
189
190* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
191- rebuilt with rpm-4.8.1-3
192
193* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
194- update to tzdata-2010l, tzcode-2010l
195- added java subpackage
196
197* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
198- update to tzdata-2009d, tzcode-2009d
199- spec in utf-8
200
201* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
202- update to tzdata-2008b, tzcode-2008a
203
204* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
205- initial build for VineSeed
206
207* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
208- Upstream 2007d
209  - Mongolia has abolished DST.
210  - Turkey will use EU rules this year, changing at 01:00 UTC rather
211    than 01:00 standard time.
212  - Cuba observed DST starting Sunday.
213  - Resolute, Nunavut switched from Central to Eastern time last
214    November.
215
216* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
217- Upstream 2007c
218  - Pulaski County, Indiana, switched back to eastern time.
219  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
220- Upstream 2007b
221  - Changes to the commentary in "leapseconds".
222- Upstream 2007a
223  - Updates to Bahamas, they will be in sync with 2007 US DST change
224  - New zone Australia/Eucla
225  - Africa/Asmera renamed to Africa/Asmara, link created
226  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
227
228* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
229- Upstream 2006p
230  - Covers changes from 2006m-2 and 2006m-3
231  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
232
233* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
234- Patch for Western Australia DST trial
235
236* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
237- Proposed upstream patch (#210058)
238  - Jordan will switch to winter time on October 27, not September 29
239  - Brazil's DST this year is the first Sunday in November to the last
240    Sunday in February.  (Thanks to Frederico A. C. Neves.)
241  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
242  - Commentary and past timestamps changes
243
244* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
245- Upstream 2006m:
246  - Adjustments for Egypt, Palestine, Uruguay
247  - Better description of `until' field in zic (8) manpage
248
249* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
250- Upstream 2006k, 2006l:
251  - Adjustments for Egypt, Palestine, Cuba, Honduras
252  - Documentation changes
253
254* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
255- Upstream 2006j
256  - Honduras stopped observing DST on Monday at 00:00
257  - America/Bermuda will follow the US's lead next year
258  - America/Moncton will use US-style rules next year
259  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
260    year
261  - New zone: America/Atikokan instead of America/Coral_Harbour
262  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
263  - Historical changes
264  - Commentary updates
265- Upstream 2006i
266  - localtime.c fixes
267- Upstream 2006h
268  - zic leapsecond fix
269
270* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
271- rebuild
272
273* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
274- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
275- Nicaragua updates
276
277* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
278- Upstream 2006f
279  - America/Guatemala observes DST between Apr/30 and Oct/1
280  - Historical changes for Nicaragua
281  - Update of America/Indiana/Vincennes in zone table
282
283* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
284- Upstream 2006d
285  - Haiti observes DST
286  - Sri Lanka change actually took effect Apr/15
287  - All Canada is now scheduled for 2007 US DST rules
288  - Some historical fixes
289
290* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
291- Upstream 2006c
292  - Time-related changes:
293    - dozens of historical and commentary changes
294    - Iran stopped observing DST
295    - Sri Lanka switches from UTC+6 to UTC+5:30
296    - America/Thule and America/Edmonton will adopt new US rules,
297      starting 2007
298    - Tunisia is adopting regular DST
299  - Code:
300    - asctime.c: Chages in format strings to silent gcc warnings
301    - removing K&R notation from function signatures
302    - few fixes across the code
303
304* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
305- Patch for Sri Lanka time zone change (#184514)
306
307* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
308- Upstream 2006b:
309  - using tz64code version, as 32 is legacy according to tzdata ML
310  - new manual pages for ctime, strftime, tzset
311  - some source code reorganizations
312  - no timezone/dst rule updates
313
314* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
315- Small changes in tst-timezone.c
316
317* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
318- Upstream 2006a:
319  - private.h(scheck): changing char* to char const*
320  - Rule changes for Palestine, zone changes for Indiana/US, both
321    changes for Canada.
322  - Many related doc changes.
323- Naming scheme in spec file doesn't use %%{name}, but tzdata.
324
325* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
326- 2005r-3
327  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
328    so that it won't clash across updates.
329
330* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
331- 2005r
332  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
333    northamerica to guard against old files with obsolete information
334    being left in the time zone binary directory.
335  - Changes for countries that are supposed to join 2007 US DST
336    change.  This includes most of Canada, however entries already in
337    the database (Alberta, British Columbia, Newfoundland, Northwest
338    Territories, and Yukon) were left alone for the time being.
339  - Fixes in zdump.c (abbrok): conditions are chained, and the string
340    is checked for emptiness.
341
342* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
343- 2005q
344  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
345  - SystemV timezone changes
346
347* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
348- 2005n
349  - changes for Kyrgyzstan and Uruguay
350- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
351  make check), update tst-timezone.c from glibc CVS (#172102)
352
353* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
354- 2005m
355  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
356    Australia, Kazakhstan
357  - historical timezone data changes for Japan, Poland, Northern Ireland and
358    Mali
359  - timezone name change for East Timor
360
361* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
362- 2005k
363  - leap seconds update
364
365* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
366- 2005i
367  - updates for Iran, Haiti and Nicaragua
368
369* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
370- 2005h
371  - fixes for Kazakhstan
372
373* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
374- 2005g
375  - fixes for Uruguay
376- include README and Theory from tzcode tarball in %{_docdir};
377  Theory includes a good summary of how the timezone data files
378  are supposed to be named
379
380* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
381- 2005f
382  - more updates for Israel, updates for Azerbaijan
383
384* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
385- 2005c
386  - updates for Israel and Paraguay
387
388* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
389- 2004g (#141107)
390  - updates for Cuba
391
392* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
393- 2004e (#135194)
394  - updates for Brazil, Uruguay and Argentina
395
396* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
397- 2004b
398
399* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
400- 2003d
401
402* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
403- 2003c
404- updates for Brazil (#104840)
405
406* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
407- rebuilt
408
409* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
410- initial package
Note: See TracBrowser for help on using the repository browser.