source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 11128

Revision 11128, 12.1 KB checked in by iwaim, 7 years ago (diff)

tzdata 2017b

Line 
1%bcond_without java18
2
3Summary: Timezone data
4Summary(ja): タイムゾーンのデータ
5Name: tzdata
6Version: 2017b
7%define tzdata_version 2017b
8%define tzcode_version 2017b
9Release: 1%{?_dist_release}
10
11License: Public Domain
12Group: System Environment/Base
13URL: https://www.iana.org/time-zones
14
15Vendor: Project Vine
16Distribution: Vine Linux
17
18# These are official upstream.
19Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
20Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
21Source2: javazic.tar.gz
22Source3: javazic-1.8-37392f2f5d59.tar.xz
23
24Patch100: javazic-fixup.patch
25Patch101: rebase-01.patch
26Patch102: rebase-02.patch
27Patch103: 7090844.patch
28Patch104: 7133138.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildArch: noarch
32BuildRequires: gawk, glibc, perl
33BuildRequires: java-1.8.0-openjdk-devel
34BuildRequires: glibc-common >= 2.5.90-7
35Conflicts: glibc-common <= 2.3.2-63
36
37
38%description
39This package contains data files with rules for various timezones around
40the world.
41
42%description -l ja
43このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
44
45%package java
46Summary: Timezone data for Java
47Group: System Environment/Base
48
49%description java
50This package contains timezone information for use by Java runtimes.
51
52
53%prep
54%setup -q -c -a 1
55
56mkdir javazic
57tar zxf %{SOURCE2} -C javazic
58pushd javazic
59%patch100
60%patch101
61%patch102
62%patch103
63%patch104
64
65# Hack alert! sun.tools may be defined and installed in the
66# VM. In order to guarantee that we are using IcedTea/OpenJDK
67# for creating the zoneinfo files, rebase all the packages
68# from "sun." to "rht.". Unfortunately, gcj does not support
69# any of the -Xclasspath options, so we must go this route
70# to ensure the greatest compatibility.
71mv sun rht
72find . -type f -name '*.java' -print0 \
73    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
74                         -e 's:sun\.util\.:rht.util.:g'
75popd
76
77tar xf %{SOURCE3}
78
79echo "%{name}%{tzdata_version}" >> VERSION
80
81
82%build
83FILES="africa antarctica asia australasia europe northamerica southamerica
84       pacificnew etcetera backward"
85
86mkdir zoneinfo/{,posix,right}
87zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
88zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
89zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
90
91grep -v tz-art.htm tz-link.htm > tz-link.html
92
93# Java 6/7 tzdata
94pushd javazic
95javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
96popd
97
98java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
99  -d javazi \
100  $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
101
102%if %{with java18}
103# Java 8 tzdata
104pushd javazic-1.8
105javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
106popd
107
108java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
109    -srcdir . -dstfile tzdb.dat \
110    -verbose \
111    $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
112%endif
113
114
115%install
116rm -fr $RPM_BUILD_ROOT
117install -d $RPM_BUILD_ROOT%{_datadir}
118cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
119install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
120cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
121
122%if %{with java18}
123mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
124install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
125%endif
126
127%clean
128rm -fr $RPM_BUILD_ROOT
129
130%files
131%defattr(-,root,root)
132%{_datadir}/zoneinfo
133%doc README
134%doc Theory
135%doc tz-link.html
136
137%files java
138%defattr(-,root,root)
139%{_datadir}/javazi
140%if %{with java18}
141%{_datadir}/javazi-1.8
142%endif
143
144%changelog
145* Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
146- update to 2017b
147
148* Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
149- updated to 2016j.
150
151* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
152- fixed changelog.
153- added Vendor and Distribution tag.
154
155* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
156- updated to 2016f.
157
158* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
159- updated to 2016e.
160- enabled java18 stuff.
161
162* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
163- updated to 2016d.
164
165* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
166- updated to 2015f.
167
168* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
169- updated to 2015e.
170
171* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
172- update to tzdata-2012c, tzcode-2012b
173
174* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
175- rebuilt with rpm-4.8.1-3
176
177* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
178- update to tzdata-2010l, tzcode-2010l
179- added java subpackage
180
181* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
182- update to tzdata-2009d, tzcode-2009d
183- spec in utf-8
184
185* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
186- update to tzdata-2008b, tzcode-2008a
187
188* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
189- initial build for VineSeed
190
191* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
192- Upstream 2007d
193  - Mongolia has abolished DST.
194  - Turkey will use EU rules this year, changing at 01:00 UTC rather
195    than 01:00 standard time.
196  - Cuba observed DST starting Sunday.
197  - Resolute, Nunavut switched from Central to Eastern time last
198    November.
199
200* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
201- Upstream 2007c
202  - Pulaski County, Indiana, switched back to eastern time.
203  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
204- Upstream 2007b
205  - Changes to the commentary in "leapseconds".
206- Upstream 2007a
207  - Updates to Bahamas, they will be in sync with 2007 US DST change
208  - New zone Australia/Eucla
209  - Africa/Asmera renamed to Africa/Asmara, link created
210  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
211
212* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
213- Upstream 2006p
214  - Covers changes from 2006m-2 and 2006m-3
215  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
216
217* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
218- Patch for Western Australia DST trial
219
220* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
221- Proposed upstream patch (#210058)
222  - Jordan will switch to winter time on October 27, not September 29
223  - Brazil's DST this year is the first Sunday in November to the last
224    Sunday in February.  (Thanks to Frederico A. C. Neves.)
225  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
226  - Commentary and past timestamps changes
227
228* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
229- Upstream 2006m:
230  - Adjustments for Egypt, Palestine, Uruguay
231  - Better description of `until' field in zic (8) manpage
232
233* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
234- Upstream 2006k, 2006l:
235  - Adjustments for Egypt, Palestine, Cuba, Honduras
236  - Documentation changes
237
238* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
239- Upstream 2006j
240  - Honduras stopped observing DST on Monday at 00:00
241  - America/Bermuda will follow the US's lead next year
242  - America/Moncton will use US-style rules next year
243  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
244    year
245  - New zone: America/Atikokan instead of America/Coral_Harbour
246  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
247  - Historical changes
248  - Commentary updates
249- Upstream 2006i
250  - localtime.c fixes
251- Upstream 2006h
252  - zic leapsecond fix
253
254* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
255- rebuild
256
257* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
258- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
259- Nicaragua updates
260
261* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
262- Upstream 2006f
263  - America/Guatemala observes DST between Apr/30 and Oct/1
264  - Historical changes for Nicaragua
265  - Update of America/Indiana/Vincennes in zone table
266
267* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
268- Upstream 2006d
269  - Haiti observes DST
270  - Sri Lanka change actually took effect Apr/15
271  - All Canada is now scheduled for 2007 US DST rules
272  - Some historical fixes
273
274* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
275- Upstream 2006c
276  - Time-related changes:
277    - dozens of historical and commentary changes
278    - Iran stopped observing DST
279    - Sri Lanka switches from UTC+6 to UTC+5:30
280    - America/Thule and America/Edmonton will adopt new US rules,
281      starting 2007
282    - Tunisia is adopting regular DST
283  - Code:
284    - asctime.c: Chages in format strings to silent gcc warnings
285    - removing K&R notation from function signatures
286    - few fixes across the code
287
288* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
289- Patch for Sri Lanka time zone change (#184514)
290
291* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
292- Upstream 2006b:
293  - using tz64code version, as 32 is legacy according to tzdata ML
294  - new manual pages for ctime, strftime, tzset
295  - some source code reorganizations
296  - no timezone/dst rule updates
297
298* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
299- Small changes in tst-timezone.c
300
301* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
302- Upstream 2006a:
303  - private.h(scheck): changing char* to char const*
304  - Rule changes for Palestine, zone changes for Indiana/US, both
305    changes for Canada.
306  - Many related doc changes.
307- Naming scheme in spec file doesn't use %%{name}, but tzdata.
308
309* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
310- 2005r-3
311  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
312    so that it won't clash across updates.
313
314* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
315- 2005r
316  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
317    northamerica to guard against old files with obsolete information
318    being left in the time zone binary directory.
319  - Changes for countries that are supposed to join 2007 US DST
320    change.  This includes most of Canada, however entries already in
321    the database (Alberta, British Columbia, Newfoundland, Northwest
322    Territories, and Yukon) were left alone for the time being.
323  - Fixes in zdump.c (abbrok): conditions are chained, and the string
324    is checked for emptiness.
325
326* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
327- 2005q
328  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
329  - SystemV timezone changes
330
331* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
332- 2005n
333  - changes for Kyrgyzstan and Uruguay
334- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
335  make check), update tst-timezone.c from glibc CVS (#172102)
336
337* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
338- 2005m
339  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
340    Australia, Kazakhstan
341  - historical timezone data changes for Japan, Poland, Northern Ireland and
342    Mali
343  - timezone name change for East Timor
344
345* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
346- 2005k
347  - leap seconds update
348
349* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
350- 2005i
351  - updates for Iran, Haiti and Nicaragua
352
353* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
354- 2005h
355  - fixes for Kazakhstan
356
357* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
358- 2005g
359  - fixes for Uruguay
360- include README and Theory from tzcode tarball in %{_docdir};
361  Theory includes a good summary of how the timezone data files
362  are supposed to be named
363
364* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
365- 2005f
366  - more updates for Israel, updates for Azerbaijan
367
368* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
369- 2005c
370  - updates for Israel and Paraguay
371
372* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
373- 2004g (#141107)
374  - updates for Cuba
375
376* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
377- 2004e (#135194)
378  - updates for Brazil, Uruguay and Argentina
379
380* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
381- 2004b
382
383* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
384- 2003d
385
386* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
387- 2003c
388- updates for Brazil (#104840)
389
390* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
391- rebuilt
392
393* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
394- initial package
Note: See TracBrowser for help on using the repository browser.