source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 10386

Revision 10386, 11.7 KB checked in by tomop, 8 years ago (diff)

tzdata-2016e-1

Line 
1%bcond_without java18
2
3Summary: Timezone data
4Summary(ja): タイムゾーンのデータ
5Name: tzdata
6Version: 2016e
7%define tzdata_version 2016e
8%define tzcode_version 2016e
9Release: 1%{?_dist_release}
10
11License: Public Domain
12Group: System Environment/Base
13URL: https://www.iana.org/time-zones
14
15# These are official upstream.
16Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
17Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
18Source2: javazic.tar.gz
19Source3: javazic-1.8-37392f2f5d59.tar.xz
20
21Patch100: javazic-fixup.patch
22Patch101: rebase-01.patch
23Patch102: rebase-02.patch
24Patch103: 7090844.patch
25Patch104: 7133138.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildArch: noarch
29BuildRequires: gawk, glibc, perl
30BuildRequires: java-devel
31BuildRequires: glibc-common >= 2.5.90-7
32Conflicts: glibc-common <= 2.3.2-63
33
34
35%description
36This package contains data files with rules for various timezones around
37the world.
38
39%description -l ja
40このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
41
42%package java
43Summary: Timezone data for Java
44Group: System Environment/Base
45
46%description java
47This package contains timezone information for use by Java runtimes.
48
49
50%prep
51%setup -q -c -a 1
52
53mkdir javazic
54tar zxf %{SOURCE2} -C javazic
55pushd javazic
56%patch100
57%patch101
58%patch102
59%patch103
60%patch104
61
62# Hack alert! sun.tools may be defined and installed in the
63# VM. In order to guarantee that we are using IcedTea/OpenJDK
64# for creating the zoneinfo files, rebase all the packages
65# from "sun." to "rht.". Unfortunately, gcj does not support
66# any of the -Xclasspath options, so we must go this route
67# to ensure the greatest compatibility.
68mv sun rht
69find . -type f -name '*.java' -print0 \
70    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
71                         -e 's:sun\.util\.:rht.util.:g'
72popd
73
74tar xf %{SOURCE3}
75
76echo "%{name}%{tzdata_version}" >> VERSION
77
78
79%build
80FILES="africa antarctica asia australasia europe northamerica southamerica
81       pacificnew etcetera backward"
82
83mkdir zoneinfo/{,posix,right}
84zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
85zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
86zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
87
88grep -v tz-art.htm tz-link.htm > tz-link.html
89
90# Java 6/7 tzdata
91pushd javazic
92javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
93popd
94
95java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
96  -d javazi \
97  $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
98
99%if %{with java18}
100# Java 8 tzdata
101pushd javazic-1.8
102javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
103popd
104
105java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
106    -srcdir . -dstfile tzdb.dat \
107    -verbose \
108    $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
109%endif
110
111
112%install
113rm -fr $RPM_BUILD_ROOT
114install -d $RPM_BUILD_ROOT%{_datadir}
115cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
116install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
117cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
118
119%if %{with java18}
120mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
121install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
122%endif
123
124%clean
125rm -fr $RPM_BUILD_ROOT
126
127%files
128%defattr(-,root,root)
129%{_datadir}/zoneinfo
130%doc README
131%doc Theory
132%doc tz-link.html
133
134%files java
135%defattr(-,root,root)
136%{_datadir}/javazi
137%if %{with java18}
138%{_datadir}/javazi-1.8
139%endif
140
141%changelog
142* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
143- updated to 2016e.
144- enabled java18 stuff.
145
146* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
147- updated to 2016d.
148
149* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
150- updated to 2015f.
151
152* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
153- updated to 2015e.
154
155* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
156- update to tzdata-2012c, tzcode-2012b
157
158* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
159- rebuilt with rpm-4.8.1-3
160
161* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
162- update to tzdata-2010l, tzcode-2010l
163- added java subpackage
164
165* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
166- update to tzdata-2009d, tzcode-2009d
167- spec in utf-8
168
169* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
170- update to tzdata-2008b, tzcode-2008a
171
172* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
173- initial build for VineSeed
174
175* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
176- Upstream 2007d
177  - Mongolia has abolished DST.
178  - Turkey will use EU rules this year, changing at 01:00 UTC rather
179    than 01:00 standard time.
180  - Cuba observed DST starting Sunday.
181  - Resolute, Nunavut switched from Central to Eastern time last
182    November.
183
184* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
185- Upstream 2007c
186  - Pulaski County, Indiana, switched back to eastern time.
187  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
188- Upstream 2007b
189  - Changes to the commentary in "leapseconds".
190- Upstream 2007a
191  - Updates to Bahamas, they will be in sync with 2007 US DST change
192  - New zone Australia/Eucla
193  - Africa/Asmera renamed to Africa/Asmara, link created
194  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
195
196* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
197- Upstream 2006p
198  - Covers changes from 2006m-2 and 2006m-3
199  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
200
201* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
202- Patch for Western Australia DST trial
203
204* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
205- Proposed upstream patch (#210058)
206  - Jordan will switch to winter time on October 27, not September 29
207  - Brazil's DST this year is the first Sunday in November to the last
208    Sunday in February.  (Thanks to Frederico A. C. Neves.)
209  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
210  - Commentary and past timestamps changes
211
212* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
213- Upstream 2006m:
214  - Adjustments for Egypt, Palestine, Uruguay
215  - Better description of `until' field in zic (8) manpage
216
217* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
218- Upstream 2006k, 2006l:
219  - Adjustments for Egypt, Palestine, Cuba, Honduras
220  - Documentation changes
221
222* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
223- Upstream 2006j
224  - Honduras stopped observing DST on Monday at 00:00
225  - America/Bermuda will follow the US's lead next year
226  - America/Moncton will use US-style rules next year
227  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
228    year
229  - New zone: America/Atikokan instead of America/Coral_Harbour
230  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
231  - Historical changes
232  - Commentary updates
233- Upstream 2006i
234  - localtime.c fixes
235- Upstream 2006h
236  - zic leapsecond fix
237
238* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
239- rebuild
240
241* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
242- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
243- Nicaragua updates
244
245* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
246- Upstream 2006f
247  - America/Guatemala observes DST between Apr/30 and Oct/1
248  - Historical changes for Nicaragua
249  - Update of America/Indiana/Vincennes in zone table
250
251* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
252- Upstream 2006d
253  - Haiti observes DST
254  - Sri Lanka change actually took effect Apr/15
255  - All Canada is now scheduled for 2007 US DST rules
256  - Some historical fixes
257
258* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
259- Upstream 2006c
260  - Time-related changes:
261    - dozens of historical and commentary changes
262    - Iran stopped observing DST
263    - Sri Lanka switches from UTC+6 to UTC+5:30
264    - America/Thule and America/Edmonton will adopt new US rules,
265      starting 2007
266    - Tunisia is adopting regular DST
267  - Code:
268    - asctime.c: Chages in format strings to silent gcc warnings
269    - removing K&R notation from function signatures
270    - few fixes across the code
271
272* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
273- Patch for Sri Lanka time zone change (#184514)
274
275* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
276- Upstream 2006b:
277  - using tz64code version, as 32 is legacy according to tzdata ML
278  - new manual pages for ctime, strftime, tzset
279  - some source code reorganizations
280  - no timezone/dst rule updates
281
282* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
283- Small changes in tst-timezone.c
284
285* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
286- Upstream 2006a:
287  - private.h(scheck): changing char* to char const*
288  - Rule changes for Palestine, zone changes for Indiana/US, both
289    changes for Canada.
290  - Many related doc changes.
291- Naming scheme in spec file doesn't use %%{name}, but tzdata.
292
293* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
294- 2005r-3
295  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
296    so that it won't clash across updates.
297
298* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
299- 2005r
300  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
301    northamerica to guard against old files with obsolete information
302    being left in the time zone binary directory.
303  - Changes for countries that are supposed to join 2007 US DST
304    change.  This includes most of Canada, however entries already in
305    the database (Alberta, British Columbia, Newfoundland, Northwest
306    Territories, and Yukon) were left alone for the time being.
307  - Fixes in zdump.c (abbrok): conditions are chained, and the string
308    is checked for emptiness.
309
310* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
311- 2005q
312  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
313  - SystemV timezone changes
314
315* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
316- 2005n
317  - changes for Kyrgyzstan and Uruguay
318- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
319  make check), update tst-timezone.c from glibc CVS (#172102)
320
321* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
322- 2005m
323  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
324    Australia, Kazakhstan
325  - historical timezone data changes for Japan, Poland, Northern Ireland and
326    Mali
327  - timezone name change for East Timor
328
329* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
330- 2005k
331  - leap seconds update
332
333* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
334- 2005i
335  - updates for Iran, Haiti and Nicaragua
336
337* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
338- 2005h
339  - fixes for Kazakhstan
340
341* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
342- 2005g
343  - fixes for Uruguay
344- include README and Theory from tzcode tarball in %{_docdir};
345  Theory includes a good summary of how the timezone data files
346  are supposed to be named
347
348* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
349- 2005f
350  - more updates for Israel, updates for Azerbaijan
351
352* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
353- 2005c
354  - updates for Israel and Paraguay
355
356* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
357- 2004g (#141107)
358  - updates for Cuba
359
360* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
361- 2004e (#135194)
362  - updates for Brazil, Uruguay and Argentina
363
364* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
365- 2004b
366
367* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
368- 2003d
369
370* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
371- 2003c
372- updates for Brazil (#104840)
373
374* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
375- rebuilt
376
377* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
378- initial package
Note: See TracBrowser for help on using the repository browser.