source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 10257

Revision 10257, 11.6 KB checked in by tomop, 8 years ago (diff)

tzdata-2016d-1

Line 
1%bcond_with java18
2
3Summary: Timezone data
4Summary(ja): タイムゾーンのデータ
5Name: tzdata
6Version: 2016d
7%define tzdata_version 2016d
8%define tzcode_version 2016d
9Release: 1%{?_dist_release}
10
11License: Public Domain
12Group: System Environment/Base
13URL: https://www.iana.org/time-zones
14
15# These are official upstream.
16Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
17Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
18Source2: javazic.tar.gz
19Source3: javazic-1.8-37392f2f5d59.tar.xz
20
21Patch100: javazic-fixup.patch
22Patch101: rebase-01.patch
23Patch102: rebase-02.patch
24Patch103: 7090844.patch
25Patch104: 7133138.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildArch: noarch
29BuildRequires: gawk, glibc, perl
30BuildRequires: java-devel
31BuildRequires: glibc-common >= 2.5.90-7
32Conflicts: glibc-common <= 2.3.2-63
33
34
35%description
36This package contains data files with rules for various timezones around
37the world.
38
39%description -l ja
40このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
41
42%package java
43Summary: Timezone data for Java
44Group: System Environment/Base
45
46%description java
47This package contains timezone information for use by Java runtimes.
48
49
50%prep
51%setup -q -c -a 1
52
53mkdir javazic
54tar zxf %{SOURCE2} -C javazic
55pushd javazic
56%patch100
57%patch101
58%patch102
59%patch103
60%patch104
61
62# Hack alert! sun.tools may be defined and installed in the
63# VM. In order to guarantee that we are using IcedTea/OpenJDK
64# for creating the zoneinfo files, rebase all the packages
65# from "sun." to "rht.". Unfortunately, gcj does not support
66# any of the -Xclasspath options, so we must go this route
67# to ensure the greatest compatibility.
68mv sun rht
69find . -type f -name '*.java' -print0 \
70    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
71                         -e 's:sun\.util\.:rht.util.:g'
72popd
73
74tar xf %{SOURCE3}
75
76echo "%{name}%{tzdata_version}" >> VERSION
77
78
79%build
80FILES="africa antarctica asia australasia europe northamerica southamerica
81       pacificnew etcetera backward"
82
83mkdir zoneinfo/{,posix,right}
84zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
85zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
86zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
87
88grep -v tz-art.htm tz-link.htm > tz-link.html
89
90# Java 6/7 tzdata
91pushd javazic
92javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
93popd
94
95java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
96  -d javazi \
97  $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
98
99%if %{with java18}
100# Java 8 tzdata
101pushd javazic-1.8
102javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
103popd
104
105java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
106    -srcdir . -dstfile tzdb.dat \
107    -verbose \
108    $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
109%endif
110
111
112%install
113rm -fr $RPM_BUILD_ROOT
114install -d $RPM_BUILD_ROOT%{_datadir}
115cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
116install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
117cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
118
119%if %{with java18}
120mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
121install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
122%endif
123
124%clean
125rm -fr $RPM_BUILD_ROOT
126
127%files
128%defattr(-,root,root)
129%{_datadir}/zoneinfo
130%doc README
131%doc Theory
132%doc tz-link.html
133
134%files java
135%defattr(-,root,root)
136%{_datadir}/javazi
137%if %{with java18}
138%{_datadir}/javazi-1.8
139%endif
140
141%changelog
142* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
143- updated to 2016d.
144
145* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
146- updated to 2015f.
147
148* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
149- updated to 2015e.
150
151* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
152- update to tzdata-2012c, tzcode-2012b
153
154* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
155- rebuilt with rpm-4.8.1-3
156
157* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
158- update to tzdata-2010l, tzcode-2010l
159- added java subpackage
160
161* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
162- update to tzdata-2009d, tzcode-2009d
163- spec in utf-8
164
165* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
166- update to tzdata-2008b, tzcode-2008a
167
168* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
169- initial build for VineSeed
170
171* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
172- Upstream 2007d
173  - Mongolia has abolished DST.
174  - Turkey will use EU rules this year, changing at 01:00 UTC rather
175    than 01:00 standard time.
176  - Cuba observed DST starting Sunday.
177  - Resolute, Nunavut switched from Central to Eastern time last
178    November.
179
180* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
181- Upstream 2007c
182  - Pulaski County, Indiana, switched back to eastern time.
183  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
184- Upstream 2007b
185  - Changes to the commentary in "leapseconds".
186- Upstream 2007a
187  - Updates to Bahamas, they will be in sync with 2007 US DST change
188  - New zone Australia/Eucla
189  - Africa/Asmera renamed to Africa/Asmara, link created
190  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
191
192* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
193- Upstream 2006p
194  - Covers changes from 2006m-2 and 2006m-3
195  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
196
197* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
198- Patch for Western Australia DST trial
199
200* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
201- Proposed upstream patch (#210058)
202  - Jordan will switch to winter time on October 27, not September 29
203  - Brazil's DST this year is the first Sunday in November to the last
204    Sunday in February.  (Thanks to Frederico A. C. Neves.)
205  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
206  - Commentary and past timestamps changes
207
208* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
209- Upstream 2006m:
210  - Adjustments for Egypt, Palestine, Uruguay
211  - Better description of `until' field in zic (8) manpage
212
213* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
214- Upstream 2006k, 2006l:
215  - Adjustments for Egypt, Palestine, Cuba, Honduras
216  - Documentation changes
217
218* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
219- Upstream 2006j
220  - Honduras stopped observing DST on Monday at 00:00
221  - America/Bermuda will follow the US's lead next year
222  - America/Moncton will use US-style rules next year
223  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
224    year
225  - New zone: America/Atikokan instead of America/Coral_Harbour
226  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
227  - Historical changes
228  - Commentary updates
229- Upstream 2006i
230  - localtime.c fixes
231- Upstream 2006h
232  - zic leapsecond fix
233
234* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
235- rebuild
236
237* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
238- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
239- Nicaragua updates
240
241* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
242- Upstream 2006f
243  - America/Guatemala observes DST between Apr/30 and Oct/1
244  - Historical changes for Nicaragua
245  - Update of America/Indiana/Vincennes in zone table
246
247* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
248- Upstream 2006d
249  - Haiti observes DST
250  - Sri Lanka change actually took effect Apr/15
251  - All Canada is now scheduled for 2007 US DST rules
252  - Some historical fixes
253
254* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
255- Upstream 2006c
256  - Time-related changes:
257    - dozens of historical and commentary changes
258    - Iran stopped observing DST
259    - Sri Lanka switches from UTC+6 to UTC+5:30
260    - America/Thule and America/Edmonton will adopt new US rules,
261      starting 2007
262    - Tunisia is adopting regular DST
263  - Code:
264    - asctime.c: Chages in format strings to silent gcc warnings
265    - removing K&R notation from function signatures
266    - few fixes across the code
267
268* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
269- Patch for Sri Lanka time zone change (#184514)
270
271* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
272- Upstream 2006b:
273  - using tz64code version, as 32 is legacy according to tzdata ML
274  - new manual pages for ctime, strftime, tzset
275  - some source code reorganizations
276  - no timezone/dst rule updates
277
278* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
279- Small changes in tst-timezone.c
280
281* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
282- Upstream 2006a:
283  - private.h(scheck): changing char* to char const*
284  - Rule changes for Palestine, zone changes for Indiana/US, both
285    changes for Canada.
286  - Many related doc changes.
287- Naming scheme in spec file doesn't use %%{name}, but tzdata.
288
289* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
290- 2005r-3
291  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
292    so that it won't clash across updates.
293
294* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
295- 2005r
296  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
297    northamerica to guard against old files with obsolete information
298    being left in the time zone binary directory.
299  - Changes for countries that are supposed to join 2007 US DST
300    change.  This includes most of Canada, however entries already in
301    the database (Alberta, British Columbia, Newfoundland, Northwest
302    Territories, and Yukon) were left alone for the time being.
303  - Fixes in zdump.c (abbrok): conditions are chained, and the string
304    is checked for emptiness.
305
306* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
307- 2005q
308  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
309  - SystemV timezone changes
310
311* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
312- 2005n
313  - changes for Kyrgyzstan and Uruguay
314- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
315  make check), update tst-timezone.c from glibc CVS (#172102)
316
317* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
318- 2005m
319  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
320    Australia, Kazakhstan
321  - historical timezone data changes for Japan, Poland, Northern Ireland and
322    Mali
323  - timezone name change for East Timor
324
325* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
326- 2005k
327  - leap seconds update
328
329* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
330- 2005i
331  - updates for Iran, Haiti and Nicaragua
332
333* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
334- 2005h
335  - fixes for Kazakhstan
336
337* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
338- 2005g
339  - fixes for Uruguay
340- include README and Theory from tzcode tarball in %{_docdir};
341  Theory includes a good summary of how the timezone data files
342  are supposed to be named
343
344* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
345- 2005f
346  - more updates for Israel, updates for Azerbaijan
347
348* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
349- 2005c
350  - updates for Israel and Paraguay
351
352* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
353- 2004g (#141107)
354  - updates for Cuba
355
356* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
357- 2004e (#135194)
358  - updates for Brazil, Uruguay and Argentina
359
360* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
361- 2004b
362
363* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
364- 2003d
365
366* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
367- 2003c
368- updates for Brazil (#104840)
369
370* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
371- rebuilt
372
373* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
374- initial package
Note: See TracBrowser for help on using the repository browser.