source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 9708

Revision 9708, 11.5 KB checked in by tomop, 9 years ago (diff)

tzdata-2015f-1

Line 
1%bcond_with java18
2
3Summary: Timezone data
4Summary(ja): タイムゾーンのデータ
5Name: tzdata
6Version: 2015f
7%define tzdata_version 2015f
8%define tzcode_version 2015f
9Release: 1%{?_dist_release}
10
11License: Public Domain
12Group: System Environment/Base
13URL: https://www.iana.org/time-zones
14
15# These are official upstream.
16Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
17Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
18Source2: javazic.tar.gz
19Source3: javazic-1.8-37392f2f5d59.tar.xz
20
21Patch100: javazic-fixup.patch
22Patch101: rebase-01.patch
23Patch102: rebase-02.patch
24Patch103: 7090844.patch
25Patch104: 7133138.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildArch: noarch
29BuildRequires: gawk, glibc, perl
30BuildRequires: java-devel
31BuildRequires: glibc-common >= 2.5.90-7
32Conflicts: glibc-common <= 2.3.2-63
33
34
35%description
36This package contains data files with rules for various timezones around
37the world.
38
39%description -l ja
40このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
41
42%package java
43Summary: Timezone data for Java
44Group: System Environment/Base
45
46%description java
47This package contains timezone information for use by Java runtimes.
48
49
50%prep
51%setup -q -c -a 1
52
53mkdir javazic
54tar zxf %{SOURCE2} -C javazic
55pushd javazic
56%patch100
57%patch101
58%patch102
59%patch103
60%patch104
61
62# Hack alert! sun.tools may be defined and installed in the
63# VM. In order to guarantee that we are using IcedTea/OpenJDK
64# for creating the zoneinfo files, rebase all the packages
65# from "sun." to "rht.". Unfortunately, gcj does not support
66# any of the -Xclasspath options, so we must go this route
67# to ensure the greatest compatibility.
68mv sun rht
69find . -type f -name '*.java' -print0 \
70    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
71                         -e 's:sun\.util\.:rht.util.:g'
72popd
73
74tar xf %{SOURCE3}
75
76echo "%{name}%{tzdata_version}" >> VERSION
77
78
79%build
80FILES="africa antarctica asia australasia europe northamerica southamerica
81       pacificnew etcetera backward"
82
83mkdir zoneinfo/{,posix,right}
84zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
85zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
86zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
87
88grep -v tz-art.htm tz-link.htm > tz-link.html
89
90# Java 6/7 tzdata
91pushd javazic
92javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
93popd
94
95java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
96  -d javazi \
97  $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
98
99%if %{with java18}
100# Java 8 tzdata
101pushd javazic-1.8
102javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
103popd
104
105java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
106    -srcdir . -dstfile tzdb.dat \
107    -verbose \
108    $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
109%endif
110
111
112%install
113rm -fr $RPM_BUILD_ROOT
114install -d $RPM_BUILD_ROOT%{_datadir}
115cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
116install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
117cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
118
119%if %{with java18}
120mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
121install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
122%endif
123
124%clean
125rm -fr $RPM_BUILD_ROOT
126
127%files
128%defattr(-,root,root)
129%{_datadir}/zoneinfo
130%doc README
131%doc Theory
132%doc tz-link.html
133
134%files java
135%defattr(-,root,root)
136%{_datadir}/javazi
137%if %{with java18}
138%{_datadir}/javazi-1.8
139%endif
140
141%changelog
142* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
143- updated to 2015f.
144
145* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
146- updated to 2015e.
147
148* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
149- update to tzdata-2012c, tzcode-2012b
150
151* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
152- rebuilt with rpm-4.8.1-3
153
154* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
155- update to tzdata-2010l, tzcode-2010l
156- added java subpackage
157
158* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
159- update to tzdata-2009d, tzcode-2009d
160- spec in utf-8
161
162* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
163- update to tzdata-2008b, tzcode-2008a
164
165* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
166- initial build for VineSeed
167
168* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
169- Upstream 2007d
170  - Mongolia has abolished DST.
171  - Turkey will use EU rules this year, changing at 01:00 UTC rather
172    than 01:00 standard time.
173  - Cuba observed DST starting Sunday.
174  - Resolute, Nunavut switched from Central to Eastern time last
175    November.
176
177* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
178- Upstream 2007c
179  - Pulaski County, Indiana, switched back to eastern time.
180  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
181- Upstream 2007b
182  - Changes to the commentary in "leapseconds".
183- Upstream 2007a
184  - Updates to Bahamas, they will be in sync with 2007 US DST change
185  - New zone Australia/Eucla
186  - Africa/Asmera renamed to Africa/Asmara, link created
187  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
188
189* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
190- Upstream 2006p
191  - Covers changes from 2006m-2 and 2006m-3
192  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
193
194* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
195- Patch for Western Australia DST trial
196
197* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
198- Proposed upstream patch (#210058)
199  - Jordan will switch to winter time on October 27, not September 29
200  - Brazil's DST this year is the first Sunday in November to the last
201    Sunday in February.  (Thanks to Frederico A. C. Neves.)
202  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
203  - Commentary and past timestamps changes
204
205* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
206- Upstream 2006m:
207  - Adjustments for Egypt, Palestine, Uruguay
208  - Better description of `until' field in zic (8) manpage
209
210* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
211- Upstream 2006k, 2006l:
212  - Adjustments for Egypt, Palestine, Cuba, Honduras
213  - Documentation changes
214
215* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
216- Upstream 2006j
217  - Honduras stopped observing DST on Monday at 00:00
218  - America/Bermuda will follow the US's lead next year
219  - America/Moncton will use US-style rules next year
220  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
221    year
222  - New zone: America/Atikokan instead of America/Coral_Harbour
223  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
224  - Historical changes
225  - Commentary updates
226- Upstream 2006i
227  - localtime.c fixes
228- Upstream 2006h
229  - zic leapsecond fix
230
231* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
232- rebuild
233
234* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
235- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
236- Nicaragua updates
237
238* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
239- Upstream 2006f
240  - America/Guatemala observes DST between Apr/30 and Oct/1
241  - Historical changes for Nicaragua
242  - Update of America/Indiana/Vincennes in zone table
243
244* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
245- Upstream 2006d
246  - Haiti observes DST
247  - Sri Lanka change actually took effect Apr/15
248  - All Canada is now scheduled for 2007 US DST rules
249  - Some historical fixes
250
251* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
252- Upstream 2006c
253  - Time-related changes:
254    - dozens of historical and commentary changes
255    - Iran stopped observing DST
256    - Sri Lanka switches from UTC+6 to UTC+5:30
257    - America/Thule and America/Edmonton will adopt new US rules,
258      starting 2007
259    - Tunisia is adopting regular DST
260  - Code:
261    - asctime.c: Chages in format strings to silent gcc warnings
262    - removing K&R notation from function signatures
263    - few fixes across the code
264
265* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
266- Patch for Sri Lanka time zone change (#184514)
267
268* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
269- Upstream 2006b:
270  - using tz64code version, as 32 is legacy according to tzdata ML
271  - new manual pages for ctime, strftime, tzset
272  - some source code reorganizations
273  - no timezone/dst rule updates
274
275* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
276- Small changes in tst-timezone.c
277
278* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
279- Upstream 2006a:
280  - private.h(scheck): changing char* to char const*
281  - Rule changes for Palestine, zone changes for Indiana/US, both
282    changes for Canada.
283  - Many related doc changes.
284- Naming scheme in spec file doesn't use %%{name}, but tzdata.
285
286* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
287- 2005r-3
288  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
289    so that it won't clash across updates.
290
291* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
292- 2005r
293  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
294    northamerica to guard against old files with obsolete information
295    being left in the time zone binary directory.
296  - Changes for countries that are supposed to join 2007 US DST
297    change.  This includes most of Canada, however entries already in
298    the database (Alberta, British Columbia, Newfoundland, Northwest
299    Territories, and Yukon) were left alone for the time being.
300  - Fixes in zdump.c (abbrok): conditions are chained, and the string
301    is checked for emptiness.
302
303* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
304- 2005q
305  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
306  - SystemV timezone changes
307
308* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
309- 2005n
310  - changes for Kyrgyzstan and Uruguay
311- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
312  make check), update tst-timezone.c from glibc CVS (#172102)
313
314* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
315- 2005m
316  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
317    Australia, Kazakhstan
318  - historical timezone data changes for Japan, Poland, Northern Ireland and
319    Mali
320  - timezone name change for East Timor
321
322* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
323- 2005k
324  - leap seconds update
325
326* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
327- 2005i
328  - updates for Iran, Haiti and Nicaragua
329
330* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
331- 2005h
332  - fixes for Kazakhstan
333
334* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
335- 2005g
336  - fixes for Uruguay
337- include README and Theory from tzcode tarball in %{_docdir};
338  Theory includes a good summary of how the timezone data files
339  are supposed to be named
340
341* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
342- 2005f
343  - more updates for Israel, updates for Azerbaijan
344
345* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
346- 2005c
347  - updates for Israel and Paraguay
348
349* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
350- 2004g (#141107)
351  - updates for Cuba
352
353* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
354- 2004e (#135194)
355  - updates for Brazil, Uruguay and Argentina
356
357* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
358- 2004b
359
360* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
361- 2003d
362
363* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
364- 2003c
365- updates for Brazil (#104840)
366
367* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
368- rebuilt
369
370* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
371- initial package
Note: See TracBrowser for help on using the repository browser.