source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 10832

Revision 10832, 12.0 KB checked in by iwaim, 8 years ago (diff)

tzdata 2016j-1

RevLine 
[10386]1%bcond_without java18
[9608]2
[521]3Summary: Timezone data
4Summary(ja): タイムゾーンのデータ
5Name: tzdata
[10832]6Version: 2016j
7%define tzdata_version 2016j
8%define tzcode_version 2016j
9Release: 1%{?_dist_release}
[1759]10
11License: Public Domain
[521]12Group: System Environment/Base
[9608]13URL: https://www.iana.org/time-zones
[1759]14
[10831]15Vendor: Project Vine
16Distribution: Vine Linux
17
[1759]18# These are official upstream.
[9608]19Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
20Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
21Source2: javazic.tar.gz
22Source3: javazic-1.8-37392f2f5d59.tar.xz
[1759]23
[6402]24Patch100: javazic-fixup.patch
[9608]25Patch101: rebase-01.patch
26Patch102: rebase-02.patch
27Patch103: 7090844.patch
28Patch104: 7133138.patch
[1759]29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildArch: noarch
32BuildRequires: gawk, glibc, perl
[10831]33BuildRequires: java-1.8.0-openjdk-devel
[1759]34BuildRequires: glibc-common >= 2.5.90-7
[521]35Conflicts: glibc-common <= 2.3.2-63
36
37
38%description
39This package contains data files with rules for various timezones around
40the world.
41
42%description -l ja
[1759]43このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
[521]44
[1759]45%package java
46Summary: Timezone data for Java
47Group: System Environment/Base
[521]48
[1759]49%description java
50This package contains timezone information for use by Java runtimes.
51
52
[521]53%prep
[9608]54%setup -q -c -a 1
[521]55
[1759]56mkdir javazic
[9608]57tar zxf %{SOURCE2} -C javazic
[1759]58pushd javazic
[6402]59%patch100
60%patch101
[9608]61%patch102
62%patch103
63%patch104
[521]64
[1759]65# Hack alert! sun.tools may be defined and installed in the
66# VM. In order to guarantee that we are using IcedTea/OpenJDK
67# for creating the zoneinfo files, rebase all the packages
68# from "sun." to "rht.". Unfortunately, gcj does not support
69# any of the -Xclasspath options, so we must go this route
70# to ensure the greatest compatibility.
71mv sun rht
72find . -type f -name '*.java' -print0 \
73    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
74                         -e 's:sun\.util\.:rht.util.:g'
75popd
76
[9608]77tar xf %{SOURCE3}
[1759]78
[9608]79echo "%{name}%{tzdata_version}" >> VERSION
80
81
[521]82%build
[9608]83FILES="africa antarctica asia australasia europe northamerica southamerica
84       pacificnew etcetera backward"
[521]85
[9608]86mkdir zoneinfo/{,posix,right}
87zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
88zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
89zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
90
91grep -v tz-art.htm tz-link.htm > tz-link.html
92
93# Java 6/7 tzdata
[1759]94pushd javazic
95javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
96popd
[9608]97
98java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
99  -d javazi \
100  $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
101
102%if %{with java18}
103# Java 8 tzdata
104pushd javazic-1.8
105javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
[1759]106popd
[521]107
[9608]108java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
109    -srcdir . -dstfile tzdb.dat \
110    -verbose \
111    $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
112%endif
[1759]113
[9608]114
[521]115%install
[1759]116rm -fr $RPM_BUILD_ROOT
[9608]117install -d $RPM_BUILD_ROOT%{_datadir}
118cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
119install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
120cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
[521]121
[9608]122%if %{with java18}
123mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
124install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
125%endif
[521]126
127%clean
[1759]128rm -fr $RPM_BUILD_ROOT
[521]129
130%files
131%defattr(-,root,root)
132%{_datadir}/zoneinfo
[9608]133%doc README
134%doc Theory
135%doc tz-link.html
[521]136
[1759]137%files java
138%defattr(-,root,root)
139%{_datadir}/javazi
[9608]140%if %{with java18}
141%{_datadir}/javazi-1.8
142%endif
[521]143
144%changelog
[10832]145* Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
146- updated to 2016j.
147
[10831]148* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
149- fixed changelog.
150- added Vendor and Distribution tag.
151
152* Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
153- updated to 2016f.
154
[10386]155* Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
156- updated to 2016e.
157- enabled java18 stuff.
158
[10257]159* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
160- updated to 2016d.
161
[9708]162* Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
163- updated to 2015f.
164
[9608]165* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
166- updated to 2015e.
167
[6402]168* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
169- update to tzdata-2012c, tzcode-2012b
170
[3534]171* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
172- rebuilt with rpm-4.8.1-3
173
[1759]174* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
175- update to tzdata-2010l, tzcode-2010l
176- added java subpackage
177
[521]178* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
179- update to tzdata-2009d, tzcode-2009d
180- spec in utf-8
181
182* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
183- update to tzdata-2008b, tzcode-2008a
184
185* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
186- initial build for VineSeed
187
188* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
189- Upstream 2007d
190  - Mongolia has abolished DST.
191  - Turkey will use EU rules this year, changing at 01:00 UTC rather
192    than 01:00 standard time.
193  - Cuba observed DST starting Sunday.
194  - Resolute, Nunavut switched from Central to Eastern time last
195    November.
196
197* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
198- Upstream 2007c
199  - Pulaski County, Indiana, switched back to eastern time.
200  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
201- Upstream 2007b
202  - Changes to the commentary in "leapseconds".
203- Upstream 2007a
204  - Updates to Bahamas, they will be in sync with 2007 US DST change
205  - New zone Australia/Eucla
206  - Africa/Asmera renamed to Africa/Asmara, link created
207  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
208
209* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
210- Upstream 2006p
211  - Covers changes from 2006m-2 and 2006m-3
212  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
213
214* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
215- Patch for Western Australia DST trial
216
217* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
218- Proposed upstream patch (#210058)
219  - Jordan will switch to winter time on October 27, not September 29
220  - Brazil's DST this year is the first Sunday in November to the last
221    Sunday in February.  (Thanks to Frederico A. C. Neves.)
222  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
223  - Commentary and past timestamps changes
224
225* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
226- Upstream 2006m:
227  - Adjustments for Egypt, Palestine, Uruguay
228  - Better description of `until' field in zic (8) manpage
229
230* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
231- Upstream 2006k, 2006l:
232  - Adjustments for Egypt, Palestine, Cuba, Honduras
233  - Documentation changes
234
235* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
236- Upstream 2006j
237  - Honduras stopped observing DST on Monday at 00:00
238  - America/Bermuda will follow the US's lead next year
239  - America/Moncton will use US-style rules next year
240  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
241    year
242  - New zone: America/Atikokan instead of America/Coral_Harbour
243  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
244  - Historical changes
245  - Commentary updates
246- Upstream 2006i
247  - localtime.c fixes
248- Upstream 2006h
249  - zic leapsecond fix
250
251* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
252- rebuild
253
254* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
255- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
256- Nicaragua updates
257
258* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
259- Upstream 2006f
260  - America/Guatemala observes DST between Apr/30 and Oct/1
261  - Historical changes for Nicaragua
262  - Update of America/Indiana/Vincennes in zone table
263
264* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
265- Upstream 2006d
266  - Haiti observes DST
267  - Sri Lanka change actually took effect Apr/15
268  - All Canada is now scheduled for 2007 US DST rules
269  - Some historical fixes
270
271* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
272- Upstream 2006c
273  - Time-related changes:
274    - dozens of historical and commentary changes
275    - Iran stopped observing DST
276    - Sri Lanka switches from UTC+6 to UTC+5:30
277    - America/Thule and America/Edmonton will adopt new US rules,
278      starting 2007
279    - Tunisia is adopting regular DST
280  - Code:
281    - asctime.c: Chages in format strings to silent gcc warnings
282    - removing K&R notation from function signatures
283    - few fixes across the code
284
285* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
286- Patch for Sri Lanka time zone change (#184514)
287
[9608]288* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
[521]289- Upstream 2006b:
290  - using tz64code version, as 32 is legacy according to tzdata ML
291  - new manual pages for ctime, strftime, tzset
292  - some source code reorganizations
293  - no timezone/dst rule updates
294
295* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
296- Small changes in tst-timezone.c
297
298* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
299- Upstream 2006a:
300  - private.h(scheck): changing char* to char const*
301  - Rule changes for Palestine, zone changes for Indiana/US, both
302    changes for Canada.
303  - Many related doc changes.
304- Naming scheme in spec file doesn't use %%{name}, but tzdata.
305
306* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
307- 2005r-3
308  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
309    so that it won't clash across updates.
310
311* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
312- 2005r
313  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
314    northamerica to guard against old files with obsolete information
315    being left in the time zone binary directory.
316  - Changes for countries that are supposed to join 2007 US DST
317    change.  This includes most of Canada, however entries already in
318    the database (Alberta, British Columbia, Newfoundland, Northwest
319    Territories, and Yukon) were left alone for the time being.
320  - Fixes in zdump.c (abbrok): conditions are chained, and the string
321    is checked for emptiness.
322
323* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
324- 2005q
325  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
326  - SystemV timezone changes
327
328* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
329- 2005n
330  - changes for Kyrgyzstan and Uruguay
331- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
332  make check), update tst-timezone.c from glibc CVS (#172102)
333
334* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
335- 2005m
336  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
337    Australia, Kazakhstan
338  - historical timezone data changes for Japan, Poland, Northern Ireland and
339    Mali
340  - timezone name change for East Timor
341
342* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
343- 2005k
344  - leap seconds update
345
346* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
347- 2005i
348  - updates for Iran, Haiti and Nicaragua
349
350* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
351- 2005h
352  - fixes for Kazakhstan
353
354* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
355- 2005g
356  - fixes for Uruguay
357- include README and Theory from tzcode tarball in %{_docdir};
358  Theory includes a good summary of how the timezone data files
359  are supposed to be named
360
361* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
362- 2005f
363  - more updates for Israel, updates for Azerbaijan
364
365* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
366- 2005c
367  - updates for Israel and Paraguay
368
369* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
370- 2004g (#141107)
371  - updates for Cuba
372
373* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
374- 2004e (#135194)
375  - updates for Brazil, Uruguay and Argentina
376
377* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
378- 2004b
379
380* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
381- 2003d
382
383* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
384- 2003c
385- updates for Brazil (#104840)
386
387* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
388- rebuilt
389
390* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
391- initial package
Note: See TracBrowser for help on using the repository browser.