source: projects/specs/trunk/t/transmission/transmission-vl.spec @ 10468

Revision 10468, 15.7 KB checked in by tomop, 8 years ago (diff)

transmission-2.84-2

Line 
1Name:           transmission
2Version:        2.84
3Release:        2%{?_dist_release}
4Summary:        A lightweight BitTorrent client
5Summary(ja):    軽量な BitTorrent クライアント
6
7Group:          Applications/Internet
8License:        MIT and GPLv2+
9URL:            http://www.transmissionbt.com/
10Source0:        http://download.m0k.org/transmission/files/transmission-%{version}.tar.xz
11Source1:        transmission-daemon-init
12#Patch0:         desktop_fix.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  openssl-devel
17BuildRequires:  curl-devel >= 7.18.0
18BuildRequires:  dbus-glib-devel
19BuildRequires:  glib2-devel >= 2.28.0
20BuildRequires:  libnotify-devel
21BuildRequires:  gtk3-devel >= 3.2.0
22BuildRequires:  desktop-file-utils
23BuildRequires:  gettext >= 0.14.1
24BuildRequires:  intltool >= 0.40
25BuildRequires:  libcanberra-devel
26BuildRequires:  libevent-devel
27
28Requires: transmission-cli
29Requires: transmission-gtk
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: kudoh
34
35%description
36Transmission is a free, lightweight BitTorrent client. It features a
37simple, intuitive interface on top on an efficient, cross-platform
38back-end.
39
40%description -l ja
41Transmission はフリーで軽量な BitTorrent クライアントです。
42シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
43
44
45%package common
46Summary: Common files for Transmission BitTorrent client
47Summary(ja): Transmission BitTorrent クライアントの共通ファイル
48Group: Applications/Internet
49Obsoletes:      transmission =< 1.83
50
51%description common
52Transmission is a free, lightweight BitTorrent client. This package
53contains the common files used by the different front-ends.
54
55%description -l ja common
56Transmission はフリーで軽量な BitTorrent クライアントです。
57このパッケージは異なるフロントエンドにより使用される
58共通ファイルを含みます。
59
60%package cli
61Summary:       Transmission command line implementation
62Summary(ja):   Transmission のコマンドライン実装
63Group:         Applications/Internet
64Requires:      transmission-common
65Provides:      transmission = %{version}-%{release}
66
67%description cli
68Command line version of Transmission BitTorrent client.
69
70%description cli -l ja
71Transmission BitTorrent クライアントのコマンドライン版です。
72
73%package daemon
74Summary:       Transmission daemon
75Summary(ja):   Transmission デーモン
76Group:         Applications/Internet
77Requires:      transmission-common
78Requires(pre): shadow-utils
79Requires(post): chkconfig
80Requires(preun): chkconfig
81Requires(preun): initscripts
82Requires(postun): initscripts
83Provides:      transmission = %{version}-%{release}
84
85%description daemon
86Transmission BitTorrent client daemon.
87
88%description daemon -l ja
89Transmission BitTorrent クライアントデーモンです。
90
91%package gtk
92Summary: GTK Interface for Transmission BitTorrent client
93Summary(ja): Transmission BitTorrent client の GTK インターフェイス
94Group: Applications/Internet
95BuildRequires:  gtk3-devel >= 3.2.0
96
97Requires:       %{name}-common = %{version}
98Provides:       %{name} = %{version}-%{release}
99Provides:       %{name}-gui = %{version}-%{release}
100Obsoletes:      transmission =< 1.83
101
102%description gtk
103Transmission is a free, lightweight BitTorrent client. It features a
104simple, intuitive interface on top of an efficient back-end.
105
106This package provides the GTK Interface.
107
108%description -l ja gtk
109Transmission はフリーで軽量な BitTorrent クライアントです。
110シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
111
112このパッケージは GTK インターフェイスを提供します。
113
114%package qt
115Summary: Qt4 Interface for Transmission BitTorrent client
116Summary(ja): Transmission BitTorrent client の Qt4 インターフェイス
117Group: Applications/Internet
118Provides:       %{name}-gui = %{version}-%{release}
119Requires:       %{name}-common = %{version}
120BuildRequires:  qt4-devel qt4-designer
121
122%description qt
123Transmission is a simple BitTorrent client. It features a very simple,
124intuitive interface on top on an efficient, cross-platform back-end.
125
126This package contains QTransmission, a QT4 based GUI for Transmission
127loosely based on the GTK+ client.
128
129%description -l ja qt
130Transmission はフリーで軽量な BitTorrent クライアントです。
131シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
132
133このパッケージは QTransmission - GTK+ クライアントに概ね基づいた
134Transmission の QT4 ベース GUI - を含みます。
135
136%pre daemon
137getent group transmission >/dev/null || groupadd -r transmission
138getent passwd transmission >/dev/null || \
139useradd -r -g transmission -d /var/lib/transmission -s /sbin/nologin \
140        -c "transmission daemon account" transmission
141exit 0
142
143%prep
144%setup -q
145#sed -i "s/x-bittorrent;x-scheme-handler\/magnet;/x-bittorrent;/g" \
146#        gtk/transmission-gtk.desktop.in
147#sed -i "s/OnlyShowIn=Unity/OnlyShowIn=Unity;/g" \
148#        gtk/transmission-gtk.desktop.in
149#%patch0 -p1
150
151%build
152%configure --disable-static --enable-daemon \
153           --enable-utp --enable-nls --enable-cli
154make %{?_smp_mflags} CC=%{__cc}
155#make CFLAGS="$RPM_OPT_FLAGS"
156
157#for QT gui build
158pushd qt
159#%{_libdir}/qt4/bin/qmake qtr.pro
160%{_libdir}/qt4/bin/qmake QMAKE_LFLAGS="$RPM_LD_FLAGS" QMAKE_CXXFLAGS="$CXXFLAGS -std=c++11" qtr.pro
161make %{?_smp_mflags}
162popd
163
164%install
165rm -rf $RPM_BUILD_ROOT
166
167mkdir -p %{buildroot}%{_initddir}
168install -m755 %{SOURCE1} %{buildroot}%{_initddir}/transmission-daemon
169mkdir -p %{buildroot}/var/lib/transmission
170
171make install DESTDIR=$RPM_BUILD_ROOT
172make install INSTALL_ROOT=%{buildroot}%{_prefix} -C qt
173
174%find_lang %{name}-gtk
175
176desktop-file-install --vendor "" \
177        --delete-original \
178        --dir $RPM_BUILD_ROOT%{_datadir}/applications/ \
179        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-gtk.desktop
180
181mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
182cat > $RPM_BUILD_ROOT%{_datadir}/applications/transmission-qt.desktop << EOF
183[Desktop Entry]
184Encoding=UTF-8
185Name=Qtransmission Bittorrent Client
186Name[ja]=Qtransmission Bittorrent クライアント
187GenericName=BitTorrent Client
188GenericName[ja]=BitTorrent クライアント
189Comment=Download and share files over BitTorrent
190Comment[ja]=BitTorrent でファイルをダウンロード及び共有します
191Exec=transmission-qt %F
192Icon=transmission
193Terminal=false
194Type=Application
195MimeType=application/x-bittorrent;
196Categories=Network;FileTransfer;P2P;Qt;
197NotShowIn=GNOME;MATE;XFCE;LXDE;
198EOF
199
200%clean
201rm -rf $RPM_BUILD_ROOT
202
203%post daemon
204/sbin/chkconfig --add transmission-daemon
205
206
207%post gtk
208touch --no-create %{_datadir}/icons/hicolor || :
209%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
210update-desktop-database > /dev/null 2>&1 || :
211
212
213%postun gtk
214touch --no-create %{_datadir}/icons/hicolor || :
215%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
216update-desktop-database > /dev/null 2>&1 || :
217
218%preun daemon
219if [ $1 = 0 ] ; then
220    /sbin/service transmission-daemon stop >/dev/null 2>&1
221    /sbin/chkconfig --del transmission-daemon
222fi
223
224%postun daemon
225if [ "$1" -ge "1" ] ; then
226    /sbin/service transmission-daemon condrestart >/dev/null 2>&1 || :
227fi
228
229%files
230
231%files common
232%defattr(-, root, root, -)
233%doc AUTHORS COPYING NEWS README
234%{_bindir}/transmission-create
235%{_bindir}/transmission-edit
236%{_bindir}/transmission-remote
237%{_bindir}/transmission-show
238%{_datadir}/transmission/web/
239%{_datadir}/pixmaps/*
240%{_datadir}/icons/hicolor/*/apps/transmission.*
241%doc %{_mandir}/man1/transmission-create*
242%doc %{_mandir}/man1/transmission-edit*
243%doc %{_mandir}/man1/transmission-remote*
244%doc %{_mandir}/man1/transmission-show*
245
246%files cli
247%defattr(-, root, root, -)
248%{_bindir}/transmission-cli
249%doc %{_mandir}/man1/transmission-cli*
250
251%files daemon
252%defattr(-, root, root, -)
253%{_bindir}/transmission-daemon
254%{_initddir}/transmission-daemon
255%attr(-,transmission, transmission)/var/lib/transmission/
256%doc %{_mandir}/man1/transmission-daemon*
257
258%files gtk -f %{name}-gtk.lang
259%defattr(-,root,root)
260%{_bindir}/%{name}-gtk
261%{_datadir}/applications/%{name}-gtk.desktop
262%{_mandir}/man1/transmission-gtk.1*
263
264%files qt
265%defattr(-,root,root)
266%{_bindir}/transmission-qt
267%{_datadir}/applications/transmission-qt.desktop
268%{_mandir}/man1/transmission-qt.1*
269
270%changelog
271* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.84-2
272- rebuilt with new toolchain.
273
274* Sun Jul 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.84-1
275- new upstream release
276- fixed qmake paramater
277- fixed License a little (GPLv2 to GPLv2+)
278
279* Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.81-1
280- new upstream release
281
282* Sat Jun 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.80-1
283- new upstream release
284
285* Sun Feb 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.77-1
286- new upstream release
287
288* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.76-1
289- new upstream release
290
291* Fri Dec 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.75-1
292- new upstream release
293
294* Thu Oct 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.73-1
295- new upstream release
296
297* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.72-1
298- new upstream release
299
300* Thu Sep 27 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.71-1
301- new upstream release
302- deleted Patch0
303- changed BuildRequires: gtk3-devel >= 3.4.0
304
305* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.61-1
306- new upstream release
307- deleted conditional branch for GTK+2
308  - because not supported GTK+2, GTK+3 only
309
310* Sat Jul 07 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.60-1
311- new upstream release
312
313* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.52-1
314- new upstream release
315- added patch0 to fix .desktop validate
316
317* Thu Apr 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.51-1
318- new upstream release
319- fixed conditional branch
320
321* Thu Feb 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.50-1
322- new upstream release
323- deleted unrecognized option: --enable-gtk
324- fixed transmission-qt desktop entry a little
325
326* Wed Nov 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.42-1
327- new upstream release
328- aded BuildRequires: gtk3-devel >= 3.2.0
329  - made conditional branch for Vine 6 (support for GTK+2)
330
331* Mon Oct 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.41-1
332- new upstream release
333- changed BuildRequires
334  - gtk2-devel >= 2.6.0 to gtk2-devel >= 2.22.0
335  - glib2-devel >= 2.28.0
336- deleted unrecognized option: --enable-libcanberra
337
338* Thu Aug 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.33-1
339- new upstream release
340- remove BuildRequires: GConf2-devel
341
342* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32-2
343- rebuild with libnotify-0.7
344
345* Sun Jul 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.32-1
346- new upstream release
347
348* Thu May 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.31-1
349- new upstream release
350- suppressed warning in installing desktop file
351- added configure option
352  --enable-utp, --enable-nls, --enable-cli, --enable-daemon
353
354* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
355- update to 2.22
356
357* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.20-1
358- Update to upstream 2.20
359
360* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-2
361- rebuilt with openssl-1.0.0c
362
363* Sat Dec 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-1
364- Update to upstream 2.13
365- deleted disable option
366- added configure option --enable-gtk
367
368* Mon Nov 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.12-1
369- Update to upstream 2.12
370
371* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.11-1
372- Update to upstream 2.11
373
374* Thu Oct 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-2
375- fixed and changed transmission-qt.desktop
376  - did not show transmission-qt.desktop in LXDE
377
378* Mon Oct 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-1
379- Update to upstream 2.10
380
381* Mon Aug 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.04-1
382- Update to upstream 2.04
383
384* Fri Jul 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.03-1
385- Update to upstream 2.03
386
387* Fri Jul 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.01-1
388- Update to upstream 2.01
389
390* Fri Jun 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00-1
391- Update to upstream 2.00
392
393* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.93-1
394- Update to upstream 1.93
395
396* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.92-1
397- Update to upstream 1.92
398- applied new naming policy to spec
399
400* Mon Feb 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.91-1
401- Update to upstream 1.91
402- changed summary, summary(ja) a little
403- added %configure option --enable-libcanberra --enable-daemon
404- added Source1 from Fedora
405- splitted common, cli, daemon, gtk, qt packages
406
407* Sat Jan 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.83-1
408- Update to upstream 1.83
409- added BuildRequires:  libcanberra-devel, libevent-devel
410
411* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.82-1
412- Update to upstream 1.82
413
414* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.80-1
415- Update to upstream 1.80
416- changed BuildRequires: intltool >= 0.40
417
418* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.77-1
419- Update to upstream 1.77
420- dropt Patch1
421- aded BuildRequires:  GConf2-devel
422
423* Mon Oct 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.76-1
424- Update to upstream 1.76
425
426* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-2
427- a few fixed transmission_ja_po.patch
428- added --disable-static=no to configure option
429- run gtk-update-icon-cache in %post, %postun
430- cleaned up spec
431
432* Tue Sep 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-1
433- Update to upstream 1.75
434
435* Sun Jul 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.73-1
436- Update to upstream 1.73
437
438* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.72-1
439- Update to upstream 1.72
440- cleaned up spec
441
442* Tue Jun 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.71-1
443- Update to upstream 1.71
444
445* Sat Jun 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.70-1
446- Update to upstream 1.70
447
448* Tue May 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.61-1
449- Update to upstream 1.61
450- added BuildRequires:  glib2-devel
451
452* Wed May 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.60-1
453- Update to upstream 1.60
454- spec in UTF-8
455
456* Mon Apr 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.52-1
457- Update to upstream 1.52
458- fixed Desktop-file name
459- fixed BuildRoot
460
461* Sat Feb 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.51-1
462- Update to upstream 1.51
463- changed BuildRequires:  curl-devel >= 7.18.0
464- dropped Patch1
465
466* Sun Feb 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.50-1
467- Update to upstream 1.50
468
469* Thu Jan 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-2
470- added Summary(ja)
471- fixed Lisense
472- added patch1 (transmission-1.42-libevent.patch, from Fedora)
473- fixed %build
474- changed %install
475- fixed %changelog
476
477* Sat Dec 27 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-1
478- initial build for VineSeed
479- Update to upstream 1.42
480- dropped Patch0 (transmission-0.71-manpath.patch)
481- added patch0 (transmission_ja_po.patch, to fix ja.po)
482- modified %files, %install
483- modified BuildRoot
484- added BuildRequires to curl-devel, dbus-glib-devel, libnotify-devel
485
486* Mon Feb 4 2008 Denis Leroy <denis@poolshark.org> - 1.04-1
487- Update to upstream 1.04
488- Modified Build-Require
489
490* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 0.80-1
491- Update to upstream 0.80
492
493* Wed May  2 2007 Denis Leroy <denis@poolshark.org> - 0.72-1
494- Update to 0.72
495- Added libevent BR
496
497* Wed Apr 25 2007 Denis Leroy <denis@poolshark.org> - 0.71-1
498- Update to 0.71
499- Removed custom desktop file
500- Added patch to fix manpath
501
502* Thu Sep 28 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-3
503- Added project icon
504- Honor cc variable
505
506* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
507- Removed ldconfig Requires
508
509* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
510- First version
511
Note: See TracBrowser for help on using the repository browser.