source: projects/specs/trunk/t/transmission/transmission-vl.spec @ 11906

Revision 11906, 15.9 KB checked in by ara_t, 5 years ago (diff)

transmission: update to 2.94

Line 
1Name:         transmission
2Version:  2.94
3Release:  1%{?_dist_release}
4Summary:  A lightweight BitTorrent client
5Summary(ja):  軽量な BitTorrent クライアント
6
7Group:          Applications/Internet
8License:  MIT and GPLv2+
9URL:          http://www.transmissionbt.com/
10# Source0:        http://download.m0k.org/transmission/files/transmission-%{version}.tar.xz
11# https://github.com/transmission/transmission
12Source0:        transmission-%{version}.tar.gz
13Source1:        transmission-daemon-init
14#Patch0:         desktop_fix.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  openssl-devel
19BuildRequires:  curl-devel >= 7.18.0
20BuildRequires:  dbus-glib-devel
21BuildRequires:  glib2-devel >= 2.28.0
22BuildRequires:  libnotify-devel
23BuildRequires:  gtk3-devel >= 3.2.0
24BuildRequires:  desktop-file-utils
25BuildRequires:  gettext >= 0.14.1
26BuildRequires:  intltool >= 0.40
27BuildRequires:  libcanberra-devel
28BuildRequires:  libevent-devel
29
30Requires: transmission-cli
31Requires: transmission-gtk
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: kudoh
36
37%description
38Transmission is a free, lightweight BitTorrent client. It features a
39simple, intuitive interface on top on an efficient, cross-platform
40back-end.
41
42%description -l ja
43Transmission はフリーで軽量な BitTorrent クライアントです。
44シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
45
46
47%package common
48Summary: Common files for Transmission BitTorrent client
49Summary(ja): Transmission BitTorrent クライアントの共通ファイル
50Group: Applications/Internet
51Obsoletes:  transmission =< 1.83
52
53%description common
54Transmission is a free, lightweight BitTorrent client. This package
55contains the common files used by the different front-ends.
56
57%description -l ja common
58Transmission はフリーで軽量な BitTorrent クライアントです。
59このパッケージは異なるフロントエンドにより使用される
60共通ファイルを含みます。
61
62%package cli
63Summary:       Transmission command line implementation
64Summary(ja):   Transmission のコマンドライン実装
65Group:         Applications/Internet
66Requires:      transmission-common
67Provides:      transmission = %{version}-%{release}
68
69%description cli
70Command line version of Transmission BitTorrent client.
71
72%description cli -l ja
73Transmission BitTorrent クライアントのコマンドライン版です。
74
75%package daemon
76Summary:       Transmission daemon
77Summary(ja):   Transmission デーモン
78Group:         Applications/Internet
79Requires:      transmission-common
80Requires(pre): shadow-utils
81Requires(post): chkconfig
82Requires(preun): chkconfig
83Requires(preun): initscripts
84Requires(postun): initscripts
85Provides:      transmission = %{version}-%{release}
86
87%description daemon
88Transmission BitTorrent client daemon.
89
90%description daemon -l ja
91Transmission BitTorrent クライアントデーモンです。
92
93%package gtk
94Summary: GTK Interface for Transmission BitTorrent client
95Summary(ja): Transmission BitTorrent client の GTK インターフェイス
96Group: Applications/Internet
97BuildRequires:  gtk3-devel >= 3.2.0
98
99Requires: %{name}-common = %{version}
100Provides: %{name} = %{version}-%{release}
101Provides: %{name}-gui = %{version}-%{release}
102Obsoletes:  transmission =< 1.83
103
104%description gtk
105Transmission is a free, lightweight BitTorrent client. It features a
106simple, intuitive interface on top of an efficient back-end.
107
108This package provides the GTK Interface.
109
110%description -l ja gtk
111Transmission はフリーで軽量な BitTorrent クライアントです。
112シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
113
114このパッケージは GTK インターフェイスを提供します。
115
116%package qt
117Summary: Qt4 Interface for Transmission BitTorrent client
118Summary(ja): Transmission BitTorrent client の Qt4 インターフェイス
119Group: Applications/Internet
120Provides: %{name}-gui = %{version}-%{release}
121Requires: %{name}-common = %{version}
122BuildRequires:  qt4-devel qt4-designer
123
124%description qt
125Transmission is a simple BitTorrent client. It features a very simple,
126intuitive interface on top on an efficient, cross-platform back-end.
127
128This package contains QTransmission, a QT4 based GUI for Transmission
129loosely based on the GTK+ client.
130
131%description -l ja qt
132Transmission はフリーで軽量な BitTorrent クライアントです。
133シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
134
135このパッケージは QTransmission - GTK+ クライアントに概ね基づいた
136Transmission の QT4 ベース GUI - を含みます。
137
138%pre daemon
139getent group transmission >/dev/null || groupadd -r transmission
140getent passwd transmission >/dev/null || \
141useradd -r -g transmission -d /var/lib/transmission -s /sbin/nologin \
142        -c "transmission daemon account" transmission
143exit 0
144
145%prep
146%setup -q
147#sed -i "s/x-bittorrent;x-scheme-handler\/magnet;/x-bittorrent;/g" \
148#        gtk/transmission-gtk.desktop.in
149#sed -i "s/OnlyShowIn=Unity/OnlyShowIn=Unity;/g" \
150#        gtk/transmission-gtk.desktop.in
151#%patch0 -p1
152
153%build
154./autogen.sh
155%configure --disable-static --enable-daemon \
156           --enable-utp --enable-nls --enable-cli
157make %{?_smp_mflags} CC=%{__cc}
158#make CFLAGS="$RPM_OPT_FLAGS"
159
160#for QT gui build
161pushd qt
162#%{_libdir}/qt4/bin/qmake qtr.pro
163%{_libdir}/qt4/bin/qmake QMAKE_LFLAGS="$RPM_LD_FLAGS" QMAKE_CXXFLAGS="$CXXFLAGS -std=c++11" qtr.pro
164make %{?_smp_mflags}
165popd
166
167%install
168rm -rf $RPM_BUILD_ROOT
169
170mkdir -p %{buildroot}%{_initddir}
171install -m755 %{SOURCE1} %{buildroot}%{_initddir}/transmission-daemon
172mkdir -p %{buildroot}/var/lib/transmission
173
174make install DESTDIR=$RPM_BUILD_ROOT
175make install INSTALL_ROOT=%{buildroot}%{_prefix} -C qt
176
177%find_lang %{name}-gtk
178
179desktop-file-install --vendor "" \
180        --delete-original \
181        --dir $RPM_BUILD_ROOT%{_datadir}/applications/ \
182        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-gtk.desktop
183
184mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
185cat > $RPM_BUILD_ROOT%{_datadir}/applications/transmission-qt.desktop << EOF
186[Desktop Entry]
187Encoding=UTF-8
188Name=Qtransmission Bittorrent Client
189Name[ja]=Qtransmission Bittorrent クライアント
190GenericName=BitTorrent Client
191GenericName[ja]=BitTorrent クライアント
192Comment=Download and share files over BitTorrent
193Comment[ja]=BitTorrent でファイルをダウンロード及び共有します
194Exec=transmission-qt %F
195Icon=transmission
196Terminal=false
197Type=Application
198MimeType=application/x-bittorrent;
199Categories=Network;FileTransfer;P2P;Qt;
200NotShowIn=GNOME;MATE;XFCE;LXDE;
201EOF
202
203%clean
204rm -rf $RPM_BUILD_ROOT
205
206%post daemon
207/sbin/chkconfig --add transmission-daemon
208
209
210%post gtk
211touch --no-create %{_datadir}/icons/hicolor || :
212%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
213update-desktop-database > /dev/null 2>&1 || :
214
215
216%postun gtk
217touch --no-create %{_datadir}/icons/hicolor || :
218%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
219update-desktop-database > /dev/null 2>&1 || :
220
221%preun daemon
222if [ $1 = 0 ] ; then
223    /sbin/service transmission-daemon stop >/dev/null 2>&1
224    /sbin/chkconfig --del transmission-daemon
225fi
226
227%postun daemon
228if [ "$1" -ge "1" ] ; then
229    /sbin/service transmission-daemon condrestart >/dev/null 2>&1 || :
230fi
231
232%files
233
234%files common
235%defattr(-, root, root, -)
236%doc AUTHORS COPYING NEWS README
237%{_bindir}/transmission-create
238%{_bindir}/transmission-edit
239%{_bindir}/transmission-remote
240%{_bindir}/transmission-show
241%{_datadir}/transmission/web/
242%{_datadir}/pixmaps/*
243%{_datadir}/icons/hicolor/*/apps/transmission.*
244%doc %{_mandir}/man1/transmission-create*
245%doc %{_mandir}/man1/transmission-edit*
246%doc %{_mandir}/man1/transmission-remote*
247%doc %{_mandir}/man1/transmission-show*
248
249%files cli
250%defattr(-, root, root, -)
251%{_bindir}/transmission-cli
252%doc %{_mandir}/man1/transmission-cli*
253
254%files daemon
255%defattr(-, root, root, -)
256%{_bindir}/transmission-daemon
257%{_initddir}/transmission-daemon
258%attr(-,transmission, transmission)/var/lib/transmission/
259%doc %{_mandir}/man1/transmission-daemon*
260
261%files gtk -f %{name}-gtk.lang
262%defattr(-,root,root)
263%{_bindir}/%{name}-gtk
264%{_datadir}/applications/%{name}-gtk.desktop
265%{_mandir}/man1/transmission-gtk.1*
266
267%files qt
268%defattr(-,root,root)
269%{_bindir}/transmission-qt
270%{_datadir}/applications/transmission-qt.desktop
271%{_mandir}/man1/transmission-qt.1*
272
273%changelog
274* Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> - 2.94-1
275- new upstream release
276
277* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.84-2
278- rebuilt with new toolchain.
279
280* Sun Jul 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.84-1
281- new upstream release
282- fixed qmake paramater
283- fixed License a little (GPLv2 to GPLv2+)
284
285* Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.81-1
286- new upstream release
287
288* Sat Jun 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.80-1
289- new upstream release
290
291* Sun Feb 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.77-1
292- new upstream release
293
294* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.76-1
295- new upstream release
296
297* Fri Dec 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.75-1
298- new upstream release
299
300* Thu Oct 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.73-1
301- new upstream release
302
303* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.72-1
304- new upstream release
305
306* Thu Sep 27 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.71-1
307- new upstream release
308- deleted Patch0
309- changed BuildRequires: gtk3-devel >= 3.4.0
310
311* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.61-1
312- new upstream release
313- deleted conditional branch for GTK+2
314  - because not supported GTK+2, GTK+3 only
315
316* Sat Jul 07 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.60-1
317- new upstream release
318
319* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.52-1
320- new upstream release
321- added patch0 to fix .desktop validate
322
323* Thu Apr 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.51-1
324- new upstream release
325- fixed conditional branch
326
327* Thu Feb 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.50-1
328- new upstream release
329- deleted unrecognized option: --enable-gtk
330- fixed transmission-qt desktop entry a little
331
332* Wed Nov 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.42-1
333- new upstream release
334- aded BuildRequires: gtk3-devel >= 3.2.0
335  - made conditional branch for Vine 6 (support for GTK+2)
336
337* Mon Oct 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.41-1
338- new upstream release
339- changed BuildRequires
340  - gtk2-devel >= 2.6.0 to gtk2-devel >= 2.22.0
341  - glib2-devel >= 2.28.0
342- deleted unrecognized option: --enable-libcanberra
343
344* Thu Aug 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.33-1
345- new upstream release
346- remove BuildRequires: GConf2-devel
347
348* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32-2
349- rebuild with libnotify-0.7
350
351* Sun Jul 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.32-1
352- new upstream release
353
354* Thu May 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.31-1
355- new upstream release
356- suppressed warning in installing desktop file
357- added configure option
358  --enable-utp, --enable-nls, --enable-cli, --enable-daemon
359
360* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
361- update to 2.22
362
363* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.20-1
364- Update to upstream 2.20
365
366* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-2
367- rebuilt with openssl-1.0.0c
368
369* Sat Dec 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-1
370- Update to upstream 2.13
371- deleted disable option
372- added configure option --enable-gtk
373
374* Mon Nov 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.12-1
375- Update to upstream 2.12
376
377* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.11-1
378- Update to upstream 2.11
379
380* Thu Oct 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-2
381- fixed and changed transmission-qt.desktop
382  - did not show transmission-qt.desktop in LXDE
383
384* Mon Oct 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-1
385- Update to upstream 2.10
386
387* Mon Aug 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.04-1
388- Update to upstream 2.04
389
390* Fri Jul 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.03-1
391- Update to upstream 2.03
392
393* Fri Jul 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.01-1
394- Update to upstream 2.01
395
396* Fri Jun 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00-1
397- Update to upstream 2.00
398
399* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.93-1
400- Update to upstream 1.93
401
402* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.92-1
403- Update to upstream 1.92
404- applied new naming policy to spec
405
406* Mon Feb 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.91-1
407- Update to upstream 1.91
408- changed summary, summary(ja) a little
409- added %configure option --enable-libcanberra --enable-daemon
410- added Source1 from Fedora
411- splitted common, cli, daemon, gtk, qt packages
412
413* Sat Jan 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.83-1
414- Update to upstream 1.83
415- added BuildRequires:  libcanberra-devel, libevent-devel
416
417* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.82-1
418- Update to upstream 1.82
419
420* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.80-1
421- Update to upstream 1.80
422- changed BuildRequires: intltool >= 0.40
423
424* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.77-1
425- Update to upstream 1.77
426- dropt Patch1
427- aded BuildRequires:  GConf2-devel
428
429* Mon Oct 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.76-1
430- Update to upstream 1.76
431
432* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-2
433- a few fixed transmission_ja_po.patch
434- added --disable-static=no to configure option
435- run gtk-update-icon-cache in %post, %postun
436- cleaned up spec
437
438* Tue Sep 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-1
439- Update to upstream 1.75
440
441* Sun Jul 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.73-1
442- Update to upstream 1.73
443
444* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.72-1
445- Update to upstream 1.72
446- cleaned up spec
447
448* Tue Jun 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.71-1
449- Update to upstream 1.71
450
451* Sat Jun 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.70-1
452- Update to upstream 1.70
453
454* Tue May 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.61-1
455- Update to upstream 1.61
456- added BuildRequires:  glib2-devel
457
458* Wed May 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.60-1
459- Update to upstream 1.60
460- spec in UTF-8
461
462* Mon Apr 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.52-1
463- Update to upstream 1.52
464- fixed Desktop-file name
465- fixed BuildRoot
466
467* Sat Feb 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.51-1
468- Update to upstream 1.51
469- changed BuildRequires:  curl-devel >= 7.18.0
470- dropped Patch1
471
472* Sun Feb 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.50-1
473- Update to upstream 1.50
474
475* Thu Jan 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-2
476- added Summary(ja)
477- fixed Lisense
478- added patch1 (transmission-1.42-libevent.patch, from Fedora)
479- fixed %build
480- changed %install
481- fixed %changelog
482
483* Sat Dec 27 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-1
484- initial build for VineSeed
485- Update to upstream 1.42
486- dropped Patch0 (transmission-0.71-manpath.patch)
487- added patch0 (transmission_ja_po.patch, to fix ja.po)
488- modified %files, %install
489- modified BuildRoot
490- added BuildRequires to curl-devel, dbus-glib-devel, libnotify-devel
491
492* Mon Feb 4 2008 Denis Leroy <denis@poolshark.org> - 1.04-1
493- Update to upstream 1.04
494- Modified Build-Require
495
496* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 0.80-1
497- Update to upstream 0.80
498
499* Wed May  2 2007 Denis Leroy <denis@poolshark.org> - 0.72-1
500- Update to 0.72
501- Added libevent BR
502
503* Wed Apr 25 2007 Denis Leroy <denis@poolshark.org> - 0.71-1
504- Update to 0.71
505- Removed custom desktop file
506- Added patch to fix manpath
507
508* Thu Sep 28 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-3
509- Added project icon
510- Honor cc variable
511
512* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
513- Removed ldconfig Requires
514
515* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
516- First version
517
Note: See TracBrowser for help on using the repository browser.