source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 1387

Revision 1387, 8.9 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
4Version: 0.8.15
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
10Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
11
12Patch0: tracker-ldfind.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15BuildRequires: gmime-devel >= 2.4, poppler-devel, gettext, file
16BuildRequires: gnome-desktop-devel, gamin-devel
17BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
18BuildRequires: gstreamer-devel
19BuildRequires: desktop-file-utils, intltool
20BuildRequires: raptor-devel >= 1.4.18
21BuildRequires: sqlite3-devel
22BuildRequires: dbus-devel >= 1.0
23BuildRequires: dbus-glib-devel >= 0.73
24BuildRequires: libgnome-devel >= 2.13.2
25BuildRequires: libgnomeui-devel >= 2.13.7
26BuildRequires: libSM-devel
27BuildRequires: libnotify-devel >= 0.4.3
28BuildRequires: libuuid-devel
29BuildRequires: vala-devel
30BuildRequires: libgee-devel
31BuildRequires: upower-devel
32BuildRequires: gnome-applets
33## BuildRequires: autoconf, automake
34
35%description
36Tracker is a powerful desktop-neutral first class object database,
37tag/metadata database, search tool and indexer.
38
39It consists of a common object database that allows entities to have an
40almost infinte number of properties, metadata (both embedded/harvested as
41well as user definable), a comprehensive database of keywords/tags and
42links to other entities.
43
44It provides additional features for file based objects including context
45linking and audit trails for a file object.
46
47It has the ability to index, store, harvest metadata. retrieve and search 
48all types of files and other first class objects
49
50%package devel
51Summary: Headers for developing programs that will use %{name}
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: pkgconfig
55Requires: dbus-glib-devel
56
57%description devel
58This package contains the static libraries and header files needed for
59developing with tracker
60
61%package search-tool
62Summary: Tracker search tool(s)
63Group: User Interface/Desktops
64Requires: %{name} = %{version}-%{release}
65
66%description search-tool
67Graphical frontend to tracker search facilities. This has dependencies on
68GNOME libraries
69
70%prep
71%setup -q
72## %patch0 -p0 -b .ld
73
74# remove shebangs from the python files as none should be executable scripts
75## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
76
77%build
78libtoolize --force --copy
79intltoolize --copy --force
80autoreconf -i -f
81%configure --disable-static \
82           --enable-video-extractor=external \
83           --enable-tracker-search-tool
84
85# Disable rpath
86sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
87sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
88
89# make %{?_smp_mflags} fails
90# %__make
91make %{?_smp_mflags}
92
93                                                                               
94%install
95rm -rf %{buildroot}
96make DESTDIR=%{buildroot} install
97
98mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
99echo "%{_libdir}/tracker-0.8"   \
100        > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
101
102desktop-file-install --delete-original               \
103        --vendor=""                             \
104        --dir=%{buildroot}%{_datadir}/applications   \
105        %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
106
107rm -rf %{buildroot}%{_libdir}/*.{a,la}
108rm -rf %{buildroot}%{_datadir}/tracker-tests
109
110%find_lang %{name}
111
112%clean
113rm -rf %{buildroot}
114
115%post
116/sbin/ldconfig
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121 
122%postun
123/sbin/ldconfig
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x /usr/bin/gtk-update-icon-cache ]; then
126  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
127fi
128 
129%files -f %{name}.lang
130%defattr(-, root, root, -)
131%doc AUTHORS ChangeLog COPYING NEWS README
132## %doc %{_datadir}/gtk-doc/html/libtracker-common/
133## %doc %{_datadir}/gtk-doc/html/libtracker-module/
134%{_bindir}/tracker*
135%exclude %{_bindir}/tracker-search-tool
136%exclude %{_bindir}/tracker-preferences
137## %exclude %{_bindir}/tracker-applet
138%{_libexecdir}/tracker*
139%{_libdir}/*.so.*
140%{_libdir}/tracker-0.8/
141%{_datadir}/tracker/
142%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
143%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
144%{_sysconfdir}/xdg/autostart/tracker*.desktop
145%{_mandir}/*/tracker*.gz
146%exclude %{_mandir}/man1/tracker-search-bar.1.gz
147%exclude %{_mandir}/man1/tracker-preferences.1.gz
148%exclude %{_mandir}/man1/tracker-search-tool.1.gz
149
150%files devel
151%defattr(-, root, root, -)
152%{_includedir}/tracker-0.8/
153## %{_includedir}/libtracker-gtk/*
154%{_libdir}/*.so
155%{_libdir}/pkgconfig/*.pc
156%{_datadir}/vala/vapi/tracker*.vapi
157%{_datadir}/vala/vapi/tracker*.deps
158
159%files search-tool
160%defattr(-, root, root, -)
161%{_bindir}/tracker-search-tool
162%{_bindir}/tracker-preferences
163%{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
164%{_datadir}/icons/*/*/apps/tracker.*
165%{_datadir}/applications/*.desktop
166%{_mandir}/man1/tracker-search-bar.1.gz
167%{_mandir}/man1/tracker-preferences.1.gz
168%{_mandir}/man1/tracker-search-tool.1.gz
169
170
171%changelog
172* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
173- new upstream release
174
175* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
176- new upstream release
177- fix URL of Source0
178
179* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
180- new upstream release
181
182* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
183- new upstream release
184
185* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
186- new upstream release
187- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
188
189* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
190- new upstream release
191
192* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
193- new upstream release
194- add BuildRequires: upower-devel, gnome-applets
195- change BuildRequires: dbus-glib -> dbus-glib-devel
196
197* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
198- new upstream release
199- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
200- fix BuildRequires: gmime-devel >= 2.4
201- add configure option (--enable-tracker-search-tool)
202
203* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
204- new upstream release
205
206* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
207- rebuild with poppler-0.10.2
208- spec in UTF-8
209
210* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
211- new upstream release
212- update Patch1
213- drop Patch10 (no more necessary)
214- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
215- remove --enable-external-sqlite option (no more bundled sqlite exist)
216- apply new versioning policy
217
218* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
219- new upstream release
220
221* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
222- add Patch10 to fix selecting video-extractor
223- use external video extractor(totem) instead of gstreamer/xine
224
225* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
226- initial build for Vine Linux
227
228* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
229- Ship both autostart desktop files in the main package (BZ #233323)
230
231* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
232- Package the deskbar plugin properly (BZ #228308)
233
234* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
235- Split out tracker-search-tool sub-packages, for the GUI facility
236- Add proper requires for the -devel subpackage
237- Deal with the rpmlint complaints on rpath
238
239* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
240- Update to 0.5.4
241
242* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
243- Update to 0.5.3
244
245* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
246- Apply patch on Makefile.am instead of Makefile.in
247- Add libtool to BR
248
249* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
250- Update to 0.5.2
251
252* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
253- Update to new version
254
255* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
256- Have the devel subpackage require pkgconfig
257- Make the description field not have more than 76 characters on a line
258- Fix up the RPM group
259
260* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
261- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
262
263* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
264- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
265
266* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
267- Add autostart desktop file.
268- Edit the package description as suggested in review
269
270* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
271- More cleaups to the spec file.
272
273* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
274- Add needed BRs
275
276* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
277- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.