source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 1638

Revision 1638, 9.3 KB checked in by Takemikaduchi, 14 years ago (diff)

tracker: new upstream release, python-crypto: change %files, libgexiv2: add Requires

Line 
1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
4Version: 0.8.16
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
10Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
11
12Patch0: tracker-ldfind.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15BuildRequires: glib2-devel >= 2.24.0
16BuildRequires: gtk2-devel >= 2.20.0
17BuildRequires: gnome-panel-devel
18BuildRequires: gmime-devel >= 2.4, poppler-devel, gettext, file
19BuildRequires: gnome-desktop-devel, gamin-devel
20BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
21BuildRequires: gstreamer-devel
22BuildRequires: desktop-file-utils, intltool
23BuildRequires: raptor-devel >= 1.4.18
24BuildRequires: sqlite3-devel
25BuildRequires: dbus-devel >= 1.0
26BuildRequires: dbus-glib-devel >= 0.78
27BuildRequires: libgnome-devel >= 2.13.2
28BuildRequires: libgnomeui-devel >= 2.13.7
29BuildRequires: libSM-devel
30BuildRequires: libnotify-devel >= 0.4.3
31BuildRequires: libuuid-devel
32BuildRequires: vala-devel
33BuildRequires: libgee-devel
34BuildRequires: upower-devel
35BuildRequires: gnome-applets
36BuildRequires: libgee-devel >= 0.3
37## BuildRequires: autoconf, automake
38
39%description
40Tracker is a powerful desktop-neutral first class object database,
41tag/metadata database, search tool and indexer.
42
43It consists of a common object database that allows entities to have an
44almost infinte number of properties, metadata (both embedded/harvested as
45well as user definable), a comprehensive database of keywords/tags and
46links to other entities.
47
48It provides additional features for file based objects including context
49linking and audit trails for a file object.
50
51It has the ability to index, store, harvest metadata. retrieve and search 
52all types of files and other first class objects
53
54%package devel
55Summary: Headers for developing programs that will use %{name}
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: pkgconfig
59Requires: dbus-glib-devel
60
61%description devel
62This package contains the static libraries and header files needed for
63developing with tracker
64
65%package search-tool
66Summary: Tracker search tool(s)
67Group: User Interface/Desktops
68Requires: %{name} = %{version}-%{release}
69
70%description search-tool
71Graphical frontend to tracker search facilities. This has dependencies on
72GNOME libraries
73
74%prep
75%setup -q
76## %patch0 -p0 -b .ld
77
78# remove shebangs from the python files as none should be executable scripts
79## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
80
81%build
82## libtoolize --force --copy
83## intltoolize --copy --force
84## autoreconf -i -f
85%configure --disable-static \
86           --enable-video-extractor=external \
87           --enable-tracker-search-tool=yes \
88           --enable-tracker-search-bar=yes
89
90# Disable rpath
91sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
92sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
93
94# make %{?_smp_mflags} fails
95# %__make
96make %{?_smp_mflags}
97
98                                                                               
99%install
100rm -rf %{buildroot}
101make DESTDIR=%{buildroot} install
102
103mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
104echo "%{_libdir}/tracker-0.8"   \
105        > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
106
107desktop-file-install --delete-original               \
108        --vendor=""                             \
109        --dir=%{buildroot}%{_datadir}/applications   \
110        %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
111
112rm -rf %{buildroot}%{_libdir}/*.{a,la}
113rm -rf %{buildroot}%{_datadir}/tracker-tests
114
115%find_lang %{name}
116
117%clean
118rm -rf %{buildroot}
119
120%post
121/sbin/ldconfig
122touch --no-create %{_datadir}/icons/hicolor
123if [ -x /usr/bin/gtk-update-icon-cache ]; then
124  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
125fi
126 
127%postun
128/sbin/ldconfig
129touch --no-create %{_datadir}/icons/hicolor
130if [ -x /usr/bin/gtk-update-icon-cache ]; then
131  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
132fi
133 
134%files -f %{name}.lang
135%defattr(-, root, root, -)
136%doc AUTHORS ChangeLog COPYING NEWS README
137### %doc %{_datadir}/gtk-doc/html/libtracker-common/
138### %doc %{_datadir}/gtk-doc/html/libtracker-module/
139%{_bindir}/tracker*
140%exclude %{_bindir}/tracker-search-tool
141%exclude %{_bindir}/tracker-preferences
142### %exclude %{_bindir}/tracker-applet
143%{_libexecdir}/tracker*
144%{_libdir}/*.so.*
145%{_libdir}/tracker-0.8/
146%{_datadir}/tracker/
147%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
148%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
149%{_sysconfdir}/xdg/autostart/tracker*.desktop
150%{_mandir}/*/tracker*.gz
151%exclude %{_mandir}/man1/tracker-search-bar.1.gz
152%exclude %{_mandir}/man1/tracker-preferences.1.gz
153%exclude %{_mandir}/man1/tracker-search-tool.1.gz
154
155%files devel
156%defattr(-, root, root, -)
157%{_includedir}/tracker-0.8/
158### %{_includedir}/libtracker-gtk/*
159%{_libdir}/*.so
160%{_libdir}/pkgconfig/*.pc
161%{_datadir}/vala/vapi/tracker*.vapi
162%{_datadir}/vala/vapi/tracker*.deps
163
164%files search-tool
165%defattr(-, root, root, -)
166%{_bindir}/tracker-search-tool
167%{_bindir}/tracker-preferences
168%{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
169%{_datadir}/icons/*/*/apps/tracker.*
170%{_datadir}/applications/*.desktop
171%{_mandir}/man1/tracker-search-bar.1.gz
172%{_mandir}/man1/tracker-preferences.1.gz
173%{_mandir}/man1/tracker-search-tool.1.gz
174
175
176%changelog
177* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
178- new upstream release
179- add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
180- add configure option (--enable-tracker-search-bar)
181
182* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
183- new upstream release
184
185* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
186- new upstream release
187- fix URL of Source0
188
189* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
190- new upstream release
191
192* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
193- new upstream release
194
195* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
196- new upstream release
197- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
198
199* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
200- new upstream release
201
202* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
203- new upstream release
204- add BuildRequires: upower-devel, gnome-applets
205- change BuildRequires: dbus-glib -> dbus-glib-devel
206
207* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
208- new upstream release
209- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
210- fix BuildRequires: gmime-devel >= 2.4
211- add configure option (--enable-tracker-search-tool)
212
213* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
214- new upstream release
215
216* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
217- rebuild with poppler-0.10.2
218- spec in UTF-8
219
220* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
221- new upstream release
222- update Patch1
223- drop Patch10 (no more necessary)
224- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
225- remove --enable-external-sqlite option (no more bundled sqlite exist)
226- apply new versioning policy
227
228* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
229- new upstream release
230
231* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
232- add Patch10 to fix selecting video-extractor
233- use external video extractor(totem) instead of gstreamer/xine
234
235* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
236- initial build for Vine Linux
237
238* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
239- Ship both autostart desktop files in the main package (BZ #233323)
240
241* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
242- Package the deskbar plugin properly (BZ #228308)
243
244* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
245- Split out tracker-search-tool sub-packages, for the GUI facility
246- Add proper requires for the -devel subpackage
247- Deal with the rpmlint complaints on rpath
248
249* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
250- Update to 0.5.4
251
252* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
253- Update to 0.5.3
254
255* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
256- Apply patch on Makefile.am instead of Makefile.in
257- Add libtool to BR
258
259* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
260- Update to 0.5.2
261
262* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
263- Update to new version
264
265* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
266- Have the devel subpackage require pkgconfig
267- Make the description field not have more than 76 characters on a line
268- Fix up the RPM group
269
270* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
271- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
272
273* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
274- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
275
276* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
277- Add autostart desktop file.
278- Edit the package description as suggested in review
279
280* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
281- More cleaups to the spec file.
282
283* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
284- Add needed BRs
285
286* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
287- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.