source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 4850

Revision 4850, 10.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

RevLine 
[521]1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
[4850]4Version: 0.12.3
[3801]5Release: 1%{?_dist_release}
[521]6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
[4812]10Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.12/tracker-%{version}.tar.xz
[521]11
[4850]12Patch0: tracker-0.12.3-sched.patch
13
[2998]14BuildRoot: %{_tmppath}/%{name}-%{version}-root
[1638]15BuildRequires: glib2-devel >= 2.24.0
[4616]16BuildRequires: gtk3-devel >= 3.0.0
[1638]17BuildRequires: gnome-panel-devel
[2998]18BuildRequires: gmime-devel >= 2.4
[4812]19BuildRequires: gstreamer-devel >= 0.10.31
20BuildRequires: gstreamer-plugins-base-devel >= 0.10.31
[2998]21BuildRequires: poppler-devel
22BuildRequires: gettext
23BuildRequires: file
[521]24BuildRequires: gnome-desktop-devel, gamin-devel
25BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
26BuildRequires: gstreamer-devel
27BuildRequires: desktop-file-utils, intltool
28BuildRequires: raptor-devel >= 1.4.18
29BuildRequires: sqlite3-devel
30BuildRequires: dbus-devel >= 1.0
[1638]31BuildRequires: dbus-glib-devel >= 0.78
[805]32BuildRequires: libgnome-devel >= 2.13.2
33BuildRequires: libgnomeui-devel >= 2.13.7
34BuildRequires: libSM-devel
35BuildRequires: libnotify-devel >= 0.4.3
36BuildRequires: libuuid-devel
[4812]37BuildRequires: NetworkManager-glib-devel
[805]38BuildRequires: vala-devel
39BuildRequires: libgee-devel
[912]40BuildRequires: upower-devel
41BuildRequires: gnome-applets
[1638]42BuildRequires: libgee-devel >= 0.3
[2998]43BuildRequires: nautilus-devel
[4616]44BuildRequires: libicu-devel
[805]45## BuildRequires: autoconf, automake
[521]46
[4616]47Vendor: Project Vine
48Distribution: Vine Linux
49
[521]50%description
51Tracker is a powerful desktop-neutral first class object database,
52tag/metadata database, search tool and indexer.
53
54It consists of a common object database that allows entities to have an
55almost infinte number of properties, metadata (both embedded/harvested as
56well as user definable), a comprehensive database of keywords/tags and
57links to other entities.
58
59It provides additional features for file based objects including context
60linking and audit trails for a file object.
61
62It has the ability to index, store, harvest metadata. retrieve and search 
63all types of files and other first class objects
64
65%package devel
66Summary: Headers for developing programs that will use %{name}
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: pkgconfig
70Requires: dbus-glib-devel
71
72%description devel
73This package contains the static libraries and header files needed for
74developing with tracker
75
76%package search-tool
77Summary: Tracker search tool(s)
78Group: User Interface/Desktops
79Requires: %{name} = %{version}-%{release}
80
81%description search-tool
82Graphical frontend to tracker search facilities. This has dependencies on
83GNOME libraries
84
85%prep
86%setup -q
[4850]87%patch0 -p1 -b .sched
[521]88
89# remove shebangs from the python files as none should be executable scripts
[805]90## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
[521]91
[4616]92sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
93
[521]94%build
[4812]95#libtoolize --force --copy
96#intltoolize --copy --force
97#autoreconf -if
[521]98%configure --disable-static \
[805]99           --enable-video-extractor=external \
[1638]100           --enable-tracker-search-tool=yes \
101           --enable-tracker-search-bar=yes
[521]102
103
[805]104make %{?_smp_mflags}
[521]105
106                                                                               
107%install
108rm -rf %{buildroot}
109make DESTDIR=%{buildroot} install
110
[1099]111mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
[4812]112echo "%{_libdir}/tracker-0.12"  \
[1099]113        > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
114
[521]115desktop-file-install --delete-original               \
116        --vendor=""                             \
117        --dir=%{buildroot}%{_datadir}/applications   \
[4616]118        %{buildroot}%{_datadir}/applications/%{name}-needle.desktop
[521]119
120rm -rf %{buildroot}%{_libdir}/*.{a,la}
[2998]121rm -f  %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
[912]122rm -rf %{buildroot}%{_datadir}/tracker-tests
[521]123
124%find_lang %{name}
125
126%clean
127rm -rf %{buildroot}
128
129%post
130/sbin/ldconfig
[2998]131touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
132
133%posttrans
134gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
[4812]135glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]136 
137%postun
138/sbin/ldconfig
[2998]139if [ $1 -eq 0 ] ; then
140    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
141    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
[4812]142    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]143fi
144 
145%files -f %{name}.lang
146%defattr(-, root, root, -)
147%doc AUTHORS ChangeLog COPYING NEWS README
[1638]148### %doc %{_datadir}/gtk-doc/html/libtracker-common/
149### %doc %{_datadir}/gtk-doc/html/libtracker-module/
[521]150%{_bindir}/tracker*
[4616]151%exclude %{_bindir}/tracker-needle
[521]152%exclude %{_bindir}/tracker-preferences
[1638]153### %exclude %{_bindir}/tracker-applet
[521]154%{_libexecdir}/tracker*
155%{_libdir}/*.so.*
[4616]156%{_libdir}/girepository-1.0/*.typelib
[4812]157%{_libdir}/tracker-0.12/
[521]158%{_datadir}/tracker/
[805]159%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
[4616]160%{_datadir}/dbus-1/services/org.gnome.panel.applet.SearchBarFactory.service
[4812]161%{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.*.xml
[4616]162%{_datadir}/gnome-panel/4.0/applets/org.gnome.panel.SearchBar.panel-applet
[1099]163%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
[805]164%{_sysconfdir}/xdg/autostart/tracker*.desktop
[521]165%{_mandir}/*/tracker*.gz
[805]166%exclude %{_mandir}/man1/tracker-search-bar.1.gz
167%exclude %{_mandir}/man1/tracker-preferences.1.gz
[4616]168%exclude %{_mandir}/man1/tracker-needle.1.gz
[521]169
170%files devel
171%defattr(-, root, root, -)
[4812]172%{_includedir}/tracker-0.12/
[1638]173### %{_includedir}/libtracker-gtk/*
[521]174%{_libdir}/*.so
175%{_libdir}/pkgconfig/*.pc
[805]176%{_datadir}/vala/vapi/tracker*.vapi
[1387]177%{_datadir}/vala/vapi/tracker*.deps
[4616]178%{_datadir}/gir-1.0/*.gir
[521]179
180%files search-tool
181%defattr(-, root, root, -)
[4616]182%{_bindir}/tracker-needle
[521]183%{_bindir}/tracker-preferences
[4616]184%{_libdir}/nautilus/extensions-3.0/*.so
[521]185%{_datadir}/icons/*/*/apps/tracker.*
186%{_datadir}/applications/*.desktop
[805]187%{_mandir}/man1/tracker-search-bar.1.gz
188%{_mandir}/man1/tracker-preferences.1.gz
[4616]189%{_mandir}/man1/tracker-needle.1.gz
[521]190
[805]191
[521]192%changelog
[4850]193* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
194- new upstream release
195- add Patch0 (tracker-0.12.3-sched.patch)
196
[4812]197* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
198- new upstream release
199- add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, NetworkManager-glib-devel
200- drop Patch0
201
[4704]202* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
203- new upstream release
204
[4650]205* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
206- new upstream release
207
[4616]208* Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
209- new upstream release
210- add BuildRequires: libicu-devel
211
[3801]212* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
213- new upstream release
214- add Patch0 (tracker-0.8.18-tracker_spawn.patch)
215- delete Patch1
216
[2998]217* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
218- rebuilt with poppler-0.16.3
219
[2041]220* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
221- rebuild with poppler-0.14.2
222
[1638]223* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
224- new upstream release
225- add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
226- add configure option (--enable-tracker-search-bar)
227
[1387]228* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
229- new upstream release
230
[1251]231* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
232- new upstream release
233- fix URL of Source0
234
[1231]235* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
236- new upstream release
237
[1198]238* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
239- new upstream release
240
[1099]241* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
242- new upstream release
243- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
244
[1018]245* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
246- new upstream release
247
[912]248* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
249- new upstream release
250- add BuildRequires: upower-devel, gnome-applets
251- change BuildRequires: dbus-glib -> dbus-glib-devel
252
[805]253* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
254- new upstream release
255- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
256- fix BuildRequires: gmime-devel >= 2.4
257- add configure option (--enable-tracker-search-tool)
258
[521]259* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
260- new upstream release
261
262* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
263- rebuild with poppler-0.10.2
264- spec in UTF-8
265
266* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
267- new upstream release
268- update Patch1
269- drop Patch10 (no more necessary)
270- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
271- remove --enable-external-sqlite option (no more bundled sqlite exist)
272- apply new versioning policy
273
274* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
275- new upstream release
276
277* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
278- add Patch10 to fix selecting video-extractor
279- use external video extractor(totem) instead of gstreamer/xine
280
281* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
282- initial build for Vine Linux
283
284* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
285- Ship both autostart desktop files in the main package (BZ #233323)
286
287* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
288- Package the deskbar plugin properly (BZ #228308)
289
290* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
291- Split out tracker-search-tool sub-packages, for the GUI facility
292- Add proper requires for the -devel subpackage
293- Deal with the rpmlint complaints on rpath
294
295* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
296- Update to 0.5.4
297
298* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
299- Update to 0.5.3
300
301* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
302- Apply patch on Makefile.am instead of Makefile.in
303- Add libtool to BR
304
305* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
306- Update to 0.5.2
307
308* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
309- Update to new version
310
311* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
312- Have the devel subpackage require pkgconfig
313- Make the description field not have more than 76 characters on a line
314- Fix up the RPM group
315
316* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
317- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
318
319* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
320- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
321
322* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
323- Add autostart desktop file.
324- Edit the package description as suggested in review
325
326* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
327- More cleaups to the spec file.
328
329* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
330- Add needed BRs
331
332* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
333- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.