source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 4812

Revision 4812, 10.6 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
4Version: 0.12.2
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
10Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.12/tracker-%{version}.tar.xz
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: glib2-devel >= 2.24.0
14BuildRequires: gtk3-devel >= 3.0.0
15BuildRequires: gnome-panel-devel
16BuildRequires: gmime-devel >= 2.4
17BuildRequires: gstreamer-devel >= 0.10.31
18BuildRequires: gstreamer-plugins-base-devel >= 0.10.31
19BuildRequires: poppler-devel
20BuildRequires: gettext
21BuildRequires: file
22BuildRequires: gnome-desktop-devel, gamin-devel
23BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
24BuildRequires: gstreamer-devel
25BuildRequires: desktop-file-utils, intltool
26BuildRequires: raptor-devel >= 1.4.18
27BuildRequires: sqlite3-devel
28BuildRequires: dbus-devel >= 1.0
29BuildRequires: dbus-glib-devel >= 0.78
30BuildRequires: libgnome-devel >= 2.13.2
31BuildRequires: libgnomeui-devel >= 2.13.7
32BuildRequires: libSM-devel
33BuildRequires: libnotify-devel >= 0.4.3
34BuildRequires: libuuid-devel
35BuildRequires: NetworkManager-glib-devel
36BuildRequires: vala-devel
37BuildRequires: libgee-devel
38BuildRequires: upower-devel
39BuildRequires: gnome-applets
40BuildRequires: libgee-devel >= 0.3
41BuildRequires: nautilus-devel
42BuildRequires: libicu-devel
43## BuildRequires: autoconf, automake
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48%description
49Tracker is a powerful desktop-neutral first class object database,
50tag/metadata database, search tool and indexer.
51
52It consists of a common object database that allows entities to have an
53almost infinte number of properties, metadata (both embedded/harvested as
54well as user definable), a comprehensive database of keywords/tags and
55links to other entities.
56
57It provides additional features for file based objects including context
58linking and audit trails for a file object.
59
60It has the ability to index, store, harvest metadata. retrieve and search 
61all types of files and other first class objects
62
63%package devel
64Summary: Headers for developing programs that will use %{name}
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67Requires: pkgconfig
68Requires: dbus-glib-devel
69
70%description devel
71This package contains the static libraries and header files needed for
72developing with tracker
73
74%package search-tool
75Summary: Tracker search tool(s)
76Group: User Interface/Desktops
77Requires: %{name} = %{version}-%{release}
78
79%description search-tool
80Graphical frontend to tracker search facilities. This has dependencies on
81GNOME libraries
82
83%prep
84%setup -q
85
86# remove shebangs from the python files as none should be executable scripts
87## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
88
89sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
90
91%build
92#libtoolize --force --copy
93#intltoolize --copy --force
94#autoreconf -if
95%configure --disable-static \
96           --enable-video-extractor=external \
97           --enable-tracker-search-tool=yes \
98           --enable-tracker-search-bar=yes
99
100
101make %{?_smp_mflags}
102
103                                                                               
104%install
105rm -rf %{buildroot}
106make DESTDIR=%{buildroot} install
107
108mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
109echo "%{_libdir}/tracker-0.12"  \
110        > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
111
112desktop-file-install --delete-original               \
113        --vendor=""                             \
114        --dir=%{buildroot}%{_datadir}/applications   \
115        %{buildroot}%{_datadir}/applications/%{name}-needle.desktop
116
117rm -rf %{buildroot}%{_libdir}/*.{a,la}
118rm -f  %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
119rm -rf %{buildroot}%{_datadir}/tracker-tests
120
121%find_lang %{name}
122
123%clean
124rm -rf %{buildroot}
125
126%post
127/sbin/ldconfig
128touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
129
130%posttrans
131gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
133 
134%postun
135/sbin/ldconfig
136if [ $1 -eq 0 ] ; then
137    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
138    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
139    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
140fi
141 
142%files -f %{name}.lang
143%defattr(-, root, root, -)
144%doc AUTHORS ChangeLog COPYING NEWS README
145### %doc %{_datadir}/gtk-doc/html/libtracker-common/
146### %doc %{_datadir}/gtk-doc/html/libtracker-module/
147%{_bindir}/tracker*
148%exclude %{_bindir}/tracker-needle
149%exclude %{_bindir}/tracker-preferences
150### %exclude %{_bindir}/tracker-applet
151%{_libexecdir}/tracker*
152%{_libdir}/*.so.*
153%{_libdir}/girepository-1.0/*.typelib
154%{_libdir}/tracker-0.12/
155%{_datadir}/tracker/
156%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
157%{_datadir}/dbus-1/services/org.gnome.panel.applet.SearchBarFactory.service
158%{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.*.xml
159%{_datadir}/gnome-panel/4.0/applets/org.gnome.panel.SearchBar.panel-applet
160%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
161%{_sysconfdir}/xdg/autostart/tracker*.desktop
162%{_mandir}/*/tracker*.gz
163%exclude %{_mandir}/man1/tracker-search-bar.1.gz
164%exclude %{_mandir}/man1/tracker-preferences.1.gz
165%exclude %{_mandir}/man1/tracker-needle.1.gz
166
167%files devel
168%defattr(-, root, root, -)
169%{_includedir}/tracker-0.12/
170### %{_includedir}/libtracker-gtk/*
171%{_libdir}/*.so
172%{_libdir}/pkgconfig/*.pc
173%{_datadir}/vala/vapi/tracker*.vapi
174%{_datadir}/vala/vapi/tracker*.deps
175%{_datadir}/gir-1.0/*.gir
176
177%files search-tool
178%defattr(-, root, root, -)
179%{_bindir}/tracker-needle
180%{_bindir}/tracker-preferences
181%{_libdir}/nautilus/extensions-3.0/*.so
182%{_datadir}/icons/*/*/apps/tracker.*
183%{_datadir}/applications/*.desktop
184%{_mandir}/man1/tracker-search-bar.1.gz
185%{_mandir}/man1/tracker-preferences.1.gz
186%{_mandir}/man1/tracker-needle.1.gz
187
188
189%changelog
190* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
191- new upstream release
192- add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, NetworkManager-glib-devel
193- drop Patch0
194
195* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
196- new upstream release
197
198* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
199- new upstream release
200
201* Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
202- new upstream release
203- add BuildRequires: libicu-devel
204
205* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
206- new upstream release
207- add Patch0 (tracker-0.8.18-tracker_spawn.patch)
208- delete Patch1
209
210* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
211- rebuilt with poppler-0.16.3
212
213* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
214- rebuild with poppler-0.14.2
215
216* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
217- new upstream release
218- add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
219- add configure option (--enable-tracker-search-bar)
220
221* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
222- new upstream release
223
224* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
225- new upstream release
226- fix URL of Source0
227
228* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
229- new upstream release
230
231* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
232- new upstream release
233
234* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
235- new upstream release
236- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
237
238* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
239- new upstream release
240
241* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
242- new upstream release
243- add BuildRequires: upower-devel, gnome-applets
244- change BuildRequires: dbus-glib -> dbus-glib-devel
245
246* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
247- new upstream release
248- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
249- fix BuildRequires: gmime-devel >= 2.4
250- add configure option (--enable-tracker-search-tool)
251
252* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
253- new upstream release
254
255* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
256- rebuild with poppler-0.10.2
257- spec in UTF-8
258
259* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
260- new upstream release
261- update Patch1
262- drop Patch10 (no more necessary)
263- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
264- remove --enable-external-sqlite option (no more bundled sqlite exist)
265- apply new versioning policy
266
267* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
268- new upstream release
269
270* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
271- add Patch10 to fix selecting video-extractor
272- use external video extractor(totem) instead of gstreamer/xine
273
274* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
275- initial build for Vine Linux
276
277* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
278- Ship both autostart desktop files in the main package (BZ #233323)
279
280* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
281- Package the deskbar plugin properly (BZ #228308)
282
283* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
284- Split out tracker-search-tool sub-packages, for the GUI facility
285- Add proper requires for the -devel subpackage
286- Deal with the rpmlint complaints on rpath
287
288* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
289- Update to 0.5.4
290
291* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
292- Update to 0.5.3
293
294* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
295- Apply patch on Makefile.am instead of Makefile.in
296- Add libtool to BR
297
298* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
299- Update to 0.5.2
300
301* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
302- Update to new version
303
304* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
305- Have the devel subpackage require pkgconfig
306- Make the description field not have more than 76 characters on a line
307- Fix up the RPM group
308
309* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
310- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
311
312* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
313- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
314
315* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
316- Add autostart desktop file.
317- Edit the package description as suggested in review
318
319* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
320- More cleaups to the spec file.
321
322* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
323- Add needed BRs
324
325* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
326- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.