source: projects/specs/trunk/t/totem/totem-vl.spec @ 9682

Revision 9682, 18.5 KB checked in by Takemikaduchi, 9 years ago (diff)

gom: NEW
ruby-mecab: rebuild
grilo-plugins,totem,clutter-gst3: add BR or R

Line 
1# define versions
2%define _glib_ver               2.44.0
3%define _gtk_ver                3.16.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.16.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.16.2
23Release:        3%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61
62BuildRequires:  clutter-gtk-devel
63BuildRequires:  clutter-gst3-devel
64
65BuildRequires:  nautilus-devel >= %{_nautilus_ver}
66BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
67
68
69Requires:       gstreamer1 >= %{_gst_ver}
70Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
71Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
72Requires:       iso-codes
73Requires:       grilo-plugins
74
75Obsoletes:      nautilus-media
76Obsoletes:      %{name}-gstreamer < 2.30.1-2
77Obsoletes:      %{name}-xine < 2.30.1-2
78Obsoletes:      %{name}-common < 2.30.1-3
79Obsoletes:      %{name}-mozilla < 3.14.0
80
81Provides:       nautilus-media
82Provides:       %{name}-common = %{version}-%{release}
83
84Requires(post):     ldconfig, desktop-file-utils
85Requires(postun):   ldconfig, desktop-file-utils
86
87%description
88Totem is simple movie player for the Gnome desktop. It features a
89simple playlist, a full-screen mode, seek and volume controls, as well as
90a pretty complete keyboard navigation.
91
92%package devel
93Summary:        Plugin writer's documentation for totem
94Group:          Development/Libraries
95Requires:       %{name} = %{version}-%{release}
96
97%description devel
98The %{name}-devel package contains API documentation for
99developing developing plugins for %{name}.
100
101%prep
102%setup -q
103
104%build
105#DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
106#export MOZILLA_PLUGINDIR=%{mozplug_dir}
107%configure \
108        --enable-python \
109        --enable-vala \
110        --enable-nautilus
111
112make %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117make install DESTDIR=$RPM_BUILD_ROOT
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
121%__rm -f %{buildroot}%{_libdir}/*.{a,la}
122%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
123%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
124%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
125%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
126%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
127
128# remove unused file
129%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
130%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
131 
132%find_lang %{name} --with-gnome
133
134# save space by linking identical images in translated docs
135helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
136for f in $helpdir/C/figures/*.png; do
137  b="$(basename $f)"
138  for d in $helpdir/*; do
139    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
140      g="$d/figures/$b"
141      if [ -f "$g" ]; then
142        if cmp -s $f $g; then
143          rm "$g"; ln -s "../../C/figures/$b" "$g"
144        fi
145      fi
146    fi
147  done
148done
149
150
151%clean
152%__rm -rf %{buildroot}
153
154%post
155%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
156touch %{_datadir}/icons/hicolor
157if [ -x /usr/bin/gtk-update-icon-cache ]; then
158  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
159fi
160
161%postun
162%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
163touch %{_datadir}/icons/hicolor
164if [ -x /usr/bin/gtk-update-icon-cache ]; then
165  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
166fi
167glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
168
169%posttrans
170glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
171
172%files -f %{name}.lang
173%defattr(-,root,root,-)
174%doc AUTHORS COPYING ChangeLog NEWS README TODO
175%{_bindir}/totem
176%{_bindir}/totem-audio-preview
177%{_bindir}/totem-video-thumbnailer
178%{_datadir}/GConf/gsettings/opensubtitles.convert
179#%{_datadir}/GConf/gsettings/pythonconsole.convert
180%{_datadir}/GConf/gsettings/totem.convert
181%{_datadir}/appdata/org.gnome.Totem.appdata.xml
182%{_datadir}/applications/org.gnome.Totem.desktop
183%{_datadir}/dbus-1/services/org.gnome.Totem.service
184%{_datadir}/glib-2.0/schemas/*.xml
185%{_datadir}/icons/*/*/*/*
186%{_datadir}/thumbnailers/totem.thumbnailer
187%{_datadir}/%{name}
188%{_datadir}/gtk-doc/html/totem
189%{_libdir}/libtotem.so.*
190%{_libdir}/girepository-1.0/*.typelib
191%dir %{_libdir}/totem
192%dir %{_libdir}/totem/plugins
193%{_libdir}/totem/plugins/apple-trailers/
194%{_libdir}/totem/plugins/autoload-subtitles
195%{_libdir}/totem/plugins/brasero-disc-recorder
196%{_libdir}/totem/plugins/dbus
197%{_libdir}/totem/plugins/gromit
198%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
199%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
200%{_libdir}/totem/plugins/lirc
201%{_libdir}/totem/plugins/media-player-keys
202%{_libdir}/totem/plugins/ontop
203%{_libdir}/totem/plugins/opensubtitles
204%{_libdir}/totem/plugins/properties
205%{_libdir}/totem/plugins/pythonconsole
206%{_libdir}/totem/plugins/recent
207%{_libdir}/totem/plugins/rotation
208%{_libdir}/totem/plugins/screensaver
209%{_libdir}/totem/plugins/screenshot
210%{_libdir}/totem/plugins/skipto
211%{_libdir}/totem/plugins/save-file/libsave-file.so
212%{_libdir}/totem/plugins/save-file/save-file.plugin
213%{_libdir}/totem/plugins/vimeo
214%{_libdir}/nautilus/extensions-3.0/*.so*
215%{_mandir}/man1/*
216
217%files devel
218%defattr(-, root, root,-)
219%{_includedir}/totem
220%{_libdir}/libtotem.so
221%{_libdir}/pkgconfig/totem.pc
222%{_datadir}/gir-1.0/Totem-1.0.gir
223%{_datadir}/gtk-doc/html/totem
224
225
226%changelog
227* Wed Jul 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
228- add Requires: grilo-plugins
229
230* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
231- remove BuildRequires: gstreamer1-plugins-bad-free-devel
232
233* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
234- new upstream release
235
236* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
237- new upstream release
238
239* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
240- new upstream release
241- change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
242
243* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
244- new upstream release
245
246* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
247- new upstream release
248
249* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
250- new upstream release
251- add BuildRequires: gnome-desktop3-devel
252- remove BuildRequires: xulrunner-devel
253- remove %%{name}-mozilla subpackage
254
255* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
256- new upstream release
257
258* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
259- new upstream release
260
261* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
262- new upstream release
263
264* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
265- rebuild with VineSeed environment
266
267* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
268- new upstream release
269
270* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
271- new upstream release
272
273* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
274- new upstream release
275- add BuildRequires: yelp-tools, vala
276- change configure option (--enable-vala)
277
278* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
279- new upstream release
280
281* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
282- new upstream release
283- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
284
285* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
286- new upstream release
287- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
288
289* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
290- new upstream release
291
292* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
293- add configure option (--disable-vegas-plugin)
294
295* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
296- new upstream release
297
298* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
299- new upstream release
300- add BuildRequires: pylint
301- remove BuildRequires: libgdata-devel
302
303* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
304- new upstream release
305
306* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
307- new upstream release
308
309* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
310- new upstream release
311- change BuildRequires: pygobject3-devel instead of pygobject-devel
312
313* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
314- new upstream release
315- change BuildRequires: gtk3-devel instead of gtk2-devel
316- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
317                     clutter-gst-devel, libmx-devel
318- change configure option (--disable-vala)
319
320* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
321- new upstream release
322- fix %files
323
324* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
325- new upstream release
326
327* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
328- clean up spec file
329- remove totem-common and merged to totem main package.
330  - add Obsoletes: totem-common
331- remove unneeded BR: and R:
332  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
333  - libmusicbrainz, alternatives
334- remove explicit dependency
335  - gtk2, glib2, dbus
336- add R: pygtk2, pyxdg, python-Coherence for python plugins
337- add R: gstreamer-plugins-good
338
339* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
340- rebuild with libgdata (add youtube plugin)
341- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
342- add Obsolete: totem-gstreamer, totem-xine)
343
344* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
345- new upstream release
346- chagnge _gst_ver from 0.10.19 to 0.10.29
347
348* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
349- new upstream release
350- drop totem-tracker package
351- add BuildRequires: unique-devel
352- remove BuildRequires: hal-devel
353- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
354
355* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
356- remove unneeded autoreconf
357- add BR: lirc
358
359* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
360- new upstream release
361
362* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
363- remove bemused plugin
364
365* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
366- new upstream release
367
368* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
369- added tracker video search sub-package
370
371* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
372- new upstream release
373
374* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
375- new upstream release
376
377* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
378- remove libxine dependency from totem-common
379- build xine backend with minimum dependency
380
381* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
382- add BR: bluez-libs-devel >= 4.15
383- fix typo in %%postun xine
384
385* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
386- rebuild with bluez-libs-devel-4.15
387
388* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
389- new upstream release
390
391* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
392- new upstream release
393
394* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
395- new upstream release
396- add patch1 to build with xulrunner-1.9
397
398* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
399- new upstream release
400
401* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
402- new upstream release
403- disabled devel package (replaced by totem-pl-parser-devel)
404
405* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
406- new upstream release
407- update version macros
408- enable browser plugins on x86_64
409
410* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
411- new upstream release
412
413* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
414- upstream release
415- drop obsolete ja.po.patch (patch0)
416- revert change of 1.4.4-0vl2
417
418* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
419- upstream release
420- enable browser plugins (exclude x86_64 arch)
421
422* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
423- upstream release
424
425* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
426- update configure options
427- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
428
429* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
430- fix mistranslation (patch0)
431- add icon symlink
432- add BuildRequires: gstreamer-plugins-good
433
434* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
435- upstream release
436- update %%_glib_ver, %%_xine_ver
437- add BuildRequires: hal
438- update %%configure options
439- update %%files
440
441* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
442- upstream release
443
444* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
445- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
446
447* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
448- upstream release
449- drop obsolete patch0
450
451* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
452- upstream release
453- add patch0 to build with intltool-0.35
454
455* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
456- upstream release
457
458* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
459- upstream release
460- update alternatives entry
461
462* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
463- upstream release
464- drop fix-sort-function.patch (was merged to upstream, #331426)
465
466* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
467- rebuild with gnome-2.14rc
468
469* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
470- upstream release
471- add macros
472  - _gtk_ver, _glib_ver
473  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
474  - _dbus_ver
475  - _gst_ver, gstpb_ver, _xine_ver
476- add fix-sort-function.patch to build with glib < 2.9.1
477
478* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
479- upstream release
480- add BuildRequires:
481  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
482  - gnome-vfs2-devel >= 2.9.92
483  - dbus-devel >= 0.35
484- use gstreamer-0.10 as backend for totem-gstreamer
485
486* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
487- use gstreamer08 instead of gstreamer
488
489* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
490- upstream release
491
492* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
493- fix missing links
494  - update file list
495  - update update-alternatives scripts
496- fix totem-gstreamer's %%postun script
497
498* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
499- upstream release
500- add BuildRequires: iso-codes, libmusicbrainz-devel
501- add Requires: iso-codes, libmusicbrains to -common package
502- remove BuildRequires: nautilus-cd-burner
503- remove Requires: nautilus-cd-burner from -common package
504
505* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
506- totem-gstreamer obsoletes nautilus-media
507
508* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
509- upstream release
510- add Requires(post,postun): alternatives for gstreamer,xine
511- add Requires(postun,triggers): alternatives for common
512
513* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
514- upstream release
515
516* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
517- build xine backend
518  - move common files to common package
519  - move GStreamer related files to gstreamer package
520  - install xine related files to xine package
521- fix scripts
522
523* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
524- upstream release
525- update URL
526- move *.{a,la} to devel package
527
528* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
529- fix %%{post,preun} script (video-thumbnail.schemas)
530- sync with Fedora Core's 1.0.1-1
531
532  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
533  - Update to upstream version 1.0.1
534  - Break out devel package
535
536* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
537- add %%{post,pre}un script
538
539* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
540- initial build for Vine Linux
541
542* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
543- fix %%post
544
545* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
546- Obsolete nautilus-media
547- Install property page and thumbnailer
548
549* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
550- Update to 0.101
551 
552* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
553- Grab patch totem-0.100-desktopfile.patch from CVS to fix
554  missing menu entry (144088)
555- Remove workaround for desktop file being misinstalled, fixed
556  by above patch
557
558* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
559- New upstream version 0.100
560
561* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
562- update to 0.99.22
563
564* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
565- Add patch to remove removed items from package from help
566
567* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
568- New upstream 0.99.19
569  - Fixes crasher with CD playback (see NEWS)
570
571* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
572- Call update-desktop-database in post
573
574* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
575- update to 0.99.18
576
577* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
578- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
579
Note: See TracBrowser for help on using the repository browser.