source: projects/specs/trunk/t/totem/totem-vl.spec @ 9668

Revision 9668, 18.4 KB checked in by Takemikaduchi, 9 years ago (diff)

fix BR & R

Line 
1# define versions
2%define _glib_ver               2.44.0
3%define _gtk_ver                3.16.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.16.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.16.2
23Release:        2%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61
62BuildRequires:  clutter-gtk-devel
63BuildRequires:  clutter-gst3-devel
64
65BuildRequires:  nautilus-devel >= %{_nautilus_ver}
66BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
67
68
69Requires:       gstreamer1 >= %{_gst_ver}
70Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
71Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
72Requires:       iso-codes
73
74Obsoletes:      nautilus-media
75Obsoletes:      %{name}-gstreamer < 2.30.1-2
76Obsoletes:      %{name}-xine < 2.30.1-2
77Obsoletes:      %{name}-common < 2.30.1-3
78Obsoletes:      %{name}-mozilla < 3.14.0
79
80Provides:       nautilus-media
81Provides:       %{name}-common = %{version}-%{release}
82
83Requires(post):     ldconfig, desktop-file-utils
84Requires(postun):   ldconfig, desktop-file-utils
85
86%description
87Totem is simple movie player for the Gnome desktop. It features a
88simple playlist, a full-screen mode, seek and volume controls, as well as
89a pretty complete keyboard navigation.
90
91%package devel
92Summary:        Plugin writer's documentation for totem
93Group:          Development/Libraries
94Requires:       %{name} = %{version}-%{release}
95
96%description devel
97The %{name}-devel package contains API documentation for
98developing developing plugins for %{name}.
99
100%prep
101%setup -q
102
103%build
104#DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
105#export MOZILLA_PLUGINDIR=%{mozplug_dir}
106%configure \
107        --enable-python \
108        --enable-vala \
109        --enable-nautilus
110
111make %{?_smp_mflags}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116make install DESTDIR=$RPM_BUILD_ROOT
117
118# remove unneeded files
119%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
120%__rm -f %{buildroot}%{_libdir}/*.{a,la}
121%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
122%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
123%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
124%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
125%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
126
127# remove unused file
128%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
129%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
130 
131%find_lang %{name} --with-gnome
132
133# save space by linking identical images in translated docs
134helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
135for f in $helpdir/C/figures/*.png; do
136  b="$(basename $f)"
137  for d in $helpdir/*; do
138    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
139      g="$d/figures/$b"
140      if [ -f "$g" ]; then
141        if cmp -s $f $g; then
142          rm "$g"; ln -s "../../C/figures/$b" "$g"
143        fi
144      fi
145    fi
146  done
147done
148
149
150%clean
151%__rm -rf %{buildroot}
152
153%post
154%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
155touch %{_datadir}/icons/hicolor
156if [ -x /usr/bin/gtk-update-icon-cache ]; then
157  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
158fi
159
160%postun
161%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
162touch %{_datadir}/icons/hicolor
163if [ -x /usr/bin/gtk-update-icon-cache ]; then
164  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
165fi
166glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
167
168%posttrans
169glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170
171%files -f %{name}.lang
172%defattr(-,root,root,-)
173%doc AUTHORS COPYING ChangeLog NEWS README TODO
174%{_bindir}/totem
175%{_bindir}/totem-audio-preview
176%{_bindir}/totem-video-thumbnailer
177%{_datadir}/GConf/gsettings/opensubtitles.convert
178#%{_datadir}/GConf/gsettings/pythonconsole.convert
179%{_datadir}/GConf/gsettings/totem.convert
180%{_datadir}/appdata/org.gnome.Totem.appdata.xml
181%{_datadir}/applications/org.gnome.Totem.desktop
182%{_datadir}/dbus-1/services/org.gnome.Totem.service
183%{_datadir}/glib-2.0/schemas/*.xml
184%{_datadir}/icons/*/*/*/*
185%{_datadir}/thumbnailers/totem.thumbnailer
186%{_datadir}/%{name}
187%{_datadir}/gtk-doc/html/totem
188%{_libdir}/libtotem.so.*
189%{_libdir}/girepository-1.0/*.typelib
190%dir %{_libdir}/totem
191%dir %{_libdir}/totem/plugins
192%{_libdir}/totem/plugins/apple-trailers/
193%{_libdir}/totem/plugins/autoload-subtitles
194%{_libdir}/totem/plugins/brasero-disc-recorder
195%{_libdir}/totem/plugins/dbus
196%{_libdir}/totem/plugins/gromit
197%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
198%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
199%{_libdir}/totem/plugins/lirc
200%{_libdir}/totem/plugins/media-player-keys
201%{_libdir}/totem/plugins/ontop
202%{_libdir}/totem/plugins/opensubtitles
203%{_libdir}/totem/plugins/properties
204%{_libdir}/totem/plugins/pythonconsole
205%{_libdir}/totem/plugins/recent
206%{_libdir}/totem/plugins/rotation
207%{_libdir}/totem/plugins/screensaver
208%{_libdir}/totem/plugins/screenshot
209%{_libdir}/totem/plugins/skipto
210%{_libdir}/totem/plugins/save-file/libsave-file.so
211%{_libdir}/totem/plugins/save-file/save-file.plugin
212%{_libdir}/totem/plugins/vimeo
213%{_libdir}/nautilus/extensions-3.0/*.so*
214%{_mandir}/man1/*
215
216%files devel
217%defattr(-, root, root,-)
218%{_includedir}/totem
219%{_libdir}/libtotem.so
220%{_libdir}/pkgconfig/totem.pc
221%{_datadir}/gir-1.0/Totem-1.0.gir
222%{_datadir}/gtk-doc/html/totem
223
224
225%changelog
226* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
227- remove BuildRequires: gstreamer1-plugins-bad-free-devel
228
229* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
230- new upstream release
231
232* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
233- new upstream release
234
235* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
236- new upstream release
237- change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
238
239* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
240- new upstream release
241
242* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
243- new upstream release
244
245* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
246- new upstream release
247- add BuildRequires: gnome-desktop3-devel
248- remove BuildRequires: xulrunner-devel
249- remove %%{name}-mozilla subpackage
250
251* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
252- new upstream release
253
254* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
255- new upstream release
256
257* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
258- new upstream release
259
260* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
261- rebuild with VineSeed environment
262
263* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
264- new upstream release
265
266* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
267- new upstream release
268
269* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
270- new upstream release
271- add BuildRequires: yelp-tools, vala
272- change configure option (--enable-vala)
273
274* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
275- new upstream release
276
277* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
278- new upstream release
279- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
280
281* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
282- new upstream release
283- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
284
285* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
286- new upstream release
287
288* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
289- add configure option (--disable-vegas-plugin)
290
291* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
292- new upstream release
293
294* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
295- new upstream release
296- add BuildRequires: pylint
297- remove BuildRequires: libgdata-devel
298
299* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
300- new upstream release
301
302* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
303- new upstream release
304
305* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
306- new upstream release
307- change BuildRequires: pygobject3-devel instead of pygobject-devel
308
309* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
310- new upstream release
311- change BuildRequires: gtk3-devel instead of gtk2-devel
312- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
313                     clutter-gst-devel, libmx-devel
314- change configure option (--disable-vala)
315
316* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
317- new upstream release
318- fix %files
319
320* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
321- new upstream release
322
323* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
324- clean up spec file
325- remove totem-common and merged to totem main package.
326  - add Obsoletes: totem-common
327- remove unneeded BR: and R:
328  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
329  - libmusicbrainz, alternatives
330- remove explicit dependency
331  - gtk2, glib2, dbus
332- add R: pygtk2, pyxdg, python-Coherence for python plugins
333- add R: gstreamer-plugins-good
334
335* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
336- rebuild with libgdata (add youtube plugin)
337- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
338- add Obsolete: totem-gstreamer, totem-xine)
339
340* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
341- new upstream release
342- chagnge _gst_ver from 0.10.19 to 0.10.29
343
344* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
345- new upstream release
346- drop totem-tracker package
347- add BuildRequires: unique-devel
348- remove BuildRequires: hal-devel
349- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
350
351* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
352- remove unneeded autoreconf
353- add BR: lirc
354
355* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
356- new upstream release
357
358* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
359- remove bemused plugin
360
361* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
362- new upstream release
363
364* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
365- added tracker video search sub-package
366
367* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
368- new upstream release
369
370* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
371- new upstream release
372
373* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
374- remove libxine dependency from totem-common
375- build xine backend with minimum dependency
376
377* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
378- add BR: bluez-libs-devel >= 4.15
379- fix typo in %%postun xine
380
381* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
382- rebuild with bluez-libs-devel-4.15
383
384* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
385- new upstream release
386
387* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
388- new upstream release
389
390* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
391- new upstream release
392- add patch1 to build with xulrunner-1.9
393
394* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
395- new upstream release
396
397* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
398- new upstream release
399- disabled devel package (replaced by totem-pl-parser-devel)
400
401* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
402- new upstream release
403- update version macros
404- enable browser plugins on x86_64
405
406* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
407- new upstream release
408
409* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
410- upstream release
411- drop obsolete ja.po.patch (patch0)
412- revert change of 1.4.4-0vl2
413
414* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
415- upstream release
416- enable browser plugins (exclude x86_64 arch)
417
418* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
419- upstream release
420
421* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
422- update configure options
423- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
424
425* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
426- fix mistranslation (patch0)
427- add icon symlink
428- add BuildRequires: gstreamer-plugins-good
429
430* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
431- upstream release
432- update %%_glib_ver, %%_xine_ver
433- add BuildRequires: hal
434- update %%configure options
435- update %%files
436
437* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
438- upstream release
439
440* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
441- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
442
443* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
444- upstream release
445- drop obsolete patch0
446
447* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
448- upstream release
449- add patch0 to build with intltool-0.35
450
451* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
452- upstream release
453
454* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
455- upstream release
456- update alternatives entry
457
458* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
459- upstream release
460- drop fix-sort-function.patch (was merged to upstream, #331426)
461
462* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
463- rebuild with gnome-2.14rc
464
465* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
466- upstream release
467- add macros
468  - _gtk_ver, _glib_ver
469  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
470  - _dbus_ver
471  - _gst_ver, gstpb_ver, _xine_ver
472- add fix-sort-function.patch to build with glib < 2.9.1
473
474* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
475- upstream release
476- add BuildRequires:
477  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
478  - gnome-vfs2-devel >= 2.9.92
479  - dbus-devel >= 0.35
480- use gstreamer-0.10 as backend for totem-gstreamer
481
482* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
483- use gstreamer08 instead of gstreamer
484
485* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
486- upstream release
487
488* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
489- fix missing links
490  - update file list
491  - update update-alternatives scripts
492- fix totem-gstreamer's %%postun script
493
494* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
495- upstream release
496- add BuildRequires: iso-codes, libmusicbrainz-devel
497- add Requires: iso-codes, libmusicbrains to -common package
498- remove BuildRequires: nautilus-cd-burner
499- remove Requires: nautilus-cd-burner from -common package
500
501* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
502- totem-gstreamer obsoletes nautilus-media
503
504* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
505- upstream release
506- add Requires(post,postun): alternatives for gstreamer,xine
507- add Requires(postun,triggers): alternatives for common
508
509* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
510- upstream release
511
512* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
513- build xine backend
514  - move common files to common package
515  - move GStreamer related files to gstreamer package
516  - install xine related files to xine package
517- fix scripts
518
519* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
520- upstream release
521- update URL
522- move *.{a,la} to devel package
523
524* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
525- fix %%{post,preun} script (video-thumbnail.schemas)
526- sync with Fedora Core's 1.0.1-1
527
528  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
529  - Update to upstream version 1.0.1
530  - Break out devel package
531
532* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
533- add %%{post,pre}un script
534
535* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
536- initial build for Vine Linux
537
538* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
539- fix %%post
540
541* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
542- Obsolete nautilus-media
543- Install property page and thumbnailer
544
545* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
546- Update to 0.101
547 
548* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
549- Grab patch totem-0.100-desktopfile.patch from CVS to fix
550  missing menu entry (144088)
551- Remove workaround for desktop file being misinstalled, fixed
552  by above patch
553
554* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
555- New upstream version 0.100
556
557* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
558- update to 0.99.22
559
560* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
561- Add patch to remove removed items from package from help
562
563* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
564- New upstream 0.99.19
565  - Fixes crasher with CD playback (see NEWS)
566
567* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
568- Call update-desktop-database in post
569
570* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
571- update to 0.99.18
572
573* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
574- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
575
Note: See TracBrowser for help on using the repository browser.