source: projects/specs/trunk/t/tk/tk-vl.spec @ 8187

Revision 8187, 9.6 KB checked in by kenta, 10 years ago (diff)
  • tk
    • new upstream release
Line 
1%define majorver        8.5
2%define minorver        15
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 1%{?_dist_release}
8Group: Development/Languages
9License: TCL
10URL: http://tcl.sourceforge.net/
11Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12# patches from Red Hat Enterprise Linux tk-8.5.7-6.el6
13Patch101: tk8.5-make.patch
14Patch102: tk8.5-conf.patch
15# this patch isn't needed since tk8.6b1
16Patch103: tk-seg_input.patch
17# fixes sigsegv if there is no font seen by fontconfig (#606671)
18Patch105: tk-8.5.7-nofont-sigsegv.patch
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: tcl = %{version}, autoconf
22BuildRequires: libX11-devel
23BuildRequires: imake
24Requires: tcl >= %{majorver}
25Provides: libtk%{majorver}.so
26Vendor: Project Vine
27Distribution: Vine Linux
28
29
30%description
31Tk is a X Windows widget set designed to work closely with the tcl
32scripting language. It allows you to write simple programs with full
33featured GUI's in only a little more time then it takes to write a
34text based interface. Tcl/Tk applications can also be run on Windows
35and Macintosh platforms.
36
37%description -l ja
38Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
39System のウィジェットセットです。 テキストベースのインターフェースを
40採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
41ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
42のプラットフォームで実行することもできます。
43
44
45%prep
46%setup -n %{name}%{version} -q
47
48%patch101 -p1 -b .make
49%patch102 -p1 -b .conf
50%patch103 -p1 -b .seg
51%patch105 -p1 -b .nofont-sigsegv
52
53%build
54cd unix
55autoconf
56%configure
57make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
63
64ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
65
66# for linking with -l%{name}
67ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
68
69mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
70find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
71( cd $RPM_BUILD_ROOT/%{_includedir}
72  for i in *.h ; do
73    [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
74  done
75)
76
77# remove buildroot traces
78sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
79rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
80rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
81
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87/sbin/ldconfig
88
89%postun
90/sbin/ldconfig
91
92%files
93%defattr(-,root,root,-)
94%doc README changes license.terms
95%{_bindir}/wish*
96%{_datadir}/tk%{majorver}
97%{_libdir}/libtk%{majorver}.so
98%{_libdir}/tk%{majorver}
99%{_libdir}/tkConfig.sh
100%{_mandir}/man1/*
101%{_includedir}/*
102%{_libdir}/libtk.so
103%{_libdir}/libtkstub%{majorver}.a
104%{_mandir}/man3/*
105%{_mandir}/mann/*
106
107%changelog
108* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
109- new upstream release
110- drop obsolete patche (Patch104)
111
112* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
113- update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
114- update License: TCL
115- drop obsolete patches
116 - lib-perm patch (Patch2)
117 - lastevent patch (Patch3)
118 - tkBind patch (Patch4)
119- add some patches from RHEL tk-8.5.7-6.el6
120 - make patch (Patch101)
121 - conf patch (Patch102)
122 - seg_input patch (Patch103)
123 - color patch (Patch104)
124 - nofont sigsegv patch (Patch105)
125- add some documents
126- update build and install section: sync RHEL tk-8.5.7-6.el6
127
128* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
129- added "BuildRequires: imake".
130
131* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
132- rebuilt with rpm-4.8.1-3
133
134* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
135- rebuilt with tcl-8.4.19-2
136- dropt Patch4: tk-8.4.18-tkBind.patch
137
138* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
139- new upstream release
140- add Patch3,4 to fix bug (broken if built with xproto-7.x)
141
142* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
143- spec in utf-8
144
145* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
146- rebuild with xorg-x11-7.3
147  - remove Requires: XFree86-libs
148  - add BuildRequires: libX11-devel
149- use autoconf instead of autoconf217
150
151* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
152- updated tk to 8.4.18
153- included CVE-2008-0553
154
155* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
156- updated tk to 8.4.16
157
158* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
159- updated tk to 8.4.15
160- rebuilt with new toolchain
161
162* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
163- updated tk to 8.4.13
164
165* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
166- updated tk to 8.4.12
167- updated tk-%%{version}-lib-perm.patch
168
169* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
170- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
171- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
172- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
173- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
174
175* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
176- added tk-8.4.6-tkUnixWm.patch
177
178* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
179- updated tk to 8.4.6
180
181* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
182- syncd with fedora
183  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
184  - add private header files needed to build tix in /usr/include/tk-private
185
186  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
187  - removed rpath (patch 3)
188
189  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
190  - new package split out from tcltk
191  - update to tk 8.4.5 (#88429)
192  - filtered changelog for tk
193  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
194  - remove build remnants from tkConfig.sh
195
196* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
197- fix buildrequires and requires section
198
199* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
200- update based on BitWalk's tcltk-8.4.2-83bw
201
202* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
203- splite source package
204- add include files
205
206* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
207- expand some macros.. (FIXME)
208
209* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
210- use %configure macros
211- add Patch 47,50
212
213* Thu May 31 2001 <sagami@vinelinux.org>
214- 8.0.5_jp-10
215- unexpand old %%{configure}, new one causes build failure
216- fixed missing libtkx.so libtclx.so symlink in /usr/lib
217- install manpages into %%{_mandir} and mode 644
218
219* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
220- 8.0.5_jp-9
221- modified %install section to handle compressed man pages
222- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
223
224* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
225- changed default fonts
226
227* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
228- added defattr
229
230* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
231- added some symlinks, such as libtcl8.0.so.
232- obsoletes version number using _jp, now 8.0.5-31vl1
233
234* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
235- Apply Tcl/Tk 8.0 Japanese Patch 1.7
236
237* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
238- fix tclX symlinks.
239- compile on systems where SIGPWR == SIGLOST.
240
241* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
242- update tcl/tk to 8.0.5.
243- avoid "containing" in Tix (#2332).
244
245* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
246- use /usr/bin/write in kibitz (#1320).
247- use cirrus.sprl.umich.edu in weather (#1926).
248
249* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
250- auto rebuild in the new build environment (release 28)
251
252* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
253- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
254
255* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
256- expect does unaligned access on alpha (#989)
257- upgrade tcl/tk/tclX to 8.0.4
258- upgrade expect to 5.28.
259- add itcl 3.0.1
260
261* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
262- call libtoolize to allow building on the arm
263- build for glibc 2.1
264- strip binaries
265
266* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
267- update tcl/tk/tclX to 8.0.3, expect is updated also.
268
269* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
270- expect: mkpasswd needs delay before sending password (problem #576)
271
272* Thu May 07 1998 Prospector System <bugs@redhat.com>
273- translations modified for de, fr, tr
274
275* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
276- fixed expect binaries exec permissions
277
278* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
279- updated to Tix 4.1.0.006
280- updated version numbers of tcl/tk to relflect includsion of p2
281
282* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
283- updated tcl/tk to patch level 2
284- updated tclX to 8.0.2
285
286* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
287- fixed filelist for tix... replacing path to the expect binary in scripts
288  was leaving junk files around.
289
290* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
291- added patch to remove libieee test in configure.in for tcl and tk.
292  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
293  solution for all systems
294- fixed src urls
295
296* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
297- removed version numbers from descriptions
298
299* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
300- updated to tcl/tk 8.0 and related versions of packages
301
302* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
303- built against glibc
304- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.