source: projects/specs/trunk/t/tk/tk-vl.spec @ 12419

Revision 12419, 10.8 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

tcl-8.6.10-1

tk-8.6.10-1

Line 
1Summary: A Tcl/Tk development environment: tk
2Summary(ja): Tcl/Tk 開発環境: tk
3Name: tk
4Version: 8.6.10
5%global majorver %(echo %{version} | sed -e 's/\.[0-9]*$//')
6%global minorver %(echo %{version} | sed -e 's/^.*\.//')
7Release: 1%{?_dist_release}
8Group: Development/Languages
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: TCL
13URL: https://tcl.sourceforge.net/
14Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: autoconf
18BuildRequires: libX11-devel
19BuildRequires: libXft-devel
20BuildRequires: tcl-devel = %{version}
21Requires: tcl >= %{majorver}
22Provides: libtk%{majorver}.so
23
24%description
25Tk is a X Windows widget set designed to work closely with the tcl
26scripting language. It allows you to write simple programs with full
27featured GUI's in only a little more time then it takes to write a
28text based interface. Tcl/Tk applications can also be run on Windows
29and Macintosh platforms.
30
31%description -l ja
32Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
33System のウィジェットセットです。 テキストベースのインターフェースを
34採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
35ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
36のプラットフォームで実行することもできます。
37
38%package devel
39Summary: Tk graphical toolkit development files
40Summary(ja): Tk ツールキットの開発環境
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: tcl-devel = %{version}
44Requires: libX11-devel
45Requires: libXft-devel
46
47%description devel
48Tk is a X Windows widget set designed to work closely with the tcl
49scripting language. It allows you to write simple programs with full
50featured GUI's in only a little more time then it takes to write a
51text based interface. Tcl/Tk applications can also be run on Windows
52and Macintosh platforms.
53
54The package contains the development files and man pages for tk.
55
56
57%prep
58%setup -n %{name}%{version} -q
59
60sed -i -e 's/555/755/g' unix/Makefile.in
61sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtk%{majorver}.so/' unix/Makefile.in
62
63%build
64cd unix
65autoconf
66
67export CFLAGS="%{optflags} -fPIC"
68%configure \
69--disable-rpath
70
71make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
77
78ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
79
80# for linking with -l%{name}
81ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
82
83mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
84find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
85( cd $RPM_BUILD_ROOT/%{_includedir}
86  for i in *.h ; do
87    [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
88  done
89)
90
91# remove buildroot traces
92sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
93rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
94rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
95
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(-,root,root,-)
106%license license.terms
107%doc README changes
108%{_bindir}/wish*
109%{_datadir}/tk%{majorver}
110%{_libdir}/libtk%{majorver}.so
111%{_libdir}/tk%{majorver}
112%{_libdir}/tkConfig.sh
113%{_mandir}/man1/*
114%{_mandir}/mann/*
115
116%files devel
117%defattr(-,root,root)
118%{_includedir}/*
119%{_libdir}/libtk.so
120%{_libdir}/libtkstub%{majorver}.a
121%{_libdir}/tkConfig.sh
122%{_libdir}/pkgconfig/tk.pc
123%{_mandir}/man3/*
124
125%changelog
126* Wed Jul 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.10-1
127- new upstream release.
128
129* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
130- new upstream release.
131- dropped Patch102: get same effects by sed and configure options.
132- dropped Patch101: get same effects by sed.
133- dropped Patch103: fixed in upstream.
134- dropped Patch105: fixed in upstream.
135
136* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-2
137- split development files into devel subpackage
138- added BR: libXft-devel
139
140* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
141- new upstream release
142- drop obsolete patche (Patch104)
143
144* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
145- update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
146- update License: TCL
147- drop obsolete patches
148 - lib-perm patch (Patch2)
149 - lastevent patch (Patch3)
150 - tkBind patch (Patch4)
151- add some patches from RHEL tk-8.5.7-6.el6
152 - make patch (Patch101)
153 - conf patch (Patch102)
154 - seg_input patch (Patch103)
155 - color patch (Patch104)
156 - nofont sigsegv patch (Patch105)
157- add some documents
158- update build and install section: sync RHEL tk-8.5.7-6.el6
159
160* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
161- added "BuildRequires: imake".
162
163* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
164- rebuilt with rpm-4.8.1-3
165
166* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
167- rebuilt with tcl-8.4.19-2
168- dropt Patch4: tk-8.4.18-tkBind.patch
169
170* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
171- new upstream release
172- add Patch3,4 to fix bug (broken if built with xproto-7.x)
173
174* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
175- spec in utf-8
176
177* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
178- rebuild with xorg-x11-7.3
179  - remove Requires: XFree86-libs
180  - add BuildRequires: libX11-devel
181- use autoconf instead of autoconf217
182
183* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
184- updated tk to 8.4.18
185- included CVE-2008-0553
186
187* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
188- updated tk to 8.4.16
189
190* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
191- updated tk to 8.4.15
192- rebuilt with new toolchain
193
194* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
195- updated tk to 8.4.13
196
197* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
198- updated tk to 8.4.12
199- updated tk-%%{version}-lib-perm.patch
200
201* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
202- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
203- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
204- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
205- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
206
207* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
208- added tk-8.4.6-tkUnixWm.patch
209
210* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
211- updated tk to 8.4.6
212
213* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
214- syncd with fedora
215  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
216  - add private header files needed to build tix in /usr/include/tk-private
217
218  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
219  - removed rpath (patch 3)
220
221  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
222  - new package split out from tcltk
223  - update to tk 8.4.5 (#88429)
224  - filtered changelog for tk
225  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
226  - remove build remnants from tkConfig.sh
227
228* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
229- fix buildrequires and requires section
230
231* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
232- update based on BitWalk's tcltk-8.4.2-83bw
233
234* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
235- splite source package
236- add include files
237
238* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
239- expand some macros.. (FIXME)
240
241* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
242- use %configure macros
243- add Patch 47,50
244
245* Thu May 31 2001 <sagami@vinelinux.org>
246- 8.0.5_jp-10
247- unexpand old %%{configure}, new one causes build failure
248- fixed missing libtkx.so libtclx.so symlink in /usr/lib
249- install manpages into %%{_mandir} and mode 644
250
251* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
252- 8.0.5_jp-9
253- modified %install section to handle compressed man pages
254- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
255
256* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
257- changed default fonts
258
259* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
260- added defattr
261
262* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
263- added some symlinks, such as libtcl8.0.so.
264- obsoletes version number using _jp, now 8.0.5-31vl1
265
266* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
267- Apply Tcl/Tk 8.0 Japanese Patch 1.7
268
269* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
270- fix tclX symlinks.
271- compile on systems where SIGPWR == SIGLOST.
272
273* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
274- update tcl/tk to 8.0.5.
275- avoid "containing" in Tix (#2332).
276
277* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
278- use /usr/bin/write in kibitz (#1320).
279- use cirrus.sprl.umich.edu in weather (#1926).
280
281* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
282- auto rebuild in the new build environment (release 28)
283
284* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
285- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
286
287* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
288- expect does unaligned access on alpha (#989)
289- upgrade tcl/tk/tclX to 8.0.4
290- upgrade expect to 5.28.
291- add itcl 3.0.1
292
293* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
294- call libtoolize to allow building on the arm
295- build for glibc 2.1
296- strip binaries
297
298* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
299- update tcl/tk/tclX to 8.0.3, expect is updated also.
300
301* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
302- expect: mkpasswd needs delay before sending password (problem #576)
303
304* Thu May 07 1998 Prospector System <bugs@redhat.com>
305- translations modified for de, fr, tr
306
307* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
308- fixed expect binaries exec permissions
309
310* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
311- updated to Tix 4.1.0.006
312- updated version numbers of tcl/tk to relflect includsion of p2
313
314* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
315- updated tcl/tk to patch level 2
316- updated tclX to 8.0.2
317
318* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
319- fixed filelist for tix... replacing path to the expect binary in scripts
320  was leaving junk files around.
321
322* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
323- added patch to remove libieee test in configure.in for tcl and tk.
324  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
325  solution for all systems
326- fixed src urls
327
328* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
329- removed version numbers from descriptions
330
331* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
332- updated to tcl/tk 8.0 and related versions of packages
333
334* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
335- built against glibc
336- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.