source: projects/specs/trunk/t/tix/tix-vl.spec @ 12236

Revision 12236, 10.0 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

expect-5.45.4-1

postgresql-12.0-1

python-2.7.16-4

python3-3.5.7-3

rp-pppoe-3.13-3

tcl-8.6.9-1

tix-8.4.3-4

tk-8.6.9-1

Line 
1%define tcl_major       8.6
2%define tk_major        8.6
3%define thread_major    2.8
4%define tix_major       8.4
5%define tixversion      %{tix_major}.3
6## can't find all provides
7#define _use_internal_dependency_generator 0
8
9Summary: A Tcl/Tk development environment: tix
10Summary(ja): Tcl/Tk 開発環境: tix
11Name: tix
12Version: %{tixversion}
13Release: 4%{?_dist_release}
14Group: Development/Languages
15License: BSD
16Vendor: Project Vine
17Distribution: Vine Linux
18
19URL: http://tix.sourceforge.net/
20Source0: Tix%{tixversion}-src.tar.gz
21#  0: Fixes BZ#81297 (soname of libraries)
22Patch0: tix-8.4.2-link.patch
23Patch1: tix-8.4.3-tcl86.patch
24Patch2: tix-8.4.3-covscan-fixes.patch
25
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: tcl-devel >= %{tcl_major}
28BuildRequires: tk-devel >= %{tk_major}
29BuildRequires: tcl-thread
30BuildRequires: libX11-devel
31Requires: tcl >= %{tcl_major}
32Requires: tk >= %{tk_major}
33Requires: tcl-thread
34
35%description
36Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
37extensive set of over 40 widgets.  In general, Tix widgets are more
38complex and more capable than the widgets provided in Tk.  Tix widgets
39include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
40FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
41directory tree and a file manager.
42
43Install the tix package if you want to try out more complicated widgets
44for Tk.  You'll also need to have the tcl and tk packages installed.
45
46%description -l ja
47Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
48は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
49Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
50コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
51ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
52ディレクトリツリー、ファイルマネージャを含んでいます。
53
54Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
55してください。tcl と tk のパッケージもインストールする必要があります。
56
57
58%prep
59%setup -q -n Tix%{tixversion}
60%patch0 -p1 -b .link
61%patch1 -p1 -b .tcl86
62%patch2 -p1 -b .covscan-fixes
63
64%build
65# make the libraries reentrant
66RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
67%configure \
68        --with-tcl=%{_libdir} \
69        --with-tk=%{_libdir} \
70        --enable-shared \
71        --disable-threads \
72        ;
73
74make %{?_smp_mflags} all
75
76%install
77rm -rf ${RPM_BUILD_ROOT}
78%makeinstall
79
80SOFILE=libTix%{version}.so
81mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
82ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
83ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
84ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
85ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
86## internal_dependency_generator can't find provides
87#ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
88cp -p ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
89
90install -d $RPM_BUILD_ROOT%{_mandir}/man1
91install -d $RPM_BUILD_ROOT%{_mandir}/mann
92install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
93install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
94
95install -d $RPM_BUILD_ROOT%{_includedir}
96install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
97
98## others
99SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
100install -d $SHAREDDIR/demos/bitmaps
101install -d $SHAREDDIR/demos/samples
102install -m 755 demos/widget $SHAREDDIR/demos
103install -m 644 demos/{*.tcl,tclIndex}  $SHAREDDIR/demos
104install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
105install -m 644 demos/samples/* $SHAREDDIR/demos/samples
106cp -a tests $SHAREDDIR
107
108## * old scripts *
109## find . -type d -name CVS | xargs -r rm -frv
110## echo "%%defattr(-,root,root)" > tix.files
111## (find ${RPM_BUILD_ROOT}%{_bindir} \
112##         ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
113##  find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
114##         | sort | uniq -u >> tix.files
115##
116## set +x +H
117## for n in `cat tix.files`; do
118##         test -f $n || continue
119##         head -1 $n | grep -q ^#! || continue
120##         chmod u+w $n
121##         perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
122## done
123## set -x -H
124##
125## #==========================================
126## # post process the *.files list, removing build sys references and mark
127## # which are directories
128## set +x
129## for n in *.files; do
130##         mv $n $n.in
131##         sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
132##             if [ -d ${RPM_BUILD_ROOT}/$file ]; then
133##                 echo -n '%dir '
134##             fi
135##             echo $file
136##         done > $n
137##         rm -f $n.in
138## done
139## set -x
140##
141## # Man pages can be compressed
142## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
143
144
145%post -p /sbin/ldconfig
146%postun -p /sbin/ldconfig
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%files
151%defattr(-,root,root,-)
152%{_libdir}/libTix*.so
153%{_libdir}/libtix*.so
154%{_libdir}/Tix%{version}
155%{_datadir}/tix-%{tixversion}
156%{_mandir}/man1/tixwish.1.gz
157%{_mandir}/mann/*.n.gz
158%{_includedir}/*.h
159%doc ChangeLog README.txt man/html man/index.html
160
161
162%changelog
163* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-4
164- rebuilt with tcl/tk-8.6.9.
165- dropped all patches.
166- imported Patch0-2 from rawhide.
167
168* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
169- rebuilt with tcl/tk 8.5.15 and thread 2.7.1
170
171* Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
172- added BR: libX11-devel
173
174* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
175- updated tix to 8.4.3
176- dropt tix-8.1.4-perf.patch
177- dropt tix-8.2.0b1-dirtree.patch
178- added "cp -p libTix8.4.3.so libtix8.4.so"
179- rebuilt with file-5.05-2
180
181* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
182- rebuilt with tcl/tk-8.4.19-2
183
184* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
185- applied new versioning policy
186
187* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
188- rebuild with tcl/tk-8.4.18
189
190* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
191- rebuild with tcl/tk-8.4.16
192
193* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
194- updated tix to 8.4.2
195- rebuilt with new toolchain
196
197* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
198- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
199
200* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
201- changed url to http://tix.sourceforge.net/download.shtml
202- rebuild for tcl/tk-8.4.11
203
204* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
205- rebuild for tcl/tk-8.4.6
206
207* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
208- rebuild for tcl/tk-8.4.5
209
210* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
211- update based on BitWalk's tcltk-8.4.2-83bw
212
213* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
214- splite source package
215
216* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
217- expand some macros.. (FIXME)
218
219* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
220- use %configure macros
221- add Patch 47,50
222
223* Thu May 31 2001 <sagami@vinelinux.org>
224- 8.0.5_jp-10
225- unexpand old %%{configure}, new one causes build failure
226- fixed missing libtkx.so libtclx.so symlink in /usr/lib
227- install manpages into %%{_mandir} and mode 644
228
229* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
230- 8.0.5_jp-9
231- modified %install section to handle compressed man pages
232- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
233
234* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
235- changed default fonts
236
237* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
238- added defattr
239
240* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
241- added some symlinks, such as libtcl8.0.so.
242- obsoletes version number using _jp, now 8.0.5-31vl1
243
244* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
245- Apply Tcl/Tk 8.0 Japanese Patch 1.7
246
247* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
248- fix tclX symlinks.
249- compile on systems where SIGPWR == SIGLOST.
250
251* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
252- update tcl/tk to 8.0.5.
253- avoid "containing" in Tix (#2332).
254
255* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
256- use /usr/bin/write in kibitz (#1320).
257- use cirrus.sprl.umich.edu in weather (#1926).
258
259* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
260- auto rebuild in the new build environment (release 28)
261
262* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
263- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
264
265* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
266- expect does unaligned access on alpha (#989)
267- upgrade tcl/tk/tclX to 8.0.4
268- upgrade expect to 5.28.
269- add itcl 3.0.1
270
271* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
272- call libtoolize to allow building on the arm
273- build for glibc 2.1
274- strip binaries
275
276* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
277- update tcl/tk/tclX to 8.0.3, expect is updated also.
278
279* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
280- expect: mkpasswd needs delay before sending password (problem #576)
281
282* Thu May 07 1998 Prospector System <bugs@redhat.com>
283- translations modified for de, fr, tr
284
285* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
286- fixed expect binaries exec permissions
287
288* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
289- updated to Tix 4.1.0.006
290- updated version numbers of tcl/tk to relflect includsion of p2
291
292* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
293- updated tcl/tk to patch level 2
294- updated tclX to 8.0.2
295
296* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
297- fixed filelist for tix... replacing path to the expect binary in scripts
298  was leaving junk files around.
299
300* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
301- added patch to remove libieee test in configure.in for tcl and tk.
302  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
303  solution for all systems
304- fixed src urls
305
306* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
307- removed version numbers from descriptions
308
309* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
310- updated to tcl/tk 8.0 and related versions of packages
311
312* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
313- built against glibc
314- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.