source: projects/specs/trunk/t/tix/tix-vl.spec @ 9210

Revision 9210, 9.7 KB checked in by inagaki, 9 years ago (diff)

2015-01-01 Ryoichi INAGAKI <ryo1@…>

  • cjs, gjs: changed Group
  • expect, tclx, thread: updated
  • pclock, tix: rebuilt


Line 
1%define tcl_major       8.5
2%define tk_major        8.5
3%define thread_major    2.7
4%define tix_major       8.4
5%define tixversion      %{tix_major}.3
6## can't find all provides
7#define _use_internal_dependency_generator 0
8
9Summary: A Tcl/Tk development environment: tix
10Summary(ja): Tcl/Tk 開発環境: tix
11Name: tix
12Version: %{tixversion}
13Release: 3%{?_dist_release}
14Group: Development/Languages
15License: BSD
16URL: http://tix.sourceforge.net/
17
18Source0: Tix%{tixversion}-src.tar.gz
19Patch20: tix-8.1.4-perf.patch
20Patch22: tix-8.2.0b1-dirtree.patch
21
22Buildroot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: tcl >= %{tcl_major}
24BuildRequires: tk >= %{tk_major}
25BuildRequires: thread >= %{thread_major}
26BuildRequires: libX11-devel
27Requires: tcl >= %{tcl_major}
28Requires: tk >= %{tk_major}
29Requires: thread >= %{thread_major}
30
31%description
32Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
33extensive set of over 40 widgets.  In general, Tix widgets are more
34complex and more capable than the widgets provided in Tk.  Tix widgets
35include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
36FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
37directory tree and a file manager.
38
39Install the tix package if you want to try out more complicated widgets
40for Tk.  You'll also need to have the tcl and tk packages installed.
41
42%description -l ja
43Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
44は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
45Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
46コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
47ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
48ディレクトリツリー、ファイルマネージャを含んでいます。
49
50Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
51してください。tcl と tk のパッケージもインストールする必要があります。
52
53
54%prep
55%setup -q -n Tix%{tixversion}
56#patch20 -p1 -b .perf
57#patch22 -p1 -b .dirtree
58
59%build
60# make the libraries reentrant
61RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
62%configure \
63        --with-tcl=%{_libdir} \
64        --with-tk=%{_libdir} \
65        --enable-shared \
66        --disable-threads \
67        ;
68
69make %{?_smp_mflags} all
70
71%install
72rm -rf ${RPM_BUILD_ROOT}
73%makeinstall
74
75SOFILE=libTix%{version}.so
76mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
77ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
78ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
79ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
80ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
81## internal_dependency_generator can't find provides
82#ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
83cp -p ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
84
85install -d $RPM_BUILD_ROOT%{_mandir}/man1
86install -d $RPM_BUILD_ROOT%{_mandir}/mann
87install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
88install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
89
90install -d $RPM_BUILD_ROOT%{_includedir}
91install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
92
93## others
94SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
95install -d $SHAREDDIR/demos/bitmaps
96install -d $SHAREDDIR/demos/samples
97install -m 755 demos/widget $SHAREDDIR/demos
98install -m 644 demos/{*.tcl,tclIndex}  $SHAREDDIR/demos
99install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
100install -m 644 demos/samples/* $SHAREDDIR/demos/samples
101cp -a tests $SHAREDDIR
102
103## * old scripts *
104## find . -type d -name CVS | xargs -r rm -frv
105## echo "%%defattr(-,root,root)" > tix.files
106## (find ${RPM_BUILD_ROOT}%{_bindir} \
107##         ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
108##  find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
109##         | sort | uniq -u >> tix.files
110##
111## set +x +H
112## for n in `cat tix.files`; do
113##         test -f $n || continue
114##         head -1 $n | grep -q ^#! || continue
115##         chmod u+w $n
116##         perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
117## done
118## set -x -H
119##
120## #==========================================
121## # post process the *.files list, removing build sys references and mark
122## # which are directories
123## set +x
124## for n in *.files; do
125##         mv $n $n.in
126##         sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
127##             if [ -d ${RPM_BUILD_ROOT}/$file ]; then
128##                 echo -n '%dir '
129##             fi
130##             echo $file
131##         done > $n
132##         rm -f $n.in
133## done
134## set -x
135##
136## # Man pages can be compressed
137## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
138
139
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%files
146%defattr(-,root,root,-)
147%{_libdir}/libTix*.so
148%{_libdir}/libtix*.so
149%{_libdir}/Tix%{version}
150%{_datadir}/tix-%{tixversion}
151%{_mandir}/man1/tixwish.1.gz
152%{_mandir}/mann/*.n.gz
153%{_includedir}/*.h
154%doc ChangeLog README.txt man/html man/index.html
155
156
157%changelog
158* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
159- rebuilt with tcl/tk 8.5.15 and thread 2.7.1
160
161* Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
162- added BR: libX11-devel
163
164* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
165- updated tix to 8.4.3
166- dropt tix-8.1.4-perf.patch
167- dropt tix-8.2.0b1-dirtree.patch
168- added "cp -p libTix8.4.3.so libtix8.4.so"
169- rebuilt with file-5.05-2
170
171* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
172- rebuilt with tcl/tk-8.4.19-2
173
174* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
175- applied new versioning policy
176
177* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
178- rebuild with tcl/tk-8.4.18
179
180* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
181- rebuild with tcl/tk-8.4.16
182
183* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
184- updated tix to 8.4.2
185- rebuilt with new toolchain
186
187* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
188- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
189
190* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
191- changed url to http://tix.sourceforge.net/download.shtml
192- rebuild for tcl/tk-8.4.11
193
194* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
195- rebuild for tcl/tk-8.4.6
196
197* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
198- rebuild for tcl/tk-8.4.5
199
200* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
201- update based on BitWalk's tcltk-8.4.2-83bw
202
203* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
204- splite source package
205
206* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
207- expand some macros.. (FIXME)
208
209* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
210- use %configure macros
211- add Patch 47,50
212
213* Thu May 31 2001 <sagami@vinelinux.org>
214- 8.0.5_jp-10
215- unexpand old %%{configure}, new one causes build failure
216- fixed missing libtkx.so libtclx.so symlink in /usr/lib
217- install manpages into %%{_mandir} and mode 644
218
219* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
220- 8.0.5_jp-9
221- modified %install section to handle compressed man pages
222- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
223
224* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
225- changed default fonts
226
227* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
228- added defattr
229
230* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
231- added some symlinks, such as libtcl8.0.so.
232- obsoletes version number using _jp, now 8.0.5-31vl1
233
234* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
235- Apply Tcl/Tk 8.0 Japanese Patch 1.7
236
237* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
238- fix tclX symlinks.
239- compile on systems where SIGPWR == SIGLOST.
240
241* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
242- update tcl/tk to 8.0.5.
243- avoid "containing" in Tix (#2332).
244
245* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
246- use /usr/bin/write in kibitz (#1320).
247- use cirrus.sprl.umich.edu in weather (#1926).
248
249* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
250- auto rebuild in the new build environment (release 28)
251
252* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
253- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
254
255* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
256- expect does unaligned access on alpha (#989)
257- upgrade tcl/tk/tclX to 8.0.4
258- upgrade expect to 5.28.
259- add itcl 3.0.1
260
261* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
262- call libtoolize to allow building on the arm
263- build for glibc 2.1
264- strip binaries
265
266* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
267- update tcl/tk/tclX to 8.0.3, expect is updated also.
268
269* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
270- expect: mkpasswd needs delay before sending password (problem #576)
271
272* Thu May 07 1998 Prospector System <bugs@redhat.com>
273- translations modified for de, fr, tr
274
275* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
276- fixed expect binaries exec permissions
277
278* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
279- updated to Tix 4.1.0.006
280- updated version numbers of tcl/tk to relflect includsion of p2
281
282* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
283- updated tcl/tk to patch level 2
284- updated tclX to 8.0.2
285
286* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
287- fixed filelist for tix... replacing path to the expect binary in scripts
288  was leaving junk files around.
289
290* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
291- added patch to remove libieee test in configure.in for tcl and tk.
292  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
293  solution for all systems
294- fixed src urls
295
296* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
297- removed version numbers from descriptions
298
299* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
300- updated to tcl/tk 8.0 and related versions of packages
301
302* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
303- built against glibc
304- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.