source: projects/specs/trunk/t/tigervnc/tigervnc-vl.spec @ 12506

Revision 12506, 27.4 KB checked in by tomop, 3 years ago (diff)

updated 16 packages

bluez-5.55-1

firefox-78.4.0-1

llvm-11.0.0-2

libdrm-2.4.102-1

libmodsecurity-3.0.4-2

mesa-20.2.1-1

nginx-1.18.0-8

nspr-4.29-1

nss-3.58-1

oniguruma-6.9.5.rev1-3

python-mako-1.1.3-1

python-markupsafe-1.1.1-2

rust-1.47.0-1

thunderbird-78.4.0-1

tigervnc-1.11.0-1

xorg-x11-server-1.20.9-2

Line 
1%bcond_with systemd
2
3Name:           tigervnc
4Version:        1.11.0
5Release:        1%{?_dist_release}%{?with_systemd:.systemd}
6Summary:        A TigerVNC remote display system
7Group:          network
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        GPLv2+
12URL:            http://www.tigervnc.com
13Source0:        https://github.com/TigerVNC/tigervnc/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14Source1:        vncserver.service.upstart
15Source2:        vncserver.sysconfig.upstart
16Source3:        10-libvnc.conf
17# Backwards compatibility
18Source5:        vncserver
19Source6:        vncserver.man
20# for systemd
21Source11:       xvnc.service
22Source12:       xvnc.socket
23
24Patch1:         tigervnc-getmaster.patch
25Patch2:         tigervnc-utilize-system-crypto-policies.patch
26Patch3:         tigervnc-passwd-crash-with-malloc-checks.patch
27Patch4:         tigervnc-systemd-service.patch
28# Upstream patches
29Patch50:        tigervnc-tolerate-specifying-boolparam.patch
30
31BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
32
33BuildRequires:  libX11-devel, automake, autoconf, libtool, gettext
34BuildRequires:  libXext-devel, libXi-devel
35BuildRequires:  xorg-x11-xtrans-devel, xorg-x11-util-macros, libXtst-devel
36BuildRequires:  libdrm-devel, libXt-devel, pixman-devel libXfont2-devel
37BuildRequires:  libxkbfile-devel, openssl-devel, libpciaccess-devel
38BuildRequires:  mesa-libGL-devel, mesa-libEGL-devel
39BuildRequires:  libXinerama-devel, ImageMagick
40BuildRequires:  freetype2-devel, libXdmcp-devel, libxshmfence-devel
41BuildRequires:  desktop-file-utils
42BuildRequires:  libjpeg-turbo-devel, gnutls-devel, pam-devel
43BuildRequires:  xorg-x11-server-source >= 1.20.9-2vl7
44BuildRequires:  cmake
45# TigerVNC 1.4.x requires fltk 1.3.3 for keyboard handling support
46# See https://github.com/TigerVNC/tigervnc/issues/8, also bug #1208814
47BuildRequires:  fltk-devel >= 1.3.3
48
49Requires(post): coreutils
50Requires(postun):coreutils
51%if %{with systemd}
52%{?systemd_requires}
53%else
54Requires(post): chkconfig, /sbin/service
55Requires(preun): chkconfig, /sbin/service
56Requires(postun): /sbin/service
57%endif
58
59Requires:       hicolor-icon-theme
60Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
61Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
62
63%description
64Virtual Network Computing (VNC) is a remote display system which
65allows you to view a computing 'desktop' environment not only on the
66machine where it is running, but from anywhere on the Internet and
67from a wide variety of machine architectures.
68This package contains a client which will allow you to connect to
69other desktops running a VNC server.
70
71
72%package server
73Summary:        A TigerVNC server
74Group:          servers
75Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
76Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
77Requires:       perl
78Requires:       xorg-x11-xauth, xorg-x11-xinit, xorg-x11-server-Xorg
79Requires:       mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
80Requires(post): chkconfig
81Requires(preun):chkconfig
82Requires(preun):initscripts
83Requires(postun):initscripts
84
85%description server
86The VNC system allows you to access the same desktop from a wide
87variety of platforms. 
88This package includes the following components:
89 - TigerVNC server: It allows others to access the desktop on your machine
90 - set of utilities: It makes usage of TigerVNC server more user friendly
91 - x0vncserver program: It can export your active X session
92
93
94%debug_package
95
96
97%prep
98%setup -q
99
100cp -r /usr/share/xorg-x11-server-source/* unix/xserver || exit 1
101pushd unix/xserver
102for all in `find . -type f -perm -001`; do
103        chmod -x "$all"
104done
105patch -p1 < ../xserver120.patch
106popd
107
108# libvnc.so: don't use unexported GetMaster function (bug #744881 again).
109%patch1 -p1 -b .getmaster
110
111# Utilize system-wide crypto policies
112# %patch2 -p1 -b .utilize-system-crypto-policies
113
114%patch3 -p1 -b .tigervnc-passwd-crash-with-malloc-checks
115
116# Enable once this is reviewed by upstream
117# https://github.com/TigerVNC/tigervnc/pull/1115
118%patch4 -p1 -b .tigervnc-systemd-service
119
120%patch50 -p1 -b .tigervnc-tolerate-specifying-boolparam
121
122
123%build
124#export CFLAGS="$RPM_OPT_FLAGS -fpic"
125export CFLAGS="$RPM_OPT_FLAGS -fpic -I%{_includedir}/libdrm"
126
127#export CXXFLAGS="$CFLAGS"
128export CXXFLAGS="$CFLAGS -std=c++11"
129
130%if %{with systemd}
131%{cmake} -DCMAKE_INSTALL_UNITDIR=%{_unitdir} .
132%else
133%{cmake} .
134%endif
135make %{?_smp_mflags}
136
137pushd unix/xserver
138autoreconf -fiv
139%configure \
140        --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
141        --disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
142        --with-pic --disable-static \
143        --with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
144        --with-fontdir=%{_datadir}/X11/fonts \
145        --with-xkb-output=%{_localstatedir}/lib/xkb \
146        --enable-install-libxf86config \
147        --enable-glx --disable-dri --enable-dri2 --enable-dri3 \
148        --disable-unit-tests \
149        --disable-config-hal \
150        --disable-config-udev \
151        --with-dri-driver-path=%{_libdir}/dri \
152        --without-dtrace \
153        --disable-devel-docs \
154        --disable-selective-werror \
155        ;
156
157make %{?_smp_mflags}
158popd
159
160# Build icons
161pushd media
162make
163popd
164
165%install
166rm -rf %{buildroot}
167make install DESTDIR=%{buildroot}
168rm -f %{buildroot}%{_docdir}/%{name}-%{version}/{README.txt,LICENCE.TXT}
169
170pushd unix/xserver/hw/vnc
171make install DESTDIR=%{buildroot}
172popd
173
174sed -i -e '/pam_selinux/d' %{buildroot}%{_sysconfdir}/pam.d/tigervnc
175
176%if %{with systemd}
177mkdir -p %{buildroot}%{_unitdir}
178#make -C unix/vncserver install DESTDIR=%{buildroot}
179# Install systemd unit file
180install -m644 %{SOURCE11} %{buildroot}%{_unitdir}/xvnc@.service
181install -m644 %{SOURCE12} %{buildroot}%{_unitdir}/xvnc.socket
182%else
183rm -f %{buildroot}/%{_mandir}/man8/vncserver.8
184install -m 755 %{SOURCE5} %{buildroot}/%{_bindir}/vncserver
185install -m 644 %{SOURCE6} %{buildroot}/%{_mandir}/man8/vncserver.8
186sed -i -e '/pam_systemd/d' %{buildroot}%{_sysconfdir}/pam.d/tigervnc
187
188# Install init stuff
189mkdir -p %{buildroot}%{_sysconfdir}/init.d
190install -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/init.d/vncserver
191mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
192install -m644 %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/vncservers
193%endif
194
195# Install desktop stuff
196mkdir -p %{buildroot}%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
197
198pushd media/icons
199for s in 16 24 48; do
200install -m644 tigervnc_$s.png %{buildroot}%{_datadir}/icons/hicolor/${s}x$s/apps/tigervnc.png
201done
202popd
203
204%find_lang %{name} %{name}.lang
205
206mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
207install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
208
209# remove unwanted files
210rm -f  %{buildroot}%{_libdir}/xorg/modules/extensions/libvnc.la
211rm -rf %{buildroot}%{_docdir}/tigervnc
212%if !%{with systemd}
213rm -rf %{buildroot}/usr/lib/systemd
214%endif
215
216
217%clean
218rm -rf %{buildroot}
219
220
221%post
222touch -c %{_datadir}/icons/hicolor
223if [ -x %{_bindir}/gtk-update-icon-cache ]; then
224        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
225fi
226
227%postun
228touch -c %{_datadir}/icons/hicolor
229if [ -x %{_bindir}/gtk-update-icon-cache ]; then
230        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
231fi
232
233%post server
234%if %{with systemd}
235%systemd_post xvnc@.service
236%systemd_post xvnc.socket
237%else
238/sbin/chkconfig --add vncserver
239%endif
240
241%preun server
242%if %{with systemd}
243%systemd_preun xvnc@.service
244%systemd_preun xvnc.socket
245%else
246if [ "$1" = 0 -o -x /bin/systemctl ]; then
247  /sbin/service vncserver stop 2>&1 ||:
248  /sbin/chkconfig --del vncserver 2>&1 ||:
249fi
250%endif
251
252%postun server
253%if %{with systemd}
254%systemd_postun xvnc@.service
255%systemd_postun xvnc.socket
256%else
257  /sbin/service vncserver condrestart 2>&1 ||:
258%endif
259
260%triggerun -- vnc-server < 4.1.3
261/sbin/service vncserver stop &>/dev/null || :
262/sbin/chkconfig --del vncserver >/dev/null 2>&1 || :
263
264
265%files -f %{name}.lang
266%defattr(-,root,root,-)
267%license LICENCE.TXT
268%doc README.txt
269%{_bindir}/vncviewer
270%{_datadir}/applications/*
271%{_mandir}/man1/vncviewer.1*
272%{_datadir}/icons/hicolor/*/apps/*
273
274%files server
275%defattr(-,root,root,-)
276%config(noreplace) %{_sysconfdir}/pam.d/tigervnc
277%dir %{_sysconfdir}/tigervnc
278%config(noreplace) %{_sysconfdir}/tigervnc/vncserver-config-defaults
279%config(noreplace) %{_sysconfdir}/tigervnc/vncserver-config-mandatory
280%config(noreplace) %{_sysconfdir}/tigervnc/vncserver.users
281%{_bindir}/x0vncserver
282%{_bindir}/vncconfig
283%{_bindir}/vncpasswd
284%{_bindir}/Xvnc
285%{_sbindir}/vncsession
286%{_libexecdir}/vncserver
287%{_libexecdir}/vncsession-start
288%{_mandir}/man1/x0vncserver.1*
289%{_mandir}/man1/Xvnc.1*
290%{_mandir}/man1/vncpasswd.1*
291%{_mandir}/man1/vncconfig.1*
292%{_mandir}/man8/vncserver.8*
293%{_mandir}/man8/vncsession.8*
294%{_libdir}/xorg/modules/extensions/libvnc.so
295%config %{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
296%if %{with systemd}
297%{_unitdir}/vncserver@.service
298%{_unitdir}/xvnc@.service
299%{_unitdir}/xvnc.socket
300%else
301%{_bindir}/vncserver
302%config(noreplace) %{_sysconfdir}/init.d/vncserver
303%config(noreplace) %{_sysconfdir}/sysconfig/vncservers
304%endif
305
306
307%changelog
308* Sun Oct 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
309- new upstream release.
310- re-imported all patches from rawhide.
311
312* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-2
313- rebuilt with nettle-3.6.
314- added systemd support (disabled as default).
315
316* Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
317- new upstream release.
318- replaced all patches.
319- dropped java stuff.
320
321* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.1-1
322- new upstream release
323- added BR: libxshmfence-devel
324
325* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.0-1
326- new upstream release
327
328* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.3-1
329- new upstream release
330
331* Wed Mar  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-2
332- rebuilt
333
334* Sun Jan  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-1
335- initial build based on Fedora rawhide
336
337* Tue Sep  9 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-11
338- Added missing part of xserver114.patch (bug #1137023).
339
340* Wed Sep  3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
341- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
342
343* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
344- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
345
346* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
347- Input reset fixes from upstream (bug #1116956).
348- No longer need ppc64le patch as it's now in xorg-x11-server.
349- Rebased xserver114.patch again.
350
351* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
352- xserver 1.15.99.903 ABI rebuild
353
354* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
355- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
356
357* Thu May 22 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-5
358- Keep pointer in sync when using module (upstream bug #152).
359
360* Mon Apr 28 2014 Adam Jackson <ajax@redhat.com> 1.3.1-4
361- Add version interlocks for -server-module
362
363* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-3
364- xserver 1.15.99-20140428 git snapshot ABI rebuild
365
366* Mon Apr  7 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-2
367- Allow build with dri3 and present extensions (bug #1063392).
368
369* Thu Mar 27 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-1
370- 1.3.1 (bug #1078806).
371- Add ppc64le support (bug #1078495).
372
373* Wed Mar 19 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-15
374- Disable dri3 to enable building (bug #1063392).
375- Fixed heap-based buffer overflow (CVE-2014-0011, bug #1050928).
376
377* Fri Feb 21 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-14
378- Enabled hardened build (bug #955206).
379
380* Mon Feb 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-13
381- Clearer xstartup file (bug #923655).
382
383* Tue Jan 14 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-12
384- Fixed instructions in systemd unit file.
385
386* Fri Jan 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-11
387- Fixed viewer crash when cursor has not been set (bug #1038701).
388
389* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-10
390- Avoid invalid read when ZRLE connection closed (upstream bug #133).
391
392* Tue Dec  3 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-9
393- Fixed build failure with -Werror=format-security (bug #1037358).
394
395* Thu Nov 07 2013 Adam Jackson <ajax@redhat.com> 1.3.0-8
396- Rebuild against xserver 1.15RC1
397
398* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
399- Removed incorrect patch (for unexpected key_is_down). Fixes stuck
400  keys bug (bug #989502).
401
402* Thu Sep 19 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-6
403- Fixed typo in 10-libvnc.conf (bug #1009111).
404
405* Wed Sep 18 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-5
406- Better fix for PIDFile problem (bug #983232).
407
408* Mon Aug  5 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-4
409- Fixed doc-related build failure (bug #992790).
410
411* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-3
412- Avoid PIDFile problems in systemd unit file (bug #983232).
413- libvnc.so: don't use unexported key_is_down function.
414- Don't use shebang in vncserver script.
415
416* Fri Jul 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-2
417- Renumbered patches.
418- libvnc.so: don't use unexported GetMaster function (bug #744881 again).
419
420* Mon Jul  8 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-1
421- 1.3.0.
422
423* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.18.20130314svn5065
424- Removed systemd_requires macro in order to fix the build.
425
426* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.17.20130314svn5065
427- Synchronise manpages and --help output (bug #980870).
428
429* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.16.20130314svn5065
430- tigervnc-setcursor-crash.patch: Attempt to paper over a crash in Xvnc when
431  setting the cursor.
432
433* Sat Jun 08 2013 Dennis Gilmore <dennis@ausil.us> 1.2.80-0.15.20130314svn5065
434- bump to rebuild and pick up bugfix causing X to crash on ppc and arm
435
436* Thu May 23 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.14.20130314svn5065
437- Use systemd rpm macros (bug #850340).  Moved systemd requirements
438  from main package to server sub-package.
439- Applied Debian patch to fix busy loop when run from inetd in nowait
440  mode (bug #920373).
441- Added dependency on xorg-x11-xinit to server sub-package so that
442  default window manager can be found (bug #896284, bug #923655).
443- Fixed bogus changelog date.
444
445* Thu Mar 14 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.13.20130314svn5065
446- Less RHEL customization
447
448* Thu Mar 14 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.12.20130314svn5065
449- include /etc/X11/xorg.conf.d/10-libvnc.conf sample configuration (#712482)
450- vncserver now honors specified -geometry parameter (#755947)
451
452* Tue Mar 12 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.11.20130307svn5060
453- update to r5060
454- split icons to separate package to avoid multilib issues
455
456* Tue Feb 19 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.10.20130219svn5047
457- update to r5047 (X.Org 1.14 support)
458
459* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.80-0.9.20121126svn5015
460- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
461
462* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.8.20121126svn5015
463- rebuild due to "jpeg8-ABI" feature drop
464
465* Wed Jan 16 2013 Adam Tkac <atkac redhat com> 1.2.80-0.7.20121126svn5015
466- rebuild
467
468* Tue Dec 04 2012 Adam Tkac <atkac redhat com> 1.2.80-0.6.20121126svn5015
469- rebuild against new fltk
470
471* Mon Nov 26 2012 Adam Tkac <atkac redhat com> 1.2.80-0.5.20121126svn5015
472- update to r5015
473- build with -fpic instead of -fPIC on all archs except s390/sparc
474
475* Wed Nov  7 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.80-0.4.20120905svn4996
476- Build with -fPIC to fix FTBFS on ARM
477
478* Wed Oct 31 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.3.20120905svn4996
479- tigervnc12-xorg113-glx.patch: Fix to only init glx on the first server
480  generation
481
482* Fri Sep 28 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.2.20120905svn4996
483- tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13
484
485* Fri Aug 17 2012 Adam Tkac <atkac redhat com> 1.2.80-0.1.20120905svn4996
486- update to 1.2.80
487- remove deprecated patches
488  - tigervnc-102434.patch
489  - tigervnc-viewer-reparent.patch
490  - tigervnc11-java7.patch
491- patches merged
492  - tigervnc11-xorg111.patch
493  - tigervnc11-xorg112.patch
494
495* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
496- fix build against newer X server
497
498* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
499- Build with the Composite extension for feature parity with other X servers
500
501* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
502- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
503
504* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
505- fix building against X.org 1.13
506
507* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
508- RHEL exclusion for -server-module on ppc* too
509
510* Mon Mar 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-5
511- clean Xvnc's /tmp environment in service file before startup
512- fix building against the latest JAVA 7 and X.Org 1.12
513
514* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-4
515- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
516
517* Tue Nov 22 2011 Adam Tkac <atkac redhat com> - 1.1.0-3
518- don't build X.Org devel docs (#755782)
519- applet: BR generic java-devel instead of java-gcj-devel (#755783)
520- use runuser to start Xvnc in systemd service file (#754259)
521- don't attepmt to restart Xvnc session during update/erase (#753216)
522
523* Fri Nov 11 2011 Adam Tkac <atkac redhat com> - 1.1.0-2
524- libvnc.so: don't use unexported GetMaster function (#744881)
525- remove nasm buildreq
526
527* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
528- update to 1.1.0
529- update the xorg11 patch
530- patches merged
531  - tigervnc11-glx.patch
532  - tigervnc11-CVE-2011-1775.patch
533  - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
534
535* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
536- add systemd service file and remove legacy SysV initscript (#717227)
537
538* Thu May 12 2011 Adam Tkac <atkac redhat com> - 1.0.90-5
539- make Xvnc buildable against X.Org 1.11
540
541* Tue May 10 2011 Adam Tkac <atkac redhat com> - 1.0.90-4
542- viewer can send password without proper validation of X.509 certs
543  (CVE-2011-1775)
544
545* Wed Apr 13 2011 Adam Tkac <atkac redhat com> - 1.0.90-3
546- fix wrong usage of memcpy which caused screen artifacts (#652590)
547- don't point to inaccessible link in sysconfig/vncservers (#644975)
548
549* Fri Apr 08 2011 Adam Tkac <atkac redhat com> - 1.0.90-2
550- improve compatibility with vinagre client (#692048)
551
552* Tue Mar 22 2011 Adam Tkac <atkac redhat com> - 1.0.90-1
553- update to 1.0.90
554
555* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.90-0.32.20110117svn4237
556- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
557
558* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
559- fix libvnc.so module loading
560
561* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
562- update to r4237
563- patches merged
564  - tigervnc11-optionsdialog.patch
565  - tigervnc11-rh607866.patch
566
567* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.29.20101208svn4225
568- improve patch for keyboard issues
569
570* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.28.20101208svn4225
571- attempt to fix various keyboard-related issues (key repeating etc)
572
573* Fri Jan 07 2011 Adam Tkac <atkac redhat com> 1.0.90-0.27.20101208svn4225
574- render "Ok" and "Cancel" buttons in the options dialog correctly
575
576* Wed Dec 15 2010 Jan Görig <jgorig redhat com> 1.0.90-0.26.20101208svn4225
577- added vncserver lock file (#662784)
578
579* Fri Dec 10 2010 Adam Tkac <atkac redhat com> 1.0.90-0.25.20101208svn4225
580- update to r4225
581- patches merged
582  - tigervnc11-rh611677.patch
583  - tigervnc11-rh633931.patch
584  - tigervnc11-xorg1.10.patch
585- enable VeNCrypt and PAM support
586
587* Mon Dec 06 2010 Adam Tkac <atkac redhat com> 1.0.90-0.24.20100813svn4123
588- rebuild against xserver 1.10.X
589- 0001-Return-Success-from-generate_modkeymap-when-max_keys.patch merged
590
591* Wed Sep 29 2010 jkeating - 1.0.90-0.23.20100813svn4123
592- Rebuilt for gcc bug 634757
593
594* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.22.20100420svn4030
595- drop xorg-x11-fonts-misc dependency (#636170)
596
597* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.21.20100420svn4030
598- improve patch for #633645 (fix tcsh incompatibilities)
599
600* Thu Sep 16 2010 Adam Tkac <atkac redhat com> 1.0.90-0.20.20100813svn4123
601- press fake modifiers correctly (#633931)
602- supress unneeded debug information emitted from initscript (#633645)
603
604* Wed Aug 25 2010 Adam Tkac <atkac redhat com> 1.0.90-0.19.20100813svn4123
605- separate Xvnc, vncpasswd and vncconfig to -server-minimal subpkg (#626946)
606- move license to separate subpkg and Requires it from main subpkgs
607- Xvnc: handle situations when no modifiers exist well (#611677)
608
609* Fri Aug 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.18.20100813svn4123
610- update to r4123 (#617973)
611- add perl requires to -server subpkg (#619791)
612
613* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
614- update to r4113
615- patches merged
616  - tigervnc11-rh586406.patch
617  - tigervnc11-libvnc.patch
618  - tigervnc11-rh597172.patch
619  - tigervnc11-rh600070.patch
620  - tigervnc11-options.patch
621- don't own %%{_datadir}/icons directory (#614301)
622- minor improvements in the .desktop file (#616340)
623- bundled libjpeg configure requires nasm; is executed even if system-wide
624  libjpeg is used
625
626* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
627- build against system-wide libjpeg-turbo (#494458)
628- build no longer requires nasm
629
630* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 1.0.90-0.15.20100420svn4030
631- vncserver: accept <+optname> option when specified as the first one
632
633* Thu Jun 24 2010 Adam Tkac <atkac redhat com> 1.0.90-0.14.20100420svn4030
634- fix memory leak in Xvnc input code (#597172)
635- don't crash when receive negative encoding (#600070)
636- explicitly disable udev configuration support
637- add gettext-autopoint to BR
638
639* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 1.0.90-0.13.20100420svn4030
640- update URL about SSH tunneling in the sysconfig file (#601996)
641
642* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 1.0.90-0.12.20100420svn4030
643- use newer gettext
644- autopoint now uses git instead of cvs, adjust BuildRequires appropriately
645
646* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.11.20100420svn4030
647- link libvnc.so "now" to catch "undefined symbol" errors during Xorg startup
648- use always XkbConvertCase instead of XConvertCase (#580159, #586406)
649- don't link libvnc.so against libXi.la, libdix.la and libxkb.la; use symbols
650  from Xorg instead
651
652* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
653- update to r4030 snapshot
654- patches merged to upstream
655  - tigervnc11-rh522369.patch
656  - tigervnc11-rh551262.patch
657  - tigervnc11-r4002.patch
658  - tigervnc11-r4014.patch
659
660* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
661- add server-applet subpackage which contains Java vncviewer applet
662- fix Java applet; it didn't work when run from web browser
663- add xorg-x11-xkb-utils to server Requires
664
665* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
666- add French translation to vncviewer.desktop (thanks to Alain Portal)
667
668* Thu Mar 04 2010 Adam Tkac <atkac redhat com> 1.0.90-0.7.20100219svn3993
669- don't crash during pixel format change (#522369, #551262)
670
671* Mon Mar 01 2010 Adam Tkac <atkac redhat com> 1.0.90-0.6.20100219svn3993
672- add mesa-dri-drivers and xkeyboard-config to -server Requires
673- update to r3993 1.0.90 snapshot
674  - tigervnc11-noexecstack.patch merged
675  - tigervnc11-xorg18.patch merged
676  - xserver18.patch is no longer needed
677
678* Wed Jan 27 2010 Jan Gorig <jgorig redhat com> 1.0.90-0.5.20091221svn3929
679- initscript LSB compliance fixes (#523974)
680
681* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
682- mark stack as non-executable in jpeg ASM code
683- add xorg-x11-xauth to Requires
684- add support for X.Org 1.8
685- drop shave sources, they are no longer needed
686
687* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
688- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
689
690* Thu Jan 07 2010 Adam Tkac <atkac redhat com> 1.0.90-0.2.20091221svn3929
691- add patch for upstream X.Org issue #25909
692- add libXdmcp-devel to build requires to build Xvnc with XDMCP support (#552322)
693
694* Mon Dec 21 2009 Adam Tkac <atkac redhat com> 1.0.90-0.1.20091221svn3929
695- update to 1.0.90 snapshot
696- patches merged
697  - tigervnc10-compat.patch
698  - tigervnc10-rh510185.patch
699  - tigervnc10-rh524340.patch
700  - tigervnc10-rh516274.patch
701
702* Mon Oct 26 2009 Adam Tkac <atkac redhat com> 1.0.0-3
703- create Xvnc keyboard mapping before first keypress (#516274)
704
705* Thu Oct 08 2009 Adam Tkac <atkac redhat com> 1.0.0-2
706- update underlying X source to 1.6.4-0.3.fc11
707- remove bogus '-nohttpd' parameter from /etc/sysconfig/vncservers (#525629)
708- initscript LSB compliance fixes (#523974)
709- improve -LowColorSwitch documentation and handling (#510185)
710- honor dotWhenNoCursor option (and it's changes) every time (#524340)
711
712* Fri Aug 28 2009 Adam Tkac <atkac redhat com> 1.0.0-1
713- update to 1.0.0
714- tigervnc10-rh495457.patch merged to upstream
715
716* Mon Aug 24 2009 Karsten Hopp <karsten@redhat.com> 0.0.91-0.17
717- fix ifnarch s390x for server-module
718
719* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.0.91-0.16
720- rebuilt with new openssl
721
722* Tue Aug 04 2009 Adam Tkac <atkac redhat com> 0.0.91-0.15
723- make Xvnc compilable
724
725* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.91-0.14.1
726- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
727
728* Mon Jul 13 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13.1
729- don't write warning when initscript is called with condrestart param (#508367)
730
731* Tue Jun 23 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13
732- temporary use F11 Xserver base to make Xvnc compilable
733- BuildRequires: libXi-devel
734- don't ship tigervnc-server-module on s390/s390x
735
736* Mon Jun 22 2009 Adam Tkac <atkac redhat com> 0.0.91-0.12
737- fix local rendering of cursor (#495457)
738
739* Thu Jun 18 2009 Adam Tkac <atkac redhat com> 0.0.91-0.11
740- update to 0.0.91 (1.0.0 RC1)
741- patches merged
742  - tigervnc10-rh499401.patch
743  - tigervnc10-rh497592.patch
744  - tigervnc10-rh501832.patch
745- after discusion in upstream drop tigervnc-bounds.patch
746- configure flags cleanup
747
748* Thu May 21 2009 Adam Tkac <atkac redhat com> 0.0.90-0.10
749- rebuild against 1.6.1.901 X server (#497835)
750- disable i18n, vncviewer is not UTF-8 compatible (#501832)
751
752* Mon May 18 2009 Adam Tkac <atkac redhat com> 0.0.90-0.9
753- fix vncpasswd crash on long passwords (#499401)
754- start session dbus daemon correctly (#497592)
755
756* Mon May 11 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8.1
757- remove merged tigervnc-manminor.patch
758
759* Tue May 05 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8
760- update to 0.0.90
761
762* Thu Apr 30 2009 Adam Tkac <atkac redhat com> 0.0.90-0.7.20090427svn3789
763- server package now requires xorg-x11-fonts-misc (#498184)
764
765* Mon Apr 27 2009 Adam Tkac <atkac redhat com> 0.0.90-0.6.20090427svn3789
766- update to r3789
767  - tigervnc-rh494801.patch merged
768- tigervnc-newfbsize.patch is no longer needed
769- fix problems when vncviewer and Xvnc run on different endianess (#496653)
770- UltraVNC and TightVNC clients work fine again (#496786)
771
772* Wed Apr 08 2009 Adam Tkac <atkac redhat com> 0.0.90-0.5.20090403svn3751
773- workaround broken fontpath handling in vncserver script (#494801)
774
775* Fri Apr 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.4.20090403svn3751
776- update to r3751
777- patches merged
778  - tigervnc-xclients.patch
779  - tigervnc-clipboard.patch
780  - tigervnc-rh212985.patch
781- basic RandR support in Xvnc (resize of the desktop)
782- use built-in libjpeg (SSE2/MMX accelerated encoding on x86 platform)
783- use Tight encoding by default
784- use TigerVNC icons
785
786* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.3.20090303svn3631
787- update to r3631
788
789* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.2.20090302svn3621
790- package review related fixes
791
792* Mon Mar 02 2009 Adam Tkac <atkac redhat com> 0.0.90-0.1.20090302svn3621
793- initial package, r3621
Note: See TracBrowser for help on using the repository browser.