source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 8011

Revision 8011, 31.5 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 24.1.1
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-esr24
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81# Vine Patch
82Patch2000:      thunderbird-24.0-vine6.patch
83
84BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
85BuildRequires:  pango-devel
86BuildRequires:  cairo-devel >= %{cairo_version}
87%if %{build_vine7}
88#BuildRequires: nspr-devel >= %{nspr_version}
89#BuildRequires: nss-devel >= %{nss_version}
90BuildRequires:  python-devel
91%endif
92%if %{build_vine6}
93BuildRequires:  python27-devel
94%endif
95BuildRequires:  gstreamer-devel
96BuildRequires:  gstreamer-plugins-base-devel
97BuildRequires:  pixman-devel
98BuildRequires:  libpng-devel
99BuildRequires:  libjpeg-turbo-devel
100BuildRequires:  gtk2-devel
101BuildRequires:  zlib-devel, gzip, zip, unzip
102BuildRequires:  libIDL-devel
103BuildRequires:  freetype2-devel >= %{freetype_version}
104## disabled libnotify support
105## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
106BuildRequires:  libnotify-devel >= %{libnotify_version}
107BuildRequires:  bzip2-devel
108#BuildRequires: gnome-vfs2-devel
109BuildRequires:  libgnome-devel
110#BuildRequires:  libgnomeui-devel
111BuildRequires:  krb5-devel
112BuildRequires:  pango-devel
113BuildRequires:  libXt-devel
114BuildRequires:  libXrender-devel
115BuildRequires:  curl-devel
116# hunspell is in plus category for vine
117#BuildRequires: hunspell-devel
118%if %{build_vine7}
119BuildRequires:  sqlite3-devel >= %{sqlite_version}
120%endif
121BuildRequires:  startup-notification-devel
122BuildRequires:  desktop-file-utils
123BuildRequires:  alsa-lib-devel
124BuildRequires:  yasm
125BuildRequires:  autoconf213
126%if %{build_vine7}
127Requires:       sqlite3 >= %{sqlite_version}
128%endif
129Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
130Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
131
132Obsoletes:      MozillaThunderbird
133Provides:       MozillaThunderbird = %{version}
134
135Vendor:         Project Vine
136Distribution:   Vine Linux
137Packager:       daisuke, ryoichi, kazutaka, Takemikaduchi
138
139AutoProv: 0
140%define _use_internal_dependency_generator 0
141%define __find_requires %{SOURCE100}
142
143%description
144Thunderbird is a standalone mail and newsgroup client.
145
146%description -l ja
147Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
148
149#===============================================================================
150
151%prep
152%setup -q %{name}-%{version} -c
153cd %{tarballdir}
154
155# Fix for version issue
156sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
157    > version.patch
158%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
159
160cd mozilla
161%patch1 -p1 -b .default-a4
162
163cd -
164%{__rm} -f .mozconfig
165%if %{build_vine6}
166%{__cp} %{SOURCE1010} .mozconfig
167%endif
168%if %{build_vine7}
169%{__cp} %{SOURCE1020} .mozconfig
170%endif
171
172# setup unofficial branding name
173%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
174%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
175
176%patch100 -p1 -b .addons
177%if %{build_vine6}
178%patch2000 -p1 -b .vine
179%endif
180
181#===============================================================================
182
183%build
184cd %{tarballdir}
185autoconf-2.13
186
187INTERNAL_GECKO=%{version_internal}
188MOZ_APP_DIR=%{mozappdir}
189
190
191#%if %{build_vine7}
192#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
193#%else
194#%ifarch x86_64
195##MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
196#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
197#%else
198#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
199#%endif
200#%endif
201
202MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | \
203                                %{__sed} -e 's/-Wall//')
204export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
205export CFLAGS="$RPM_OPT_FLAGS"
206#export CFLAGS=""
207export CXXFLAGS="$CFLAGS"
208export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
209
210export PREFIX='%{_prefix}'
211export LIBDIR='%{_libdir}'
212
213MOZ_SMP_FLAGS=-j1
214# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
215# however builds tend to fail on other arches when building in parallel.
216%ifarch %{ix86} x86_64
217[ -z "$RPM_BUILD_NCPUS" ] && \
218     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
219[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
220[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
221[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
222 %endif
223
224export LDFLAGS="-Wl,-rpath,%{ffdir}"
225%__make -f client.mk build STRIP="/bin/true" \
226                           MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
227
228## build locales
229#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
230#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
231#for dir in $LOCALEDIRS
232#do
233#  for lang in %{MOZ_BUILD_LOCALES} ; do
234#    make -C $dir/locales AB_CD=$lang
235#  done
236#done
237
238#===============================================================================
239
240%install
241%{__rm} -rf $RPM_BUILD_ROOT
242cd %{tarballdir}
243
244INTERNAL_GECKO=%{version_internal}
245
246INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
247MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
248
249cd %{moz_objdir}
250DESTDIR=$RPM_BUILD_ROOT make install
251
252# install unofficial icons
253cd -
254
255%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
256%{__cp} mail/branding/aurora/mailicon16.png \
257        $RPM_BUILD_ROOT/%{mozappdir}/icons/
258%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
259%{__cp} mail/branding/aurora/mailicon16.png \
260        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
261%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
262%{__cp} mail/branding/aurora/mailicon22.png \
263        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
265%{__cp} mail/branding/aurora/mailicon24.png \
266        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
267%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
268%{__cp} mail/branding/aurora/mailicon32.png \
269        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
270%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
271%{__cp} mail/branding/aurora/mailicon48.png \
272        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
273%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
274%{__cp} mail/branding/aurora/mailicon256.png \
275        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
276
277desktop-file-install --vendor vine \
278  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
279
280# set up the thunderbird start script
281rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
282%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
283  $RPM_BUILD_ROOT%{_bindir}/thunderbird
284%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
285
286install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
287%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
288
289%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
290                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
291        $RPM_BUILD_ROOT/vine-default-prefs
292%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
293%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
294%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
295
296%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
297
298# own mozilla plugin dir (#135050)
299%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
300
301# own extension directories
302%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
303%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
304
305# install locales
306#for lang in %{MOZ_BUILD_LOCALES} ; do
307#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
308#done
309
310# install ja.xpi to langpacks directory
311#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
312#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
313# also setup unofficial branding name
314#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
315#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
316
317# install ja.xpi to langpack file
318%{__mkdir_p} lang_tmp
319unzip %{SOURCE1} -d lang_tmp
320# also setup unofficial branding name
321%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
322%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
323
324%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
325cd lang_tmp; \
326zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
327
328
329%clean
330%{__rm} -rf $RPM_BUILD_ROOT
331
332#===============================================================================
333
334%post
335update-desktop-database &> /dev/null || :
336touch --no-create %{_datadir}/icons/hicolor
337if [ -x %{_bindir}/gtk-update-icon-cache ]; then
338  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
339fi
340
341%postun
342update-desktop-database &> /dev/null || :
343touch --no-create %{_datadir}/icons/hicolor
344if [ -x %{_bindir}/gtk-update-icon-cache ]; then
345  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
346fi
347
348
349%files
350%defattr(-,root,root,-)
351%attr(755,root,root) %{_bindir}/thunderbird
352%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
353%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
354%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
355%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
356%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
357%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
358%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
359%{mozappdir}
360#%{_libdir}/mozilla
361%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
362%exclude %{_datadir}/idl/%{name}-%{version_internal}
363%exclude %{_includedir}/%{name}-%{version_internal}
364%exclude %{_libdir}/%{name}-devel-%{version_internal}
365
366#===============================================================================
367
368%changelog
369* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.1.1-1
370- new upstream release
371
372* Tue Nov 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.1.0-1
373- new upstream release
374
375* Sat Sep 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0-1
376- new upstream release
377- remove BuildRequires: nspr-devel, nss-devel
378- add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel
379- add Patch2000 (thunderbird-24.0-vine6.patch)
380
381* Tue Aug 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.8-1
382- new upstream release
383
384* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.7-1
385- new upstream release
386
387* Sun May 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.6-1
388- new upstream release
389
390* Wed Mar 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.4-1
391- new upstream release
392
393* Sat Mar 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.3-1
394- new upstream release
395
396* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.2-1
397- new upstream release
398- update Source1010,1020
399- fix %% build
400
401* Wed Nov 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0-1
402- new upstream release
403
404* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
405- use --disable-install-strip instead of --enable-install-strip
406- add --disable-debug-symbols
407
408* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
409- new upstream release
410
411* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
412- new upstream release
413
414* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
415- new upstream release
416
417* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
418- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
419
420* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
421- new upstream release
422
423* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
424- new upstream release
425- add BuildRequires: python-devel (Vine6 only)
426- remove build rule of Vine5
427
428* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
429- new upstream release
430- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
431
432* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
433- new upstream release
434
435* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
436- new upstream release
437- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
438
439* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
440- new upstream release
441
442* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
443- new upstream release
444- update Source1030 (mozconfig-thunderbird-vine7)
445
446* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
447- new upstream release
448- update Source1020 (mozconfig-thunderbird-vine6)
449
450* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
451- new upstream release
452
453* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
454- new upstream release
455
456* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
457- new upstream release
458
459* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
460- new upstream release
461- update Source1
462
463* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
464- new upstream release
465- update Source1
466- add Source1030 (mozconfig-thunderbird-vine7)
467- add Patch100 (thunderbird-9.0-enable-addons.patch)
468
469* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
470- fix %%version_internal
471
472* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
473- new upstream release
474- update Source1
475
476* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
477- new upstream release
478- update Source1,21,1010,1020
479
480* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
481- rebuild with libnotify-0.7
482
483* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
484- enable-install-strip
485
486* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
487- new upstream release
488- drop obsolete patch and renumber patch26 to patch1
489- add BuildRequires: yasm
490- enable libnotify support
491- add --disable-updater and --disable-installer to mozconfig
492- use ja.xpi instead of l10n source
493- update Source21: add step to setup langpack plugin
494- update Source20: add japanese translation
495- add Source42 & Source43 for localized branding
496- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
497  for mozconfig-thunderbird-vine5
498
499* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
500- new upstream release with security fix
501
502* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
503- new upstream release with security fix
504
505* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
506- new upstream release with security fix
507
508* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
509- new upstream release with security fix
510- add patch5 to fix build failure
511
512* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
513- new upstream release
514
515* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
516- new upstream release with security fix
517- add Patch1030 to fix compilation error
518
519* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
520- change mozconfig (Source1030 & 1040): add --enable-jsd
521
522* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
523- new upstream release
524
525* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
526- new upstream release with security fix
527- add Patch0 from fedora development: fix version issue
528- remove BuildRequires: hunspell-devel
529- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
530
531* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
532- add BuildRequires: alsa-lib-devel
533- remove BuildRequires: libnotify-devel
534  (workaround for known bug)
535- update mozconfig to add --disable-libnotify option
536
537* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
538- new upstream release
539- update spec entirely
540- import patches from fedora (Patch1, 2 & 4)
541- drop outdated patches (Patch22, 24)
542- update Sources:
543  - mozconfig (Source1030 & Source1040)
544  - default prefs.js (Source12)
545  - unofficial branding (Source40 & Source41)
546  - japanese translation (Source1000)
547- update Patch1000 (sjis-alias)
548
549* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
550- new upstream release
551
552* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
553- new upstream release
554
555* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
556- don't install official branding logos
557
558* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
559- add necessary icons in %%{tbdir}/chrome/icons/default
560- add Packager tag
561
562* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
563- new upstream release
564
565* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
566- new upstream release
567
568* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
569- new upstream release
570
571* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
572- new upstream release
573
574* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
575- rebuilt for VineSeed
576
577* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
578- new upstream release
579
580* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
581- new upstream release
582- built for Vine Linux 4.x
583- dropped Patch1020 (merged into upstream)
584
585* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
586- added Patch1020 for workaround gcc visibility hidden bugs
587
588* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
589- build with new environment/toolchain
590- add build options to build with external nss/nspr libraries
591    ac_add_options --with-system-nspr
592    ac_add_options --with-system-nss
593
594* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
595- new upstream release
596
597* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
598- new upstream release
599
600* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
601- new upstream release
602
603* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
604- new upstream release
605
606* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
607- new upstream release
608- merge changes from firefox
609  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
610
611* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
612- new upstream release
613- build en-US locale
614- merge changes from firefox
615  - add upstream patches
616  - disable pango rendering by default
617    (workaround fix slow rendering in some page)
618
619* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
620- initial build for Vine Linux based on FC package
621- update to 1.5RC2
622
623* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
624- Fix issue with popup dialogs and other actions causing lockups
625
626* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
627- Update to 1.5 rc1
628
629* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
630- Update to 1.5 beta2
631
632* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
633- Update to 1.5 beta1
634- Bring the install phase of the spec file up to speed
635
636* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
637- Rebuild
638
639* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
640- Add patch to make file chooser dialog modal
641
642* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
643- Update to 1.0.6
644
645* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
646- 1.0.6 Release Candidate
647
648* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
649- Use system NSPR
650- Fix crash on 64bit platforms (#160330)
651
652* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
653- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
654  references, fixing the "no fonts" problem.
655
656* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
657- Change the Exec line in the desktop file to `thunderbird`
658
659* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
660- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
661
662* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
663- Add temporary workaround to not create files in the user's $HOME (#149664)
664
665* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
666- Don't have downloads "disappear" when downloading to desktop (#139015)
667- Fix for some more cursor issues in textareas (149991, 150002, 152089)
668- Add upstream patch to fix bidi justification of pango
669- Add patch to fix launching of helper applications
670- Add patch to properly link against libgfxshared_s.a
671- Fix multilib conflicts
672
673* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
674- correct confusing PANGO vars in startup script
675
676* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
677- Thunderbird 1.0.2
678
679* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
680- Add patch to compile against new fortified glibc macros
681
682* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
683- Rebuild against GCC 4.0
684- Add execshield patches
685- Minor specfile cleanup
686
687* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
688- Rebuild
689
690* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
691- Add RPM version to useragent
692
693* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
694- Port over pango patches from firefox
695
696* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
697- Thunderbird 1.0
698
699* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
700- Fix advanced prefs
701
702* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
703- Make this run on s390(x) now for real
704
705* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
706- Update to 1.0 rc1
707
708* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
709- Add patches to build and run on s390(x)
710
711* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
712- Rebuild to fix file chooser
713
714* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
715- Update to 0.9
716
717* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
718- Prevent inlining of stack direction detection (#135255)
719
720* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
721- More file chooser fixes (same as in firefox)
722- Fix for upstream 28327.
723
724* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
725- Update the pango patch
726
727* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
728- Pull over patches from firefox build:
729  - disable default application dialog
730  - don't include software update since it doesn't work
731  - make external app support work
732
733* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
734- Use pango for rendering
735
736* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
737- Fix for 64 bit crash at startup (b.m.o #256603)
738
739* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
740- Add patches to fix xremote (#135036)
741
742* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
743- Add patch to fix button focus issues (#133507)
744- Add patch for fix IMAP race issues (bmo #246439)
745
746* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
747- filter out library Provides: and internal Requires:
748
749* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
750- Backport the GTK+ File Chooser.
751- Add fix for JS math on x86_64 systems
752- Add pkgconfig patch
753
754* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
755- Update to 0.8.0
756- Remove enigmail
757- Update BuildRequires
758- Remove gcc34 and extension manager patches -- they are upstreamed.
759- Fix for gnome-vfs2 error at component registration
760
761* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
762- Build with --disable-xprint
763
764* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
765- remove all Xvfb-related hacks
766
767* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
768- actually apply psfonts
769- add mozilla gnome-uriloader patch to prevent build failure
770
771* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
772- rawhide import
773- apply NetBSD's freetype 2.1.8 patch
774- apply psfonts patch
775- remove BR on /usr/bin/ex, breaks beehive
776
777* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
778- oops, fix %%install
779
780* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
781- update to Thunderbird 0.7.3 and Enigmail 0.85.0
782- remove XUL.mfasl on startup, add Debian enigmail patches
783- add Xvfb hack for -install-global-extension
784
785* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
786- update to 0.7.2, just because it's there
787- update gcc-3.4 patch (Kaj Niemi)
788- add EM registration patch and remove instdir hack
789
790* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
791- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
792
793* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
794- update to 0.7.1
795- remove Enigmail
796
797* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
798- re-enable Enigmail 0.84.1
799- add gcc-3.4 patch (Kaj Niemi)
800- use official branding (with permission)
801
802* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
803- update to 0.7
804- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
805- specify libdir, change BR for apt (V. Skytt辰, #1617)
806
807* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
808- temporary workaround for enigmail skin "modern" bug
809
810* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
811- update to Enigmail 0.84.0
812- update launch script
813
814* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
815- installation directory now versioned
816- allow root to run the program (for installing extensions)
817- remove unnecessary %%pre and %%post
818- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
819
820* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
821- include Enigmail, re-add release notes
822- delete %{_libdir}/thunderbird in %%pre
823
824* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
825- update to Thunderbird 0.6
826
827* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
828- update to Thunderbird 0.6 RC1
829- add new icon, remove release notes
830
831* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
832- update to latest CVS, update mozconfig and %%build accordingly
833- update to Enigmail 0.83.6
834- remove x-remote and x86_64 patches
835- build with -Os
836
837* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
838- update x-remote patch
839- more startup script fixes
840
841* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
842- startup script fixes, and a minor cleanup
843
844* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
845- Minor cleanups
846
847* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
848- minor improvements to open-browser.sh and startup script
849- update to latest version of Blizzard's x-remote patch
850
851* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
852- update open-browser.sh, startup script, and BuildRequires
853
854* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
855- update open-browser script, modify BuildRequires (Warren)
856- add Blizzard's x-remote patch
857- initial attempt at x-remote-enabled startup script
858
859* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
860- refuse to run with excessive privileges
861
862* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
863- add Mozilla x86_64 patch (Oliver Sontag)
864- Enigmail source filenames now include the version
865- modify BuildRoot
866
867* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
868- use the updated official tarball
869
870* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
871- fix %%prep script
872
873* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
874- update Enigmail to 0.83.3
875- use official source tarball (after removing the CRLFs)
876- package renamed to thunderbird
877
878* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
879- update to 0.5
880- check for lockfile before launching
881
882* Fri Feb 06 2004 David Hill <djh[at]ii.net>
883- update to latest cvs
884- update to Enigmail 0.83.2
885
886* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
887- update to Enigmail 0.83.1
888- removed Mozilla/Firebird script patching
889
890* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
891- add startup notification to .desktop file
892
893* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
894- open-browser.sh release 3
895- patch broken /usr/bin/mozilla script during install
896- dir ownership
897- XXX: Source fails build on x86_64... fix later
898
899* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
900- update to Enigmail 0.82.5
901- add Warren's open-browser.sh (#1113)
902
903* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
904- use Thunderbird's mozilla-xremote-client to launch browser
905
906* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
907- update to 0.4
908- make hyperlinks work (with recent versions of Firebird/Mozilla)
909
910* Thu Dec 04 2003 David Hill <djh[at]ii.net>
911- update to 0.4rc2
912
913* Wed Dec 03 2003 David Hill <djh[at]ii.net>
914- update to 0.4rc1 and Enigmail 0.82.4
915
916* Thu Nov 27 2003 David Hill <djh[at]ii.net>
917- update to latest CVS and Enigmail 0.82.3
918
919* Sun Nov 16 2003 David Hill <djh[at]ii.net>
920- update to latest CVS (0.4a)
921- update Enigmail to 0.82.2
922- alter mozconfig for new build requirements
923- add missing BuildReq (#987)
924
925* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
926- update to 0.3
927
928* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
929- update to 0.3rc3
930- update Enigmail to 0.81.7
931
932* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
933- update to 0.3rc2
934
935* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
936- simplify startup script
937
938* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
939- add GPG support (Enigmail 0.81.6)
940- specfile fixes (#679)
941
942* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
943- update to 0.2
944
945* Mon Sep 01 2003 David Hill <djh[at]ii.net>
946- initial RPM
947  (based on the fedora MozillaFirebird-0.6.1 specfile)
948
Note: See TracBrowser for help on using the repository browser.