source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 7992

Revision 7992, 31.4 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 24.1.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-esr24
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81# Vine Patch
82Patch2000:      thunderbird-24.0-vine6.patch
83
84BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
85BuildRequires:  pango-devel
86BuildRequires:  cairo-devel >= %{cairo_version}
87%if %{build_vine7}
88#BuildRequires: nspr-devel >= %{nspr_version}
89#BuildRequires: nss-devel >= %{nss_version}
90BuildRequires:  python-devel
91%endif
92%if %{build_vine6}
93BuildRequires:  python27-devel
94%endif
95BuildRequires:  gstreamer-devel
96BuildRequires:  gstreamer-plugins-base-devel
97BuildRequires:  pixman-devel
98BuildRequires:  libpng-devel
99BuildRequires:  libjpeg-turbo-devel
100BuildRequires:  gtk2-devel
101BuildRequires:  zlib-devel, gzip, zip, unzip
102BuildRequires:  libIDL-devel
103BuildRequires:  freetype2-devel >= %{freetype_version}
104## disabled libnotify support
105## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
106BuildRequires:  libnotify-devel >= %{libnotify_version}
107BuildRequires:  bzip2-devel
108#BuildRequires: gnome-vfs2-devel
109BuildRequires:  libgnome-devel
110#BuildRequires:  libgnomeui-devel
111BuildRequires:  krb5-devel
112BuildRequires:  pango-devel
113BuildRequires:  libXt-devel
114BuildRequires:  libXrender-devel
115BuildRequires:  curl-devel
116# hunspell is in plus category for vine
117#BuildRequires: hunspell-devel
118%if %{build_vine7}
119BuildRequires:  sqlite3-devel >= %{sqlite_version}
120%endif
121BuildRequires:  startup-notification-devel
122BuildRequires:  desktop-file-utils
123BuildRequires:  alsa-lib-devel
124BuildRequires:  yasm
125BuildRequires:  autoconf213
126%if %{build_vine7}
127Requires:       sqlite3 >= %{sqlite_version}
128%endif
129Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
130Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
131
132Obsoletes:      MozillaThunderbird
133Provides:       MozillaThunderbird = %{version}
134
135Vendor:         Project Vine
136Distribution:   Vine Linux
137Packager:       daisuke, ryoichi, kazutaka, Takemikaduchi
138
139AutoProv: 0
140%define _use_internal_dependency_generator 0
141%define __find_requires %{SOURCE100}
142
143%description
144Thunderbird is a standalone mail and newsgroup client.
145
146%description -l ja
147Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
148
149#===============================================================================
150
151%prep
152%setup -q %{name}-%{version} -c
153cd %{tarballdir}
154
155# Fix for version issue
156sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
157    > version.patch
158%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
159
160cd mozilla
161%patch1 -p1 -b .default-a4
162
163cd -
164%{__rm} -f .mozconfig
165%if %{build_vine6}
166%{__cp} %{SOURCE1010} .mozconfig
167%endif
168%if %{build_vine7}
169%{__cp} %{SOURCE1020} .mozconfig
170%endif
171
172# setup unofficial branding name
173%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
174%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
175
176%patch100 -p1 -b .addons
177%if %{build_vine6}
178%patch2000 -p1 -b .vine
179%endif
180
181#===============================================================================
182
183%build
184cd %{tarballdir}
185autoconf-2.13
186
187INTERNAL_GECKO=%{version_internal}
188MOZ_APP_DIR=%{mozappdir}
189
190
191#%if %{build_vine7}
192#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
193#%else
194#%ifarch x86_64
195##MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
196#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
197#%else
198#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
199#%endif
200#%endif
201
202MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | \
203                                %{__sed} -e 's/-Wall//')
204export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
205export CFLAGS="$RPM_OPT_FLAGS"
206#export CFLAGS=""
207export CXXFLAGS="$CFLAGS"
208export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
209
210export PREFIX='%{_prefix}'
211export LIBDIR='%{_libdir}'
212
213MOZ_SMP_FLAGS=-j1
214# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
215# however builds tend to fail on other arches when building in parallel.
216%ifarch %{ix86} x86_64
217[ -z "$RPM_BUILD_NCPUS" ] && \
218     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
219[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
220[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
221[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
222 %endif
223
224export LDFLAGS="-Wl,-rpath,%{ffdir}"
225%__make -f client.mk build STRIP="/bin/true" \
226                           MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
227
228## build locales
229#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
230#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
231#for dir in $LOCALEDIRS
232#do
233#  for lang in %{MOZ_BUILD_LOCALES} ; do
234#    make -C $dir/locales AB_CD=$lang
235#  done
236#done
237
238#===============================================================================
239
240%install
241%{__rm} -rf $RPM_BUILD_ROOT
242cd %{tarballdir}
243
244INTERNAL_GECKO=%{version_internal}
245
246INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
247MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
248
249cd %{moz_objdir}
250DESTDIR=$RPM_BUILD_ROOT make install
251
252# install unofficial icons
253cd -
254
255%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
256%{__cp} mail/branding/aurora/mailicon16.png \
257        $RPM_BUILD_ROOT/%{mozappdir}/icons/
258%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
259%{__cp} mail/branding/aurora/mailicon16.png \
260        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
261%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
262%{__cp} mail/branding/aurora/mailicon22.png \
263        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
265%{__cp} mail/branding/aurora/mailicon24.png \
266        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
267%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
268%{__cp} mail/branding/aurora/mailicon32.png \
269        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
270%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
271%{__cp} mail/branding/aurora/mailicon48.png \
272        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
273%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
274%{__cp} mail/branding/aurora/mailicon256.png \
275        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
276
277desktop-file-install --vendor vine \
278  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
279
280# set up the thunderbird start script
281rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
282%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
283  $RPM_BUILD_ROOT%{_bindir}/thunderbird
284%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
285
286install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
287%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
288
289%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
290                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
291        $RPM_BUILD_ROOT/vine-default-prefs
292%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
293%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
294%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
295
296%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
297
298# own mozilla plugin dir (#135050)
299%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
300
301# own extension directories
302%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
303%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
304
305# install locales
306#for lang in %{MOZ_BUILD_LOCALES} ; do
307#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
308#done
309
310# install ja.xpi to langpacks directory
311#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
312#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
313# also setup unofficial branding name
314#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
315#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
316
317# install ja.xpi to langpack file
318%{__mkdir_p} lang_tmp
319unzip %{SOURCE1} -d lang_tmp
320# also setup unofficial branding name
321%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
322%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
323
324%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
325cd lang_tmp; \
326zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
327
328
329%clean
330%{__rm} -rf $RPM_BUILD_ROOT
331
332#===============================================================================
333
334%post
335update-desktop-database &> /dev/null || :
336touch --no-create %{_datadir}/icons/hicolor
337if [ -x %{_bindir}/gtk-update-icon-cache ]; then
338  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
339fi
340
341%postun
342update-desktop-database &> /dev/null || :
343touch --no-create %{_datadir}/icons/hicolor
344if [ -x %{_bindir}/gtk-update-icon-cache ]; then
345  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
346fi
347
348
349%files
350%defattr(-,root,root,-)
351%attr(755,root,root) %{_bindir}/thunderbird
352%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
353%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
354%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
355%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
356%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
357%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
358%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
359%{mozappdir}
360#%{_libdir}/mozilla
361%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
362%exclude %{_datadir}/idl/%{name}-%{version_internal}
363%exclude %{_includedir}/%{name}-%{version_internal}
364%exclude %{_libdir}/%{name}-devel-%{version_internal}
365
366#===============================================================================
367
368%changelog
369* Tue Nov 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.1.0-1
370- new upstream release
371
372* Sat Sep 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0-1
373- new upstream release
374- remove BuildRequires: nspr-devel, nss-devel
375- add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel
376- add Patch2000 (thunderbird-24.0-vine6.patch)
377
378* Tue Aug 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.8-1
379- new upstream release
380
381* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.7-1
382- new upstream release
383
384* Sun May 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.6-1
385- new upstream release
386
387* Wed Mar 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.4-1
388- new upstream release
389
390* Sat Mar 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.3-1
391- new upstream release
392
393* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.2-1
394- new upstream release
395- update Source1010,1020
396- fix %% build
397
398* Wed Nov 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0-1
399- new upstream release
400
401* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
402- use --disable-install-strip instead of --enable-install-strip
403- add --disable-debug-symbols
404
405* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
406- new upstream release
407
408* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
409- new upstream release
410
411* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
412- new upstream release
413
414* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
415- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
416
417* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
418- new upstream release
419
420* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
421- new upstream release
422- add BuildRequires: python-devel (Vine6 only)
423- remove build rule of Vine5
424
425* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
426- new upstream release
427- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
428
429* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
430- new upstream release
431
432* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
433- new upstream release
434- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
435
436* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
437- new upstream release
438
439* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
440- new upstream release
441- update Source1030 (mozconfig-thunderbird-vine7)
442
443* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
444- new upstream release
445- update Source1020 (mozconfig-thunderbird-vine6)
446
447* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
448- new upstream release
449
450* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
451- new upstream release
452
453* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
454- new upstream release
455
456* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
457- new upstream release
458- update Source1
459
460* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
461- new upstream release
462- update Source1
463- add Source1030 (mozconfig-thunderbird-vine7)
464- add Patch100 (thunderbird-9.0-enable-addons.patch)
465
466* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
467- fix %%version_internal
468
469* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
470- new upstream release
471- update Source1
472
473* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
474- new upstream release
475- update Source1,21,1010,1020
476
477* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
478- rebuild with libnotify-0.7
479
480* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
481- enable-install-strip
482
483* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
484- new upstream release
485- drop obsolete patch and renumber patch26 to patch1
486- add BuildRequires: yasm
487- enable libnotify support
488- add --disable-updater and --disable-installer to mozconfig
489- use ja.xpi instead of l10n source
490- update Source21: add step to setup langpack plugin
491- update Source20: add japanese translation
492- add Source42 & Source43 for localized branding
493- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
494  for mozconfig-thunderbird-vine5
495
496* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
497- new upstream release with security fix
498
499* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
500- new upstream release with security fix
501
502* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
503- new upstream release with security fix
504
505* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
506- new upstream release with security fix
507- add patch5 to fix build failure
508
509* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
510- new upstream release
511
512* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
513- new upstream release with security fix
514- add Patch1030 to fix compilation error
515
516* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
517- change mozconfig (Source1030 & 1040): add --enable-jsd
518
519* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
520- new upstream release
521
522* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
523- new upstream release with security fix
524- add Patch0 from fedora development: fix version issue
525- remove BuildRequires: hunspell-devel
526- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
527
528* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
529- add BuildRequires: alsa-lib-devel
530- remove BuildRequires: libnotify-devel
531  (workaround for known bug)
532- update mozconfig to add --disable-libnotify option
533
534* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
535- new upstream release
536- update spec entirely
537- import patches from fedora (Patch1, 2 & 4)
538- drop outdated patches (Patch22, 24)
539- update Sources:
540  - mozconfig (Source1030 & Source1040)
541  - default prefs.js (Source12)
542  - unofficial branding (Source40 & Source41)
543  - japanese translation (Source1000)
544- update Patch1000 (sjis-alias)
545
546* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
547- new upstream release
548
549* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
550- new upstream release
551
552* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
553- don't install official branding logos
554
555* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
556- add necessary icons in %%{tbdir}/chrome/icons/default
557- add Packager tag
558
559* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
560- new upstream release
561
562* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
563- new upstream release
564
565* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
566- new upstream release
567
568* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
569- new upstream release
570
571* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
572- rebuilt for VineSeed
573
574* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
575- new upstream release
576
577* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
578- new upstream release
579- built for Vine Linux 4.x
580- dropped Patch1020 (merged into upstream)
581
582* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
583- added Patch1020 for workaround gcc visibility hidden bugs
584
585* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
586- build with new environment/toolchain
587- add build options to build with external nss/nspr libraries
588    ac_add_options --with-system-nspr
589    ac_add_options --with-system-nss
590
591* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
592- new upstream release
593
594* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
595- new upstream release
596
597* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
598- new upstream release
599
600* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
601- new upstream release
602
603* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
604- new upstream release
605- merge changes from firefox
606  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
607
608* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
609- new upstream release
610- build en-US locale
611- merge changes from firefox
612  - add upstream patches
613  - disable pango rendering by default
614    (workaround fix slow rendering in some page)
615
616* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
617- initial build for Vine Linux based on FC package
618- update to 1.5RC2
619
620* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
621- Fix issue with popup dialogs and other actions causing lockups
622
623* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
624- Update to 1.5 rc1
625
626* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
627- Update to 1.5 beta2
628
629* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
630- Update to 1.5 beta1
631- Bring the install phase of the spec file up to speed
632
633* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
634- Rebuild
635
636* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
637- Add patch to make file chooser dialog modal
638
639* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
640- Update to 1.0.6
641
642* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
643- 1.0.6 Release Candidate
644
645* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
646- Use system NSPR
647- Fix crash on 64bit platforms (#160330)
648
649* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
650- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
651  references, fixing the "no fonts" problem.
652
653* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
654- Change the Exec line in the desktop file to `thunderbird`
655
656* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
657- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
658
659* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
660- Add temporary workaround to not create files in the user's $HOME (#149664)
661
662* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
663- Don't have downloads "disappear" when downloading to desktop (#139015)
664- Fix for some more cursor issues in textareas (149991, 150002, 152089)
665- Add upstream patch to fix bidi justification of pango
666- Add patch to fix launching of helper applications
667- Add patch to properly link against libgfxshared_s.a
668- Fix multilib conflicts
669
670* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
671- correct confusing PANGO vars in startup script
672
673* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
674- Thunderbird 1.0.2
675
676* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
677- Add patch to compile against new fortified glibc macros
678
679* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
680- Rebuild against GCC 4.0
681- Add execshield patches
682- Minor specfile cleanup
683
684* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
685- Rebuild
686
687* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
688- Add RPM version to useragent
689
690* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
691- Port over pango patches from firefox
692
693* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
694- Thunderbird 1.0
695
696* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
697- Fix advanced prefs
698
699* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
700- Make this run on s390(x) now for real
701
702* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
703- Update to 1.0 rc1
704
705* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
706- Add patches to build and run on s390(x)
707
708* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
709- Rebuild to fix file chooser
710
711* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
712- Update to 0.9
713
714* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
715- Prevent inlining of stack direction detection (#135255)
716
717* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
718- More file chooser fixes (same as in firefox)
719- Fix for upstream 28327.
720
721* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
722- Update the pango patch
723
724* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
725- Pull over patches from firefox build:
726  - disable default application dialog
727  - don't include software update since it doesn't work
728  - make external app support work
729
730* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
731- Use pango for rendering
732
733* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
734- Fix for 64 bit crash at startup (b.m.o #256603)
735
736* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
737- Add patches to fix xremote (#135036)
738
739* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
740- Add patch to fix button focus issues (#133507)
741- Add patch for fix IMAP race issues (bmo #246439)
742
743* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
744- filter out library Provides: and internal Requires:
745
746* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
747- Backport the GTK+ File Chooser.
748- Add fix for JS math on x86_64 systems
749- Add pkgconfig patch
750
751* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
752- Update to 0.8.0
753- Remove enigmail
754- Update BuildRequires
755- Remove gcc34 and extension manager patches -- they are upstreamed.
756- Fix for gnome-vfs2 error at component registration
757
758* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
759- Build with --disable-xprint
760
761* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
762- remove all Xvfb-related hacks
763
764* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
765- actually apply psfonts
766- add mozilla gnome-uriloader patch to prevent build failure
767
768* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
769- rawhide import
770- apply NetBSD's freetype 2.1.8 patch
771- apply psfonts patch
772- remove BR on /usr/bin/ex, breaks beehive
773
774* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
775- oops, fix %%install
776
777* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
778- update to Thunderbird 0.7.3 and Enigmail 0.85.0
779- remove XUL.mfasl on startup, add Debian enigmail patches
780- add Xvfb hack for -install-global-extension
781
782* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
783- update to 0.7.2, just because it's there
784- update gcc-3.4 patch (Kaj Niemi)
785- add EM registration patch and remove instdir hack
786
787* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
788- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
789
790* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
791- update to 0.7.1
792- remove Enigmail
793
794* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
795- re-enable Enigmail 0.84.1
796- add gcc-3.4 patch (Kaj Niemi)
797- use official branding (with permission)
798
799* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
800- update to 0.7
801- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
802- specify libdir, change BR for apt (V. Skytt辰, #1617)
803
804* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
805- temporary workaround for enigmail skin "modern" bug
806
807* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
808- update to Enigmail 0.84.0
809- update launch script
810
811* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
812- installation directory now versioned
813- allow root to run the program (for installing extensions)
814- remove unnecessary %%pre and %%post
815- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
816
817* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
818- include Enigmail, re-add release notes
819- delete %{_libdir}/thunderbird in %%pre
820
821* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
822- update to Thunderbird 0.6
823
824* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
825- update to Thunderbird 0.6 RC1
826- add new icon, remove release notes
827
828* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
829- update to latest CVS, update mozconfig and %%build accordingly
830- update to Enigmail 0.83.6
831- remove x-remote and x86_64 patches
832- build with -Os
833
834* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
835- update x-remote patch
836- more startup script fixes
837
838* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
839- startup script fixes, and a minor cleanup
840
841* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
842- Minor cleanups
843
844* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
845- minor improvements to open-browser.sh and startup script
846- update to latest version of Blizzard's x-remote patch
847
848* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
849- update open-browser.sh, startup script, and BuildRequires
850
851* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
852- update open-browser script, modify BuildRequires (Warren)
853- add Blizzard's x-remote patch
854- initial attempt at x-remote-enabled startup script
855
856* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
857- refuse to run with excessive privileges
858
859* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
860- add Mozilla x86_64 patch (Oliver Sontag)
861- Enigmail source filenames now include the version
862- modify BuildRoot
863
864* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
865- use the updated official tarball
866
867* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
868- fix %%prep script
869
870* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
871- update Enigmail to 0.83.3
872- use official source tarball (after removing the CRLFs)
873- package renamed to thunderbird
874
875* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
876- update to 0.5
877- check for lockfile before launching
878
879* Fri Feb 06 2004 David Hill <djh[at]ii.net>
880- update to latest cvs
881- update to Enigmail 0.83.2
882
883* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
884- update to Enigmail 0.83.1
885- removed Mozilla/Firebird script patching
886
887* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
888- add startup notification to .desktop file
889
890* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
891- open-browser.sh release 3
892- patch broken /usr/bin/mozilla script during install
893- dir ownership
894- XXX: Source fails build on x86_64... fix later
895
896* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
897- update to Enigmail 0.82.5
898- add Warren's open-browser.sh (#1113)
899
900* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
901- use Thunderbird's mozilla-xremote-client to launch browser
902
903* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
904- update to 0.4
905- make hyperlinks work (with recent versions of Firebird/Mozilla)
906
907* Thu Dec 04 2003 David Hill <djh[at]ii.net>
908- update to 0.4rc2
909
910* Wed Dec 03 2003 David Hill <djh[at]ii.net>
911- update to 0.4rc1 and Enigmail 0.82.4
912
913* Thu Nov 27 2003 David Hill <djh[at]ii.net>
914- update to latest CVS and Enigmail 0.82.3
915
916* Sun Nov 16 2003 David Hill <djh[at]ii.net>
917- update to latest CVS (0.4a)
918- update Enigmail to 0.82.2
919- alter mozconfig for new build requirements
920- add missing BuildReq (#987)
921
922* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
923- update to 0.3
924
925* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
926- update to 0.3rc3
927- update Enigmail to 0.81.7
928
929* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
930- update to 0.3rc2
931
932* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
933- simplify startup script
934
935* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
936- add GPG support (Enigmail 0.81.6)
937- specfile fixes (#679)
938
939* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
940- update to 0.2
941
942* Mon Sep 01 2003 David Hill <djh[at]ii.net>
943- initial RPM
944  (based on the fedora MozillaFirebird-0.6.1 specfile)
945
Note: See TracBrowser for help on using the repository browser.