source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 6592

Revision 6592, 29.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 14.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30%define build_vine5 0
31
32%if "%{?_dist_release}" >= "vl7"
33%define build_vine7 1
34%endif
35%if "%{?_dist_release}" == "vl6"
36%define build_vine6 1
37%endif
38%if "%{?_dist_release}" == "vl5"
39%define build_vine5 1
40%endif
41
42
43Summary:        Thunderbird Community Edition, Mail/newsgroup client
44Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
45Name:           thunderbird
46Version:        %{tbversion}
47Release:        %{tbrelease}
48URL:            http://www.mozilla.org/projects/thunderbird/
49License:        MPL
50Group:          Applications/Internet
51
52Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
53Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
54Source1010:     mozconfig-thunderbird-vine5
55Source1020:     mozconfig-thunderbird-vine6
56Source1030:     mozconfig-thunderbird-vine7
57Source12:       thunderbird-vine-default-prefs.js
58Source20:       thunderbird.desktop
59Source21:       thunderbird.vine.sh.in
60Source30:       thunderbird-open-browser.sh
61Source40:       thunderbird-unofficial-brandig-tb-brand.properties
62Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
63Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
64Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
65Source100:      find-external-requires
66
67# locale sources
68#%define MOZ_BUILD_LOCALES "ja"
69# get from mercurial repository with command,
70# mkdir l10n
71# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
72#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
73
74
75# upstream patch
76
77# Fix for version issues
78Patch0:         thunderbird-version.patch
79
80# customization patches
81Patch1:         firefox-1.5-default-a4-paper.patch
82
83
84# Linux specific
85Patch100:       thunderbird-9.0-enable-addons.patch
86
87BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
88BuildRequires:  pango-devel
89BuildRequires:  cairo-devel >= %{cairo_version}
90%if %{build_vine7}
91BuildRequires:  nspr-devel >= %{nspr_version}
92BuildRequires:  nss-devel >= %{nss_version}
93BuildRequires:  hunspell-devel
94%endif
95%if %{build_vine6}
96BuildRequires:  hunspell-devel
97%endif
98BuildRequires:  pixman-devel
99BuildRequires:  libpng-devel
100%if %{build_vine5}
101BuildRequires:  libjpeg-devel
102%else
103BuildRequires:  libjpeg-turbo-devel
104%endif
105BuildRequires:  gtk2-devel
106BuildRequires:  zlib-devel, gzip, zip, unzip
107BuildRequires:  libIDL-devel
108BuildRequires:  freetype2-devel >= %{freetype_version}
109## disabled libnotify support
110## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
111BuildRequires:  libnotify-devel >= %{libnotify_version}
112BuildRequires:  bzip2-devel
113BuildRequires:  gnome-vfs2-devel
114BuildRequires:  libgnome-devel
115BuildRequires:  libgnomeui-devel
116BuildRequires:  krb5-devel
117BuildRequires:  pango-devel
118BuildRequires:  libXt-devel
119BuildRequires:  libXrender-devel
120# hunspell is in plus category for vine
121#BuildRequires: hunspell-devel
122BuildRequires:  sqlite3-devel >= %{sqlite_version}
123BuildRequires:  startup-notification-devel
124BuildRequires:  desktop-file-utils
125BuildRequires:  alsa-lib-devel
126BuildRequires:  yasm
127Requires:       sqlite3 >= %{sqlite_version}
128Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
129Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
130
131Obsoletes:      MozillaThunderbird
132Provides:       MozillaThunderbird = %{version}
133
134Vendor:         Project Vine
135Distribution:   Vine Linux
136Packager:       daisuke, ryoichi, kazutaka
137
138AutoProv: 0
139%define _use_internal_dependency_generator 0
140%define __find_requires %{SOURCE100}
141
142%description
143Thunderbird is a standalone mail and newsgroup client.
144
145%description -l ja
146Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
147
148#===============================================================================
149
150%prep
151%setup -q %{name}-%{version} -c
152cd %{tarballdir}
153
154# Fix for version issue
155sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
156    > version.patch
157%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
158
159cd mozilla
160%patch1 -p1 -b .default-a4
161
162cd -
163%{__rm} -f .mozconfig
164%if %{build_vine5}
165%{__cp} %{SOURCE1010} .mozconfig
166%endif
167%if %{build_vine6}
168%{__cp} %{SOURCE1020} .mozconfig
169%endif
170%if %{build_vine7}
171%{__cp} %{SOURCE1030} .mozconfig
172%endif
173
174# setup unofficial branding name
175%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
176%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
177
178%patch100 -p1 -b .addons
179
180#===============================================================================
181
182%build
183cd %{tarballdir}
184
185INTERNAL_GECKO=%{version_internal}
186MOZ_APP_DIR=%{mozappdir}
187
188
189%if %{build_vine7}
190MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
191%else
192%ifarch x86_64
193#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
194MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
195%else
196MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
197%endif
198%endif
199export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
200export CFLAGS="$RPM_OPT_FLAGS"
201#export CFLAGS=""
202export CXXFLAGS="$CFLAGS"
203export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
204
205%ifarch ppc ppc64 s390 s390x
206%define moz_make_flags -j1
207%else
208%define moz_make_flags %{?_smp_mflags}
209%endif
210
211export PREFIX='%{_prefix}'
212export LIBDIR='%{_libdir}'
213
214export LDFLAGS="-Wl,-rpath,%{mozappdir}"
215export MAKE="gmake %{moz_make_flags}"
216%{__make} -f client.mk build
217
218## build locales
219#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
220#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
221#for dir in $LOCALEDIRS
222#do
223#  for lang in %{MOZ_BUILD_LOCALES} ; do
224#    make -C $dir/locales AB_CD=$lang
225#  done
226#done
227
228#===============================================================================
229
230%install
231%{__rm} -rf $RPM_BUILD_ROOT
232cd %{tarballdir}
233
234INTERNAL_GECKO=%{version_internal}
235
236INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
237MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
238
239cd %{moz_objdir}
240DESTDIR=$RPM_BUILD_ROOT make install
241
242# install unofficial icons
243cd -
244
245%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
246%{__cp} mail/branding/aurora/mailicon16.png \
247        $RPM_BUILD_ROOT/%{mozappdir}/icons/
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
249%{__cp} mail/branding/aurora/mailicon16.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
252%{__cp} mail/branding/aurora/mailicon22.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
254%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
255%{__cp} mail/branding/aurora/mailicon24.png \
256        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
257%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
258%{__cp} mail/branding/aurora/mailicon32.png \
259        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
260%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
261%{__cp} mail/branding/aurora/mailicon48.png \
262        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
263%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
264%{__cp} mail/branding/aurora/mailicon256.png \
265        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
266
267desktop-file-install --vendor vine \
268  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
269
270# set up the thunderbird start script
271rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
272%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
273  $RPM_BUILD_ROOT%{_bindir}/thunderbird
274%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
275
276install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
277%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
278
279%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
280                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
281        $RPM_BUILD_ROOT/vine-default-prefs
282%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
283%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
284%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
285
286%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
287
288# own mozilla plugin dir (#135050)
289%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
290
291# own extension directories
292%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
293%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
294
295# install locales
296#for lang in %{MOZ_BUILD_LOCALES} ; do
297#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
298#done
299
300# install ja.xpi to langpacks directory
301#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
302#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
303# also setup unofficial branding name
304#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
305#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
306
307# install ja.xpi to langpack file
308%{__mkdir_p} lang_tmp
309unzip %{SOURCE1} -d lang_tmp
310# also setup unofficial branding name
311%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
312%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
313
314%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
315cd lang_tmp; \
316zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
317
318
319%clean
320%{__rm} -rf $RPM_BUILD_ROOT
321
322#===============================================================================
323
324%post
325update-desktop-database &> /dev/null || :
326touch --no-create %{_datadir}/icons/hicolor
327if [ -x %{_bindir}/gtk-update-icon-cache ]; then
328  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
329fi
330
331%postun
332update-desktop-database &> /dev/null || :
333touch --no-create %{_datadir}/icons/hicolor
334if [ -x %{_bindir}/gtk-update-icon-cache ]; then
335  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
336fi
337
338
339%files
340%defattr(-,root,root,-)
341%attr(755,root,root) %{_bindir}/thunderbird
342%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
343%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
344%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
345%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
346%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
347%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
348%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
349%{mozappdir}
350#%{_libdir}/mozilla
351%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
352%exclude %{_datadir}/idl/%{name}-%{version_internal}
353%exclude %{_includedir}/%{name}-%{version_internal}
354%exclude %{_libdir}/%{name}-devel-%{version_internal}
355
356#===============================================================================
357
358%changelog
359* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
360- new upstream release
361- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
362
363* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
364- new upstream release
365
366* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
367- new upstream release
368- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
369
370* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
371- new upstream release
372
373* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
374- new upstream release
375- update Source1030 (mozconfig-thunderbird-vine7)
376
377* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
378- new upstream release
379- update Source1020 (mozconfig-thunderbird-vine6)
380
381* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
382- new upstream release
383
384* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
385- new upstream release
386
387* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
388- new upstream release
389
390* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
391- new upstream release
392- update Source1
393
394* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
395- new upstream release
396- update Source1
397- add Source1030 (mozconfig-thunderbird-vine7)
398- add Patch100 (thunderbird-9.0-enable-addons.patch)
399
400* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
401- fix %%version_internal
402
403* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
404- new upstream release
405- update Source1
406
407* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
408- new upstream release
409- update Source1,21,1010,1020
410
411* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
412- rebuild with libnotify-0.7
413
414* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
415- enable-install-strip
416
417* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
418- new upstream release
419- drop obsolete patch and renumber patch26 to patch1
420- add BuildRequires: yasm
421- enable libnotify support
422- add --disable-updater and --disable-installer to mozconfig
423- use ja.xpi instead of l10n source
424- update Source21: add step to setup langpack plugin
425- update Source20: add japanese translation
426- add Source42 & Source43 for localized branding
427- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
428  for mozconfig-thunderbird-vine5
429
430* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
431- new upstream release with security fix
432
433* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
434- new upstream release with security fix
435
436* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
437- new upstream release with security fix
438
439* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
440- new upstream release with security fix
441- add patch5 to fix build failure
442
443* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
444- new upstream release
445
446* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
447- new upstream release with security fix
448- add Patch1030 to fix compilation error
449
450* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
451- change mozconfig (Source1030 & 1040): add --enable-jsd
452
453* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
454- new upstream release
455
456* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
457- new upstream release with security fix
458- add Patch0 from fedora development: fix version issue
459- remove BuildRequires: hunspell-devel
460- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
461
462* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
463- add BuildRequires: alsa-lib-devel
464- remove BuildRequires: libnotify-devel
465  (workaround for known bug)
466- update mozconfig to add --disable-libnotify option
467
468* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
469- new upstream release
470- update spec entirely
471- import patches from fedora (Patch1, 2 & 4)
472- drop outdated patches (Patch22, 24)
473- update Sources:
474  - mozconfig (Source1030 & Source1040)
475  - default prefs.js (Source12)
476  - unofficial branding (Source40 & Source41)
477  - japanese translation (Source1000)
478- update Patch1000 (sjis-alias)
479
480* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
481- new upstream release
482
483* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
484- new upstream release
485
486* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
487- don't install official branding logos
488
489* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
490- add necessary icons in %%{tbdir}/chrome/icons/default
491- add Packager tag
492
493* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
494- new upstream release
495
496* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
497- new upstream release
498
499* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
500- new upstream release
501
502* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
503- new upstream release
504
505* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
506- rebuilt for VineSeed
507
508* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
509- new upstream release
510
511* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
512- new upstream release
513- built for Vine Linux 4.x
514- dropped Patch1020 (merged into upstream)
515
516* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
517- added Patch1020 for workaround gcc visibility hidden bugs
518
519* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
520- build with new environment/toolchain
521- add build options to build with external nss/nspr libraries
522    ac_add_options --with-system-nspr
523    ac_add_options --with-system-nss
524
525* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
526- new upstream release
527
528* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
529- new upstream release
530
531* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
532- new upstream release
533
534* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
535- new upstream release
536
537* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
538- new upstream release
539- merge changes from firefox
540  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
541
542* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
543- new upstream release
544- build en-US locale
545- merge changes from firefox
546  - add upstream patches
547  - disable pango rendering by default
548    (workaround fix slow rendering in some page)
549
550* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
551- initial build for Vine Linux based on FC package
552- update to 1.5RC2
553
554* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
555- Fix issue with popup dialogs and other actions causing lockups
556
557* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
558- Update to 1.5 rc1
559
560* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
561- Update to 1.5 beta2
562
563* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
564- Update to 1.5 beta1
565- Bring the install phase of the spec file up to speed
566
567* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
568- Rebuild
569
570* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
571- Add patch to make file chooser dialog modal
572
573* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
574- Update to 1.0.6
575
576* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
577- 1.0.6 Release Candidate
578
579* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
580- Use system NSPR
581- Fix crash on 64bit platforms (#160330)
582
583* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
584- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
585  references, fixing the "no fonts" problem.
586
587* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
588- Change the Exec line in the desktop file to `thunderbird`
589
590* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
591- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
592
593* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
594- Add temporary workaround to not create files in the user's $HOME (#149664)
595
596* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
597- Don't have downloads "disappear" when downloading to desktop (#139015)
598- Fix for some more cursor issues in textareas (149991, 150002, 152089)
599- Add upstream patch to fix bidi justification of pango
600- Add patch to fix launching of helper applications
601- Add patch to properly link against libgfxshared_s.a
602- Fix multilib conflicts
603
604* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
605- correct confusing PANGO vars in startup script
606
607* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
608- Thunderbird 1.0.2
609
610* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
611- Add patch to compile against new fortified glibc macros
612
613* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
614- Rebuild against GCC 4.0
615- Add execshield patches
616- Minor specfile cleanup
617
618* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
619- Rebuild
620
621* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
622- Add RPM version to useragent
623
624* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
625- Port over pango patches from firefox
626
627* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
628- Thunderbird 1.0
629
630* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
631- Fix advanced prefs
632
633* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
634- Make this run on s390(x) now for real
635
636* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
637- Update to 1.0 rc1
638
639* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
640- Add patches to build and run on s390(x)
641
642* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
643- Rebuild to fix file chooser
644
645* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
646- Update to 0.9
647
648* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
649- Prevent inlining of stack direction detection (#135255)
650
651* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
652- More file chooser fixes (same as in firefox)
653- Fix for upstream 28327.
654
655* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
656- Update the pango patch
657
658* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
659- Pull over patches from firefox build:
660  - disable default application dialog
661  - don't include software update since it doesn't work
662  - make external app support work
663
664* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
665- Use pango for rendering
666
667* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
668- Fix for 64 bit crash at startup (b.m.o #256603)
669
670* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
671- Add patches to fix xremote (#135036)
672
673* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
674- Add patch to fix button focus issues (#133507)
675- Add patch for fix IMAP race issues (bmo #246439)
676
677* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
678- filter out library Provides: and internal Requires:
679
680* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
681- Backport the GTK+ File Chooser.
682- Add fix for JS math on x86_64 systems
683- Add pkgconfig patch
684
685* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
686- Update to 0.8.0
687- Remove enigmail
688- Update BuildRequires
689- Remove gcc34 and extension manager patches -- they are upstreamed.
690- Fix for gnome-vfs2 error at component registration
691
692* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
693- Build with --disable-xprint
694
695* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
696- remove all Xvfb-related hacks
697
698* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
699- actually apply psfonts
700- add mozilla gnome-uriloader patch to prevent build failure
701
702* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
703- rawhide import
704- apply NetBSD's freetype 2.1.8 patch
705- apply psfonts patch
706- remove BR on /usr/bin/ex, breaks beehive
707
708* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
709- oops, fix %%install
710
711* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
712- update to Thunderbird 0.7.3 and Enigmail 0.85.0
713- remove XUL.mfasl on startup, add Debian enigmail patches
714- add Xvfb hack for -install-global-extension
715
716* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
717- update to 0.7.2, just because it's there
718- update gcc-3.4 patch (Kaj Niemi)
719- add EM registration patch and remove instdir hack
720
721* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
722- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
723
724* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
725- update to 0.7.1
726- remove Enigmail
727
728* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
729- re-enable Enigmail 0.84.1
730- add gcc-3.4 patch (Kaj Niemi)
731- use official branding (with permission)
732
733* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
734- update to 0.7
735- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
736- specify libdir, change BR for apt (V. Skytt辰, #1617)
737
738* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
739- temporary workaround for enigmail skin "modern" bug
740
741* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
742- update to Enigmail 0.84.0
743- update launch script
744
745* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
746- installation directory now versioned
747- allow root to run the program (for installing extensions)
748- remove unnecessary %%pre and %%post
749- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
750
751* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
752- include Enigmail, re-add release notes
753- delete %{_libdir}/thunderbird in %%pre
754
755* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
756- update to Thunderbird 0.6
757
758* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
759- update to Thunderbird 0.6 RC1
760- add new icon, remove release notes
761
762* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
763- update to latest CVS, update mozconfig and %%build accordingly
764- update to Enigmail 0.83.6
765- remove x-remote and x86_64 patches
766- build with -Os
767
768* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
769- update x-remote patch
770- more startup script fixes
771
772* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
773- startup script fixes, and a minor cleanup
774
775* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
776- Minor cleanups
777
778* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
779- minor improvements to open-browser.sh and startup script
780- update to latest version of Blizzard's x-remote patch
781
782* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
783- update open-browser.sh, startup script, and BuildRequires
784
785* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
786- update open-browser script, modify BuildRequires (Warren)
787- add Blizzard's x-remote patch
788- initial attempt at x-remote-enabled startup script
789
790* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
791- refuse to run with excessive privileges
792
793* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
794- add Mozilla x86_64 patch (Oliver Sontag)
795- Enigmail source filenames now include the version
796- modify BuildRoot
797
798* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
799- use the updated official tarball
800
801* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
802- fix %%prep script
803
804* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
805- update Enigmail to 0.83.3
806- use official source tarball (after removing the CRLFs)
807- package renamed to thunderbird
808
809* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
810- update to 0.5
811- check for lockfile before launching
812
813* Fri Feb 06 2004 David Hill <djh[at]ii.net>
814- update to latest cvs
815- update to Enigmail 0.83.2
816
817* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
818- update to Enigmail 0.83.1
819- removed Mozilla/Firebird script patching
820
821* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
822- add startup notification to .desktop file
823
824* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
825- open-browser.sh release 3
826- patch broken /usr/bin/mozilla script during install
827- dir ownership
828- XXX: Source fails build on x86_64... fix later
829
830* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
831- update to Enigmail 0.82.5
832- add Warren's open-browser.sh (#1113)
833
834* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
835- use Thunderbird's mozilla-xremote-client to launch browser
836
837* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
838- update to 0.4
839- make hyperlinks work (with recent versions of Firebird/Mozilla)
840
841* Thu Dec 04 2003 David Hill <djh[at]ii.net>
842- update to 0.4rc2
843
844* Wed Dec 03 2003 David Hill <djh[at]ii.net>
845- update to 0.4rc1 and Enigmail 0.82.4
846
847* Thu Nov 27 2003 David Hill <djh[at]ii.net>
848- update to latest CVS and Enigmail 0.82.3
849
850* Sun Nov 16 2003 David Hill <djh[at]ii.net>
851- update to latest CVS (0.4a)
852- update Enigmail to 0.82.2
853- alter mozconfig for new build requirements
854- add missing BuildReq (#987)
855
856* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
857- update to 0.3
858
859* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
860- update to 0.3rc3
861- update Enigmail to 0.81.7
862
863* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
864- update to 0.3rc2
865
866* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
867- simplify startup script
868
869* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
870- add GPG support (Enigmail 0.81.6)
871- specfile fixes (#679)
872
873* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
874- update to 0.2
875
876* Mon Sep 01 2003 David Hill <djh[at]ii.net>
877- initial RPM
878  (based on the fedora MozillaFirebird-0.6.1 specfile)
879
Note: See TracBrowser for help on using the repository browser.