source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 6761

Revision 6761, 29.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 15.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
82BuildRequires:  pango-devel
83BuildRequires:  cairo-devel >= %{cairo_version}
84%if %{build_vine7}
85BuildRequires:  nspr-devel >= %{nspr_version}
86BuildRequires:  nss-devel >= %{nss_version}
87BuildRequires:  hunspell-devel
88%endif
89%if %{build_vine6}
90BuildRequires:  hunspell-devel
91BuildRequires:  python-devel
92%endif
93BuildRequires:  pixman-devel
94BuildRequires:  libpng-devel
95BuildRequires:  libjpeg-turbo-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  zlib-devel, gzip, zip, unzip
98BuildRequires:  libIDL-devel
99BuildRequires:  freetype2-devel >= %{freetype_version}
100## disabled libnotify support
101## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
102BuildRequires:  libnotify-devel >= %{libnotify_version}
103BuildRequires:  bzip2-devel
104BuildRequires:  gnome-vfs2-devel
105BuildRequires:  libgnome-devel
106BuildRequires:  libgnomeui-devel
107BuildRequires:  krb5-devel
108BuildRequires:  pango-devel
109BuildRequires:  libXt-devel
110BuildRequires:  libXrender-devel
111# hunspell is in plus category for vine
112#BuildRequires: hunspell-devel
113BuildRequires:  sqlite3-devel >= %{sqlite_version}
114BuildRequires:  startup-notification-devel
115BuildRequires:  desktop-file-utils
116BuildRequires:  alsa-lib-devel
117BuildRequires:  yasm
118Requires:       sqlite3 >= %{sqlite_version}
119Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
120Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
121
122Obsoletes:      MozillaThunderbird
123Provides:       MozillaThunderbird = %{version}
124
125Vendor:         Project Vine
126Distribution:   Vine Linux
127Packager:       daisuke, ryoichi, kazutaka
128
129AutoProv: 0
130%define _use_internal_dependency_generator 0
131%define __find_requires %{SOURCE100}
132
133%description
134Thunderbird is a standalone mail and newsgroup client.
135
136%description -l ja
137Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
138
139#===============================================================================
140
141%prep
142%setup -q %{name}-%{version} -c
143cd %{tarballdir}
144
145# Fix for version issue
146sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
147    > version.patch
148%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
149
150cd mozilla
151%patch1 -p1 -b .default-a4
152
153cd -
154%{__rm} -f .mozconfig
155%if %{build_vine6}
156%{__cp} %{SOURCE1010} .mozconfig
157%endif
158%if %{build_vine7}
159%{__cp} %{SOURCE1020} .mozconfig
160%endif
161
162# setup unofficial branding name
163%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
164%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
165
166%patch100 -p1 -b .addons
167
168#===============================================================================
169
170%build
171cd %{tarballdir}
172
173INTERNAL_GECKO=%{version_internal}
174MOZ_APP_DIR=%{mozappdir}
175
176
177%if %{build_vine7}
178MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
179%else
180%ifarch x86_64
181#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
182MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
183%else
184MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
185%endif
186%endif
187export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
188export CFLAGS="$RPM_OPT_FLAGS"
189#export CFLAGS=""
190export CXXFLAGS="$CFLAGS"
191export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
192
193%ifarch ppc ppc64 s390 s390x
194%define moz_make_flags -j1
195%else
196%define moz_make_flags %{?_smp_mflags}
197%endif
198
199export PREFIX='%{_prefix}'
200export LIBDIR='%{_libdir}'
201
202export LDFLAGS="-Wl,-rpath,%{mozappdir}"
203export MAKE="gmake %{moz_make_flags}"
204%{__make} -f client.mk build
205
206## build locales
207#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
208#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
209#for dir in $LOCALEDIRS
210#do
211#  for lang in %{MOZ_BUILD_LOCALES} ; do
212#    make -C $dir/locales AB_CD=$lang
213#  done
214#done
215
216#===============================================================================
217
218%install
219%{__rm} -rf $RPM_BUILD_ROOT
220cd %{tarballdir}
221
222INTERNAL_GECKO=%{version_internal}
223
224INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
225MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
226
227cd %{moz_objdir}
228DESTDIR=$RPM_BUILD_ROOT make install
229
230# install unofficial icons
231cd -
232
233%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
234%{__cp} mail/branding/aurora/mailicon16.png \
235        $RPM_BUILD_ROOT/%{mozappdir}/icons/
236%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
237%{__cp} mail/branding/aurora/mailicon16.png \
238        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
239%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
240%{__cp} mail/branding/aurora/mailicon22.png \
241        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
242%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
243%{__cp} mail/branding/aurora/mailicon24.png \
244        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
245%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
246%{__cp} mail/branding/aurora/mailicon32.png \
247        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
249%{__cp} mail/branding/aurora/mailicon48.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
252%{__cp} mail/branding/aurora/mailicon256.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
254
255desktop-file-install --vendor vine \
256  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
257
258# set up the thunderbird start script
259rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
260%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
261  $RPM_BUILD_ROOT%{_bindir}/thunderbird
262%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
263
264install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
265%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
266
267%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
268                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
269        $RPM_BUILD_ROOT/vine-default-prefs
270%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
271%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
272%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
273
274%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
275
276# own mozilla plugin dir (#135050)
277%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
278
279# own extension directories
280%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
281%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
282
283# install locales
284#for lang in %{MOZ_BUILD_LOCALES} ; do
285#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
286#done
287
288# install ja.xpi to langpacks directory
289#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
290#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
291# also setup unofficial branding name
292#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
293#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
294
295# install ja.xpi to langpack file
296%{__mkdir_p} lang_tmp
297unzip %{SOURCE1} -d lang_tmp
298# also setup unofficial branding name
299%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
300%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
301
302%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
303cd lang_tmp; \
304zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
305
306
307%clean
308%{__rm} -rf $RPM_BUILD_ROOT
309
310#===============================================================================
311
312%post
313update-desktop-database &> /dev/null || :
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x %{_bindir}/gtk-update-icon-cache ]; then
316  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
317fi
318
319%postun
320update-desktop-database &> /dev/null || :
321touch --no-create %{_datadir}/icons/hicolor
322if [ -x %{_bindir}/gtk-update-icon-cache ]; then
323  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
324fi
325
326
327%files
328%defattr(-,root,root,-)
329%attr(755,root,root) %{_bindir}/thunderbird
330%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
331%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
332%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
333%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
334%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
335%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
336%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
337%{mozappdir}
338#%{_libdir}/mozilla
339%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
340%exclude %{_datadir}/idl/%{name}-%{version_internal}
341%exclude %{_includedir}/%{name}-%{version_internal}
342%exclude %{_libdir}/%{name}-devel-%{version_internal}
343
344#===============================================================================
345
346%changelog
347* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
348- new upstream release
349- add BuildRequires: python-devel (Vine6 only)
350- remove build rule of Vine5
351
352* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
353- new upstream release
354- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
355
356* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
357- new upstream release
358
359* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
360- new upstream release
361- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
362
363* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
364- new upstream release
365
366* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
367- new upstream release
368- update Source1030 (mozconfig-thunderbird-vine7)
369
370* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
371- new upstream release
372- update Source1020 (mozconfig-thunderbird-vine6)
373
374* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
375- new upstream release
376
377* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
378- new upstream release
379
380* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
381- new upstream release
382
383* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
384- new upstream release
385- update Source1
386
387* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
388- new upstream release
389- update Source1
390- add Source1030 (mozconfig-thunderbird-vine7)
391- add Patch100 (thunderbird-9.0-enable-addons.patch)
392
393* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
394- fix %%version_internal
395
396* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
397- new upstream release
398- update Source1
399
400* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
401- new upstream release
402- update Source1,21,1010,1020
403
404* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
405- rebuild with libnotify-0.7
406
407* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
408- enable-install-strip
409
410* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
411- new upstream release
412- drop obsolete patch and renumber patch26 to patch1
413- add BuildRequires: yasm
414- enable libnotify support
415- add --disable-updater and --disable-installer to mozconfig
416- use ja.xpi instead of l10n source
417- update Source21: add step to setup langpack plugin
418- update Source20: add japanese translation
419- add Source42 & Source43 for localized branding
420- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
421  for mozconfig-thunderbird-vine5
422
423* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
424- new upstream release with security fix
425
426* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
427- new upstream release with security fix
428
429* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
430- new upstream release with security fix
431
432* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
433- new upstream release with security fix
434- add patch5 to fix build failure
435
436* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
437- new upstream release
438
439* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
440- new upstream release with security fix
441- add Patch1030 to fix compilation error
442
443* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
444- change mozconfig (Source1030 & 1040): add --enable-jsd
445
446* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
447- new upstream release
448
449* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
450- new upstream release with security fix
451- add Patch0 from fedora development: fix version issue
452- remove BuildRequires: hunspell-devel
453- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
454
455* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
456- add BuildRequires: alsa-lib-devel
457- remove BuildRequires: libnotify-devel
458  (workaround for known bug)
459- update mozconfig to add --disable-libnotify option
460
461* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
462- new upstream release
463- update spec entirely
464- import patches from fedora (Patch1, 2 & 4)
465- drop outdated patches (Patch22, 24)
466- update Sources:
467  - mozconfig (Source1030 & Source1040)
468  - default prefs.js (Source12)
469  - unofficial branding (Source40 & Source41)
470  - japanese translation (Source1000)
471- update Patch1000 (sjis-alias)
472
473* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
474- new upstream release
475
476* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
477- new upstream release
478
479* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
480- don't install official branding logos
481
482* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
483- add necessary icons in %%{tbdir}/chrome/icons/default
484- add Packager tag
485
486* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
487- new upstream release
488
489* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
490- new upstream release
491
492* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
493- new upstream release
494
495* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
496- new upstream release
497
498* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
499- rebuilt for VineSeed
500
501* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
502- new upstream release
503
504* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
505- new upstream release
506- built for Vine Linux 4.x
507- dropped Patch1020 (merged into upstream)
508
509* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
510- added Patch1020 for workaround gcc visibility hidden bugs
511
512* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
513- build with new environment/toolchain
514- add build options to build with external nss/nspr libraries
515    ac_add_options --with-system-nspr
516    ac_add_options --with-system-nss
517
518* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
519- new upstream release
520
521* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
522- new upstream release
523
524* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
525- new upstream release
526
527* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
528- new upstream release
529
530* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
531- new upstream release
532- merge changes from firefox
533  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
534
535* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
536- new upstream release
537- build en-US locale
538- merge changes from firefox
539  - add upstream patches
540  - disable pango rendering by default
541    (workaround fix slow rendering in some page)
542
543* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
544- initial build for Vine Linux based on FC package
545- update to 1.5RC2
546
547* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
548- Fix issue with popup dialogs and other actions causing lockups
549
550* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
551- Update to 1.5 rc1
552
553* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
554- Update to 1.5 beta2
555
556* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
557- Update to 1.5 beta1
558- Bring the install phase of the spec file up to speed
559
560* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
561- Rebuild
562
563* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
564- Add patch to make file chooser dialog modal
565
566* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
567- Update to 1.0.6
568
569* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
570- 1.0.6 Release Candidate
571
572* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
573- Use system NSPR
574- Fix crash on 64bit platforms (#160330)
575
576* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
577- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
578  references, fixing the "no fonts" problem.
579
580* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
581- Change the Exec line in the desktop file to `thunderbird`
582
583* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
584- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
585
586* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
587- Add temporary workaround to not create files in the user's $HOME (#149664)
588
589* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
590- Don't have downloads "disappear" when downloading to desktop (#139015)
591- Fix for some more cursor issues in textareas (149991, 150002, 152089)
592- Add upstream patch to fix bidi justification of pango
593- Add patch to fix launching of helper applications
594- Add patch to properly link against libgfxshared_s.a
595- Fix multilib conflicts
596
597* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
598- correct confusing PANGO vars in startup script
599
600* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
601- Thunderbird 1.0.2
602
603* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
604- Add patch to compile against new fortified glibc macros
605
606* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
607- Rebuild against GCC 4.0
608- Add execshield patches
609- Minor specfile cleanup
610
611* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
612- Rebuild
613
614* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
615- Add RPM version to useragent
616
617* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
618- Port over pango patches from firefox
619
620* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
621- Thunderbird 1.0
622
623* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
624- Fix advanced prefs
625
626* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
627- Make this run on s390(x) now for real
628
629* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
630- Update to 1.0 rc1
631
632* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
633- Add patches to build and run on s390(x)
634
635* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
636- Rebuild to fix file chooser
637
638* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
639- Update to 0.9
640
641* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
642- Prevent inlining of stack direction detection (#135255)
643
644* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
645- More file chooser fixes (same as in firefox)
646- Fix for upstream 28327.
647
648* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
649- Update the pango patch
650
651* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
652- Pull over patches from firefox build:
653  - disable default application dialog
654  - don't include software update since it doesn't work
655  - make external app support work
656
657* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
658- Use pango for rendering
659
660* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
661- Fix for 64 bit crash at startup (b.m.o #256603)
662
663* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
664- Add patches to fix xremote (#135036)
665
666* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
667- Add patch to fix button focus issues (#133507)
668- Add patch for fix IMAP race issues (bmo #246439)
669
670* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
671- filter out library Provides: and internal Requires:
672
673* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
674- Backport the GTK+ File Chooser.
675- Add fix for JS math on x86_64 systems
676- Add pkgconfig patch
677
678* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
679- Update to 0.8.0
680- Remove enigmail
681- Update BuildRequires
682- Remove gcc34 and extension manager patches -- they are upstreamed.
683- Fix for gnome-vfs2 error at component registration
684
685* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
686- Build with --disable-xprint
687
688* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
689- remove all Xvfb-related hacks
690
691* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
692- actually apply psfonts
693- add mozilla gnome-uriloader patch to prevent build failure
694
695* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
696- rawhide import
697- apply NetBSD's freetype 2.1.8 patch
698- apply psfonts patch
699- remove BR on /usr/bin/ex, breaks beehive
700
701* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
702- oops, fix %%install
703
704* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
705- update to Thunderbird 0.7.3 and Enigmail 0.85.0
706- remove XUL.mfasl on startup, add Debian enigmail patches
707- add Xvfb hack for -install-global-extension
708
709* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
710- update to 0.7.2, just because it's there
711- update gcc-3.4 patch (Kaj Niemi)
712- add EM registration patch and remove instdir hack
713
714* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
715- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
716
717* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
718- update to 0.7.1
719- remove Enigmail
720
721* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
722- re-enable Enigmail 0.84.1
723- add gcc-3.4 patch (Kaj Niemi)
724- use official branding (with permission)
725
726* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
727- update to 0.7
728- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
729- specify libdir, change BR for apt (V. Skytt辰, #1617)
730
731* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
732- temporary workaround for enigmail skin "modern" bug
733
734* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
735- update to Enigmail 0.84.0
736- update launch script
737
738* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
739- installation directory now versioned
740- allow root to run the program (for installing extensions)
741- remove unnecessary %%pre and %%post
742- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
743
744* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
745- include Enigmail, re-add release notes
746- delete %{_libdir}/thunderbird in %%pre
747
748* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
749- update to Thunderbird 0.6
750
751* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
752- update to Thunderbird 0.6 RC1
753- add new icon, remove release notes
754
755* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
756- update to latest CVS, update mozconfig and %%build accordingly
757- update to Enigmail 0.83.6
758- remove x-remote and x86_64 patches
759- build with -Os
760
761* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
762- update x-remote patch
763- more startup script fixes
764
765* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
766- startup script fixes, and a minor cleanup
767
768* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
769- Minor cleanups
770
771* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
772- minor improvements to open-browser.sh and startup script
773- update to latest version of Blizzard's x-remote patch
774
775* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
776- update open-browser.sh, startup script, and BuildRequires
777
778* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
779- update open-browser script, modify BuildRequires (Warren)
780- add Blizzard's x-remote patch
781- initial attempt at x-remote-enabled startup script
782
783* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
784- refuse to run with excessive privileges
785
786* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
787- add Mozilla x86_64 patch (Oliver Sontag)
788- Enigmail source filenames now include the version
789- modify BuildRoot
790
791* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
792- use the updated official tarball
793
794* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
795- fix %%prep script
796
797* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
798- update Enigmail to 0.83.3
799- use official source tarball (after removing the CRLFs)
800- package renamed to thunderbird
801
802* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
803- update to 0.5
804- check for lockfile before launching
805
806* Fri Feb 06 2004 David Hill <djh[at]ii.net>
807- update to latest cvs
808- update to Enigmail 0.83.2
809
810* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
811- update to Enigmail 0.83.1
812- removed Mozilla/Firebird script patching
813
814* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
815- add startup notification to .desktop file
816
817* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
818- open-browser.sh release 3
819- patch broken /usr/bin/mozilla script during install
820- dir ownership
821- XXX: Source fails build on x86_64... fix later
822
823* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
824- update to Enigmail 0.82.5
825- add Warren's open-browser.sh (#1113)
826
827* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
828- use Thunderbird's mozilla-xremote-client to launch browser
829
830* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
831- update to 0.4
832- make hyperlinks work (with recent versions of Firebird/Mozilla)
833
834* Thu Dec 04 2003 David Hill <djh[at]ii.net>
835- update to 0.4rc2
836
837* Wed Dec 03 2003 David Hill <djh[at]ii.net>
838- update to 0.4rc1 and Enigmail 0.82.4
839
840* Thu Nov 27 2003 David Hill <djh[at]ii.net>
841- update to latest CVS and Enigmail 0.82.3
842
843* Sun Nov 16 2003 David Hill <djh[at]ii.net>
844- update to latest CVS (0.4a)
845- update Enigmail to 0.82.2
846- alter mozconfig for new build requirements
847- add missing BuildReq (#987)
848
849* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
850- update to 0.3
851
852* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
853- update to 0.3rc3
854- update Enigmail to 0.81.7
855
856* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
857- update to 0.3rc2
858
859* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
860- simplify startup script
861
862* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
863- add GPG support (Enigmail 0.81.6)
864- specfile fixes (#679)
865
866* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
867- update to 0.2
868
869* Mon Sep 01 2003 David Hill <djh[at]ii.net>
870- initial RPM
871  (based on the fedora MozillaFirebird-0.6.1 specfile)
872
Note: See TracBrowser for help on using the repository browser.