source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 5549

Revision 5549, 28.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 10.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal 9.0.1
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.13.1
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30%define build_vine5 0
31
32%if "%{?_dist_release}" >= "vl7"
33%define build_vine7 1
34%endif
35%if "%{?_dist_release}" == "vl6"
36%define build_vine6 1
37%endif
38%if "%{?_dist_release}" == "vl5"
39%define build_vine5 1
40%endif
41
42
43Summary:        Thunderbird Community Edition, Mail/newsgroup client
44Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
45Name:           thunderbird
46Version:        %{tbversion}
47Release:        %{tbrelease}
48URL:            http://www.mozilla.org/projects/thunderbird/
49License:        MPL
50Group:          Applications/Internet
51
52Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
53Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
54Source1010:     mozconfig-thunderbird-vine5
55Source1020:     mozconfig-thunderbird-vine6
56Source1030:     mozconfig-thunderbird-vine7
57Source12:       thunderbird-vine-default-prefs.js
58Source20:       thunderbird.desktop
59Source21:       thunderbird.vine.sh.in
60Source30:       thunderbird-open-browser.sh
61Source40:       thunderbird-unofficial-brandig-tb-brand.properties
62Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
63Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
64Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
65Source100:      find-external-requires
66
67# locale sources
68#%define MOZ_BUILD_LOCALES "ja"
69# get from mercurial repository with command,
70# mkdir l10n
71# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
72#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
73
74
75# upstream patch
76
77# Fix for version issues
78Patch0:         thunderbird-version.patch
79
80# customization patches
81Patch1:         firefox-1.5-default-a4-paper.patch
82
83# Linux specific
84Patch100:       thunderbird-9.0-enable-addons.patch
85
86BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
87BuildRequires:  pango-devel
88BuildRequires:  cairo-devel >= %{cairo_version}
89%if %{build_vine7}
90BuildRequires:  nspr-devel >= %{nspr_version}
91BuildRequires:  nss-devel >= %{nss_version}
92BuildRequires:  hunspell-devel
93%endif
94%if %{build_vine6}
95BuildRequires:  nspr-devel >= %{nspr_version}
96BuildRequires:  hunspell-devel
97%endif
98BuildRequires:  pixman-devel
99BuildRequires:  libpng-devel
100%if %{build_vine5}
101BuildRequires:  libjpeg-devel
102%else
103BuildRequires:  libjpeg-turbo-devel
104%endif
105BuildRequires:  gtk2-devel
106BuildRequires:  zlib-devel, gzip, zip, unzip
107BuildRequires:  libIDL-devel
108BuildRequires:  freetype2-devel >= %{freetype_version}
109## disabled libnotify support
110## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
111BuildRequires:  libnotify-devel >= %{libnotify_version}
112BuildRequires:  bzip2-devel
113BuildRequires:  gnome-vfs2-devel
114BuildRequires:  libgnome-devel
115BuildRequires:  libgnomeui-devel
116BuildRequires:  krb5-devel
117BuildRequires:  pango-devel
118BuildRequires:  libXt-devel
119BuildRequires:  libXrender-devel
120# hunspell is in plus category for vine
121#BuildRequires: hunspell-devel
122BuildRequires:  sqlite3-devel >= %{sqlite_version}
123BuildRequires:  startup-notification-devel
124BuildRequires:  desktop-file-utils
125BuildRequires:  alsa-lib-devel
126BuildRequires:  yasm
127Requires:       sqlite3 >= %{sqlite_version}
128Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
129Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
130
131Obsoletes:      MozillaThunderbird
132Provides:       MozillaThunderbird = %{version}
133
134Vendor:         Project Vine
135Distribution:   Vine Linux
136Packager:       daisuke, ryoichi, kazutaka
137
138AutoProv: 0
139%define _use_internal_dependency_generator 0
140%define __find_requires %{SOURCE100}
141
142%description
143Thunderbird is a standalone mail and newsgroup client.
144
145%description -l ja
146Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
147
148#===============================================================================
149
150%prep
151%setup -q %{name}-%{version} -c
152cd %{tarballdir}
153
154# Fix for version issue
155sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
156    > version.patch
157%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
158
159cd mozilla
160%patch1 -p1 -b .default-a4
161
162cd -
163%{__rm} -f .mozconfig
164%if %{build_vine5}
165%{__cp} %{SOURCE1010} .mozconfig
166%endif
167%if %{build_vine6}
168%{__cp} %{SOURCE1020} .mozconfig
169%endif
170%if %{build_vine7}
171%{__cp} %{SOURCE1030} .mozconfig
172%endif
173
174# setup unofficial branding name
175%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
176%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
177
178%patch100 -p1 -b .addons
179
180#===============================================================================
181
182%build
183cd %{tarballdir}
184
185INTERNAL_GECKO=%{version_internal}
186MOZ_APP_DIR=%{mozappdir}
187
188
189#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
190MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
191export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
192export CFLAGS="$RPM_OPT_FLAGS"
193export CXXFLAGS="$CFLAGS"
194export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
195
196%ifarch ppc ppc64 s390 s390x
197%define moz_make_flags -j1
198%else
199%define moz_make_flags %{?_smp_mflags}
200%endif
201
202export PREFIX='%{_prefix}'
203export LIBDIR='%{_libdir}'
204
205export LDFLAGS="-Wl,-rpath,%{mozappdir}"
206export MAKE="gmake %{moz_make_flags}"
207%{__make} -f client.mk build
208
209## build locales
210#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
211#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
212#for dir in $LOCALEDIRS
213#do
214#  for lang in %{MOZ_BUILD_LOCALES} ; do
215#    make -C $dir/locales AB_CD=$lang
216#  done
217#done
218
219#===============================================================================
220
221%install
222%{__rm} -rf $RPM_BUILD_ROOT
223cd %{tarballdir}
224
225INTERNAL_GECKO=%{version_internal}
226
227INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
228MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
229
230cd %{moz_objdir}
231DESTDIR=$RPM_BUILD_ROOT make install
232
233# install unofficial icons
234cd -
235
236%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
237%{__cp} mail/branding/aurora/mailicon16.png \
238        $RPM_BUILD_ROOT/%{mozappdir}/icons/
239%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
240%{__cp} mail/branding/aurora/mailicon16.png \
241        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
242%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
243%{__cp} mail/branding/aurora/mailicon22.png \
244        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
245%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
246%{__cp} mail/branding/aurora/mailicon24.png \
247        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
249%{__cp} mail/branding/aurora/mailicon32.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
252%{__cp} mail/branding/aurora/mailicon48.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
254%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
255%{__cp} mail/branding/aurora/mailicon256.png \
256        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
257
258desktop-file-install --vendor vine \
259  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
260
261# set up the thunderbird start script
262rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
263%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
264  $RPM_BUILD_ROOT%{_bindir}/thunderbird
265%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
266
267install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
268%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
269
270%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
271                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
272        $RPM_BUILD_ROOT/vine-default-prefs
273%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
274%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
275%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
276
277%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
278
279# own mozilla plugin dir (#135050)
280%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
281
282# own extension directories
283%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
284%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
285
286# install locales
287#for lang in %{MOZ_BUILD_LOCALES} ; do
288#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
289#done
290
291# install ja.xpi to langpacks directory
292#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
293#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
294# also setup unofficial branding name
295#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
296#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
297
298# install ja.xpi to langpack file
299%{__mkdir_p} lang_tmp
300unzip %{SOURCE1} -d lang_tmp
301# also setup unofficial branding name
302%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
303%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
304
305%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
306cd lang_tmp; \
307zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
308
309
310%clean
311%{__rm} -rf $RPM_BUILD_ROOT
312
313#===============================================================================
314
315%post
316update-desktop-database &> /dev/null || :
317touch --no-create %{_datadir}/icons/hicolor
318if [ -x %{_bindir}/gtk-update-icon-cache ]; then
319  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
320fi
321
322%postun
323update-desktop-database &> /dev/null || :
324touch --no-create %{_datadir}/icons/hicolor
325if [ -x %{_bindir}/gtk-update-icon-cache ]; then
326  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
327fi
328
329
330%files
331%defattr(-,root,root,-)
332%attr(755,root,root) %{_bindir}/thunderbird
333%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
334%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
335%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
336%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
337%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
338%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
339%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
340%{mozappdir}
341#%{_libdir}/mozilla
342%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
343%exclude %{_datadir}/idl/%{name}-%{version_internal}
344%exclude %{_includedir}/%{name}-%{version_internal}
345%exclude %{_libdir}/%{name}-devel-%{version_internal}
346
347#===============================================================================
348
349%changelog
350* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
351- new upstream release
352
353* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
354- new upstream release
355- update Source1
356
357* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
358- new upstream release
359- update Source1
360- add Source1030 (mozconfig-thunderbird-vine7)
361- add Patch100 (thunderbird-9.0-enable-addons.patch)
362
363* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
364- fix %%version_internal
365
366* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
367- new upstream release
368- update Source1
369
370* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
371- new upstream release
372- update Source1,21,1010,1020
373
374* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
375- rebuild with libnotify-0.7
376
377* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
378- enable-install-strip
379
380* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
381- new upstream release
382- drop obsolete patch and renumber patch26 to patch1
383- add BuildRequires: yasm
384- enable libnotify support
385- add --disable-updater and --disable-installer to mozconfig
386- use ja.xpi instead of l10n source
387- update Source21: add step to setup langpack plugin
388- update Source20: add japanese translation
389- add Source42 & Source43 for localized branding
390- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
391  for mozconfig-thunderbird-vine5
392
393* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
394- new upstream release with security fix
395
396* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
397- new upstream release with security fix
398
399* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
400- new upstream release with security fix
401
402* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
403- new upstream release with security fix
404- add patch5 to fix build failure
405
406* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
407- new upstream release
408
409* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
410- new upstream release with security fix
411- add Patch1030 to fix compilation error
412
413* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
414- change mozconfig (Source1030 & 1040): add --enable-jsd
415
416* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
417- new upstream release
418
419* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
420- new upstream release with security fix
421- add Patch0 from fedora development: fix version issue
422- remove BuildRequires: hunspell-devel
423- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
424
425* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
426- add BuildRequires: alsa-lib-devel
427- remove BuildRequires: libnotify-devel
428  (workaround for known bug)
429- update mozconfig to add --disable-libnotify option
430
431* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
432- new upstream release
433- update spec entirely
434- import patches from fedora (Patch1, 2 & 4)
435- drop outdated patches (Patch22, 24)
436- update Sources:
437  - mozconfig (Source1030 & Source1040)
438  - default prefs.js (Source12)
439  - unofficial branding (Source40 & Source41)
440  - japanese translation (Source1000)
441- update Patch1000 (sjis-alias)
442
443* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
444- new upstream release
445
446* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
447- new upstream release
448
449* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
450- don't install official branding logos
451
452* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
453- add necessary icons in %%{tbdir}/chrome/icons/default
454- add Packager tag
455
456* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
457- new upstream release
458
459* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
460- new upstream release
461
462* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
463- new upstream release
464
465* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
466- new upstream release
467
468* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
469- rebuilt for VineSeed
470
471* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
472- new upstream release
473
474* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
475- new upstream release
476- built for Vine Linux 4.x
477- dropped Patch1020 (merged into upstream)
478
479* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
480- added Patch1020 for workaround gcc visibility hidden bugs
481
482* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
483- build with new environment/toolchain
484- add build options to build with external nss/nspr libraries
485    ac_add_options --with-system-nspr
486    ac_add_options --with-system-nss
487
488* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
489- new upstream release
490
491* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
492- new upstream release
493
494* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
495- new upstream release
496
497* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
498- new upstream release
499
500* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
501- new upstream release
502- merge changes from firefox
503  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
504
505* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
506- new upstream release
507- build en-US locale
508- merge changes from firefox
509  - add upstream patches
510  - disable pango rendering by default
511    (workaround fix slow rendering in some page)
512
513* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
514- initial build for Vine Linux based on FC package
515- update to 1.5RC2
516
517* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
518- Fix issue with popup dialogs and other actions causing lockups
519
520* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
521- Update to 1.5 rc1
522
523* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
524- Update to 1.5 beta2
525
526* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
527- Update to 1.5 beta1
528- Bring the install phase of the spec file up to speed
529
530* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
531- Rebuild
532
533* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
534- Add patch to make file chooser dialog modal
535
536* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
537- Update to 1.0.6
538
539* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
540- 1.0.6 Release Candidate
541
542* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
543- Use system NSPR
544- Fix crash on 64bit platforms (#160330)
545
546* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
547- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
548  references, fixing the "no fonts" problem.
549
550* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
551- Change the Exec line in the desktop file to `thunderbird`
552
553* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
554- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
555
556* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
557- Add temporary workaround to not create files in the user's $HOME (#149664)
558
559* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
560- Don't have downloads "disappear" when downloading to desktop (#139015)
561- Fix for some more cursor issues in textareas (149991, 150002, 152089)
562- Add upstream patch to fix bidi justification of pango
563- Add patch to fix launching of helper applications
564- Add patch to properly link against libgfxshared_s.a
565- Fix multilib conflicts
566
567* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
568- correct confusing PANGO vars in startup script
569
570* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
571- Thunderbird 1.0.2
572
573* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
574- Add patch to compile against new fortified glibc macros
575
576* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
577- Rebuild against GCC 4.0
578- Add execshield patches
579- Minor specfile cleanup
580
581* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
582- Rebuild
583
584* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
585- Add RPM version to useragent
586
587* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
588- Port over pango patches from firefox
589
590* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
591- Thunderbird 1.0
592
593* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
594- Fix advanced prefs
595
596* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
597- Make this run on s390(x) now for real
598
599* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
600- Update to 1.0 rc1
601
602* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
603- Add patches to build and run on s390(x)
604
605* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
606- Rebuild to fix file chooser
607
608* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
609- Update to 0.9
610
611* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
612- Prevent inlining of stack direction detection (#135255)
613
614* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
615- More file chooser fixes (same as in firefox)
616- Fix for upstream 28327.
617
618* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
619- Update the pango patch
620
621* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
622- Pull over patches from firefox build:
623  - disable default application dialog
624  - don't include software update since it doesn't work
625  - make external app support work
626
627* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
628- Use pango for rendering
629
630* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
631- Fix for 64 bit crash at startup (b.m.o #256603)
632
633* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
634- Add patches to fix xremote (#135036)
635
636* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
637- Add patch to fix button focus issues (#133507)
638- Add patch for fix IMAP race issues (bmo #246439)
639
640* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
641- filter out library Provides: and internal Requires:
642
643* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
644- Backport the GTK+ File Chooser.
645- Add fix for JS math on x86_64 systems
646- Add pkgconfig patch
647
648* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
649- Update to 0.8.0
650- Remove enigmail
651- Update BuildRequires
652- Remove gcc34 and extension manager patches -- they are upstreamed.
653- Fix for gnome-vfs2 error at component registration
654
655* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
656- Build with --disable-xprint
657
658* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
659- remove all Xvfb-related hacks
660
661* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
662- actually apply psfonts
663- add mozilla gnome-uriloader patch to prevent build failure
664
665* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
666- rawhide import
667- apply NetBSD's freetype 2.1.8 patch
668- apply psfonts patch
669- remove BR on /usr/bin/ex, breaks beehive
670
671* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
672- oops, fix %%install
673
674* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
675- update to Thunderbird 0.7.3 and Enigmail 0.85.0
676- remove XUL.mfasl on startup, add Debian enigmail patches
677- add Xvfb hack for -install-global-extension
678
679* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
680- update to 0.7.2, just because it's there
681- update gcc-3.4 patch (Kaj Niemi)
682- add EM registration patch and remove instdir hack
683
684* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
685- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
686
687* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
688- update to 0.7.1
689- remove Enigmail
690
691* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
692- re-enable Enigmail 0.84.1
693- add gcc-3.4 patch (Kaj Niemi)
694- use official branding (with permission)
695
696* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
697- update to 0.7
698- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
699- specify libdir, change BR for apt (V. Skytt辰, #1617)
700
701* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
702- temporary workaround for enigmail skin "modern" bug
703
704* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
705- update to Enigmail 0.84.0
706- update launch script
707
708* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
709- installation directory now versioned
710- allow root to run the program (for installing extensions)
711- remove unnecessary %%pre and %%post
712- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
713
714* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
715- include Enigmail, re-add release notes
716- delete %{_libdir}/thunderbird in %%pre
717
718* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
719- update to Thunderbird 0.6
720
721* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
722- update to Thunderbird 0.6 RC1
723- add new icon, remove release notes
724
725* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
726- update to latest CVS, update mozconfig and %%build accordingly
727- update to Enigmail 0.83.6
728- remove x-remote and x86_64 patches
729- build with -Os
730
731* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
732- update x-remote patch
733- more startup script fixes
734
735* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
736- startup script fixes, and a minor cleanup
737
738* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
739- Minor cleanups
740
741* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
742- minor improvements to open-browser.sh and startup script
743- update to latest version of Blizzard's x-remote patch
744
745* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
746- update open-browser.sh, startup script, and BuildRequires
747
748* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
749- update open-browser script, modify BuildRequires (Warren)
750- add Blizzard's x-remote patch
751- initial attempt at x-remote-enabled startup script
752
753* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
754- refuse to run with excessive privileges
755
756* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
757- add Mozilla x86_64 patch (Oliver Sontag)
758- Enigmail source filenames now include the version
759- modify BuildRoot
760
761* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
762- use the updated official tarball
763
764* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
765- fix %%prep script
766
767* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
768- update Enigmail to 0.83.3
769- use official source tarball (after removing the CRLFs)
770- package renamed to thunderbird
771
772* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
773- update to 0.5
774- check for lockfile before launching
775
776* Fri Feb 06 2004 David Hill <djh[at]ii.net>
777- update to latest cvs
778- update to Enigmail 0.83.2
779
780* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
781- update to Enigmail 0.83.1
782- removed Mozilla/Firebird script patching
783
784* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
785- add startup notification to .desktop file
786
787* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
788- open-browser.sh release 3
789- patch broken /usr/bin/mozilla script during install
790- dir ownership
791- XXX: Source fails build on x86_64... fix later
792
793* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
794- update to Enigmail 0.82.5
795- add Warren's open-browser.sh (#1113)
796
797* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
798- use Thunderbird's mozilla-xremote-client to launch browser
799
800* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
801- update to 0.4
802- make hyperlinks work (with recent versions of Firebird/Mozilla)
803
804* Thu Dec 04 2003 David Hill <djh[at]ii.net>
805- update to 0.4rc2
806
807* Wed Dec 03 2003 David Hill <djh[at]ii.net>
808- update to 0.4rc1 and Enigmail 0.82.4
809
810* Thu Nov 27 2003 David Hill <djh[at]ii.net>
811- update to latest CVS and Enigmail 0.82.3
812
813* Sun Nov 16 2003 David Hill <djh[at]ii.net>
814- update to latest CVS (0.4a)
815- update Enigmail to 0.82.2
816- alter mozconfig for new build requirements
817- add missing BuildReq (#987)
818
819* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
820- update to 0.3
821
822* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
823- update to 0.3rc3
824- update Enigmail to 0.81.7
825
826* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
827- update to 0.3rc2
828
829* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
830- simplify startup script
831
832* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
833- add GPG support (Enigmail 0.81.6)
834- specfile fixes (#679)
835
836* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
837- update to 0.2
838
839* Mon Sep 01 2003 David Hill <djh[at]ii.net>
840- initial RPM
841  (based on the fedora MozillaFirebird-0.6.1 specfile)
842
Note: See TracBrowser for help on using the repository browser.