source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 5636

Revision 5636, 28.2 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 10.0.1
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.13.1
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30%define build_vine5 0
31
32%if "%{?_dist_release}" >= "vl7"
33%define build_vine7 1
34%endif
35%if "%{?_dist_release}" == "vl6"
36%define build_vine6 1
37%endif
38%if "%{?_dist_release}" == "vl5"
39%define build_vine5 1
40%endif
41
42
43Summary:        Thunderbird Community Edition, Mail/newsgroup client
44Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
45Name:           thunderbird
46Version:        %{tbversion}
47Release:        %{tbrelease}
48URL:            http://www.mozilla.org/projects/thunderbird/
49License:        MPL
50Group:          Applications/Internet
51
52Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
53Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
54Source1010:     mozconfig-thunderbird-vine5
55Source1020:     mozconfig-thunderbird-vine6
56Source1030:     mozconfig-thunderbird-vine7
57Source12:       thunderbird-vine-default-prefs.js
58Source20:       thunderbird.desktop
59Source21:       thunderbird.vine.sh.in
60Source30:       thunderbird-open-browser.sh
61Source40:       thunderbird-unofficial-brandig-tb-brand.properties
62Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
63Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
64Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
65Source100:      find-external-requires
66
67# locale sources
68#%define MOZ_BUILD_LOCALES "ja"
69# get from mercurial repository with command,
70# mkdir l10n
71# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
72#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
73
74
75# upstream patch
76
77# Fix for version issues
78Patch0:         thunderbird-version.patch
79
80# customization patches
81Patch1:         firefox-1.5-default-a4-paper.patch
82
83# Linux specific
84Patch100:       thunderbird-9.0-enable-addons.patch
85
86BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
87BuildRequires:  pango-devel
88BuildRequires:  cairo-devel >= %{cairo_version}
89%if %{build_vine7}
90BuildRequires:  nspr-devel >= %{nspr_version}
91BuildRequires:  nss-devel >= %{nss_version}
92BuildRequires:  hunspell-devel
93%endif
94%if %{build_vine6}
95BuildRequires:  nspr-devel >= %{nspr_version}
96BuildRequires:  hunspell-devel
97%endif
98BuildRequires:  pixman-devel
99BuildRequires:  libpng-devel
100%if %{build_vine5}
101BuildRequires:  libjpeg-devel
102%else
103BuildRequires:  libjpeg-turbo-devel
104%endif
105BuildRequires:  gtk2-devel
106BuildRequires:  zlib-devel, gzip, zip, unzip
107BuildRequires:  libIDL-devel
108BuildRequires:  freetype2-devel >= %{freetype_version}
109## disabled libnotify support
110## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
111BuildRequires:  libnotify-devel >= %{libnotify_version}
112BuildRequires:  bzip2-devel
113BuildRequires:  gnome-vfs2-devel
114BuildRequires:  libgnome-devel
115BuildRequires:  libgnomeui-devel
116BuildRequires:  krb5-devel
117BuildRequires:  pango-devel
118BuildRequires:  libXt-devel
119BuildRequires:  libXrender-devel
120# hunspell is in plus category for vine
121#BuildRequires: hunspell-devel
122BuildRequires:  sqlite3-devel >= %{sqlite_version}
123BuildRequires:  startup-notification-devel
124BuildRequires:  desktop-file-utils
125BuildRequires:  alsa-lib-devel
126BuildRequires:  yasm
127Requires:       sqlite3 >= %{sqlite_version}
128Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
129Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
130
131Obsoletes:      MozillaThunderbird
132Provides:       MozillaThunderbird = %{version}
133
134Vendor:         Project Vine
135Distribution:   Vine Linux
136Packager:       daisuke, ryoichi, kazutaka
137
138AutoProv: 0
139%define _use_internal_dependency_generator 0
140%define __find_requires %{SOURCE100}
141
142%description
143Thunderbird is a standalone mail and newsgroup client.
144
145%description -l ja
146Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
147
148#===============================================================================
149
150%prep
151%setup -q %{name}-%{version} -c
152cd %{tarballdir}
153
154# Fix for version issue
155sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
156    > version.patch
157%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
158
159cd mozilla
160%patch1 -p1 -b .default-a4
161
162cd -
163%{__rm} -f .mozconfig
164%if %{build_vine5}
165%{__cp} %{SOURCE1010} .mozconfig
166%endif
167%if %{build_vine6}
168%{__cp} %{SOURCE1020} .mozconfig
169%endif
170%if %{build_vine7}
171%{__cp} %{SOURCE1030} .mozconfig
172%endif
173
174# setup unofficial branding name
175%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
176%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
177
178%patch100 -p1 -b .addons
179
180#===============================================================================
181
182%build
183cd %{tarballdir}
184
185INTERNAL_GECKO=%{version_internal}
186MOZ_APP_DIR=%{mozappdir}
187
188
189#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
190MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
191export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
192export CFLAGS="$RPM_OPT_FLAGS"
193export CXXFLAGS="$CFLAGS"
194export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
195
196%ifarch ppc ppc64 s390 s390x
197%define moz_make_flags -j1
198%else
199%define moz_make_flags %{?_smp_mflags}
200%endif
201
202export PREFIX='%{_prefix}'
203export LIBDIR='%{_libdir}'
204
205export LDFLAGS="-Wl,-rpath,%{mozappdir}"
206export MAKE="gmake %{moz_make_flags}"
207%{__make} -f client.mk build
208
209## build locales
210#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
211#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
212#for dir in $LOCALEDIRS
213#do
214#  for lang in %{MOZ_BUILD_LOCALES} ; do
215#    make -C $dir/locales AB_CD=$lang
216#  done
217#done
218
219#===============================================================================
220
221%install
222%{__rm} -rf $RPM_BUILD_ROOT
223cd %{tarballdir}
224
225INTERNAL_GECKO=%{version_internal}
226
227INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
228MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
229
230cd %{moz_objdir}
231DESTDIR=$RPM_BUILD_ROOT make install
232
233# install unofficial icons
234cd -
235
236%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
237%{__cp} mail/branding/aurora/mailicon16.png \
238        $RPM_BUILD_ROOT/%{mozappdir}/icons/
239%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
240%{__cp} mail/branding/aurora/mailicon16.png \
241        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
242%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
243%{__cp} mail/branding/aurora/mailicon22.png \
244        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
245%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
246%{__cp} mail/branding/aurora/mailicon24.png \
247        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
249%{__cp} mail/branding/aurora/mailicon32.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
252%{__cp} mail/branding/aurora/mailicon48.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
254%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
255%{__cp} mail/branding/aurora/mailicon256.png \
256        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
257
258desktop-file-install --vendor vine \
259  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
260
261# set up the thunderbird start script
262rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
263%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
264  $RPM_BUILD_ROOT%{_bindir}/thunderbird
265%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
266
267install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
268%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
269
270%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
271                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
272        $RPM_BUILD_ROOT/vine-default-prefs
273%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
274%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
275%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
276
277%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
278
279# own mozilla plugin dir (#135050)
280%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
281
282# own extension directories
283%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
284%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
285
286# install locales
287#for lang in %{MOZ_BUILD_LOCALES} ; do
288#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
289#done
290
291# install ja.xpi to langpacks directory
292#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
293#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
294# also setup unofficial branding name
295#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
296#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
297
298# install ja.xpi to langpack file
299%{__mkdir_p} lang_tmp
300unzip %{SOURCE1} -d lang_tmp
301# also setup unofficial branding name
302%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
303%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
304
305%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
306cd lang_tmp; \
307zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
308
309
310%clean
311%{__rm} -rf $RPM_BUILD_ROOT
312
313#===============================================================================
314
315%post
316update-desktop-database &> /dev/null || :
317touch --no-create %{_datadir}/icons/hicolor
318if [ -x %{_bindir}/gtk-update-icon-cache ]; then
319  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
320fi
321
322%postun
323update-desktop-database &> /dev/null || :
324touch --no-create %{_datadir}/icons/hicolor
325if [ -x %{_bindir}/gtk-update-icon-cache ]; then
326  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
327fi
328
329
330%files
331%defattr(-,root,root,-)
332%attr(755,root,root) %{_bindir}/thunderbird
333%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
334%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
335%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
336%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
337%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
338%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
339%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
340%{mozappdir}
341#%{_libdir}/mozilla
342%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
343%exclude %{_datadir}/idl/%{name}-%{version_internal}
344%exclude %{_includedir}/%{name}-%{version_internal}
345%exclude %{_libdir}/%{name}-devel-%{version_internal}
346
347#===============================================================================
348
349%changelog
350* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
351- new upstream release
352
353* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
354- new upstream release
355
356* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
357- new upstream release
358- update Source1
359
360* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
361- new upstream release
362- update Source1
363- add Source1030 (mozconfig-thunderbird-vine7)
364- add Patch100 (thunderbird-9.0-enable-addons.patch)
365
366* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
367- fix %%version_internal
368
369* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
370- new upstream release
371- update Source1
372
373* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
374- new upstream release
375- update Source1,21,1010,1020
376
377* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
378- rebuild with libnotify-0.7
379
380* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
381- enable-install-strip
382
383* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
384- new upstream release
385- drop obsolete patch and renumber patch26 to patch1
386- add BuildRequires: yasm
387- enable libnotify support
388- add --disable-updater and --disable-installer to mozconfig
389- use ja.xpi instead of l10n source
390- update Source21: add step to setup langpack plugin
391- update Source20: add japanese translation
392- add Source42 & Source43 for localized branding
393- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
394  for mozconfig-thunderbird-vine5
395
396* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
397- new upstream release with security fix
398
399* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
400- new upstream release with security fix
401
402* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
403- new upstream release with security fix
404
405* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
406- new upstream release with security fix
407- add patch5 to fix build failure
408
409* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
410- new upstream release
411
412* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
413- new upstream release with security fix
414- add Patch1030 to fix compilation error
415
416* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
417- change mozconfig (Source1030 & 1040): add --enable-jsd
418
419* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
420- new upstream release
421
422* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
423- new upstream release with security fix
424- add Patch0 from fedora development: fix version issue
425- remove BuildRequires: hunspell-devel
426- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
427
428* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
429- add BuildRequires: alsa-lib-devel
430- remove BuildRequires: libnotify-devel
431  (workaround for known bug)
432- update mozconfig to add --disable-libnotify option
433
434* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
435- new upstream release
436- update spec entirely
437- import patches from fedora (Patch1, 2 & 4)
438- drop outdated patches (Patch22, 24)
439- update Sources:
440  - mozconfig (Source1030 & Source1040)
441  - default prefs.js (Source12)
442  - unofficial branding (Source40 & Source41)
443  - japanese translation (Source1000)
444- update Patch1000 (sjis-alias)
445
446* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
447- new upstream release
448
449* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
450- new upstream release
451
452* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
453- don't install official branding logos
454
455* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
456- add necessary icons in %%{tbdir}/chrome/icons/default
457- add Packager tag
458
459* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
460- new upstream release
461
462* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
463- new upstream release
464
465* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
466- new upstream release
467
468* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
469- new upstream release
470
471* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
472- rebuilt for VineSeed
473
474* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
475- new upstream release
476
477* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
478- new upstream release
479- built for Vine Linux 4.x
480- dropped Patch1020 (merged into upstream)
481
482* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
483- added Patch1020 for workaround gcc visibility hidden bugs
484
485* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
486- build with new environment/toolchain
487- add build options to build with external nss/nspr libraries
488    ac_add_options --with-system-nspr
489    ac_add_options --with-system-nss
490
491* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
492- new upstream release
493
494* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
495- new upstream release
496
497* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
498- new upstream release
499
500* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
501- new upstream release
502
503* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
504- new upstream release
505- merge changes from firefox
506  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
507
508* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
509- new upstream release
510- build en-US locale
511- merge changes from firefox
512  - add upstream patches
513  - disable pango rendering by default
514    (workaround fix slow rendering in some page)
515
516* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
517- initial build for Vine Linux based on FC package
518- update to 1.5RC2
519
520* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
521- Fix issue with popup dialogs and other actions causing lockups
522
523* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
524- Update to 1.5 rc1
525
526* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
527- Update to 1.5 beta2
528
529* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
530- Update to 1.5 beta1
531- Bring the install phase of the spec file up to speed
532
533* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
534- Rebuild
535
536* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
537- Add patch to make file chooser dialog modal
538
539* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
540- Update to 1.0.6
541
542* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
543- 1.0.6 Release Candidate
544
545* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
546- Use system NSPR
547- Fix crash on 64bit platforms (#160330)
548
549* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
550- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
551  references, fixing the "no fonts" problem.
552
553* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
554- Change the Exec line in the desktop file to `thunderbird`
555
556* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
557- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
558
559* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
560- Add temporary workaround to not create files in the user's $HOME (#149664)
561
562* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
563- Don't have downloads "disappear" when downloading to desktop (#139015)
564- Fix for some more cursor issues in textareas (149991, 150002, 152089)
565- Add upstream patch to fix bidi justification of pango
566- Add patch to fix launching of helper applications
567- Add patch to properly link against libgfxshared_s.a
568- Fix multilib conflicts
569
570* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
571- correct confusing PANGO vars in startup script
572
573* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
574- Thunderbird 1.0.2
575
576* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
577- Add patch to compile against new fortified glibc macros
578
579* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
580- Rebuild against GCC 4.0
581- Add execshield patches
582- Minor specfile cleanup
583
584* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
585- Rebuild
586
587* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
588- Add RPM version to useragent
589
590* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
591- Port over pango patches from firefox
592
593* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
594- Thunderbird 1.0
595
596* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
597- Fix advanced prefs
598
599* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
600- Make this run on s390(x) now for real
601
602* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
603- Update to 1.0 rc1
604
605* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
606- Add patches to build and run on s390(x)
607
608* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
609- Rebuild to fix file chooser
610
611* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
612- Update to 0.9
613
614* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
615- Prevent inlining of stack direction detection (#135255)
616
617* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
618- More file chooser fixes (same as in firefox)
619- Fix for upstream 28327.
620
621* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
622- Update the pango patch
623
624* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
625- Pull over patches from firefox build:
626  - disable default application dialog
627  - don't include software update since it doesn't work
628  - make external app support work
629
630* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
631- Use pango for rendering
632
633* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
634- Fix for 64 bit crash at startup (b.m.o #256603)
635
636* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
637- Add patches to fix xremote (#135036)
638
639* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
640- Add patch to fix button focus issues (#133507)
641- Add patch for fix IMAP race issues (bmo #246439)
642
643* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
644- filter out library Provides: and internal Requires:
645
646* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
647- Backport the GTK+ File Chooser.
648- Add fix for JS math on x86_64 systems
649- Add pkgconfig patch
650
651* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
652- Update to 0.8.0
653- Remove enigmail
654- Update BuildRequires
655- Remove gcc34 and extension manager patches -- they are upstreamed.
656- Fix for gnome-vfs2 error at component registration
657
658* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
659- Build with --disable-xprint
660
661* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
662- remove all Xvfb-related hacks
663
664* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
665- actually apply psfonts
666- add mozilla gnome-uriloader patch to prevent build failure
667
668* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
669- rawhide import
670- apply NetBSD's freetype 2.1.8 patch
671- apply psfonts patch
672- remove BR on /usr/bin/ex, breaks beehive
673
674* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
675- oops, fix %%install
676
677* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
678- update to Thunderbird 0.7.3 and Enigmail 0.85.0
679- remove XUL.mfasl on startup, add Debian enigmail patches
680- add Xvfb hack for -install-global-extension
681
682* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
683- update to 0.7.2, just because it's there
684- update gcc-3.4 patch (Kaj Niemi)
685- add EM registration patch and remove instdir hack
686
687* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
688- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
689
690* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
691- update to 0.7.1
692- remove Enigmail
693
694* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
695- re-enable Enigmail 0.84.1
696- add gcc-3.4 patch (Kaj Niemi)
697- use official branding (with permission)
698
699* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
700- update to 0.7
701- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
702- specify libdir, change BR for apt (V. Skytt辰, #1617)
703
704* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
705- temporary workaround for enigmail skin "modern" bug
706
707* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
708- update to Enigmail 0.84.0
709- update launch script
710
711* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
712- installation directory now versioned
713- allow root to run the program (for installing extensions)
714- remove unnecessary %%pre and %%post
715- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
716
717* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
718- include Enigmail, re-add release notes
719- delete %{_libdir}/thunderbird in %%pre
720
721* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
722- update to Thunderbird 0.6
723
724* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
725- update to Thunderbird 0.6 RC1
726- add new icon, remove release notes
727
728* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
729- update to latest CVS, update mozconfig and %%build accordingly
730- update to Enigmail 0.83.6
731- remove x-remote and x86_64 patches
732- build with -Os
733
734* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
735- update x-remote patch
736- more startup script fixes
737
738* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
739- startup script fixes, and a minor cleanup
740
741* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
742- Minor cleanups
743
744* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
745- minor improvements to open-browser.sh and startup script
746- update to latest version of Blizzard's x-remote patch
747
748* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
749- update open-browser.sh, startup script, and BuildRequires
750
751* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
752- update open-browser script, modify BuildRequires (Warren)
753- add Blizzard's x-remote patch
754- initial attempt at x-remote-enabled startup script
755
756* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
757- refuse to run with excessive privileges
758
759* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
760- add Mozilla x86_64 patch (Oliver Sontag)
761- Enigmail source filenames now include the version
762- modify BuildRoot
763
764* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
765- use the updated official tarball
766
767* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
768- fix %%prep script
769
770* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
771- update Enigmail to 0.83.3
772- use official source tarball (after removing the CRLFs)
773- package renamed to thunderbird
774
775* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
776- update to 0.5
777- check for lockfile before launching
778
779* Fri Feb 06 2004 David Hill <djh[at]ii.net>
780- update to latest cvs
781- update to Enigmail 0.83.2
782
783* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
784- update to Enigmail 0.83.1
785- removed Mozilla/Firebird script patching
786
787* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
788- add startup notification to .desktop file
789
790* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
791- open-browser.sh release 3
792- patch broken /usr/bin/mozilla script during install
793- dir ownership
794- XXX: Source fails build on x86_64... fix later
795
796* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
797- update to Enigmail 0.82.5
798- add Warren's open-browser.sh (#1113)
799
800* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
801- use Thunderbird's mozilla-xremote-client to launch browser
802
803* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
804- update to 0.4
805- make hyperlinks work (with recent versions of Firebird/Mozilla)
806
807* Thu Dec 04 2003 David Hill <djh[at]ii.net>
808- update to 0.4rc2
809
810* Wed Dec 03 2003 David Hill <djh[at]ii.net>
811- update to 0.4rc1 and Enigmail 0.82.4
812
813* Thu Nov 27 2003 David Hill <djh[at]ii.net>
814- update to latest CVS and Enigmail 0.82.3
815
816* Sun Nov 16 2003 David Hill <djh[at]ii.net>
817- update to latest CVS (0.4a)
818- update Enigmail to 0.82.2
819- alter mozconfig for new build requirements
820- add missing BuildReq (#987)
821
822* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
823- update to 0.3
824
825* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
826- update to 0.3rc3
827- update Enigmail to 0.81.7
828
829* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
830- update to 0.3rc2
831
832* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
833- simplify startup script
834
835* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
836- add GPG support (Enigmail 0.81.6)
837- specfile fixes (#679)
838
839* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
840- update to 0.2
841
842* Mon Sep 01 2003 David Hill <djh[at]ii.net>
843- initial RPM
844  (based on the fedora MozillaFirebird-0.6.1 specfile)
845
Note: See TracBrowser for help on using the repository browser.