source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 1830

Revision 1830, 25.8 KB checked in by kazutaka, 14 years ago (diff)

3.1.4 に更新

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 3.1
3%define tbversion %{tbmajor}.4
4%define tbrelease 1%{?_dist_release}
5
6# The tarball is pretty inconsistent with directory structure.
7# Sometimes there is a top level directory.  That goes here.
8#
9# IMPORTANT: If there is no top level directory, this should be
10# set to the cwd, ie: '.'
11#%define tarballdir .
12%define tarballdir comm-1.9.2
13
14%define mozappdir %{_libdir}/%{name}-%{version_internal}
15%define moz_objdir objdir-tb
16%define version_internal 3.1
17%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
18
19%define desktop_file_utils_version 0.6
20%define nspr_version 4.8
21%define nss_version 3.12.6
22%define cairo_version 1.6.0
23%define freetype_version 2.1.9
24%define sqlite_version 3.6.14
25%define libnotify_version 0.4
26
27%define build_vineseed 0
28%define build_vine5 0
29
30%if "%{?_dist_release}" == "vl6"
31%define build_vineseed 1
32%endif
33%if "%{?_dist_release}" == "vl5"
34%define build_vine5 1
35%endif
36
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48#Source1010:    mozconfig-thunderbird-vine3
49#Source1020:    mozconfig-thunderbird-vine4
50Source1030:     mozconfig-thunderbird-vine5
51Source1040:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55#Source22:      thunderbird.png
56Source30:       thunderbird-open-browser.sh
57Source40:       thunderbird-unofficial-brandig-tb-brand.properties
58Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73# Fix for jemalloc
74Patch1:         mozilla-jemalloc.patch
75# Fix for installation fail when building with dynamic linked libraries
76Patch2:         thunderbird-shared-error.patch
77# Fixes gcc complain that nsFrame::delete is protected
78Patch4:         xulrunner-1.9.2.1-build.patch
79
80# customization patches
81#Patch22:        firefox-1.0-psfonts.patch
82#Patch24:        thunderbird-2.0-default-applications.patch
83#Patch25:        thunderbird-1.1-software-update.patch
84Patch26:        firefox-1.5-default-a4-paper.patch
85
86# font system fixes
87#Patch81:        firefox-nopangoxft.patch
88
89## Vine patch
90# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
91Patch1000:      thunderbird-3.1-sjisalias.patch
92
93# use /proc/net/netstat for random seed instead of netstat command.
94#Patch1010:      firefox-nss-no_netstat.patch
95
96# workaround gcc visibility hidden bugs (see gcc#26905)
97Patch1020:      firefox-2.0.0.3-visibility.patch
98
99# temporary fix for compilation error with PR_STATIC_ASSERT
100# refer http://bugs.gentoo.org/show_bug.cgi?id=336413
101Patch1030:      thunderbird-3.1.3-fix-prlog-include-error.patch
102
103BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
104BuildRequires:  pango-devel
105BuildRequires:  cairo-devel >= %{cairo_version}
106%if %{build_vineseed}
107BuildRequires:  nspr-devel >= %{nspr_version}
108BuildRequires:  nss-devel >= %{nss_version}
109%endif
110BuildRequires:  pixman-devel
111BuildRequires:  libpng-devel
112BuildRequires:  libjpeg-devel
113BuildRequires:  gtk2-devel
114BuildRequires:  zlib-devel, gzip, zip, unzip
115BuildRequires:  libIDL-devel
116BuildRequires:  freetype2-devel >= %{freetype_version}
117## disabled libnotify support
118## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
119#BuildRequires:  libnotify-devel >= %{libnotify_version}
120BuildRequires:  bzip2-devel
121BuildRequires:  gnome-vfs2-devel
122BuildRequires:  libgnome-devel
123BuildRequires:  libgnomeui-devel
124BuildRequires:  krb5-devel
125BuildRequires:  pango-devel
126BuildRequires:  libXt-devel
127BuildRequires:  libXrender-devel
128# hunspell is in plus category for vine
129#BuildRequires: hunspell-devel
130BuildRequires:  sqlite3-devel >= %{sqlite_version}
131BuildRequires:  startup-notification-devel
132BuildRequires:  desktop-file-utils
133BuildRequires:  alsa-lib-devel
134Requires:       sqlite3 >= %{sqlite_version}
135Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
136Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
137
138Obsoletes:      MozillaThunderbird
139Provides:       MozillaThunderbird = %{version}
140
141Packager:       daisuke, ryoichi, kazutaka
142
143AutoProv: 0
144%define _use_internal_dependency_generator 0
145%define __find_requires %{SOURCE100}
146
147%description
148Thunderbird is a standalone mail and newsgroup client.
149
150%description -l ja
151Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
152
153#===============================================================================
154
155%prep
156%setup -q %{name}-%{version} -c -b 1000
157cd %{tarballdir}
158
159# Fix for version issue
160sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
161    > version.patch
162%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
163
164%patch1 -p0 -b .jemalloc
165%patch2 -p1 -b .shared-error
166%patch4 -p1 -b .protected
167
168cd mozilla
169
170#%patch22 -p1
171#%patch24 -p1
172#%patch25 -p0
173%patch26 -p1 -b .default-a4
174%patch1000 -p1 -b .sjis-alias
175%patch1030 -p3 -b .prlog-fix
176
177cd -
178%{__rm} -f .mozconfig
179%if %{build_vine5}
180%{__cp} %{SOURCE1030} .mozconfig
181%endif
182%if %{build_vineseed}
183%{__cp} %{SOURCE1040} .mozconfig
184# cannot build with xulrunner (yet)
185# see tracking bugs.
186#   https://bugzilla.mozilla.org/show_bug.cgi?id=306324
187#   https://bugzilla.mozilla.org/show_bug.cgi?id=377319
188#echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
189%endif
190
191# setup unofficial branding name
192%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
193%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
194
195#===============================================================================
196
197%build
198cd %{tarballdir}
199
200INTERNAL_GECKO=%{version_internal}
201MOZ_APP_DIR=%{mozappdir}
202
203
204#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
205MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
206export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
207export CFLAGS="$RPM_OPT_FLAGS"
208export CXXFLAGS="$CFLAGS"
209export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
210
211%ifarch ppc ppc64 s390 s390x
212%define moz_make_flags -j1
213%else
214%define moz_make_flags %{?_smp_mflags}
215%endif
216
217export PREFIX='%{_prefix}'
218export LIBDIR='%{_libdir}'
219
220export LDFLAGS="-Wl,-rpath,%{mozappdir}"
221export MAKE="gmake %{moz_make_flags}"
222%{__make} -f client.mk build
223
224# build locales
225LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
226            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
227for dir in $LOCALEDIRS
228do
229  for lang in %{MOZ_BUILD_LOCALES} ; do
230    make -C $dir/locales AB_CD=$lang
231  done
232done
233
234#===============================================================================
235
236%install
237%{__rm} -rf $RPM_BUILD_ROOT
238cd %{tarballdir}
239
240INTERNAL_GECKO=%{version_internal}
241
242INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
243MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
244
245cd %{moz_objdir}
246DESTDIR=$RPM_BUILD_ROOT make install
247
248# install unofficial icons
249cd -
250%{__cp} mail/branding/unofficial/mailicon16.png \
251        $RPM_BUILD_ROOT/%{mozappdir}/icons/
252%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
253%{__cp} mail/branding/unofficial/mailicon16.png \
254        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
255%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
256%{__cp} mail/branding/unofficial/mailicon22.png \
257        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
258%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
259%{__cp} mail/branding/unofficial//mailicon24.png \
260        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
261%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
262%{__cp} mail/branding/unofficial/mailicon32.png \
263        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
265%{__cp} mail/branding/unofficial/mailicon48.png \
266        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
267%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
268%{__cp} mail/branding/unofficial/mailicon256.png \
269        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
270
271desktop-file-install --vendor vine \
272  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
273  --add-category Application \
274  --add-category Network \
275  %{SOURCE20}
276
277# set up the thunderbird start script
278rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
279%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
280  $RPM_BUILD_ROOT%{_bindir}/thunderbird
281%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
282
283install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
284%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
285
286%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
287                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
288        $RPM_BUILD_ROOT/vine-default-prefs
289%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
290%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
291%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
292
293%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
294
295# own mozilla plugin dir (#135050)
296%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
297
298# own extension directories
299%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
300%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
301
302# install locales
303for lang in %{MOZ_BUILD_LOCALES} ; do
304  %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
305done
306
307
308%clean
309%{__rm} -rf $RPM_BUILD_ROOT
310
311#===============================================================================
312
313%post
314update-desktop-database &> /dev/null || :
315touch --no-create %{_datadir}/icons/hicolor
316if [ -x %{_bindir}/gtk-update-icon-cache ]; then
317  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
318fi
319
320%postun
321update-desktop-database &> /dev/null || :
322touch --no-create %{_datadir}/icons/hicolor
323if [ -x %{_bindir}/gtk-update-icon-cache ]; then
324  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
325fi
326
327
328%files
329%defattr(-,root,root,-)
330%attr(755,root,root) %{_bindir}/thunderbird
331%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
332%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
333%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
334%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
335%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
336%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
337%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
338%{mozappdir}
339
340#===============================================================================
341
342%changelog
343* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
344- new upstream release
345
346* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
347- new upstream release with security fix
348- add Patch1030 to fix compilation error
349
350* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
351- change mozconfig (Source1030 & 1040): add --enable-jsd
352
353* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
354- new upstream release
355
356* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
357- new upstream release with security fix
358- add Patch0 from fedora development: fix version issue
359- remove BuildRequires: hunspell-devel
360- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
361
362* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
363- add BuildRequires: alsa-lib-devel
364- remove BuildRequires: libnotify-devel
365  (workaround for known bug)
366- update mozconfig to add --disable-libnotify option
367
368* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
369- new upstream release
370- update spec entirely
371- import patches from fedora (Patch1, 2 & 4)
372- drop outdated patches (Patch22, 24)
373- update Sources:
374  - mozconfig (Source1030 & Source1040)
375  - default prefs.js (Source12)
376  - unofficial branding (Source40 & Source41)
377  - japanese translation (Source1000)
378- update Patch1000 (sjis-alias)
379
380* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
381- new upstream release
382
383* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
384- new upstream release
385
386* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
387- don't install official branding logos
388
389* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
390- add necessary icons in %%{tbdir}/chrome/icons/default
391- add Packager tag
392
393* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
394- new upstream release
395
396* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
397- new upstream release
398
399* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
400- new upstream release
401
402* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
403- new upstream release
404
405* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
406- rebuilt for VineSeed
407
408* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
409- new upstream release
410
411* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
412- new upstream release
413- built for Vine Linux 4.x
414- dropped Patch1020 (merged into upstream)
415
416* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
417- added Patch1020 for workaround gcc visibility hidden bugs
418
419* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
420- build with new environment/toolchain
421- add build options to build with external nss/nspr libraries
422    ac_add_options --with-system-nspr
423    ac_add_options --with-system-nss
424
425* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
426- new upstream release
427
428* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
429- new upstream release
430
431* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
432- new upstream release
433
434* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
435- new upstream release
436
437* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
438- new upstream release
439- merge changes from firefox
440  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
441
442* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
443- new upstream release
444- build en-US locale
445- merge changes from firefox
446  - add upstream patches
447  - disable pango rendering by default
448    (workaround fix slow rendering in some page)
449
450* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
451- initial build for Vine Linux based on FC package
452- update to 1.5RC2
453
454* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
455- Fix issue with popup dialogs and other actions causing lockups
456
457* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
458- Update to 1.5 rc1
459
460* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
461- Update to 1.5 beta2
462
463* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
464- Update to 1.5 beta1
465- Bring the install phase of the spec file up to speed
466
467* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
468- Rebuild
469
470* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
471- Add patch to make file chooser dialog modal
472
473* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
474- Update to 1.0.6
475
476* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
477- 1.0.6 Release Candidate
478
479* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
480- Use system NSPR
481- Fix crash on 64bit platforms (#160330)
482
483* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
484- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
485  references, fixing the "no fonts" problem.
486
487* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
488- Change the Exec line in the desktop file to `thunderbird`
489
490* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
491- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
492
493* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
494- Add temporary workaround to not create files in the user's $HOME (#149664)
495
496* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
497- Don't have downloads "disappear" when downloading to desktop (#139015)
498- Fix for some more cursor issues in textareas (149991, 150002, 152089)
499- Add upstream patch to fix bidi justification of pango
500- Add patch to fix launching of helper applications
501- Add patch to properly link against libgfxshared_s.a
502- Fix multilib conflicts
503
504* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
505- correct confusing PANGO vars in startup script
506
507* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
508- Thunderbird 1.0.2
509
510* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
511- Add patch to compile against new fortified glibc macros
512
513* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
514- Rebuild against GCC 4.0
515- Add execshield patches
516- Minor specfile cleanup
517
518* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
519- Rebuild
520
521* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
522- Add RPM version to useragent
523
524* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
525- Port over pango patches from firefox
526
527* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
528- Thunderbird 1.0
529
530* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
531- Fix advanced prefs
532
533* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
534- Make this run on s390(x) now for real
535
536* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
537- Update to 1.0 rc1
538
539* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
540- Add patches to build and run on s390(x)
541
542* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
543- Rebuild to fix file chooser
544
545* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
546- Update to 0.9
547
548* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
549- Prevent inlining of stack direction detection (#135255)
550
551* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
552- More file chooser fixes (same as in firefox)
553- Fix for upstream 28327.
554
555* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
556- Update the pango patch
557
558* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
559- Pull over patches from firefox build:
560  - disable default application dialog
561  - don't include software update since it doesn't work
562  - make external app support work
563
564* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
565- Use pango for rendering
566
567* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
568- Fix for 64 bit crash at startup (b.m.o #256603)
569
570* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
571- Add patches to fix xremote (#135036)
572
573* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
574- Add patch to fix button focus issues (#133507)
575- Add patch for fix IMAP race issues (bmo #246439)
576
577* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
578- filter out library Provides: and internal Requires:
579
580* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
581- Backport the GTK+ File Chooser.
582- Add fix for JS math on x86_64 systems
583- Add pkgconfig patch
584
585* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
586- Update to 0.8.0
587- Remove enigmail
588- Update BuildRequires
589- Remove gcc34 and extension manager patches -- they are upstreamed.
590- Fix for gnome-vfs2 error at component registration
591
592* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
593- Build with --disable-xprint
594
595* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
596- remove all Xvfb-related hacks
597
598* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
599- actually apply psfonts
600- add mozilla gnome-uriloader patch to prevent build failure
601
602* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
603- rawhide import
604- apply NetBSD's freetype 2.1.8 patch
605- apply psfonts patch
606- remove BR on /usr/bin/ex, breaks beehive
607
608* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
609- oops, fix %%install
610
611* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
612- update to Thunderbird 0.7.3 and Enigmail 0.85.0
613- remove XUL.mfasl on startup, add Debian enigmail patches
614- add Xvfb hack for -install-global-extension
615
616* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
617- update to 0.7.2, just because it's there
618- update gcc-3.4 patch (Kaj Niemi)
619- add EM registration patch and remove instdir hack
620
621* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
622- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
623
624* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
625- update to 0.7.1
626- remove Enigmail
627
628* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
629- re-enable Enigmail 0.84.1
630- add gcc-3.4 patch (Kaj Niemi)
631- use official branding (with permission)
632
633* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
634- update to 0.7
635- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
636- specify libdir, change BR for apt (V. Skytt辰, #1617)
637
638* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
639- temporary workaround for enigmail skin "modern" bug
640
641* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
642- update to Enigmail 0.84.0
643- update launch script
644
645* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
646- installation directory now versioned
647- allow root to run the program (for installing extensions)
648- remove unnecessary %%pre and %%post
649- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
650
651* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
652- include Enigmail, re-add release notes
653- delete %{_libdir}/thunderbird in %%pre
654
655* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
656- update to Thunderbird 0.6
657
658* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
659- update to Thunderbird 0.6 RC1
660- add new icon, remove release notes
661
662* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
663- update to latest CVS, update mozconfig and %%build accordingly
664- update to Enigmail 0.83.6
665- remove x-remote and x86_64 patches
666- build with -Os
667
668* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
669- update x-remote patch
670- more startup script fixes
671
672* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
673- startup script fixes, and a minor cleanup
674
675* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
676- Minor cleanups
677
678* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
679- minor improvements to open-browser.sh and startup script
680- update to latest version of Blizzard's x-remote patch
681
682* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
683- update open-browser.sh, startup script, and BuildRequires
684
685* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
686- update open-browser script, modify BuildRequires (Warren)
687- add Blizzard's x-remote patch
688- initial attempt at x-remote-enabled startup script
689
690* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
691- refuse to run with excessive privileges
692
693* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
694- add Mozilla x86_64 patch (Oliver Sontag)
695- Enigmail source filenames now include the version
696- modify BuildRoot
697
698* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
699- use the updated official tarball
700
701* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
702- fix %%prep script
703
704* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
705- update Enigmail to 0.83.3
706- use official source tarball (after removing the CRLFs)
707- package renamed to thunderbird
708
709* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
710- update to 0.5
711- check for lockfile before launching
712
713* Fri Feb 06 2004 David Hill <djh[at]ii.net>
714- update to latest cvs
715- update to Enigmail 0.83.2
716
717* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
718- update to Enigmail 0.83.1
719- removed Mozilla/Firebird script patching
720
721* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
722- add startup notification to .desktop file
723
724* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
725- open-browser.sh release 3
726- patch broken /usr/bin/mozilla script during install
727- dir ownership
728- XXX: Source fails build on x86_64... fix later
729
730* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
731- update to Enigmail 0.82.5
732- add Warren's open-browser.sh (#1113)
733
734* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
735- use Thunderbird's mozilla-xremote-client to launch browser
736
737* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
738- update to 0.4
739- make hyperlinks work (with recent versions of Firebird/Mozilla)
740
741* Thu Dec 04 2003 David Hill <djh[at]ii.net>
742- update to 0.4rc2
743
744* Wed Dec 03 2003 David Hill <djh[at]ii.net>
745- update to 0.4rc1 and Enigmail 0.82.4
746
747* Thu Nov 27 2003 David Hill <djh[at]ii.net>
748- update to latest CVS and Enigmail 0.82.3
749
750* Sun Nov 16 2003 David Hill <djh[at]ii.net>
751- update to latest CVS (0.4a)
752- update Enigmail to 0.82.2
753- alter mozconfig for new build requirements
754- add missing BuildReq (#987)
755
756* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
757- update to 0.3
758
759* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
760- update to 0.3rc3
761- update Enigmail to 0.81.7
762
763* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
764- update to 0.3rc2
765
766* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
767- simplify startup script
768
769* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
770- add GPG support (Enigmail 0.81.6)
771- specfile fixes (#679)
772
773* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
774- update to 0.2
775
776* Mon Sep 01 2003 David Hill <djh[at]ii.net>
777- initial RPM
778  (based on the fedora MozillaFirebird-0.6.1 specfile)
779
Note: See TracBrowser for help on using the repository browser.