source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 2142

Revision 2142, 26.0 KB checked in by kazutaka, 14 years ago (diff)

3.1.5 に更新

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 3.1
3%define tbversion %{tbmajor}.5
4%define tbrelease 1%{?_dist_release}
5
6# The tarball is pretty inconsistent with directory structure.
7# Sometimes there is a top level directory.  That goes here.
8#
9# IMPORTANT: If there is no top level directory, this should be
10# set to the cwd, ie: '.'
11#%define tarballdir .
12%define tarballdir comm-1.9.2
13
14%define mozappdir %{_libdir}/%{name}-%{version_internal}
15%define moz_objdir objdir-tb
16%define version_internal 3.1
17%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
18
19%define desktop_file_utils_version 0.6
20%define nspr_version 4.8
21%define nss_version 3.12.6
22%define cairo_version 1.6.0
23%define freetype_version 2.1.9
24%define sqlite_version 3.6.14
25%define libnotify_version 0.4
26
27%define build_vineseed 0
28%define build_vine5 0
29
30%if "%{?_dist_release}" == "vl6"
31%define build_vineseed 1
32%endif
33%if "%{?_dist_release}" == "vl5"
34%define build_vine5 1
35%endif
36
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48#Source1010:    mozconfig-thunderbird-vine3
49#Source1020:    mozconfig-thunderbird-vine4
50Source1030:     mozconfig-thunderbird-vine5
51Source1040:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55#Source22:      thunderbird.png
56Source30:       thunderbird-open-browser.sh
57Source40:       thunderbird-unofficial-brandig-tb-brand.properties
58Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73# Fix for jemalloc
74Patch1:         mozilla-jemalloc.patch
75# Fix for installation fail when building with dynamic linked libraries
76Patch2:         thunderbird-shared-error.patch
77# Fixes gcc complain that nsFrame::delete is protected
78Patch4:         xulrunner-1.9.2.1-build.patch
79# Fix for building with libjpeg-turbo
80Patch5:        mozilla-libjpeg-turbo.patch
81
82# customization patches
83#Patch22:        firefox-1.0-psfonts.patch
84#Patch24:        thunderbird-2.0-default-applications.patch
85#Patch25:        thunderbird-1.1-software-update.patch
86Patch26:        firefox-1.5-default-a4-paper.patch
87
88# font system fixes
89#Patch81:        firefox-nopangoxft.patch
90
91## Vine patch
92# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
93Patch1000:      thunderbird-3.1-sjisalias.patch
94
95# use /proc/net/netstat for random seed instead of netstat command.
96#Patch1010:      firefox-nss-no_netstat.patch
97
98# workaround gcc visibility hidden bugs (see gcc#26905)
99Patch1020:      firefox-2.0.0.3-visibility.patch
100
101# temporary fix for compilation error with PR_STATIC_ASSERT
102# refer http://bugs.gentoo.org/show_bug.cgi?id=336413
103Patch1030:      thunderbird-3.1.3-fix-prlog-include-error.patch
104
105BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
106BuildRequires:  pango-devel
107BuildRequires:  cairo-devel >= %{cairo_version}
108%if %{build_vineseed}
109BuildRequires:  nspr-devel >= %{nspr_version}
110BuildRequires:  nss-devel >= %{nss_version}
111%endif
112BuildRequires:  pixman-devel
113BuildRequires:  libpng-devel
114BuildRequires:  libjpeg-devel
115BuildRequires:  gtk2-devel
116BuildRequires:  zlib-devel, gzip, zip, unzip
117BuildRequires:  libIDL-devel
118BuildRequires:  freetype2-devel >= %{freetype_version}
119## disabled libnotify support
120## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
121#BuildRequires:  libnotify-devel >= %{libnotify_version}
122BuildRequires:  bzip2-devel
123BuildRequires:  gnome-vfs2-devel
124BuildRequires:  libgnome-devel
125BuildRequires:  libgnomeui-devel
126BuildRequires:  krb5-devel
127BuildRequires:  pango-devel
128BuildRequires:  libXt-devel
129BuildRequires:  libXrender-devel
130# hunspell is in plus category for vine
131#BuildRequires: hunspell-devel
132BuildRequires:  sqlite3-devel >= %{sqlite_version}
133BuildRequires:  startup-notification-devel
134BuildRequires:  desktop-file-utils
135BuildRequires:  alsa-lib-devel
136Requires:       sqlite3 >= %{sqlite_version}
137Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
138Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
139
140Obsoletes:      MozillaThunderbird
141Provides:       MozillaThunderbird = %{version}
142
143Packager:       daisuke, ryoichi, kazutaka
144
145AutoProv: 0
146%define _use_internal_dependency_generator 0
147%define __find_requires %{SOURCE100}
148
149%description
150Thunderbird is a standalone mail and newsgroup client.
151
152%description -l ja
153Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
154
155#===============================================================================
156
157%prep
158%setup -q %{name}-%{version} -c -b 1000
159cd %{tarballdir}
160
161# Fix for version issue
162sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
163    > version.patch
164%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
165
166%patch1 -p0 -b .jemalloc
167%patch2 -p1 -b .shared-error
168%patch4 -p1 -b .protected
169
170cd mozilla
171
172%patch5 -p1 -b .libjpeg-turbo
173#%patch22 -p1
174#%patch24 -p1
175#%patch25 -p0
176%patch26 -p1 -b .default-a4
177%patch1000 -p1 -b .sjis-alias
178%patch1030 -p3 -b .prlog-fix
179
180cd -
181%{__rm} -f .mozconfig
182%if %{build_vine5}
183%{__cp} %{SOURCE1030} .mozconfig
184%endif
185%if %{build_vineseed}
186%{__cp} %{SOURCE1040} .mozconfig
187# cannot build with xulrunner (yet)
188# see tracking bugs.
189#   https://bugzilla.mozilla.org/show_bug.cgi?id=306324
190#   https://bugzilla.mozilla.org/show_bug.cgi?id=377319
191#echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
192%endif
193
194# setup unofficial branding name
195%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
196%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
197
198#===============================================================================
199
200%build
201cd %{tarballdir}
202
203INTERNAL_GECKO=%{version_internal}
204MOZ_APP_DIR=%{mozappdir}
205
206
207#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
208MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
209export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
210export CFLAGS="$RPM_OPT_FLAGS"
211export CXXFLAGS="$CFLAGS"
212export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
213
214%ifarch ppc ppc64 s390 s390x
215%define moz_make_flags -j1
216%else
217%define moz_make_flags %{?_smp_mflags}
218%endif
219
220export PREFIX='%{_prefix}'
221export LIBDIR='%{_libdir}'
222
223export LDFLAGS="-Wl,-rpath,%{mozappdir}"
224export MAKE="gmake %{moz_make_flags}"
225%{__make} -f client.mk build
226
227# build locales
228LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
229            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
230for dir in $LOCALEDIRS
231do
232  for lang in %{MOZ_BUILD_LOCALES} ; do
233    make -C $dir/locales AB_CD=$lang
234  done
235done
236
237#===============================================================================
238
239%install
240%{__rm} -rf $RPM_BUILD_ROOT
241cd %{tarballdir}
242
243INTERNAL_GECKO=%{version_internal}
244
245INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
246MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
247
248cd %{moz_objdir}
249DESTDIR=$RPM_BUILD_ROOT make install
250
251# install unofficial icons
252cd -
253%{__cp} mail/branding/unofficial/mailicon16.png \
254        $RPM_BUILD_ROOT/%{mozappdir}/icons/
255%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
256%{__cp} mail/branding/unofficial/mailicon16.png \
257        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
258%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
259%{__cp} mail/branding/unofficial/mailicon22.png \
260        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
261%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
262%{__cp} mail/branding/unofficial//mailicon24.png \
263        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
265%{__cp} mail/branding/unofficial/mailicon32.png \
266        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
267%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
268%{__cp} mail/branding/unofficial/mailicon48.png \
269        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
270%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
271%{__cp} mail/branding/unofficial/mailicon256.png \
272        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
273
274desktop-file-install --vendor vine \
275  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
276  --add-category Application \
277  --add-category Network \
278  %{SOURCE20}
279
280# set up the thunderbird start script
281rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
282%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
283  $RPM_BUILD_ROOT%{_bindir}/thunderbird
284%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
285
286install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
287%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
288
289%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
290                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
291        $RPM_BUILD_ROOT/vine-default-prefs
292%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
293%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
294%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
295
296%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
297
298# own mozilla plugin dir (#135050)
299%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
300
301# own extension directories
302%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
303%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
304
305# install locales
306for lang in %{MOZ_BUILD_LOCALES} ; do
307  %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
308done
309
310
311%clean
312%{__rm} -rf $RPM_BUILD_ROOT
313
314#===============================================================================
315
316%post
317update-desktop-database &> /dev/null || :
318touch --no-create %{_datadir}/icons/hicolor
319if [ -x %{_bindir}/gtk-update-icon-cache ]; then
320  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
321fi
322
323%postun
324update-desktop-database &> /dev/null || :
325touch --no-create %{_datadir}/icons/hicolor
326if [ -x %{_bindir}/gtk-update-icon-cache ]; then
327  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
328fi
329
330
331%files
332%defattr(-,root,root,-)
333%attr(755,root,root) %{_bindir}/thunderbird
334%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
335%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
336%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
337%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
338%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
339%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
340%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
341%{mozappdir}
342
343#===============================================================================
344
345%changelog
346* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
347- new upstream release with security fix
348- add patch5 to fix build failure
349
350* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
351- new upstream release
352
353* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
354- new upstream release with security fix
355- add Patch1030 to fix compilation error
356
357* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
358- change mozconfig (Source1030 & 1040): add --enable-jsd
359
360* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
361- new upstream release
362
363* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
364- new upstream release with security fix
365- add Patch0 from fedora development: fix version issue
366- remove BuildRequires: hunspell-devel
367- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
368
369* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
370- add BuildRequires: alsa-lib-devel
371- remove BuildRequires: libnotify-devel
372  (workaround for known bug)
373- update mozconfig to add --disable-libnotify option
374
375* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
376- new upstream release
377- update spec entirely
378- import patches from fedora (Patch1, 2 & 4)
379- drop outdated patches (Patch22, 24)
380- update Sources:
381  - mozconfig (Source1030 & Source1040)
382  - default prefs.js (Source12)
383  - unofficial branding (Source40 & Source41)
384  - japanese translation (Source1000)
385- update Patch1000 (sjis-alias)
386
387* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
388- new upstream release
389
390* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
391- new upstream release
392
393* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
394- don't install official branding logos
395
396* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
397- add necessary icons in %%{tbdir}/chrome/icons/default
398- add Packager tag
399
400* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
401- new upstream release
402
403* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
404- new upstream release
405
406* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
407- new upstream release
408
409* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
410- new upstream release
411
412* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
413- rebuilt for VineSeed
414
415* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
416- new upstream release
417
418* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
419- new upstream release
420- built for Vine Linux 4.x
421- dropped Patch1020 (merged into upstream)
422
423* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
424- added Patch1020 for workaround gcc visibility hidden bugs
425
426* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
427- build with new environment/toolchain
428- add build options to build with external nss/nspr libraries
429    ac_add_options --with-system-nspr
430    ac_add_options --with-system-nss
431
432* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
433- new upstream release
434
435* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
436- new upstream release
437
438* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
439- new upstream release
440
441* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
442- new upstream release
443
444* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
445- new upstream release
446- merge changes from firefox
447  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
448
449* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
450- new upstream release
451- build en-US locale
452- merge changes from firefox
453  - add upstream patches
454  - disable pango rendering by default
455    (workaround fix slow rendering in some page)
456
457* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
458- initial build for Vine Linux based on FC package
459- update to 1.5RC2
460
461* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
462- Fix issue with popup dialogs and other actions causing lockups
463
464* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
465- Update to 1.5 rc1
466
467* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
468- Update to 1.5 beta2
469
470* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
471- Update to 1.5 beta1
472- Bring the install phase of the spec file up to speed
473
474* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
475- Rebuild
476
477* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
478- Add patch to make file chooser dialog modal
479
480* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
481- Update to 1.0.6
482
483* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
484- 1.0.6 Release Candidate
485
486* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
487- Use system NSPR
488- Fix crash on 64bit platforms (#160330)
489
490* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
491- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
492  references, fixing the "no fonts" problem.
493
494* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
495- Change the Exec line in the desktop file to `thunderbird`
496
497* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
498- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
499
500* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
501- Add temporary workaround to not create files in the user's $HOME (#149664)
502
503* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
504- Don't have downloads "disappear" when downloading to desktop (#139015)
505- Fix for some more cursor issues in textareas (149991, 150002, 152089)
506- Add upstream patch to fix bidi justification of pango
507- Add patch to fix launching of helper applications
508- Add patch to properly link against libgfxshared_s.a
509- Fix multilib conflicts
510
511* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
512- correct confusing PANGO vars in startup script
513
514* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
515- Thunderbird 1.0.2
516
517* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
518- Add patch to compile against new fortified glibc macros
519
520* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
521- Rebuild against GCC 4.0
522- Add execshield patches
523- Minor specfile cleanup
524
525* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
526- Rebuild
527
528* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
529- Add RPM version to useragent
530
531* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
532- Port over pango patches from firefox
533
534* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
535- Thunderbird 1.0
536
537* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
538- Fix advanced prefs
539
540* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
541- Make this run on s390(x) now for real
542
543* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
544- Update to 1.0 rc1
545
546* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
547- Add patches to build and run on s390(x)
548
549* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
550- Rebuild to fix file chooser
551
552* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
553- Update to 0.9
554
555* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
556- Prevent inlining of stack direction detection (#135255)
557
558* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
559- More file chooser fixes (same as in firefox)
560- Fix for upstream 28327.
561
562* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
563- Update the pango patch
564
565* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
566- Pull over patches from firefox build:
567  - disable default application dialog
568  - don't include software update since it doesn't work
569  - make external app support work
570
571* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
572- Use pango for rendering
573
574* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
575- Fix for 64 bit crash at startup (b.m.o #256603)
576
577* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
578- Add patches to fix xremote (#135036)
579
580* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
581- Add patch to fix button focus issues (#133507)
582- Add patch for fix IMAP race issues (bmo #246439)
583
584* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
585- filter out library Provides: and internal Requires:
586
587* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
588- Backport the GTK+ File Chooser.
589- Add fix for JS math on x86_64 systems
590- Add pkgconfig patch
591
592* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
593- Update to 0.8.0
594- Remove enigmail
595- Update BuildRequires
596- Remove gcc34 and extension manager patches -- they are upstreamed.
597- Fix for gnome-vfs2 error at component registration
598
599* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
600- Build with --disable-xprint
601
602* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
603- remove all Xvfb-related hacks
604
605* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
606- actually apply psfonts
607- add mozilla gnome-uriloader patch to prevent build failure
608
609* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
610- rawhide import
611- apply NetBSD's freetype 2.1.8 patch
612- apply psfonts patch
613- remove BR on /usr/bin/ex, breaks beehive
614
615* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
616- oops, fix %%install
617
618* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
619- update to Thunderbird 0.7.3 and Enigmail 0.85.0
620- remove XUL.mfasl on startup, add Debian enigmail patches
621- add Xvfb hack for -install-global-extension
622
623* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
624- update to 0.7.2, just because it's there
625- update gcc-3.4 patch (Kaj Niemi)
626- add EM registration patch and remove instdir hack
627
628* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
629- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
630
631* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
632- update to 0.7.1
633- remove Enigmail
634
635* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
636- re-enable Enigmail 0.84.1
637- add gcc-3.4 patch (Kaj Niemi)
638- use official branding (with permission)
639
640* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
641- update to 0.7
642- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
643- specify libdir, change BR for apt (V. Skytt辰, #1617)
644
645* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
646- temporary workaround for enigmail skin "modern" bug
647
648* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
649- update to Enigmail 0.84.0
650- update launch script
651
652* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
653- installation directory now versioned
654- allow root to run the program (for installing extensions)
655- remove unnecessary %%pre and %%post
656- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
657
658* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
659- include Enigmail, re-add release notes
660- delete %{_libdir}/thunderbird in %%pre
661
662* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
663- update to Thunderbird 0.6
664
665* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
666- update to Thunderbird 0.6 RC1
667- add new icon, remove release notes
668
669* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
670- update to latest CVS, update mozconfig and %%build accordingly
671- update to Enigmail 0.83.6
672- remove x-remote and x86_64 patches
673- build with -Os
674
675* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
676- update x-remote patch
677- more startup script fixes
678
679* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
680- startup script fixes, and a minor cleanup
681
682* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
683- Minor cleanups
684
685* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
686- minor improvements to open-browser.sh and startup script
687- update to latest version of Blizzard's x-remote patch
688
689* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
690- update open-browser.sh, startup script, and BuildRequires
691
692* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
693- update open-browser script, modify BuildRequires (Warren)
694- add Blizzard's x-remote patch
695- initial attempt at x-remote-enabled startup script
696
697* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
698- refuse to run with excessive privileges
699
700* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
701- add Mozilla x86_64 patch (Oliver Sontag)
702- Enigmail source filenames now include the version
703- modify BuildRoot
704
705* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
706- use the updated official tarball
707
708* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
709- fix %%prep script
710
711* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
712- update Enigmail to 0.83.3
713- use official source tarball (after removing the CRLFs)
714- package renamed to thunderbird
715
716* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
717- update to 0.5
718- check for lockfile before launching
719
720* Fri Feb 06 2004 David Hill <djh[at]ii.net>
721- update to latest cvs
722- update to Enigmail 0.83.2
723
724* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
725- update to Enigmail 0.83.1
726- removed Mozilla/Firebird script patching
727
728* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
729- add startup notification to .desktop file
730
731* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
732- open-browser.sh release 3
733- patch broken /usr/bin/mozilla script during install
734- dir ownership
735- XXX: Source fails build on x86_64... fix later
736
737* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
738- update to Enigmail 0.82.5
739- add Warren's open-browser.sh (#1113)
740
741* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
742- use Thunderbird's mozilla-xremote-client to launch browser
743
744* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
745- update to 0.4
746- make hyperlinks work (with recent versions of Firebird/Mozilla)
747
748* Thu Dec 04 2003 David Hill <djh[at]ii.net>
749- update to 0.4rc2
750
751* Wed Dec 03 2003 David Hill <djh[at]ii.net>
752- update to 0.4rc1 and Enigmail 0.82.4
753
754* Thu Nov 27 2003 David Hill <djh[at]ii.net>
755- update to latest CVS and Enigmail 0.82.3
756
757* Sun Nov 16 2003 David Hill <djh[at]ii.net>
758- update to latest CVS (0.4a)
759- update Enigmail to 0.82.2
760- alter mozconfig for new build requirements
761- add missing BuildReq (#987)
762
763* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
764- update to 0.3
765
766* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
767- update to 0.3rc3
768- update Enigmail to 0.81.7
769
770* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
771- update to 0.3rc2
772
773* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
774- simplify startup script
775
776* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
777- add GPG support (Enigmail 0.81.6)
778- specfile fixes (#679)
779
780* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
781- update to 0.2
782
783* Mon Sep 01 2003 David Hill <djh[at]ii.net>
784- initial RPM
785  (based on the fedora MozillaFirebird-0.6.1 specfile)
786
Note: See TracBrowser for help on using the repository browser.