source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 2148

Revision 2148, 26.2 KB checked in by kazutaka, 14 years ago (diff)

3.1.6 に更新

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 3.1
3%define tbversion %{tbmajor}.6
4%define tbrelease 1%{?_dist_release}
5
6# The tarball is pretty inconsistent with directory structure.
7# Sometimes there is a top level directory.  That goes here.
8#
9# IMPORTANT: If there is no top level directory, this should be
10# set to the cwd, ie: '.'
11#%define tarballdir .
12%define tarballdir comm-1.9.2
13
14%define mozappdir %{_libdir}/%{name}-%{version_internal}
15%define moz_objdir objdir-tb
16%define version_internal 3.1
17%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
18
19%define desktop_file_utils_version 0.6
20%define nspr_version 4.8
21%define nss_version 3.12.6
22%define cairo_version 1.6.0
23%define freetype_version 2.1.9
24%define sqlite_version 3.6.14
25%define libnotify_version 0.4
26
27%define build_vineseed 0
28%define build_vine5 0
29
30%if "%{?_dist_release}" == "vl6"
31%define build_vineseed 1
32%endif
33%if "%{?_dist_release}" == "vl5"
34%define build_vine5 1
35%endif
36
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48#Source1010:    mozconfig-thunderbird-vine3
49#Source1020:    mozconfig-thunderbird-vine4
50Source1030:     mozconfig-thunderbird-vine5
51Source1040:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55#Source22:      thunderbird.png
56Source30:       thunderbird-open-browser.sh
57Source40:       thunderbird-unofficial-brandig-tb-brand.properties
58Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73# Fix for jemalloc
74Patch1:         mozilla-jemalloc.patch
75# Fix for installation fail when building with dynamic linked libraries
76Patch2:         thunderbird-shared-error.patch
77# Fixes gcc complain that nsFrame::delete is protected
78Patch4:         xulrunner-1.9.2.1-build.patch
79# Fix for building with libjpeg-turbo
80Patch5:        mozilla-libjpeg-turbo.patch
81
82# customization patches
83#Patch22:        firefox-1.0-psfonts.patch
84#Patch24:        thunderbird-2.0-default-applications.patch
85#Patch25:        thunderbird-1.1-software-update.patch
86Patch26:        firefox-1.5-default-a4-paper.patch
87
88# font system fixes
89#Patch81:        firefox-nopangoxft.patch
90
91## Vine patch
92# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
93Patch1000:      thunderbird-3.1-sjisalias.patch
94
95# use /proc/net/netstat for random seed instead of netstat command.
96#Patch1010:      firefox-nss-no_netstat.patch
97
98# workaround gcc visibility hidden bugs (see gcc#26905)
99Patch1020:      firefox-2.0.0.3-visibility.patch
100
101# temporary fix for compilation error with PR_STATIC_ASSERT
102# refer http://bugs.gentoo.org/show_bug.cgi?id=336413
103Patch1030:      thunderbird-3.1.3-fix-prlog-include-error.patch
104
105BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
106BuildRequires:  pango-devel
107BuildRequires:  cairo-devel >= %{cairo_version}
108%if %{build_vineseed}
109BuildRequires:  nspr-devel >= %{nspr_version}
110BuildRequires:  nss-devel >= %{nss_version}
111%endif
112BuildRequires:  pixman-devel
113BuildRequires:  libpng-devel
114BuildRequires:  libjpeg-devel
115BuildRequires:  gtk2-devel
116BuildRequires:  zlib-devel, gzip, zip, unzip
117BuildRequires:  libIDL-devel
118BuildRequires:  freetype2-devel >= %{freetype_version}
119## disabled libnotify support
120## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
121#BuildRequires:  libnotify-devel >= %{libnotify_version}
122BuildRequires:  bzip2-devel
123BuildRequires:  gnome-vfs2-devel
124BuildRequires:  libgnome-devel
125BuildRequires:  libgnomeui-devel
126BuildRequires:  krb5-devel
127BuildRequires:  pango-devel
128BuildRequires:  libXt-devel
129BuildRequires:  libXrender-devel
130# hunspell is in plus category for vine
131#BuildRequires: hunspell-devel
132BuildRequires:  sqlite3-devel >= %{sqlite_version}
133BuildRequires:  startup-notification-devel
134BuildRequires:  desktop-file-utils
135BuildRequires:  alsa-lib-devel
136Requires:       sqlite3 >= %{sqlite_version}
137Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
138Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
139
140Obsoletes:      MozillaThunderbird
141Provides:       MozillaThunderbird = %{version}
142
143Packager:       daisuke, ryoichi, kazutaka
144
145AutoProv: 0
146%define _use_internal_dependency_generator 0
147%define __find_requires %{SOURCE100}
148
149%description
150Thunderbird is a standalone mail and newsgroup client.
151
152%description -l ja
153Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
154
155#===============================================================================
156
157%prep
158%setup -q %{name}-%{version} -c -b 1000
159cd %{tarballdir}
160
161# Fix for version issue
162sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
163    > version.patch
164%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
165
166%patch1 -p0 -b .jemalloc
167%patch2 -p1 -b .shared-error
168%patch4 -p1 -b .protected
169
170cd mozilla
171
172%patch5 -p1 -b .libjpeg-turbo
173#%patch22 -p1
174#%patch24 -p1
175#%patch25 -p0
176%patch26 -p1 -b .default-a4
177%patch1000 -p1 -b .sjis-alias
178%patch1030 -p3 -b .prlog-fix
179
180cd -
181%{__rm} -f .mozconfig
182%if %{build_vine5}
183%{__cp} %{SOURCE1030} .mozconfig
184%endif
185%if %{build_vineseed}
186%{__cp} %{SOURCE1040} .mozconfig
187# cannot build with xulrunner (yet)
188# see tracking bugs.
189#   https://bugzilla.mozilla.org/show_bug.cgi?id=306324
190#   https://bugzilla.mozilla.org/show_bug.cgi?id=377319
191#echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
192%endif
193
194# setup unofficial branding name
195%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
196%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
197
198#===============================================================================
199
200%build
201cd %{tarballdir}
202
203INTERNAL_GECKO=%{version_internal}
204MOZ_APP_DIR=%{mozappdir}
205
206
207#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
208MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
209export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
210export CFLAGS="$RPM_OPT_FLAGS"
211export CXXFLAGS="$CFLAGS"
212export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
213
214%ifarch ppc ppc64 s390 s390x
215%define moz_make_flags -j1
216%else
217%define moz_make_flags %{?_smp_mflags}
218%endif
219
220export PREFIX='%{_prefix}'
221export LIBDIR='%{_libdir}'
222
223export LDFLAGS="-Wl,-rpath,%{mozappdir}"
224export MAKE="gmake %{moz_make_flags}"
225%{__make} -f client.mk build
226
227# build locales
228LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
229            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
230for dir in $LOCALEDIRS
231do
232  for lang in %{MOZ_BUILD_LOCALES} ; do
233    make -C $dir/locales AB_CD=$lang
234  done
235done
236
237#===============================================================================
238
239%install
240%{__rm} -rf $RPM_BUILD_ROOT
241cd %{tarballdir}
242
243INTERNAL_GECKO=%{version_internal}
244
245INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
246MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
247
248cd %{moz_objdir}
249DESTDIR=$RPM_BUILD_ROOT make install
250
251# install unofficial icons
252cd -
253%{__cp} mail/branding/unofficial/mailicon16.png \
254        $RPM_BUILD_ROOT/%{mozappdir}/icons/
255%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
256%{__cp} mail/branding/unofficial/mailicon16.png \
257        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
258%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
259%{__cp} mail/branding/unofficial/mailicon22.png \
260        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
261%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
262%{__cp} mail/branding/unofficial//mailicon24.png \
263        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
265%{__cp} mail/branding/unofficial/mailicon32.png \
266        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
267%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
268%{__cp} mail/branding/unofficial/mailicon48.png \
269        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
270%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
271%{__cp} mail/branding/unofficial/mailicon256.png \
272        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
273
274desktop-file-install --vendor vine \
275  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
276  --add-category Application \
277  --add-category Network \
278  %{SOURCE20}
279
280# set up the thunderbird start script
281rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
282%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
283  $RPM_BUILD_ROOT%{_bindir}/thunderbird
284%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
285
286install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
287%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
288
289%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
290                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
291        $RPM_BUILD_ROOT/vine-default-prefs
292%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
293%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
294%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
295
296%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
297
298# own mozilla plugin dir (#135050)
299%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
300
301# own extension directories
302%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
303%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
304
305# install locales
306for lang in %{MOZ_BUILD_LOCALES} ; do
307  %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
308done
309
310
311%clean
312%{__rm} -rf $RPM_BUILD_ROOT
313
314#===============================================================================
315
316%post
317update-desktop-database &> /dev/null || :
318touch --no-create %{_datadir}/icons/hicolor
319if [ -x %{_bindir}/gtk-update-icon-cache ]; then
320  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
321fi
322
323%postun
324update-desktop-database &> /dev/null || :
325touch --no-create %{_datadir}/icons/hicolor
326if [ -x %{_bindir}/gtk-update-icon-cache ]; then
327  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
328fi
329
330
331%files
332%defattr(-,root,root,-)
333%attr(755,root,root) %{_bindir}/thunderbird
334%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
335%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
336%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
337%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
338%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
339%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
340%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
341%{mozappdir}
342
343#===============================================================================
344
345%changelog
346* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
347- new upstream release with security fix
348
349* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
350- new upstream release with security fix
351- add patch5 to fix build failure
352
353* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
354- new upstream release
355
356* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
357- new upstream release with security fix
358- add Patch1030 to fix compilation error
359
360* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
361- change mozconfig (Source1030 & 1040): add --enable-jsd
362
363* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
364- new upstream release
365
366* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
367- new upstream release with security fix
368- add Patch0 from fedora development: fix version issue
369- remove BuildRequires: hunspell-devel
370- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
371
372* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
373- add BuildRequires: alsa-lib-devel
374- remove BuildRequires: libnotify-devel
375  (workaround for known bug)
376- update mozconfig to add --disable-libnotify option
377
378* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
379- new upstream release
380- update spec entirely
381- import patches from fedora (Patch1, 2 & 4)
382- drop outdated patches (Patch22, 24)
383- update Sources:
384  - mozconfig (Source1030 & Source1040)
385  - default prefs.js (Source12)
386  - unofficial branding (Source40 & Source41)
387  - japanese translation (Source1000)
388- update Patch1000 (sjis-alias)
389
390* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
391- new upstream release
392
393* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
394- new upstream release
395
396* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
397- don't install official branding logos
398
399* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
400- add necessary icons in %%{tbdir}/chrome/icons/default
401- add Packager tag
402
403* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
404- new upstream release
405
406* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
407- new upstream release
408
409* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
410- new upstream release
411
412* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
413- new upstream release
414
415* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
416- rebuilt for VineSeed
417
418* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
419- new upstream release
420
421* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
422- new upstream release
423- built for Vine Linux 4.x
424- dropped Patch1020 (merged into upstream)
425
426* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
427- added Patch1020 for workaround gcc visibility hidden bugs
428
429* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
430- build with new environment/toolchain
431- add build options to build with external nss/nspr libraries
432    ac_add_options --with-system-nspr
433    ac_add_options --with-system-nss
434
435* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
436- new upstream release
437
438* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
439- new upstream release
440
441* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
442- new upstream release
443
444* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
445- new upstream release
446
447* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
448- new upstream release
449- merge changes from firefox
450  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
451
452* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
453- new upstream release
454- build en-US locale
455- merge changes from firefox
456  - add upstream patches
457  - disable pango rendering by default
458    (workaround fix slow rendering in some page)
459
460* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
461- initial build for Vine Linux based on FC package
462- update to 1.5RC2
463
464* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
465- Fix issue with popup dialogs and other actions causing lockups
466
467* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
468- Update to 1.5 rc1
469
470* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
471- Update to 1.5 beta2
472
473* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
474- Update to 1.5 beta1
475- Bring the install phase of the spec file up to speed
476
477* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
478- Rebuild
479
480* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
481- Add patch to make file chooser dialog modal
482
483* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
484- Update to 1.0.6
485
486* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
487- 1.0.6 Release Candidate
488
489* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
490- Use system NSPR
491- Fix crash on 64bit platforms (#160330)
492
493* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
494- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
495  references, fixing the "no fonts" problem.
496
497* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
498- Change the Exec line in the desktop file to `thunderbird`
499
500* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
501- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
502
503* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
504- Add temporary workaround to not create files in the user's $HOME (#149664)
505
506* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
507- Don't have downloads "disappear" when downloading to desktop (#139015)
508- Fix for some more cursor issues in textareas (149991, 150002, 152089)
509- Add upstream patch to fix bidi justification of pango
510- Add patch to fix launching of helper applications
511- Add patch to properly link against libgfxshared_s.a
512- Fix multilib conflicts
513
514* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
515- correct confusing PANGO vars in startup script
516
517* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
518- Thunderbird 1.0.2
519
520* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
521- Add patch to compile against new fortified glibc macros
522
523* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
524- Rebuild against GCC 4.0
525- Add execshield patches
526- Minor specfile cleanup
527
528* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
529- Rebuild
530
531* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
532- Add RPM version to useragent
533
534* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
535- Port over pango patches from firefox
536
537* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
538- Thunderbird 1.0
539
540* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
541- Fix advanced prefs
542
543* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
544- Make this run on s390(x) now for real
545
546* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
547- Update to 1.0 rc1
548
549* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
550- Add patches to build and run on s390(x)
551
552* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
553- Rebuild to fix file chooser
554
555* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
556- Update to 0.9
557
558* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
559- Prevent inlining of stack direction detection (#135255)
560
561* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
562- More file chooser fixes (same as in firefox)
563- Fix for upstream 28327.
564
565* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
566- Update the pango patch
567
568* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
569- Pull over patches from firefox build:
570  - disable default application dialog
571  - don't include software update since it doesn't work
572  - make external app support work
573
574* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
575- Use pango for rendering
576
577* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
578- Fix for 64 bit crash at startup (b.m.o #256603)
579
580* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
581- Add patches to fix xremote (#135036)
582
583* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
584- Add patch to fix button focus issues (#133507)
585- Add patch for fix IMAP race issues (bmo #246439)
586
587* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
588- filter out library Provides: and internal Requires:
589
590* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
591- Backport the GTK+ File Chooser.
592- Add fix for JS math on x86_64 systems
593- Add pkgconfig patch
594
595* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
596- Update to 0.8.0
597- Remove enigmail
598- Update BuildRequires
599- Remove gcc34 and extension manager patches -- they are upstreamed.
600- Fix for gnome-vfs2 error at component registration
601
602* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
603- Build with --disable-xprint
604
605* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
606- remove all Xvfb-related hacks
607
608* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
609- actually apply psfonts
610- add mozilla gnome-uriloader patch to prevent build failure
611
612* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
613- rawhide import
614- apply NetBSD's freetype 2.1.8 patch
615- apply psfonts patch
616- remove BR on /usr/bin/ex, breaks beehive
617
618* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
619- oops, fix %%install
620
621* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
622- update to Thunderbird 0.7.3 and Enigmail 0.85.0
623- remove XUL.mfasl on startup, add Debian enigmail patches
624- add Xvfb hack for -install-global-extension
625
626* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
627- update to 0.7.2, just because it's there
628- update gcc-3.4 patch (Kaj Niemi)
629- add EM registration patch and remove instdir hack
630
631* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
632- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
633
634* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
635- update to 0.7.1
636- remove Enigmail
637
638* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
639- re-enable Enigmail 0.84.1
640- add gcc-3.4 patch (Kaj Niemi)
641- use official branding (with permission)
642
643* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
644- update to 0.7
645- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
646- specify libdir, change BR for apt (V. Skytt辰, #1617)
647
648* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
649- temporary workaround for enigmail skin "modern" bug
650
651* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
652- update to Enigmail 0.84.0
653- update launch script
654
655* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
656- installation directory now versioned
657- allow root to run the program (for installing extensions)
658- remove unnecessary %%pre and %%post
659- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
660
661* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
662- include Enigmail, re-add release notes
663- delete %{_libdir}/thunderbird in %%pre
664
665* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
666- update to Thunderbird 0.6
667
668* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
669- update to Thunderbird 0.6 RC1
670- add new icon, remove release notes
671
672* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
673- update to latest CVS, update mozconfig and %%build accordingly
674- update to Enigmail 0.83.6
675- remove x-remote and x86_64 patches
676- build with -Os
677
678* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
679- update x-remote patch
680- more startup script fixes
681
682* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
683- startup script fixes, and a minor cleanup
684
685* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
686- Minor cleanups
687
688* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
689- minor improvements to open-browser.sh and startup script
690- update to latest version of Blizzard's x-remote patch
691
692* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
693- update open-browser.sh, startup script, and BuildRequires
694
695* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
696- update open-browser script, modify BuildRequires (Warren)
697- add Blizzard's x-remote patch
698- initial attempt at x-remote-enabled startup script
699
700* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
701- refuse to run with excessive privileges
702
703* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
704- add Mozilla x86_64 patch (Oliver Sontag)
705- Enigmail source filenames now include the version
706- modify BuildRoot
707
708* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
709- use the updated official tarball
710
711* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
712- fix %%prep script
713
714* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
715- update Enigmail to 0.83.3
716- use official source tarball (after removing the CRLFs)
717- package renamed to thunderbird
718
719* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
720- update to 0.5
721- check for lockfile before launching
722
723* Fri Feb 06 2004 David Hill <djh[at]ii.net>
724- update to latest cvs
725- update to Enigmail 0.83.2
726
727* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
728- update to Enigmail 0.83.1
729- removed Mozilla/Firebird script patching
730
731* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
732- add startup notification to .desktop file
733
734* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
735- open-browser.sh release 3
736- patch broken /usr/bin/mozilla script during install
737- dir ownership
738- XXX: Source fails build on x86_64... fix later
739
740* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
741- update to Enigmail 0.82.5
742- add Warren's open-browser.sh (#1113)
743
744* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
745- use Thunderbird's mozilla-xremote-client to launch browser
746
747* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
748- update to 0.4
749- make hyperlinks work (with recent versions of Firebird/Mozilla)
750
751* Thu Dec 04 2003 David Hill <djh[at]ii.net>
752- update to 0.4rc2
753
754* Wed Dec 03 2003 David Hill <djh[at]ii.net>
755- update to 0.4rc1 and Enigmail 0.82.4
756
757* Thu Nov 27 2003 David Hill <djh[at]ii.net>
758- update to latest CVS and Enigmail 0.82.3
759
760* Sun Nov 16 2003 David Hill <djh[at]ii.net>
761- update to latest CVS (0.4a)
762- update Enigmail to 0.82.2
763- alter mozconfig for new build requirements
764- add missing BuildReq (#987)
765
766* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
767- update to 0.3
768
769* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
770- update to 0.3rc3
771- update Enigmail to 0.81.7
772
773* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
774- update to 0.3rc2
775
776* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
777- simplify startup script
778
779* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
780- add GPG support (Enigmail 0.81.6)
781- specfile fixes (#679)
782
783* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
784- update to 0.2
785
786* Mon Sep 01 2003 David Hill <djh[at]ii.net>
787- initial RPM
788  (based on the fedora MozillaFirebird-0.6.1 specfile)
789
Note: See TracBrowser for help on using the repository browser.