source: projects/specs/trunk/t/thread/thread-vl.spec @ 9210

Revision 9210, 12.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-01 Ryoichi INAGAKI <ryo1@…>

  • cjs, gjs: changed Group
  • expect, tclx, thread: updated
  • pclock, tix: rebuilt


Line 
1%define tclmajor 8.5
2%define majorver 2.7
3
4Summary: A Tcl/Tk development environment: thread
5Summary(ja): Tcl/Tk 開発環境: thread
6Name: thread
7Version: %{majorver}.1
8Release: 1%{?_dist_release}
9License: BSD
10Group: Development/Languages
11URL: http://tcl.sourceforge.net/
12Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
13
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libtool
16BuildRequires: util-linux
17BuildRequires: perl
18BuildRequires: gdbm
19BuildRequires: tcl >= %{tclmajor}
20BuildRequires: tk >= %{tclmajor}
21Requires: tcl >= %{tclmajor}
22Requires: tk >= %{tclmajor}
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27
28%description
29You can use this extension to gain script-level access to Tcl threading capabilities.
30
31%prep
32
33%setup -q -n %{name}%{version}
34
35%build
36chmod 755 ./configure
37%configure \
38    --with-tcl=%{_libdir} \
39    --with-tk=%{_libdir} \
40    --enable-shared \
41    --enable-threads \
42    --enable-64bit
43
44make %{?_smp_mflags}
45
46%install
47rm -rf ${RPM_BUILD_ROOT}
48rm -f *.files
49
50make install DESTDIR=$RPM_BUILD_ROOT
51
52echo "%%defattr(-,root,root)" > thread.files
53(find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
54 find ${RPM_BUILD_ROOT}%{_includedir}/*;
55 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
56        | sort | uniq -u >> thread.files
57
58set +x +H
59for n in `cat thread.files`; do
60        test -f $n || continue
61        head -1 $n | grep -q ^#! || continue
62        chmod u+w $n
63        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
64done
65set -x -H
66
67#
68# post process the *.files list, removing build sys references and mark
69# which are directories
70set +x
71for n in *.files; do
72        mv $n $n.in
73        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
74            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
75                echo -n '%dir '
76            fi
77            echo $file
78        done > $n
79        rm -f $n.in
80done
81set -x
82
83#
84# Man pages can be compressed
85perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
86
87%post -p /sbin/ldconfig -n thread
88
89%postun -p /sbin/ldconfig -n thread
90
91%clean
92rm -rf ${RPM_BUILD_ROOT}
93rm -f *.files
94
95%files -f thread.files -n thread
96%doc README ChangeLog doc/html/*
97
98%changelog
99* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.7.1-1
100- updated to 2.7.1
101
102* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
103- rebuilt with rpm-4.8.1-3
104
105* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
106- rebuilt with new environment
107
108* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
109- applied new versioning policy and spec in utf-8
110
111* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
112- rebuild with tcl/tk-8.4.18
113
114* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
115- rebuild with tcl/tk-8.4.16
116
117* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
118- update thread to 2.6.5
119- rebuilt with new toolchain
120
121* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
122- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
123
124* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
125- update thread to 2.6.2
126- rebuilt for tcl/tk-8.4.11
127
128* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
129- rebuild for tcl/tk-8.4.6
130
131* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
132- source update
133
134* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
135- modified for Vine Linux
136- splite source package
137
138* Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
139- update Tcl/Tk 8.4.2
140
141* Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
142- update thread 2.5
143- update expect-20030203 (nightly-cvs)
144- remove xotcl
145
146* Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
147- add config patch for Trf
148- add static libraries of Tcl and Tk
149- add tbcload and tclcompiler again
150
151* Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
152- build on RH 8.0
153- update expect 5.38.0
154- remove tcllib module, which will be separate RPM from this.
155- remove tbcload module, which will be separate RPM from this.
156- remove tclcompiler module, which will be separate RPM from this.
157- add XOTcl 1.0
158- add Tcl-Trf 2.1p2
159- add Memchan 2.2a4
160
161* Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
162- fix to make XIC free, and eliminate XCloseIM when exiting Tk.
163
164* Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
165- update Tcl/Tk 8.4.1.
166
167* Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
168- correct install sequence in Tk.
169
170* Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
171- add TclPro tools:
172- tbcload CVS
173- tclcompiler CVS
174
175* Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
176- add iwidgets4.0.1.
177- correct symbolic link
178
179* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
180- fix stub problem in itcl.
181
182* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
183- adjust libary names to meet compatibility.
184
185* Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
186- update Tcl/Tk 8.4.0.
187- update TclX 8.4.
188- update tcllib 1.3.
189- add thread2.4.
190
191* Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
192- update tcllib 1.2.
193
194* Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
195- correct to install all of message catalogs for Img.
196
197* Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
198- add tcl-8.3.4-encoding.patch for JIS encoding
199
200* Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
201- update itcl 3.2.1
202
203* Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
204- add link for tclth8.3 and wish8.3
205- add img 1.2.4
206
207* Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
208- update Tcl/Tk 8.3.4
209- update tcllib 1.1
210- update patch tcl-8.3.4-cruft.patch
211- update patch tcl-8.3.4-makecfg.patch
212- update patch tk-8.3.4-makecfg.patch
213
214* Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
215- hard-coded the compat symlink for tix libdir. (bug 52812)
216
217* Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
218- fixed itkwish/itclsh lib problem (bug 52608)
219- make itcl install not need tclsh/wish during config/make (bug 52606)
220- expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
221
222* Mon Aug  8 2001 Adrian Havill <havill@redhat.com>
223- changed rev for tcllib to 1.0
224- added execute bit mode for itclsh and itksh compat shells
225- re-enable glibc string and math inlines; recent gcc is a-ok.
226- optimize at -O2 instead of -O
227- rename "soname" patches related to makefile/autoconf changes
228- added elf "needed" for tk, tclx, tix, itk
229- removed warnings from tclX
230
231* Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
232- added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
233- fixed 64 bit RPM provides for dependencies
234
235* Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
236- updated tclX to the latest version
237- fixed tclX 8.3's busted help install
238- eliminated make TK_LIB kludge for multiple math libs for tclX
239- used %%makeinstall to brute force fix any remaining unflexible makefile dirs
240- fixed bad ref count release in tcl (bug 49406)
241- improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
242- revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
243- fixed DirTree in Tix (bug 45570)
244
245* Sun Jul  8 2001 Adrian Havill <havill@redhat.com>
246- refresh all sources to latest stable (TODO: separate expect/expectk)
247- massage out some build stuff to patches (TODO: libtoolize hacked constants)
248- remove patches already rolled into the upstream
249- remove unneeded autopasswd
250- removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
251- changed shared object filenames to something less gross
252- fixed tclX shell's argv parsing (bug 47710)
253- reenable threads which seem to work now
254- added all necessary header files for itcl (bug 41374)
255- fixed spawn/eof read problem with expect (bug 43310)
256- made compile-friendly for IA64
257
258* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
259- Bump release + rebuild for 7.2.
260
261* Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
262- bzip2 sources
263
264* Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
265- build with -D_GNU_SOURCE - fixes expect on ia64
266
267* Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
268- build fix from ahavill.
269
270* Wed Feb 21 2001 Tim Powers <timp@redhat.com>
271- fixed weather expect script using wrong server (#28505)
272
273* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
274- added "ja_JP.eucJP" to locale list for tcl
275
276* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
277- rebuild so make check passes
278
279* Fri Oct 20 2000 Than Ngo <than@redhat.com>
280- rebuild with -O0 on alpha (bug #19461)
281
282* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
283- summaries from specspo.
284
285* Tue Aug  8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
286- remove symlink to libtixsam.so
287
288* Thu Aug  3 2000 Jeff Johnson <jbj@redhat.com>
289- merge "best known" patches from searching, stubs were broken.
290- tix needs -fwritable-strings (#14352).
291- create tixwish symlink.
292
293* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
294- rebuild against "working" util-linux col.
295
296* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
297- automatic rebuild
298
299* Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
300- make sure that tix shared libraries are installed.
301- don't mess with %%{_libdir}, it's gonna be a FHS pita.
302
303* Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
304- move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
305
306* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
307- tclX had wrong version.
308
309* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
310- FHS packaging changes.
311- revert --enable-threads, linux is not ready (yet) (#11789).
312- tcl/tk: update to 8.3.1 (#10779).
313- expect: update to 5.31.7+ (#11595).
314- add tcllib-0.4.
315- abstract major tcltk version for soname expansion etc.
316
317* Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
318- update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
319- use perl to drill out pre-pended RPM_BUILD_ROOT.
320- configure with --enable-threads (experimental).
321- improved version of autopasswd (#4788).
322- autopasswd needs to handle password starting with hyphen (#9917).
323- handle 553 ftp status in rftp expect script (#7869).
324- remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
325- correct hierarchy spelling (#7082).
326- fix "expect -d ...", format string had int printed as string (#7775).
327
328* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
329- rebuild for sparc baud rates > 38400.
330
331* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
332- handle compressed manpages
333
334* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
335- Make changes from bug number 7602
336- Apply patch from bug number 7537
337- Apply fix from bug number 7157
338- Add fixes from bug #7601 to the runtcl patch
339
340* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
341- fix descriptions
342- man pages are compressed (whatapain)
343
344* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
345- fix tclX symlinks.
346- compile on systems where SIGPWR == SIGLOST.
347
348* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
349- update tcl/tk to 8.0.5.
350- avoid "containing" in Tix (#2332).
351
352* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
353- use /usr/bin/write in kibitz (#1320).
354- use cirrus.sprl.umich.edu in weather (#1926).
355
356* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
357- auto rebuild in the new build environment (release 28)
358
359* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
360- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
361
362* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
363- expect does unaligned access on alpha (#989)
364- upgrade tcl/tk/tclX to 8.0.4
365- upgrade expect to 5.28.
366- add itcl 3.0.1
367
368* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
369- call libtoolize to allow building on the arm
370- build for glibc 2.1
371- strip binaries
372
373* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
374- update tcl/tk/tclX to 8.0.3, expect is updated also.
375
376* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
377- expect: mkpasswd needs delay before sending password (problem #576)
378
379* Thu May 07 1998 Prospector System <bugs@redhat.com>
380- translations modified for de, fr, tr
381
382* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
383- fixed expect binaries exec permissions
384
385* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
386- updated to Tix 4.1.0.006
387- updated version numbers of tcl/tk to relflect includsion of p2
388
389* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
390- updated tcl/tk to patch level 2
391- updated tclX to 8.0.2
392
393* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
394- fixed filelist for tix... replacing path to the expect binary in scripts
395  was leaving junk files around.
396
397* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
398- added patch to remove libieee test in configure.in for tcl and tk.
399  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
400  solution for all systems
401- fixed src urls
402
403* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
404- removed version numbers from descriptions
405
406* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
407- updated to tcl/tk 8.0 and related versions of packages
408
409* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
410- built against glibc
411- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.