source: projects/specs/trunk/t/texmacro-otf/texmacro-otf-vl.spec @ 5261

Revision 5261, 8.1 KB checked in by munepi, 12 years ago (diff)

updated texmacro-otf-vl.spec

Line 
1%define tlversion       2011
2
3%define hirapropver     0.3
4%define kokanaver       1.0b2
5%define otfver          1.7
6%define otfbetaver      b3
7
8%define texmf           %{_datadir}/texmf
9%define texvf           %{texmf}/fonts/vf/public
10%define texofm          %{texmf}/fonts/ofm/public
11%define textfm          %{texmf}/fonts/tfm/public
12%define mapdir          %{texmf}/fonts/map/dvipdfm/otf
13%define build_texmf     %{buildroot}%{texmf}
14%define build_texvf     %{buildroot}%{texvf}
15%define build_texofm    %{buildroot}%{texofm}
16%define build_textfm    %{buildroot}%{textfm}
17%define build_mapdir    %{buildroot}%{mapdir}
18%define dvipdfmconfig   %{texmf}/dvipdfm/config
19
20%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
21%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys 2> /dev/null
22%define exec_updmap_otf [ -x %{_bindir}/updmap-otf ] && %{_bindir}/env - %{_bindir}/updmap-otf auto 2> /dev/null
23
24Summary: TeX Live macro packages for "VF for OpenType Fonts" by S. Saito
25Summary(ja): TeX Live で使うマクロパッケージ (齋藤修三郎氏による「OpenType Font用VF」)
26Name: texmacro-otf
27Version: %{otfver}
28Release: 2%{?otfbetaver:.%otfbetaver}%{?_dist_release}
29BuildArch: noarch
30
31Source0: http://psitau.kitunebi.com/otf%{version}%{?otfbetaver:%otfbetaver}.zip
32#Source1: http://psitau.at.infoseek.co.jp/hiraprop.zip
33Source1: hiraprop-%{hirapropver}.tar.bz2
34#Source2: http://psitau.at.infoseek.co.jp/kokana.zip
35Source2: kokana-%{kokanaver}.tar.bz2
36
37Source3: http://psitau.at.infoseek.co.jp/otfmanual.pdf
38Source4: http://psitau.at.infoseek.co.jp/kitunetuki.pdf
39Source5: http://psitau.at.infoseek.co.jp/meijinden.pdf
40
41#Source10: updmap-otf
42#NOTE: we renamed http://www.logic.at/people/preining/texlive/updmap-otf with updmap-otf.sh.v0.9.1
43Source10: updmap-otf.sh.v0.9.1
44# Source20: otf-noEmbed.map
45# Source21: otf-cktx.map
46
47Patch1: texmacro-otf-RmlGbm.patch
48
49URL: http://psitau.kitunebi.com/otf.html
50License: BSD
51Group:  Applications/Publishing
52BuildRequires: texlive = %{tlversion}
53BuildRequires: perl, nkf
54Requires:     texlive = %{tlversion}
55Requires:     ghostscript
56
57Buildroot:    %{_tmppath}/%{name}-%{version}-root
58
59Obsoletes: texlive-texmacro-otf <= 1.5.6.1
60
61Distribution: Vine Linux
62Vendor:       Project Vine
63
64%description
65TeX Live macro packages of VF for OpenType Fonts by SAITO Shuzaburo
66Users can use these macros on platex.
67Including
68        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
69        otfaltkana.sty redeffont.sty
70
71%description -l ja
72齋藤修三郎氏作成の TeX Live で用いる追加マクロパッケージです。
73LaTeX(pLaTeX2e)でOpen Type Fontを有効に利用するための
74VF およびスタイルファイルです。
75platex 上で利用できます。
76以下のマクロが含まれています。
77        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
78        otfaltkana.sty redeffont.sty
79
80%prep
81%setup -q -c -n %{name}-%{version} -a 1 -a 2
82
83##
84(cd otfbeta
85    %__sed -i -e "s/ovp2ovf/wovp2ovf/" mkjvf && chmod +x mkjvf || exit 1
86    for x in script/*.pl; do
87        %__sed -i -e "s/ovp2ovf/wovp2ovf/" $x && chmod +x $x || exit 1
88    done
89)
90
91## rename from pltotf to ppltotf
92%__sed -i -e "s,^pltotf,ppltotf,g" kokana-%{kokanaver}/makealtkana || exit 1
93
94%build
95
96###### otf #####
97(cd otfbeta
98./makeotf
99)
100
101###### kokana #####
102pushd kokana-%{kokanaver}
103nkf -be basepl/base-h.pl > base-h.pl
104nkf -be basepl/base-v.pl > base-v.pl
105%__mv -f base-[hv].pl basepl
106./makealtkana
107popd
108
109%install
110%__rm -rf %{buildroot}
111
112%__mkdir fontmap test pdf
113%__mkdir_p %{buildroot}%{_bindir}
114%__mkdir_p %{build_texmf}/tex/platex/otf
115#%__mkdir_p %{build_texmf}-var/updmap-otf
116%__mkdir_p %{build_texvf}/otf
117%__mkdir_p %{build_textfm}/otf
118%__mkdir_p %{build_mapdir}
119
120%__install -m 644 %{SOURCE3} %{SOURCE4} %{SOURCE5} pdf
121%__install -m 755 %{SOURCE10} %{buildroot}%{_bindir}/updmap-otf
122
123###### otfstable #####
124(cd otfbeta
125%__install -m 644 sty/* %{build_texmf}/tex/platex/otf
126%__install -m 644 vf/* %{build_texvf}/otf
127%__install -m 644 tfm/* %{build_textfm}/otf
128
129%__install -m 644 readme.txt ../readme-otf.txt
130%__install -m 644 test/*.tex ../test
131)
132
133###### hiraprop #####
134%__mkdir_p %{build_texmf}/tex/platex/hiraprop
135%__mkdir_p %{build_texvf}/hiraprop
136%__mkdir_p %{build_texofm}/hiraprop
137%__mkdir_p %{build_textfm}/hiraprop
138
139pushd hiraprop-%{hirapropver}
140%__install -m 644 sty/* %{build_texmf}/tex/platex/hiraprop
141%__install -m 644 vf/hiraprop/* %{build_texvf}/hiraprop
142%__install -m 644 ofm/hiraprop/* %{build_texofm}/hiraprop
143%__install -m 644 tfm/hiraprop/* %{build_textfm}/hiraprop
144
145%__install -m 644 *.tex ../test
146%__install -m 644 readme.txt ../readme-hiraprop.txt
147popd
148
149###### kokana #####
150pushd kokana-%{kokanaver}
151%__install -m 644 otfaltkana.sty %{build_texmf}/tex/platex/otf
152%__install -m 644 vf/* %{build_texvf}/otf
153%__install -m 644 tfm/* %{build_textfm}/otf
154
155%__install -m 644 sample/kokanatest.tex ../test
156%__install -m 644 readme.txt ../readme-kokana.txt
157popd
158
159
160%post
161%{exec_texhash}
162
163#%{exec_updmap}
164
165%{exec_updmap_otf}
166exit 0
167
168%postun
169if [ "$1" = 0 ]; then
170    #%__rm -rf %{texmf}-var/updmap-otf
171
172    %{exec_texhash}
173
174    %{exec_updmap}
175fi
176exit 0
177
178%clean
179%__rm -rf %{buildroot}
180
181%files
182%defattr(-,root,root)
183%doc readme* fontmap test pdf
184#%dir %{texmf}-var/updmap-otf
185%{_bindir}/updmap-otf
186%{texmf}/tex/platex/otf
187%{texmf}/tex/platex/hiraprop
188%{texvf}
189%{textfm}
190%{texofm}
191%{mapdir}
192
193%changelog
194* Sun Dec  4 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-2.b3
195- defined %%exec_texhash
196
197* Sat Nov 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-1.b3
198- new upstream release
199  - changed Url, License tags
200- TeX Linux 2011
201 
202* Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-4
203- fixed updmap-otf
204  - changed $$MAPDIR to $${TEXMF}/fonts/map/dvipdfm/otf
205
206* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-3
207- changed %%mapdir to %%{texmf}/fonts/map/dvipdfm/otf
208
209* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-2
210- added Obsoletes: texlive-texmacro-otf <= 1.5.6.1
211  - for TeX Live 2009 of VinePlus/5, supported texlive-texmacro-otf
212
213* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-1
214- new upstream release
215- TeX Linux 2009
216
217* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-3
218- added otf-ps-morisawax{-noEmbed}.map
219
220* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-2
221- spec in utf8
222
223* Tue Aug 05 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-1
224- applied new versioning policy
225
226* Sun Apr 07 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-0vl1
227- new upstream release
228
229* Sat May 27 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl2
230- updmap-otf v0.9: use noEmbed.map instead of noEmbeddedFont.map
231
232* Fri May 12 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl1
233- resync with ptetex3-20060506
234
235* Sun Nov 06 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl3
236- resync with ptetex3-20051102
237
238* Wed Aug 31 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl2
239- resync with ptetex3-20050830
240
241* Sat Jun 18 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl1
242- source update
243- modified for teTeX3
244
245* Thu Feb 03 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.6-0vl1
246- source update
247
248* Thu Jan 20 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.5-0vl1
249- source update
250
251* Sun Nov 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl5
252- updmap-0.7
253
254* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl4
255- updmap-0.6
256
257* Mon Oct 11 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl3
258- updmap-0.5
259
260* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl2
261- fixed updmap
262
263* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl1
264- source update
265- updmap-0.4
266
267* Thu Apr 08 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl4
268- update updmap-otf: take over before setting in "auto" target
269- remove requires texmacro-sfujita
270
271* Sat Apr 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl3
272- fix postun
273
274* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl2
275- drop extrafonts and added hiraprop
276- update updmap-otf and *-udvips.map
277
278* Sun Mar 28 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl1
279- source update
280- added updmap-otf
281
282* Wed Feb 04 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.9-0vl1
283- first release
Note: See TracBrowser for help on using the repository browser.