source: projects/specs/trunk/t/texmacro-otf/texmacro-otf-vl.spec @ 5207

Revision 5207, 7.9 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1%define tlversion       2011
2
3%define hirapropver     0.3
4%define kokanaver       1.0b2
5%define otfver          1.7
6%define otfbetaver      b3
7
8%define texmf           %{_datadir}/texmf
9%define texvf           %{texmf}/fonts/vf/public
10%define texofm          %{texmf}/fonts/ofm/public
11%define textfm          %{texmf}/fonts/tfm/public
12%define mapdir          %{texmf}/fonts/map/dvipdfm/otf
13%define build_texmf     %{buildroot}%{texmf}
14%define build_texvf     %{buildroot}%{texvf}
15%define build_texofm    %{buildroot}%{texofm}
16%define build_textfm    %{buildroot}%{textfm}
17%define build_mapdir    %{buildroot}%{mapdir}
18%define dvipdfmconfig   %{texmf}/dvipdfm/config
19
20%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys 2> /dev/null
21%define exec_updmap_otf [ -x %{_bindir}/updmap-otf ] && %{_bindir}/env - %{_bindir}/updmap-otf auto 2> /dev/null
22
23Summary: TeX Live macro packages for "VF for OpenType Fonts" by S. Saito
24Summary(ja): TeX Live で使うマクロパッケージ (齋藤修三郎氏による「OpenType Font用VF」)
25Name: texmacro-otf
26Version: %{otfver}
27Release: 1%{?otfbetaver:.%otfbetaver}%{?_dist_release}
28BuildArch: noarch
29
30Source0: http://psitau.kitunebi.com/otf%{version}%{?otfbetaver:%otfbetaver}.zip
31#Source1: http://psitau.at.infoseek.co.jp/hiraprop.zip
32Source1: hiraprop-%{hirapropver}.tar.bz2
33#Source2: http://psitau.at.infoseek.co.jp/kokana.zip
34Source2: kokana-%{kokanaver}.tar.bz2
35
36Source3: http://psitau.at.infoseek.co.jp/otfmanual.pdf
37Source4: http://psitau.at.infoseek.co.jp/kitunetuki.pdf
38Source5: http://psitau.at.infoseek.co.jp/meijinden.pdf
39
40#Source10: updmap-otf
41#NOTE: we renamed http://www.logic.at/people/preining/texlive/updmap-otf with updmap-otf.sh.v0.9.1
42Source10: updmap-otf.sh.v0.9.1
43# Source20: otf-noEmbed.map
44# Source21: otf-cktx.map
45
46Patch1: texmacro-otf-RmlGbm.patch
47
48URL: http://psitau.kitunebi.com/otf.html
49License: BSD
50Group:  Applications/Publishing
51BuildRequires: texlive = %{tlversion}
52BuildRequires: perl, nkf
53Requires:     texlive = %{tlversion}
54Requires:     ghostscript
55
56Buildroot:    %{_tmppath}/%{name}-%{version}-root
57
58Obsoletes: texlive-texmacro-otf <= 1.5.6.1
59
60Distribution: Vine Linux
61Vendor:       Project Vine
62
63%description
64TeX Live macro packages of VF for OpenType Fonts by SAITO Shuzaburo
65Users can use these macros on platex.
66Including
67        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
68        otfaltkana.sty redeffont.sty
69
70%description -l ja
71齋藤修三郎氏作成の TeX Live で用いる追加マクロパッケージです。
72LaTeX(pLaTeX2e)でOpen Type Fontを有効に利用するための
73VF およびスタイルファイルです。
74platex 上で利用できます。
75以下のマクロが含まれています。
76        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
77        otfaltkana.sty redeffont.sty
78
79%prep
80%setup -q -c -n %{name}-%{version} -a 1 -a 2
81
82##
83(cd otfbeta
84    %__sed -i -e "s/ovp2ovf/wovp2ovf/" mkjvf && chmod +x mkjvf || exit 1
85    for x in script/*.pl; do
86        %__sed -i -e "s/ovp2ovf/wovp2ovf/" $x && chmod +x $x || exit 1
87    done
88)
89
90## rename from pltotf to ppltotf
91%__sed -i -e "s,^pltotf,ppltotf,g" kokana-%{kokanaver}/makealtkana || exit 1
92
93%build
94
95###### otf #####
96(cd otfbeta
97./makeotf
98)
99
100###### kokana #####
101pushd kokana-%{kokanaver}
102nkf -be basepl/base-h.pl > base-h.pl
103nkf -be basepl/base-v.pl > base-v.pl
104%__mv -f base-[hv].pl basepl
105./makealtkana
106popd
107
108%install
109%__rm -rf %{buildroot}
110
111%__mkdir fontmap test pdf
112%__mkdir_p %{buildroot}%{_bindir}
113%__mkdir_p %{build_texmf}/tex/platex/otf
114#%__mkdir_p %{build_texmf}-var/updmap-otf
115%__mkdir_p %{build_texvf}/otf
116%__mkdir_p %{build_textfm}/otf
117%__mkdir_p %{build_mapdir}
118
119%__install -m 644 %{SOURCE3} %{SOURCE4} %{SOURCE5} pdf
120%__install -m 755 %{SOURCE10} %{buildroot}%{_bindir}/updmap-otf
121
122###### otfstable #####
123(cd otfbeta
124%__install -m 644 sty/* %{build_texmf}/tex/platex/otf
125%__install -m 644 vf/* %{build_texvf}/otf
126%__install -m 644 tfm/* %{build_textfm}/otf
127
128%__install -m 644 readme.txt ../readme-otf.txt
129%__install -m 644 test/*.tex ../test
130)
131
132###### hiraprop #####
133%__mkdir_p %{build_texmf}/tex/platex/hiraprop
134%__mkdir_p %{build_texvf}/hiraprop
135%__mkdir_p %{build_texofm}/hiraprop
136%__mkdir_p %{build_textfm}/hiraprop
137
138pushd hiraprop-%{hirapropver}
139%__install -m 644 sty/* %{build_texmf}/tex/platex/hiraprop
140%__install -m 644 vf/hiraprop/* %{build_texvf}/hiraprop
141%__install -m 644 ofm/hiraprop/* %{build_texofm}/hiraprop
142%__install -m 644 tfm/hiraprop/* %{build_textfm}/hiraprop
143
144%__install -m 644 *.tex ../test
145%__install -m 644 readme.txt ../readme-hiraprop.txt
146popd
147
148###### kokana #####
149pushd kokana-%{kokanaver}
150%__install -m 644 otfaltkana.sty %{build_texmf}/tex/platex/otf
151%__install -m 644 vf/* %{build_texvf}/otf
152%__install -m 644 tfm/* %{build_textfm}/otf
153
154%__install -m 644 sample/kokanatest.tex ../test
155%__install -m 644 readme.txt ../readme-kokana.txt
156popd
157
158
159%post
160%{exec_texhash}
161
162#%{exec_updmap}
163
164%{exec_updmap_otf}
165exit 0
166
167%postun
168if [ "$1" = 0 ]; then
169    #%__rm -rf %{texmf}-var/updmap-otf
170
171    %{exec_texhash}
172
173    %{exec_updmap}
174fi
175exit 0
176
177%clean
178%__rm -rf %{buildroot}
179
180%files
181%defattr(-,root,root)
182%doc readme* fontmap test pdf
183#%dir %{texmf}-var/updmap-otf
184%{_bindir}/updmap-otf
185%{texmf}/tex/platex/otf
186%{texmf}/tex/platex/hiraprop
187%{texvf}
188%{textfm}
189%{texofm}
190%{mapdir}
191
192%changelog
193* Sat Nov 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-1.b3
194- new upstream release
195  - changed Url, License tags
196- TeX Linux 2011
197 
198* Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-4
199- fixed updmap-otf
200  - changed $$MAPDIR to $${TEXMF}/fonts/map/dvipdfm/otf
201
202* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-3
203- changed %%mapdir to %%{texmf}/fonts/map/dvipdfm/otf
204
205* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-2
206- added Obsoletes: texlive-texmacro-otf <= 1.5.6.1
207  - for TeX Live 2009 of VinePlus/5, supported texlive-texmacro-otf
208
209* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-1
210- new upstream release
211- TeX Linux 2009
212
213* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-3
214- added otf-ps-morisawax{-noEmbed}.map
215
216* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-2
217- spec in utf8
218
219* Tue Aug 05 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-1
220- applied new versioning policy
221
222* Sun Apr 07 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-0vl1
223- new upstream release
224
225* Sat May 27 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl2
226- updmap-otf v0.9: use noEmbed.map instead of noEmbeddedFont.map
227
228* Fri May 12 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl1
229- resync with ptetex3-20060506
230
231* Sun Nov 06 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl3
232- resync with ptetex3-20051102
233
234* Wed Aug 31 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl2
235- resync with ptetex3-20050830
236
237* Sat Jun 18 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl1
238- source update
239- modified for teTeX3
240
241* Thu Feb 03 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.6-0vl1
242- source update
243
244* Thu Jan 20 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.5-0vl1
245- source update
246
247* Sun Nov 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl5
248- updmap-0.7
249
250* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl4
251- updmap-0.6
252
253* Mon Oct 11 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl3
254- updmap-0.5
255
256* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl2
257- fixed updmap
258
259* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl1
260- source update
261- updmap-0.4
262
263* Thu Apr 08 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl4
264- update updmap-otf: take over before setting in "auto" target
265- remove requires texmacro-sfujita
266
267* Sat Apr 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl3
268- fix postun
269
270* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl2
271- drop extrafonts and added hiraprop
272- update updmap-otf and *-udvips.map
273
274* Sun Mar 28 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl1
275- source update
276- added updmap-otf
277
278* Wed Feb 04 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.9-0vl1
279- first release
Note: See TracBrowser for help on using the repository browser.