source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 9576

Revision 9576, 26.0 KB checked in by munepi, 9 years ago (diff)

synced tlnet to 20150522

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20150523
9#% global tlptexlivesrcver   20140507
10
11Summary: The TeX text formatting system
12Summary(ja): TeX 文書整形システム
13Name: texlive
14Version: 2015
15Release: 2%{?_dist_release}
16License: distributable
17Group: Applications/Publishing
18URL: http://www.tug.org/texlive/
19
20## original TeX Live source
21Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
22# Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
23## snapshot
24# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
25# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
26# Source: %{name}-source-%{texlivesrcver}.tar.xz
27
28# ## tlptexlive: pmetapost
29# Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
30Source2: http://www.tug.org/texlive/updmap-kanji.html
31
32## our updmap{,-hdr}.cfg from collection-basic 20140524
33# NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
34Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
35Source7: updmap.cfg.texlive-%{texlivesrcver}
36
37## desktop files
38Source11: texdoctk.desktop
39
40Source98: find-requires-texlive.sh
41## find library sonames for libkpathsea, libptexenc, and libsynctex
42Source99:  find-provides-texlive.sh
43
44######
45# TeX patches
46######
47
48## vine
49Patch0:         reautoconf-parallel.diff
50#Patch1:                texlive-%{texlivesrcver}-vine.patch
51Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
52Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
53#Patch4:                texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
54#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
55
56## security
57
58Requires:    perl-Tk perl-Tk-TableMatrix
59Requires:    ghostscript >= 8.71
60Requires:    nkf
61Requires(post,postun): fontconfig
62Requires(post): ed mktemp
63Requires(post): vutils >= 7.1
64%{!?with_firstbuild:Requires: texlive-common = %{version}}
65BuildRequires: autoconf >= 2.68
66BuildRequires: bison flex
67BuildRequires: bzip2-devel
68BuildRequires: cairo-devel >= 1.12
69BuildRequires: fontconfig-devel
70BuildRequires: freetype2-devel >= 2.1.10
71BuildRequires: gd-devel
72BuildRequires: libjpeg-devel
73BuildRequires: libpng-devel >= 1.6
74BuildRequires: ncurses-devel
75BuildRequires: nkf
76BuildRequires: openssl-devel
77BuildRequires: pixman-devel >= 0.18
78#BuildRequires: poppler-devel >= 0.26
79BuildRequires: xorg-x11-devel
80BuildRequires: zlib-devel
81## use distro's libpaper
82#BuildRequires: libpaper-devel >= 1.1.24-2
83## do not xdvi(k)
84#BuildRequires: XOrg-devel
85#BuildRequires: openMotif-devel
86## needs to build pxdvi
87#BuildRequires: t1lib-devel
88
89BuildRequires: texlive-vtlpkg = %{version}
90
91Buildroot:    %{_tmppath}/%{name}-%{version}-root
92
93Vendor:       Project Vine
94Distribution: Vine Linux
95Packager:     munepi
96
97
98%description
99The TeX Live software distribution offers a complete TeX system for a
100variety of Unix, Macintosh, Windows and other platforms. It
101encompasses programs for editing, typesetting, previewing and printing
102of TeX documents in many different languages, and a large collection
103of TeX macros and font libraries.
104
105The distribution includes extensive general documentation about TeX,
106as well as the documentation for the included software packages.
107
108
109%description -l ja
110TeX Live ソフトウェアディストリビューションは、
111さまざまな Unix, Macintosh, Windows、および
112他のプラットホームに対して完全な TeX システムを提供します。
113多くの異なった言語を含む TeX ドキュメントの
114編集、組版、閲覧、印刷するためのプログラム、
115そして、TeX マクロやフォントライブラリの大きなコレクションを
116同梱しています。
117
118このディストリビューションは
119同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
120TeX に関するたくさんの一般的なドキュメントを含んでいます。
121
122
123%package doc
124Summary: TeX Live: Documentation files of %{name}
125Group: Applications/Publishing
126Requires: %{name} = %{version}-%{release}
127BuildArch: noarch
128
129%description doc
130This package contains documentation files of %{name}.
131
132%package -n libkpathsea
133Summary: path search library for the TeX Live
134Summary(ja): TeX Live 用パス検索ライブラリ
135Group: System Environment/Libraries
136
137%description -n libkpathsea
138This package includes runtime part of the Kpathsea library.
139
140
141%package -n libkpathsea-devel
142Summary: path search libary and header files for the TeX Live
143Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
144Group: Development/Libraries
145Requires: libkpathsea = %{version}-%{release}
146
147%description -n libkpathsea-devel
148This package includes static library and header files of the Kpathsea library.
149
150
151%package -n libptexenc
152Summary: Kanji code convert library for Japanese pTeX
153Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
154Group: System Environment/Libraries
155Requires: libkpathsea = %{version}-%{release}
156
157%description -n libptexenc
158This package includes runtime part of the ptexenc library.
159
160
161%package -n libptexenc-devel
162Summary: Kanji code convert library and header files for Japanese pTeX
163Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
164Group: Development/Libraries
165Requires: libptexenc = %{version}-%{release}
166
167%description -n libptexenc-devel
168This package includes header files of the ptexenc library.
169
170
171%package -n libsynctex
172Summary: SyncTeX library
173Group: System Environment/Libraries
174
175%description -n libsynctex
176This package includes the runtime part of SyncTeX library.
177
178%package -n libsynctex-devel
179Summary: SyncTeX header files
180Group: Development/Libraries
181Requires: libsynctex = %{version}-%{release}
182
183%description -n libsynctex-devel
184This package includes the header files of SyncTeX library.
185
186
187%prep
188[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
189
190%setup -q -n %{name}-%{texlivesrcver}-source
191# %setup -q -n %{name}-source-%{texlivesrcver}
192
193%patch0 -p0 -b .parallel
194# %patch1 -p1 -b .vine
195%patch2 -p1 -b .vine
196%patch3 -p1 -b .vine
197# %patch4 -p1 -b .vine
198
199# ## Applying tlptexlive that provides pxdvi(k) and pmpost
200# echo "applying patches"
201# cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
202#     echo $p | grep '^#' >/dev/null  || \
203#     patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
204# done
205
206## Avoid pollution from internal libraries.
207#,paper,poppler,xpdf
208%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
209./reautoconf || exit 1
210
211
212%build
213set -x
214unset TEXINPUTS || :
215unset HOME || :
216
217export CFLAGS="$RPM_OPT_FLAGS" \
218       CXXFLAGS="$RPM_OPT_FLAGS" \
219       LANG=C
220
221PREFIX=$(pwd)/work
222
223TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
224TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
225
226TL_CONFIGURE_ARGS=" \
227    --disable-multiplatform \
228    --disable-native-texlive-build \
229    --with-banner-add=\"/Vine Linux\" \
230    --enable-shared --disable-static \
231    --enable-compiler-warnings=max \
232    --without-cxx-runtime-hack \
233    \
234    --with-system-xpdf=no --with-system-poppler=no \
235    --with-system-gd \
236    --with-system-t1lib \
237    --with-system-libpng \
238    --with-system-zlib \
239    --with-system-freetype2 \
240    --with-system-pixman \
241    --with-system-cairo \
242    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
243    --with-pic \
244    \
245    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
246    --disable-xdvik \
247    --disable-dvi2tty \
248    --disable-t1utils --disable-psutils --disable-detex \
249    --disable-dvipng --disable-lcdf-typetools \
250"
251
252export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
253TL_MAKE=%__make ./Build || exit 1
254
255
256%install
257## prepare %%install session
258[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
259
260## copy inst directory to /usr
261%__mkdir_p %{buildroot}
262%__cp -a inst %{buildroot}%{_prefix} || exit 1
263%ifarch x86_64
264%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
265%endif
266
267## make some fundamental texmf trees
268%__mkdir_p %{buildroot}%{_tl_texmfvine}
269%__mkdir_p %{buildroot}%{_tl_texmfdist}
270%__mkdir_p %{buildroot}%{_tl_texmflocal}
271%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
272%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
273%__mkdir_p %{buildroot}%{_tl_vartexfonts}
274%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
275%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
276
277cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
278The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
279distribution wide.
280You must not do any changes in this directory.
281EOF
282
283cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
284The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
285You should not use this directory to manage any other packages because
286we Project Vine use this directory to manage non-CTAN packages, some
287enhancement packages and so on.
288EOF
289
290cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
291The directory %{_tl_texmflocal} is the texmf tree of the system wide.
292If you are a privileged user of this system,
293you can use this directory to manage your local packages.
294EOF
295
296## our texmf-dist/web2c/updmap{,-hdr}.cfg
297%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
298%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
299%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
300
301## our map files for dvipdfmx
302%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
303%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
304for x in ptex uptex otf otf-up; do
305    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
306done
307for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
308    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
309done
310
311## desktop things
312%__mkdir_p %{buildroot}%{_datadir}/applications
313# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
314%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
315
316# for created fonts
317%__mkdir_p %{buildroot}%{_tl_vartexfonts}
318# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
319# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
320
321## set executable bit for the library
322%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
323%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
324
325# configure ConTeXt
326for x in context luatools texexec texmfstart; do
327  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
328done
329for x in contextjit; do
330  %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
331done
332
333# touch ghosts
334touch %{buildroot}%{_tl_texmfvine}/ls-R
335touch %{buildroot}%{_tl_texmfdist}/ls-R
336touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
337touch %{buildroot}%{_tl_texmfsysvar}/ls-R
338
339%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
340%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
341%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
342%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
343touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
344touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
345touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
346touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
347touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
348touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
350#touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
351touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
352touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
353touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
354
355
356## remove unpackaging files
357find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
358find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
359%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
360find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
361find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
362%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
363%__rm -f %{buildroot}%{_infodir}/*
364
365## use external packages
366%__rm %{buildroot}/usr/bin/latexmk || exit 1
367
368
369### Files list
370find %{buildroot} -type f -or -type l | \
371    %__sed -e "s|%{buildroot}||g" | \
372    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
373    %__grep -v "%{_includedir}" | \
374    %__grep -v "%{_libdir}" | \
375    %__grep -v "%{_infodir}" | \
376    %__sed -e "s|.*ls-R$|%ghost &|" \
377           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
378           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
379           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
380           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
381           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
382           -e "s|.*\.cnf$|%config(noreplace) &|" \
383           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
384           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
385           -e "s|^.*/updmap/$|%config &|" \
386           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
387           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
388           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
389           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
390           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
391           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
392           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
393           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
394           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
395           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
396           -e "s|%{_mandir}/.*|&*|" \
397        > %{_builddir}/filelist.full
398
399find %{buildroot}%{_tl_texmfvine}* -type d | \
400    %__sed -e "s|^%{buildroot}|%dir |" \
401           -e "s|$|/|" >> %{_builddir}/filelist.full
402
403## subpackages
404%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
405cat %{_builddir}/filelist.doc \
406    %{_builddir}/filelist.full | \
407    sort | uniq -u > %{_builddir}/filelist.tmp
408%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
409
410
411%clean
412%__rm -rf %{buildroot}
413
414
415%pretrans
416rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
417[ $? -eq 1 ] && exit 0
418_trans_time=$(date +%Y%m%d)
419echo "Running some transitional processes on your TeX system ... "
420x=(
421    /usr/share/texmf-local
422    /usr/share/texmf-var
423    /usr/share/texmf-config
424)
425for dir in ${x[@]}; do
426    _trans_dir=${dir}.${_trans_time}.rpmorig
427    [ -d ${_trans_dir}.old ] && \
428        echo -n "  " && \
429        echo "Found ${_trans_dir}.old: " && \
430        echo -n "    " && \
431        %__rm -rvf ${_trans_dir}.old
432    [ -d ${_trans_dir} ] && \
433        echo -n "  " && \
434        echo "Found ${_trans_dir}: " && \
435        echo -n "    " && \
436        %__mv -v ${_trans_dir} ${_trans_dir}.old
437    [ -d ${dir} ] && \
438        echo -n "  " && \
439        echo "Found ${dir}: " && \
440        echo -n "    " && \
441        %__mv -v ${dir} ${_trans_dir}
442done
443echo "done."
444
445%postun
446if [ "$1" = 0 ]; then
447    %__rm -rf %{_tl_vartexfonts}
448fi
449exit 0
450
451%post
452%_tl_touch_run texhash
453%_tl_touch_run updmap
454%_tl_touch_run mtxrun
455%_tl_touch_run fmtutil
456exit 0
457
458%posttrans
459%__mkdir_p %{_tl_vartexfonts}
460%__chmod 1777 %{_tl_vartexfonts}
461
462## create our map files {ptex,uptex,otf,otf-up}-vine.map
463( %{_tl_exec_upddeffont} ) ||:
464
465%{_tl_exec_texhash}
466%{_tl_exec_mtxrun}
467%{_tl_exec_updmap}
468%{_tl_exec_fmtutil}
469exit 0
470
471%post -n libkpathsea
472/sbin/ldconfig
473# for x in kpathsea tds web2c; do
474#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
475# done
476
477# %preun -n libkpathsea
478# if [ "$1" = 0 ]; then
479#     for x in kpathsea tds web2c; do
480#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
481#     done
482# fi
483
484%postun -n libkpathsea
485/sbin/ldconfig
486
487%post -n libptexenc
488/sbin/ldconfig
489
490%postun -n libptexenc
491/sbin/ldconfig
492
493%triggerin -- ghostscript
494%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
495if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
496    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
497elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
498    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
499fi
500%_tl_touch_run texhash
501exit 0
502
503
504%files -f %{_builddir}/filelist.full
505%defattr(-,root,root)
506%{_libdir}/libtexlua52.so.*
507%{_libdir}/libtexluajit.so.*
508%dir %{_tl_aliasttfdir}
509%attr(1777,root,root) %dir %{_tl_vartexfonts}
510# %config %{_sysconfdir}/cron.daily/texlive.cron
511
512%files doc -f %{_builddir}/filelist.doc
513%defattr(-,root,root)
514
515%files -n libkpathsea
516%defattr(-,root,root)
517%{_libdir}/libkpathsea.so.*
518# %{_infodir}/kpathsea.info*
519
520%files -n libkpathsea-devel
521%defattr(-,root,root)
522%{_libdir}/libkpathsea.so
523%dir %{_includedir}/kpathsea
524%{_includedir}/kpathsea/*.h
525%{_libdir}/pkgconfig/kpathsea.pc
526
527%files -n libptexenc
528%defattr(-,root,root)
529%{_libdir}/libptexenc.so.*
530
531%files -n libptexenc-devel
532%defattr(-,root,root)
533%{_libdir}/libptexenc.so
534%dir %{_includedir}/ptexenc
535%{_includedir}/ptexenc/*.h
536%{_libdir}/pkgconfig/ptexenc.pc
537
538%files -n libsynctex
539%defattr(-,root,root)
540%{_libdir}/libsynctex.so.*
541
542%files -n libsynctex-devel
543%defattr(-,root,root)
544%{_libdir}/libsynctex.so
545%dir %{_includedir}/synctex
546%{_includedir}/synctex/*.h
547%{_libdir}/pkgconfig/synctex.pc
548
549
550%changelog
551* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
552- texlive-source-20150523 (TeX Live 2015/pretest)
553- configure ConTeXt/LuaTeX+LuaJIT
554
555* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
556- texlive-source-20150426 (TeX Live 2015/pretest)
557
558* Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
559- texlive-source-20141230 (TeX Live 2015/dev)
560
561* Thu Jul  3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
562- texlive-source-20140525 + tlptexlive 20140507
563- dropped texlive-20140524-vine.patch: built with libpng >= 1.6
564
565* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
566- upgrade to TeX Live 2014
567  - texlive-source-20140524 + tlptexlive 20140507
568
569* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
570- rebuild with poppler-0.24.5
571
572* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
573- rebuilt
574
575* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
576- texlive-source-20131101 2014/dev + tlptexlive 20130815
577- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
578
579* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
580- updated texlive-20131002-texmfcnf-vine.patch:
581  texmf.cnf (shell_escape_commands): added some programs
582
583* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
584- texlive-source-20131002 2014/dev + tlptexlive 20130815
585- defined %%global __find_requires find-requires-texlive.sh
586  - dropped unused dependencies of Requires
587
588* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
589- texlive-source-20130919 2014/dev + tlptexlive 20130815
590- correct some scripts of README.vine for each texmf trees
591
592* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
593- upgrade to TeX Live 2013
594  - texlive-source-20130823 2014/dev + tlptexlive 20130815
595- dropped Requires: jvf
596
597* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
598- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
599- fixed duplicated lw35 for updmap.pl
600- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
601
602* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
603- touch the map files generated by updmap-sys
604
605* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
606- fixed Source7: updmap.cfg.texlive-20120701
607  (upto /etc/texmf/web2c/updmap.cfg)
608- fixex %%triggerin -- ghostscript
609  - replaced %%exec_texhash with %%touch_run texhash
610
611* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
612- TeX Live 2012 + tlptexlive 20121107
613
614* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
615- drop BR: poppler-devel temporaly
616  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
617
618* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
619- build with poppler-0.18.4
620- remove tlmgr
621
622* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
623- updated to tl11supp-120120
624- run %%{exec_fmtutil} at %%post when upgrading
625
626* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
627- updated to tl11supp-111214
628
629* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
630- added BuildRequires: texlive-common
631  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
632  - check japanese.ldf
633- updated tl11supp-111120-vine.patch
634  - added the following options to $$TL_CONFIGURE_ARGS:
635    --disable-detex
636    --disable-dvipng
637    --disable-lcdf-typetools
638- remove some files of asymptote
639- remove a man file of latexmk
640- remove man files of lcdf-typetools
641- remove man files of dvipng
642- remove a man file of detex
643
644* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
645- added find-provides-texlive.sh and set it to %%__find_provides
646  - use to find library sonames for libkpathsea and libptexenc
647- added cmex.enc (%%{SOURCE110})
648  - do not install cmex.enc in our TDS, yet
649- removed some unused directories in texmf/fonts/map
650- removed man files of lcdf-typetools
651- moved texdoc{,tk} and its related files to texlive-doc
652
653* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
654- TeX Live 2011 + tl11supp-111120
655
656* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
657- make the directory VARTEXFONTS (%%posttrans)
658  - dropped %%triggerpostun -- texlive < 2009-17vl6
659
660* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
661- fixed ptexlive-20100711-dvipdfmx-vine.patch
662  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
663
664* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
665- added %%pre to avoid conflictions of texmf-{config,var}
666
667* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
668- dropped Requires: texlive-common
669- added perl-Tk-TableMatrix
670  - supported texdoctk
671- removed broken symbolic links in /usr/bin
672  - for each these symbolic links, the package of its real file/path
673    should be its owner.
674
675* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
676- added %%triggerpostun -- texlive < 2009-17vl6
677  - make the directory VARTEXFONTS
678
679* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
680- fixed %%dir VARTEXFONTS around in %%files
681- dropped BuildRequires: t1utils
682
683* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
684- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
685  - changed VARTEXFONTS to /var/lib/texmf/fonts
686
687* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
688- fixed updmap.cfg
689
690* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
691- dropped Requires: texlive-macros
692
693* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
694- updated ptexlive-20100711-pxdvik-vine.patch
695  and added texlive-20091107-xdvik-vine.patch
696  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
697
698* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
699- supported Vine Linux 5
700  - for vl5, changed a requirement of Japanese VF package
701    - added Requires: texlive-jvf = 2009 (vl5)
702- dropped dependencies of Provides:/Obsoletes: tags
703  - merged these dependencies in texlive-common-vl.spec
704
705* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
706- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
707
708* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
709- applied some security patches from Debian
710  - texlive-2009-CVE-2010-0827.patch
711  - texlive-2009-CVE-2010-1440.patch
712- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
713- applied texlive-2009-luatexdir-libpoppler-0.12.patch
714  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
715- fixed some dependencies
716
717* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
718- added BuildArch: noarch in %%package doc
719- removed some comment-out sentences
720
721* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
722- separeted texmf-dist to texlive-common package
723
724* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
725- unpacked texlive-20091107-source.tar.xz
726- babel is available now
727- applied eptex-100420 and some patches:
728  - eptex-100420-vine.patch
729  - eptex-100420-patch1.diff
730
731* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
732- updated ptexlive-20100711
733
734* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
735- customized updmap.cfg to correspond installed fonts
736
737* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
738- fixed insttexfont()
739
740* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
741- added jvf of MORISAWA basic 5 fonts
742- added cm-super, mathdesign in fntlst
743
744* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
745- define insttexfont() in %%install
746  - copy almost compatible tetex-3.0
747
748* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
749- ptexlive-20090322 + TeXLive 2009
750- added BuildRequires: openssl-devel
751
752* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
753- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.