source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 9529

Revision 9529, 25.3 KB checked in by munepi, 9 years ago (diff)

TeX Live 2015/pretest

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20150426
9#% global tlptexlivesrcver   20140507
10
11Summary: The TeX text formatting system
12Summary(ja): TeX 文書整形システム
13Name: texlive
14Version: 2015
15Release: 1%{?_dist_release}
16License: distributable
17Group: Applications/Publishing
18URL: http://www.tug.org/texlive/
19
20## original TeX Live source
21# Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
22## snapshot
23# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
24# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
25Source: %{name}-source-%{texlivesrcver}.tar.xz
26
27# ## tlptexlive: pmetapost
28# Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
29Source2: http://www.tug.org/texlive/updmap-kanji.html
30
31## our updmap{,-hdr}.cfg from collection-basic 20140524
32# NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
33Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
34Source7: updmap.cfg.texlive-%{texlivesrcver}
35
36## desktop files
37Source11: texdoctk.desktop
38
39Source98: find-requires-texlive.sh
40## find library sonames for libkpathsea, libptexenc, and libsynctex
41Source99:  find-provides-texlive.sh
42
43######
44# TeX patches
45######
46
47## vine
48Patch0:         reautoconf-parallel.diff
49#Patch1:                texlive-%{texlivesrcver}-vine.patch
50Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
51Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
52#Patch4:                texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
53#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
54
55## security
56
57Requires:    perl-Tk perl-Tk-TableMatrix
58Requires:    ghostscript >= 8.71
59Requires:    nkf
60Requires(post,postun): fontconfig
61Requires(post): ed mktemp
62Requires(post): vutils >= 7.1
63%{!?with_firstbuild:Requires: texlive-common = %{version}}
64BuildRequires: autoconf >= 2.68
65BuildRequires: bison flex
66BuildRequires: bzip2-devel
67BuildRequires: cairo-devel >= 1.12
68BuildRequires: fontconfig-devel
69BuildRequires: freetype2-devel >= 2.1.10
70BuildRequires: gd-devel
71BuildRequires: libjpeg-devel
72BuildRequires: libpng-devel >= 1.6
73BuildRequires: ncurses-devel
74BuildRequires: nkf
75BuildRequires: openssl-devel
76BuildRequires: pixman-devel >= 0.18
77#BuildRequires: poppler-devel >= 0.26
78BuildRequires: xorg-x11-devel
79BuildRequires: zlib-devel
80## use distro's libpaper
81#BuildRequires: libpaper-devel >= 1.1.24-2
82## do not xdvi(k)
83#BuildRequires: XOrg-devel
84#BuildRequires: openMotif-devel
85## needs to build pxdvi
86#BuildRequires: t1lib-devel
87
88BuildRequires: texlive-vtlpkg = %{version}
89
90Buildroot:    %{_tmppath}/%{name}-%{version}-root
91
92Vendor:       Project Vine
93Distribution: Vine Linux
94Packager:     munepi
95
96
97%description
98The TeX Live software distribution offers a complete TeX system for a
99variety of Unix, Macintosh, Windows and other platforms. It
100encompasses programs for editing, typesetting, previewing and printing
101of TeX documents in many different languages, and a large collection
102of TeX macros and font libraries.
103
104The distribution includes extensive general documentation about TeX,
105as well as the documentation for the included software packages.
106
107
108%description -l ja
109TeX Live ソフトウェアディストリビューションは、
110さまざまな Unix, Macintosh, Windows、および
111他のプラットホームに対して完全な TeX システムを提供します。
112多くの異なった言語を含む TeX ドキュメントの
113編集、組版、閲覧、印刷するためのプログラム、
114そして、TeX マクロやフォントライブラリの大きなコレクションを
115同梱しています。
116
117このディストリビューションは
118同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
119TeX に関するたくさんの一般的なドキュメントを含んでいます。
120
121
122%package doc
123Summary: TeX Live: Documentation files of %{name}
124Group: Applications/Publishing
125Requires: %{name} = %{version}-%{release}
126BuildArch: noarch
127
128%description doc
129This package contains documentation files of %{name}.
130
131%package -n libkpathsea
132Summary: path search library for the TeX Live
133Summary(ja): TeX Live 用パス検索ライブラリ
134Group: System Environment/Libraries
135
136%description -n libkpathsea
137This package includes runtime part of the Kpathsea library.
138
139
140%package -n libkpathsea-devel
141Summary: path search libary and header files for the TeX Live
142Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
143Group: Development/Libraries
144Requires: libkpathsea = %{version}-%{release}
145
146%description -n libkpathsea-devel
147This package includes static library and header files of the Kpathsea library.
148
149
150%package -n libptexenc
151Summary: Kanji code convert library for Japanese pTeX
152Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
153Group: System Environment/Libraries
154Requires: libkpathsea = %{version}-%{release}
155
156%description -n libptexenc
157This package includes runtime part of the ptexenc library.
158
159
160%package -n libptexenc-devel
161Summary: Kanji code convert library and header files for Japanese pTeX
162Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
163Group: Development/Libraries
164Requires: libptexenc = %{version}-%{release}
165
166%description -n libptexenc-devel
167This package includes header files of the ptexenc library.
168
169
170%package -n libsynctex
171Summary: SyncTeX library
172Group: System Environment/Libraries
173
174%description -n libsynctex
175This package includes the runtime part of SyncTeX library.
176
177%package -n libsynctex-devel
178Summary: SyncTeX header files
179Group: Development/Libraries
180Requires: libsynctex = %{version}-%{release}
181
182%description -n libsynctex-devel
183This package includes the header files of SyncTeX library.
184
185
186%prep
187[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
188
189#% setup -q -n %{name}-%{texlivesrcver}-source -a 1
190%setup -q -n %{name}-source-%{texlivesrcver}
191
192%patch0 -p0 -b .parallel
193# %patch1 -p1 -b .vine
194%patch2 -p1 -b .vine
195%patch3 -p1 -b .vine
196# %patch4 -p1 -b .vine
197
198# ## Applying tlptexlive that provides pxdvi(k) and pmpost
199# echo "applying patches"
200# cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
201#     echo $p | grep '^#' >/dev/null  || \
202#     patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
203# done
204
205## Avoid pollution from internal libraries.
206#,paper,poppler,xpdf
207%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
208./reautoconf || exit 1
209
210
211%build
212set -x
213unset TEXINPUTS || :
214unset HOME || :
215
216export CFLAGS="$RPM_OPT_FLAGS" \
217       CXXFLAGS="$RPM_OPT_FLAGS" \
218       LANG=C
219
220PREFIX=$(pwd)/work
221
222TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
223TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
224
225TL_CONFIGURE_ARGS=" \
226    --disable-multiplatform \
227    --disable-native-texlive-build \
228    --with-banner-add=\"/Vine Linux\" \
229    --enable-shared --disable-static \
230    --enable-compiler-warnings=max \
231    --without-cxx-runtime-hack \
232    \
233    --with-system-xpdf=no --with-system-poppler=no \
234    --with-system-gd \
235    --with-system-t1lib \
236    --with-system-libpng \
237    --with-system-zlib \
238    --with-system-freetype2 \
239    --with-system-pixman \
240    --with-system-cairo \
241    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
242    --with-pic \
243    \
244    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
245    --disable-xdvik \
246    --disable-dvi2tty \
247    --disable-t1utils --disable-psutils --disable-detex \
248    --disable-dvipng --disable-lcdf-typetools \
249"
250
251export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
252TL_MAKE=%__make ./Build || exit 1
253
254
255%install
256## prepare %%install session
257[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
258
259## copy inst directory to /usr
260%__mkdir_p %{buildroot}
261%__cp -a inst %{buildroot}%{_prefix} || exit 1
262%ifarch x86_64
263%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
264%endif
265
266## make some fundamental texmf trees
267%__mkdir_p %{buildroot}%{_tl_texmfvine}
268%__mkdir_p %{buildroot}%{_tl_texmfdist}
269%__mkdir_p %{buildroot}%{_tl_texmflocal}
270%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
271%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
272%__mkdir_p %{buildroot}%{_tl_vartexfonts}
273%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
274%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
275
276cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
277The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
278distribution wide.
279You must not do any changes in this directory.
280EOF
281
282cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
283The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
284You should not use this directory to manage any other packages because
285we Project Vine use this directory to manage non-CTAN packages, some
286enhancement packages and so on.
287EOF
288
289cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
290The directory %{_tl_texmflocal} is the texmf tree of the system wide.
291If you are a privileged user of this system,
292you can use this directory to manage your local packages.
293EOF
294
295## our texmf-dist/web2c/updmap{,-hdr}.cfg
296%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
297%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
298%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
299
300## our map files for dvipdfmx
301%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
302%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
303for x in ptex uptex otf otf-up; do
304    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
305done
306for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
307    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
308done
309
310## desktop things
311%__mkdir_p %{buildroot}%{_datadir}/applications
312# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
313%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
314
315# for created fonts
316%__mkdir_p %{buildroot}%{_tl_vartexfonts}
317# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
318# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
319
320## set executable bit for the library
321%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
322%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
323
324# configure ConTeXt
325for x in context luatools texexec texmfstart; do
326  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
327done
328
329# touch ghosts
330touch %{buildroot}%{_tl_texmfvine}/ls-R
331touch %{buildroot}%{_tl_texmfdist}/ls-R
332touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
333touch %{buildroot}%{_tl_texmfsysvar}/ls-R
334
335%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
336%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
337%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
338%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
339touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
340touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
341touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
342touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
343touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
344touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
345touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
346#touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
347touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
348touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
350
351
352## remove unpackaging files
353find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
354find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
355%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
356find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
357find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
358%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
359%__rm -f %{buildroot}%{_infodir}/*
360
361## use external packages
362%__rm %{buildroot}/usr/bin/latexmk || exit 1
363
364
365### Files list
366find %{buildroot} -type f -or -type l | \
367    %__sed -e "s|%{buildroot}||g" | \
368    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
369    %__grep -v "%{_includedir}" | \
370    %__grep -v "%{_libdir}" | \
371    %__grep -v "%{_infodir}" | \
372    %__sed -e "s|.*ls-R$|%ghost &|" \
373           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
374           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
375           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
376           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
377           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
378           -e "s|.*\.cnf$|%config(noreplace) &|" \
379           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
380           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
381           -e "s|^.*/updmap/$|%config &|" \
382           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
383           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
384           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
385           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
386           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
387           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
388           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
389           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
390           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
391           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
392           -e "s|%{_mandir}/.*|&*|" \
393        > %{_builddir}/filelist.full
394
395find %{buildroot}%{_tl_texmfvine}* -type d | \
396    %__sed -e "s|^%{buildroot}|%dir |" \
397           -e "s|$|/|" >> %{_builddir}/filelist.full
398
399## subpackages
400%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
401cat %{_builddir}/filelist.doc \
402    %{_builddir}/filelist.full | \
403    sort | uniq -u > %{_builddir}/filelist.tmp
404%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
405
406
407%clean
408%__rm -rf %{buildroot}
409
410
411%pretrans
412rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
413[ $? -eq 1 ] && exit 0
414_trans_time=$(date +%Y%m%d)
415echo "Running some transitional processes on your TeX system ... "
416x=(
417    /usr/share/texmf-local
418    /usr/share/texmf-var
419    /usr/share/texmf-config
420)
421for dir in ${x[@]}; do
422    _trans_dir=${dir}.${_trans_time}.rpmorig
423    [ -d ${_trans_dir}.old ] && \
424        echo -n "  " && \
425        echo "Found ${_trans_dir}.old: " && \
426        echo -n "    " && \
427        %__rm -rvf ${_trans_dir}.old
428    [ -d ${_trans_dir} ] && \
429        echo -n "  " && \
430        echo "Found ${_trans_dir}: " && \
431        echo -n "    " && \
432        %__mv -v ${_trans_dir} ${_trans_dir}.old
433    [ -d ${dir} ] && \
434        echo -n "  " && \
435        echo "Found ${dir}: " && \
436        echo -n "    " && \
437        %__mv -v ${dir} ${_trans_dir}
438done
439echo "done."
440
441%postun
442if [ "$1" = 0 ]; then
443    %__rm -rf %{_tl_vartexfonts}
444fi
445exit 0
446
447%post
448%_tl_touch_run texhash
449%_tl_touch_run updmap
450%_tl_touch_run mtxrun
451%_tl_touch_run fmtutil
452exit 0
453
454%posttrans
455%__mkdir_p %{_tl_vartexfonts}
456%__chmod 1777 %{_tl_vartexfonts}
457
458## create our map files {ptex,uptex,otf,otf-up}-vine.map
459( %{_tl_exec_upddeffont} ) ||:
460
461%{_tl_exec_texhash}
462%{_tl_exec_mtxrun}
463%{_tl_exec_updmap}
464%{_tl_exec_fmtutil}
465exit 0
466
467%post -n libkpathsea
468/sbin/ldconfig
469# for x in kpathsea tds web2c; do
470#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
471# done
472
473# %preun -n libkpathsea
474# if [ "$1" = 0 ]; then
475#     for x in kpathsea tds web2c; do
476#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
477#     done
478# fi
479
480%postun -n libkpathsea
481/sbin/ldconfig
482
483%post -n libptexenc
484/sbin/ldconfig
485
486%postun -n libptexenc
487/sbin/ldconfig
488
489%triggerin -- ghostscript
490%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
491if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
492    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
493elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
494    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
495fi
496%_tl_touch_run texhash
497exit 0
498
499
500%files -f %{_builddir}/filelist.full
501%defattr(-,root,root)
502%{_libdir}/libtexlua52.so.*
503%{_libdir}/libtexluajit.so.*
504%dir %{_tl_aliasttfdir}
505%attr(1777,root,root) %dir %{_tl_vartexfonts}
506# %config %{_sysconfdir}/cron.daily/texlive.cron
507
508%files doc -f %{_builddir}/filelist.doc
509%defattr(-,root,root)
510
511%files -n libkpathsea
512%defattr(-,root,root)
513%{_libdir}/libkpathsea.so.*
514# %{_infodir}/kpathsea.info*
515
516%files -n libkpathsea-devel
517%defattr(-,root,root)
518%{_libdir}/libkpathsea.so
519%dir %{_includedir}/kpathsea
520%{_includedir}/kpathsea/*.h
521%{_libdir}/pkgconfig/kpathsea.pc
522
523%files -n libptexenc
524%defattr(-,root,root)
525%{_libdir}/libptexenc.so.*
526
527%files -n libptexenc-devel
528%defattr(-,root,root)
529%{_libdir}/libptexenc.so
530%dir %{_includedir}/ptexenc
531%{_includedir}/ptexenc/*.h
532%{_libdir}/pkgconfig/ptexenc.pc
533
534%files -n libsynctex
535%defattr(-,root,root)
536%{_libdir}/libsynctex.so.*
537
538%files -n libsynctex-devel
539%defattr(-,root,root)
540%{_libdir}/libsynctex.so
541%dir %{_includedir}/synctex
542%{_includedir}/synctex/*.h
543%{_libdir}/pkgconfig/synctex.pc
544
545
546%changelog
547* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
548- texlive-source-20150426 (TeX Live 2015/pretest)
549
550* Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
551- texlive-source-20141230 (TeX Live 2015/dev)
552
553* Thu Jul  3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
554- texlive-source-20140525 + tlptexlive 20140507
555- dropped texlive-20140524-vine.patch: built with libpng >= 1.6
556
557* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
558- upgrade to TeX Live 2014
559  - texlive-source-20140524 + tlptexlive 20140507
560
561* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
562- rebuild with poppler-0.24.5
563
564* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
565- rebuilt
566
567* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
568- texlive-source-20131101 2014/dev + tlptexlive 20130815
569- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
570
571* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
572- updated texlive-20131002-texmfcnf-vine.patch:
573  texmf.cnf (shell_escape_commands): added some programs
574
575* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
576- texlive-source-20131002 2014/dev + tlptexlive 20130815
577- defined %%global __find_requires find-requires-texlive.sh
578  - dropped unused dependencies of Requires
579
580* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
581- texlive-source-20130919 2014/dev + tlptexlive 20130815
582- correct some scripts of README.vine for each texmf trees
583
584* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
585- upgrade to TeX Live 2013
586  - texlive-source-20130823 2014/dev + tlptexlive 20130815
587- dropped Requires: jvf
588
589* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
590- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
591- fixed duplicated lw35 for updmap.pl
592- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
593
594* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
595- touch the map files generated by updmap-sys
596
597* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
598- fixed Source7: updmap.cfg.texlive-20120701
599  (upto /etc/texmf/web2c/updmap.cfg)
600- fixex %%triggerin -- ghostscript
601  - replaced %%exec_texhash with %%touch_run texhash
602
603* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
604- TeX Live 2012 + tlptexlive 20121107
605
606* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
607- drop BR: poppler-devel temporaly
608  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
609
610* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
611- build with poppler-0.18.4
612- remove tlmgr
613
614* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
615- updated to tl11supp-120120
616- run %%{exec_fmtutil} at %%post when upgrading
617
618* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
619- updated to tl11supp-111214
620
621* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
622- added BuildRequires: texlive-common
623  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
624  - check japanese.ldf
625- updated tl11supp-111120-vine.patch
626  - added the following options to $$TL_CONFIGURE_ARGS:
627    --disable-detex
628    --disable-dvipng
629    --disable-lcdf-typetools
630- remove some files of asymptote
631- remove a man file of latexmk
632- remove man files of lcdf-typetools
633- remove man files of dvipng
634- remove a man file of detex
635
636* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
637- added find-provides-texlive.sh and set it to %%__find_provides
638  - use to find library sonames for libkpathsea and libptexenc
639- added cmex.enc (%%{SOURCE110})
640  - do not install cmex.enc in our TDS, yet
641- removed some unused directories in texmf/fonts/map
642- removed man files of lcdf-typetools
643- moved texdoc{,tk} and its related files to texlive-doc
644
645* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
646- TeX Live 2011 + tl11supp-111120
647
648* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
649- make the directory VARTEXFONTS (%%posttrans)
650  - dropped %%triggerpostun -- texlive < 2009-17vl6
651
652* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
653- fixed ptexlive-20100711-dvipdfmx-vine.patch
654  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
655
656* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
657- added %%pre to avoid conflictions of texmf-{config,var}
658
659* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
660- dropped Requires: texlive-common
661- added perl-Tk-TableMatrix
662  - supported texdoctk
663- removed broken symbolic links in /usr/bin
664  - for each these symbolic links, the package of its real file/path
665    should be its owner.
666
667* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
668- added %%triggerpostun -- texlive < 2009-17vl6
669  - make the directory VARTEXFONTS
670
671* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
672- fixed %%dir VARTEXFONTS around in %%files
673- dropped BuildRequires: t1utils
674
675* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
676- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
677  - changed VARTEXFONTS to /var/lib/texmf/fonts
678
679* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
680- fixed updmap.cfg
681
682* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
683- dropped Requires: texlive-macros
684
685* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
686- updated ptexlive-20100711-pxdvik-vine.patch
687  and added texlive-20091107-xdvik-vine.patch
688  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
689
690* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
691- supported Vine Linux 5
692  - for vl5, changed a requirement of Japanese VF package
693    - added Requires: texlive-jvf = 2009 (vl5)
694- dropped dependencies of Provides:/Obsoletes: tags
695  - merged these dependencies in texlive-common-vl.spec
696
697* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
698- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
699
700* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
701- applied some security patches from Debian
702  - texlive-2009-CVE-2010-0827.patch
703  - texlive-2009-CVE-2010-1440.patch
704- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
705- applied texlive-2009-luatexdir-libpoppler-0.12.patch
706  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
707- fixed some dependencies
708
709* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
710- added BuildArch: noarch in %%package doc
711- removed some comment-out sentences
712
713* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
714- separeted texmf-dist to texlive-common package
715
716* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
717- unpacked texlive-20091107-source.tar.xz
718- babel is available now
719- applied eptex-100420 and some patches:
720  - eptex-100420-vine.patch
721  - eptex-100420-patch1.diff
722
723* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
724- updated ptexlive-20100711
725
726* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
727- customized updmap.cfg to correspond installed fonts
728
729* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
730- fixed insttexfont()
731
732* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
733- added jvf of MORISAWA basic 5 fonts
734- added cm-super, mathdesign in fntlst
735
736* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
737- define insttexfont() in %%install
738  - copy almost compatible tetex-3.0
739
740* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
741- ptexlive-20090322 + TeXLive 2009
742- added BuildRequires: openssl-devel
743
744* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
745- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.