source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 8771

Revision 8771, 24.3 KB checked in by Takemikaduchi, 10 years ago (diff)

poppler-0.26.2

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20140525
9%global tlptexlivesrcver   20140507
10
11Summary: The TeX text formatting system
12Summary(ja): TeX 文書整形システム
13Name: texlive
14Version: 2014
15Release: 3%{?_dist_release}
16License: distributable
17Group: Applications/Publishing
18URL: http://www.tug.org/texlive/
19
20## original TeX Live source
21Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
22## snapshot
23# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
24# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
25# Source: %{name}-source-%{texlivesrcver}.tar.xz
26
27## tlptexlive: pmetapost
28Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
29Source2: http://www.tug.org/texlive/updmap-kanji.html
30
31## our updmap{,-hdr}.cfg from collection-basic 20140524
32# NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
33Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
34Source7: updmap.cfg.texlive-%{texlivesrcver}
35
36## desktop files
37Source11: texdoctk.desktop
38
39Source98: find-requires-texlive.sh
40## find library sonames for libkpathsea and libptexenc
41Source99:  find-provides-texlive.sh
42
43######
44# TeX patches
45######
46
47## vine
48#Patch0:                reautoconf-parallel.diff
49#Patch1:                texlive-%{texlivesrcver}-vine.patch
50Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
51Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
52#Patch4:                texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
53#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
54
55## security
56
57Requires:    perl-Tk perl-Tk-TableMatrix
58Requires:    ghostscript >= 8.71
59Requires:    nkf
60Requires(post,postun): fontconfig
61Requires(post): ed mktemp
62Requires(post): vutils >= 7.1
63%{!?with_firstbuild:Requires: texlive-common = %{version}}
64BuildRequires: bison flex
65BuildRequires: bzip2-devel
66BuildRequires: zlib-devel
67BuildRequires: libpng-devel >= 1.6
68BuildRequires: gd-devel
69BuildRequires: ncurses-devel
70BuildRequires: libjpeg-devel
71BuildRequires: XOrg-devel
72BuildRequires: freetype2-devel >= 2.1.10
73BuildRequires: autoconf >= 2.68
74BuildRequires: openMotif-devel
75BuildRequires: poppler-devel >= 0.20
76BuildRequires: openssl-devel
77BuildRequires: fontconfig-devel
78# BuildRequires: libpaper-devel >= 1.1.24-2
79BuildRequires: nkf
80## needs to build pxdvi
81#BuildRequires: t1lib-devel
82
83BuildRequires: texlive-vtlpkg = %{version}
84
85Buildroot:    %{_tmppath}/%{name}-%{version}-root
86
87Vendor:       Project Vine
88Distribution: Vine Linux
89Packager:     munepi
90
91
92%description
93The TeX Live software distribution offers a complete TeX system for a
94variety of Unix, Macintosh, Windows and other platforms. It
95encompasses programs for editing, typesetting, previewing and printing
96of TeX documents in many different languages, and a large collection
97of TeX macros and font libraries.
98
99The distribution includes extensive general documentation about TeX,
100as well as the documentation for the included software packages.
101
102
103%description -l ja
104TeX Live ソフトウェアディストリビューションは、
105さまざまな Unix, Macintosh, Windows、および
106他のプラットホームに対して完全な TeX システムを提供します。
107多くの異なった言語を含む TeX ドキュメントの
108編集、組版、閲覧、印刷するためのプログラム、
109そして、TeX マクロやフォントライブラリの大きなコレクションを
110同梱しています。
111
112このディストリビューションは
113同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
114TeX に関するたくさんの一般的なドキュメントを含んでいます。
115
116
117%package doc
118Summary: TeX Live: Documentation files of %{name}
119Group: Applications/Publishing
120Requires: %{name} = %{version}-%{release}
121BuildArch: noarch
122
123%description doc
124This package contains documentation files of %{name}.
125
126%package -n libkpathsea
127Summary: path search library for the TeX Live
128Summary(ja): TeX Live 用パス検索ライブラリ
129Group: System Environment/Libraries
130
131%description -n libkpathsea
132This package includes runtime part of the Kpathsea library.
133
134
135%package -n libkpathsea-devel
136Summary: path search libary and header files for the TeX Live
137Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
138Group: Development/Libraries
139Requires: libkpathsea = %{version}-%{release}
140
141%description -n libkpathsea-devel
142This package includes static library and header files of the Kpathsea library.
143
144
145%package -n libptexenc
146Summary: Kanji code convert library for Japanese pTeX
147Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
148Group: System Environment/Libraries
149Requires: libkpathsea = %{version}-%{release}
150
151%description -n libptexenc
152This package includes runtime part of the ptexenc library.
153
154
155%package -n libptexenc-devel
156Summary: Kanji code convert library and header files for Japanese pTeX
157Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
158Group: Development/Libraries
159Requires: libptexenc = %{version}-%{release}
160
161%description -n libptexenc-devel
162This package includes header files of the ptexenc library.
163
164
165%prep
166[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
167
168%setup -q -n %{name}-%{texlivesrcver}-source -a 1
169# %setup -q -n %{name}-source-%{texlivesrcver} -a 1
170
171# %patch0 -p0 -b .parallel
172# %patch1 -p1 -b .vine
173%patch2 -p1 -b .vine
174%patch3 -p1 -b .vine
175# %patch4 -p1 -b .vine
176
177## Applying tlptexlive that provides pxdvi(k) and pmpost
178echo "applying patches"
179cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
180    echo $p | grep '^#' >/dev/null  || \
181    patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
182done
183
184## Avoid pollution from internal libraries.
185%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,paper,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
186# ./reautoconf || exit 1
187
188
189%build
190set -x
191unset TEXINPUTS || :
192unset HOME || :
193
194export CFLAGS="$RPM_OPT_FLAGS" \
195       CXXFLAGS="$RPM_OPT_FLAGS" \
196       LANG=C
197
198PREFIX=$(pwd)/work
199
200TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
201TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
202
203TL_CONFIGURE_ARGS=" \
204    --disable-multiplatform \
205    --disable-native-texlive-build \
206    --with-banner-add=\"/Vine Linux\" \
207    --enable-shared --disable-static \
208    --enable-compiler-warnings=max \
209    --without-cxx-runtime-hack \
210    \
211    --with-system-xpdf \
212    --with-system-gd \
213    --with-system-t1lib \
214    --with-system-libpng \
215    --with-system-zlib \
216    --with-system-freetype2 \
217    --with-system-pixman \
218    --with-system-poppler \
219    --with-system-cairo \
220    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
221    --with-pic \
222    \
223    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
224    --disable-dvi2tty \
225    --disable-t1utils --disable-psutils --disable-detex \
226    --disable-dvipng --disable-lcdf-typetools \
227"
228
229export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
230TL_MAKE=%__make ./Build || exit 1
231
232
233%install
234## prepare %%install session
235[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
236
237## copy inst directory to /usr
238%__mkdir_p %{buildroot}
239%__cp -a inst %{buildroot}%{_prefix} || exit 1
240%ifarch x86_64
241%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
242%endif
243
244## make some fundamental texmf trees
245%__mkdir_p %{buildroot}%{_tl_texmfvine}
246%__mkdir_p %{buildroot}%{_tl_texmfdist}
247%__mkdir_p %{buildroot}%{_tl_texmflocal}
248%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
249%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
250%__mkdir_p %{buildroot}%{_tl_vartexfonts}
251%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
252%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
253
254cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
255The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
256distribution wide.
257You must not do any changes in this directory.
258EOF
259
260cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
261The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
262You should not use this directory to manage any other packages because
263we Project Vine use this directory to manage non-CTAN packages, some
264enhancement packages and so on.
265EOF
266
267cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
268The directory %{_tl_texmflocal} is the texmf tree of the system wide.
269If you are a privileged user of this system,
270you can use this directory to manage your local packages.
271EOF
272
273## our texmf-dist/web2c/updmap{,-hdr}.cfg
274%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
275%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
276%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
277
278## our map files for dvipdfmx
279%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
280%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
281for x in ptex uptex otf otf-up; do
282    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
283done
284for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
285    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
286done
287
288## desktop things
289%__mkdir_p %{buildroot}%{_datadir}/applications
290# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
291%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
292
293# for created fonts
294%__mkdir_p %{buildroot}%{_tl_vartexfonts}
295# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
296# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
297
298## set executable bit for the library
299%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
300%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
301
302# configure ConTeXt
303for x in context luatools texexec texmfstart; do
304  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
305done
306
307# touch ghosts
308touch %{buildroot}%{_tl_texmfvine}/ls-R
309touch %{buildroot}%{_tl_texmfdist}/ls-R
310touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
311touch %{buildroot}%{_tl_texmfsysvar}/ls-R
312
313%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
314%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
315%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
316%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
317touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
318touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
319touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
320touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
321touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
322touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
323touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
324touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
325touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
326touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
327touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
328
329
330## remove unpackaging files
331find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
332find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
333%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
334find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
335find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
336%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
337%__rm -f %{buildroot}%{_infodir}/*
338
339## use external packages
340%__rm %{buildroot}/usr/bin/latexmk || exit 1
341
342
343### Files list
344find %{buildroot} -type f -or -type l | \
345    %__sed -e "s|%{buildroot}||g" | \
346    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
347    %__grep -v "%{_includedir}" | \
348    %__grep -v "%{_libdir}" | \
349    %__grep -v "%{_infodir}" | \
350    %__sed -e "s|.*ls-R$|%ghost &|" \
351           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
352           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
353           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
354           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
355           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
356           -e "s|.*\.cnf$|%config(noreplace) &|" \
357           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
358           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
359           -e "s|^.*/updmap/$|%config &|" \
360           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
361           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
362           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
363           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
364           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
365           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
366           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
367           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
368           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
369           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
370           -e "s|%{_mandir}/.*|&*|" \
371        > %{_builddir}/filelist.full
372
373find %{buildroot}%{_tl_texmfvine}* -type d | \
374    %__sed -e "s|^%{buildroot}|%dir |" \
375           -e "s|$|/|" >> %{_builddir}/filelist.full
376
377## subpackages
378%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
379cat %{_builddir}/filelist.doc \
380    %{_builddir}/filelist.full | \
381    sort | uniq -u > %{_builddir}/filelist.tmp
382%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
383
384
385%clean
386%__rm -rf %{buildroot}
387
388
389%pretrans
390rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013
391[ $? -eq 1 ] && exit 0
392_trans_time=$(date +%Y%m%d)
393echo "Running some transitional processes on your TeX system ... "
394x=(
395    /usr/share/texmf-local
396    /usr/share/texmf-var
397    /usr/share/texmf-config
398)
399for dir in ${x[@]}; do
400    _trans_dir=${dir}.${_trans_time}.rpmorig
401    [ -d ${_trans_dir}.old ] && \
402        echo -n "  " && \
403        echo "Found ${_trans_dir}.old: " && \
404        echo -n "    " && \
405        %__rm -rvf ${_trans_dir}.old
406    [ -d ${_trans_dir} ] && \
407        echo -n "  " && \
408        echo "Found ${_trans_dir}: " && \
409        echo -n "    " && \
410        %__mv -v ${_trans_dir} ${_trans_dir}.old
411    [ -d ${dir} ] && \
412        echo -n "  " && \
413        echo "Found ${dir}: " && \
414        echo -n "    " && \
415        %__mv -v ${dir} ${_trans_dir}
416done
417echo "done."
418
419%postun
420if [ "$1" = 0 ]; then
421    %__rm -rf %{_tl_vartexfonts}
422fi
423exit 0
424
425%post
426%_tl_touch_run texhash
427%_tl_touch_run updmap
428%_tl_touch_run mtxrun
429%_tl_touch_run fmtutil
430exit 0
431
432%posttrans
433%__mkdir_p %{_tl_vartexfonts}
434%__chmod 1777 %{_tl_vartexfonts}
435
436## create our map files {ptex,uptex,otf,otf-up}-vine.map
437( %{_tl_exec_upddeffont} ) ||:
438
439%{_tl_exec_texhash}
440%{_tl_exec_mtxrun}
441%{_tl_exec_updmap}
442%{_tl_exec_fmtutil}
443exit 0
444
445%post -n libkpathsea
446/sbin/ldconfig
447# for x in kpathsea tds web2c; do
448#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
449# done
450
451# %preun -n libkpathsea
452# if [ "$1" = 0 ]; then
453#     for x in kpathsea tds web2c; do
454#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
455#     done
456# fi
457
458%postun -n libkpathsea
459/sbin/ldconfig
460
461%post -n libptexenc
462/sbin/ldconfig
463
464%postun -n libptexenc
465/sbin/ldconfig
466
467%triggerin -- ghostscript
468%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
469if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
470    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
471elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
472    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
473fi
474%_tl_touch_run texhash
475exit 0
476
477
478%files -f %{_builddir}/filelist.full
479%defattr(-,root,root)
480%dir %{_tl_aliasttfdir}
481%attr(1777,root,root) %dir %{_tl_vartexfonts}
482# %config %{_sysconfdir}/cron.daily/texlive.cron
483
484%files doc -f %{_builddir}/filelist.doc
485%defattr(-,root,root)
486
487%files -n libkpathsea
488%defattr(-,root,root)
489%{_libdir}/libkpathsea.so.*
490# %{_infodir}/kpathsea.info*
491
492%files -n libkpathsea-devel
493%defattr(-,root,root)
494%{_libdir}/libkpathsea.so
495%dir %{_includedir}/kpathsea
496%{_includedir}/kpathsea/*
497
498%files -n libptexenc
499%defattr(-,root,root)
500%{_libdir}/libptexenc.so.*
501
502%files -n libptexenc-devel
503%defattr(-,root,root)
504%{_libdir}/libptexenc.so
505%dir %{_includedir}/ptexenc
506%{_includedir}/ptexenc/*
507
508
509%changelog
510* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2014-3
511- rebuild with poppler-0.26.2
512
513* Thu Jul  3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
514- texlive-source-20140525 + tlptexlive 20140507
515- dropped texlive-20140524-vine.patch: built with libpng >= 1.6
516
517* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
518- upgrade to TeX Live 2014
519  - texlive-source-20140524 + tlptexlive 20140507
520
521* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
522- rebuild with poppler-0.24.5
523
524* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
525- rebuilt
526
527* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
528- texlive-source-20131101 2014/dev + tlptexlive 20130815
529- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
530
531* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
532- updated texlive-20131002-texmfcnf-vine.patch:
533  texmf.cnf (shell_escape_commands): added some programs
534
535* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
536- texlive-source-20131002 2014/dev + tlptexlive 20130815
537- defined %%global __find_requires find-requires-texlive.sh
538  - dropped unused dependencies of Requires
539
540* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
541- texlive-source-20130919 2014/dev + tlptexlive 20130815
542- correct some scripts of README.vine for each texmf trees
543
544* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
545- upgrade to TeX Live 2013
546  - texlive-source-20130823 2014/dev + tlptexlive 20130815
547- dropped Requires: jvf
548
549* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
550- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
551- fixed duplicated lw35 for updmap.pl
552- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
553
554* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
555- touch the map files generated by updmap-sys
556
557* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
558- fixed Source7: updmap.cfg.texlive-20120701
559  (upto /etc/texmf/web2c/updmap.cfg)
560- fixex %%triggerin -- ghostscript
561  - replaced %%exec_texhash with %%touch_run texhash
562
563* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
564- TeX Live 2012 + tlptexlive 20121107
565
566* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
567- drop BR: poppler-devel temporaly
568  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
569
570* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
571- build with poppler-0.18.4
572- remove tlmgr
573
574* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
575- updated to tl11supp-120120
576- run %%{exec_fmtutil} at %%post when upgrading
577
578* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
579- updated to tl11supp-111214
580
581* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
582- added BuildRequires: texlive-common
583  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
584  - check japanese.ldf
585- updated tl11supp-111120-vine.patch
586  - added the following options to $$TL_CONFIGURE_ARGS:
587    --disable-detex
588    --disable-dvipng
589    --disable-lcdf-typetools
590- remove some files of asymptote
591- remove a man file of latexmk
592- remove man files of lcdf-typetools
593- remove man files of dvipng
594- remove a man file of detex
595
596* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
597- added find-provides-texlive.sh and set it to %%__find_provides
598  - use to find library sonames for libkpathsea and libptexenc
599- added cmex.enc (%%{SOURCE110})
600  - do not install cmex.enc in our TDS, yet
601- removed some unused directories in texmf/fonts/map
602- removed man files of lcdf-typetools
603- moved texdoc{,tk} and its related files to texlive-doc
604
605* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
606- TeX Live 2011 + tl11supp-111120
607
608* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
609- make the directory VARTEXFONTS (%%posttrans)
610  - dropped %%triggerpostun -- texlive < 2009-17vl6
611
612* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
613- fixed ptexlive-20100711-dvipdfmx-vine.patch
614  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
615
616* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
617- added %%pre to avoid conflictions of texmf-{config,var}
618
619* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
620- dropped Requires: texlive-common
621- added perl-Tk-TableMatrix
622  - supported texdoctk
623- removed broken symbolic links in /usr/bin
624  - for each these symbolic links, the package of its real file/path
625    should be its owner.
626
627* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
628- added %%triggerpostun -- texlive < 2009-17vl6
629  - make the directory VARTEXFONTS
630
631* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
632- fixed %%dir VARTEXFONTS around in %%files
633- dropped BuildRequires: t1utils
634
635* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
636- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
637  - changed VARTEXFONTS to /var/lib/texmf/fonts
638
639* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
640- fixed updmap.cfg
641
642* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
643- dropped Requires: texlive-macros
644
645* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
646- updated ptexlive-20100711-pxdvik-vine.patch
647  and added texlive-20091107-xdvik-vine.patch
648  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
649
650* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
651- supported Vine Linux 5
652  - for vl5, changed a requirement of Japanese VF package
653    - added Requires: texlive-jvf = 2009 (vl5)
654- dropped dependencies of Provides:/Obsoletes: tags
655  - merged these dependencies in texlive-common-vl.spec
656
657* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
658- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
659
660* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
661- applied some security patches from Debian
662  - texlive-2009-CVE-2010-0827.patch
663  - texlive-2009-CVE-2010-1440.patch
664- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
665- applied texlive-2009-luatexdir-libpoppler-0.12.patch
666  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
667- fixed some dependencies
668
669* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
670- added BuildArch: noarch in %%package doc
671- removed some comment-out sentences
672
673* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
674- separeted texmf-dist to texlive-common package
675
676* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
677- unpacked texlive-20091107-source.tar.xz
678- babel is available now
679- applied eptex-100420 and some patches:
680  - eptex-100420-vine.patch
681  - eptex-100420-patch1.diff
682
683* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
684- updated ptexlive-20100711
685
686* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
687- customized updmap.cfg to correspond installed fonts
688
689* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
690- fixed insttexfont()
691
692* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
693- added jvf of MORISAWA basic 5 fonts
694- added cm-super, mathdesign in fntlst
695
696* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
697- define insttexfont() in %%install
698  - copy almost compatible tetex-3.0
699
700* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
701- ptexlive-20090322 + TeXLive 2009
702- added BuildRequires: openssl-devel
703
704* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
705- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.