source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 8476

Revision 8476, 23.9 KB checked in by munepi, 10 years ago (diff)

TeX Live 2014

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20140524
9%global tlptexlivesrcver   20140507
10
11Summary: The TeX text formatting system
12Summary(ja): TeX 文書整形システム
13Name: texlive
14Version: 2014
15Release: 1%{?_dist_release}
16License: distributable
17Group: Applications/Publishing
18URL: http://www.tug.org/texlive/
19
20## original TeX Live source
21Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
22## snapshot
23# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
24# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
25# Source: %{name}-source-%{texlivesrcver}.tar.xz
26
27## tlptexlive: pmetapost
28Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
29Source2: http://www.tug.org/texlive/updmap-kanji.html
30
31## our updmap{,-hdr}.cfg from collection-basic 20130823
32# NOTE:
33# * texmf.cnf: we use the conf file texmf.cnf generated from Source0
34Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
35Source7: updmap.cfg.texlive-%{texlivesrcver}
36
37## desktop files
38Source11: texdoctk.desktop
39
40Source98: find-requires-texlive.sh
41## find library sonames for libkpathsea and libptexenc
42Source99:  find-provides-texlive.sh
43
44######
45# TeX patches
46######
47
48## vine
49Patch0:         reautoconf-parallel.diff
50Patch1:         texlive-%{texlivesrcver}-vine.patch
51Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
52Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
53#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
54
55## security
56
57Requires:    perl-Tk perl-Tk-TableMatrix
58Requires:    ghostscript >= 8.71
59Requires:    nkf
60Requires(post,postun): fontconfig
61Requires(post): ed mktemp
62Requires(post): vutils >= 7.1
63%{!?with_firstbuild:Requires: texlive-common = %{version}}
64BuildRequires: bison flex
65BuildRequires: bzip2-devel
66BuildRequires: zlib-devel
67BuildRequires: libpng-devel
68BuildRequires: gd-devel
69BuildRequires: ncurses-devel
70BuildRequires: libjpeg-devel
71BuildRequires: XOrg-devel
72BuildRequires: freetype2-devel >= 2.1.10
73BuildRequires: autoconf >= 2.68
74BuildRequires: openMotif-devel
75BuildRequires: poppler-devel >= 0.20
76BuildRequires: openssl-devel
77BuildRequires: fontconfig-devel
78# BuildRequires: libpaper-devel >= 1.1.24-2
79BuildRequires: nkf
80## needs to build pxdvi
81#BuildRequires: t1lib-devel
82
83BuildRequires: texlive-vtlpkg = %{version}
84
85Buildroot:    %{_tmppath}/%{name}-%{version}-root
86
87Vendor:       Project Vine
88Distribution: Vine Linux
89Packager:     munepi
90
91
92%description
93The TeX Live software distribution offers a complete TeX system for a
94variety of Unix, Macintosh, Windows and other platforms. It
95encompasses programs for editing, typesetting, previewing and printing
96of TeX documents in many different languages, and a large collection
97of TeX macros and font libraries.
98
99The distribution includes extensive general documentation about TeX,
100as well as the documentation for the included software packages.
101
102
103%description -l ja
104TeX Live ソフトウェアディストリビューションは、
105さまざまな Unix, Macintosh, Windows、および
106他のプラットホームに対して完全な TeX システムを提供します。
107多くの異なった言語を含む TeX ドキュメントの
108編集、組版、閲覧、印刷するためのプログラム、
109そして、TeX マクロやフォントライブラリの大きなコレクションを
110同梱しています。
111
112このディストリビューションは
113同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
114TeX に関するたくさんの一般的なドキュメントを含んでいます。
115
116
117%package doc
118Summary: TeX Live: Documentation files of %{name}
119Group: Applications/Publishing
120Requires: %{name} = %{version}-%{release}
121BuildArch: noarch
122
123%description doc
124This package contains documentation files of %{name}.
125
126%package -n libkpathsea
127Summary: path search library for the TeX Live
128Summary(ja): TeX Live 用パス検索ライブラリ
129Group: System Environment/Libraries
130
131%description -n libkpathsea
132This package includes runtime part of the Kpathsea library.
133
134
135%package -n libkpathsea-devel
136Summary: path search libary and header files for the TeX Live
137Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
138Group: Development/Libraries
139Requires: libkpathsea = %{version}-%{release}
140
141%description -n libkpathsea-devel
142This package includes static library and header files of the Kpathsea library.
143
144
145%package -n libptexenc
146Summary: Kanji code convert library for Japanese pTeX
147Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
148Group: System Environment/Libraries
149Requires: libkpathsea = %{version}-%{release}
150
151%description -n libptexenc
152This package includes runtime part of the ptexenc library.
153
154
155%package -n libptexenc-devel
156Summary: Kanji code convert library and header files for Japanese pTeX
157Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
158Group: Development/Libraries
159Requires: libptexenc = %{version}-%{release}
160
161%description -n libptexenc-devel
162This package includes header files of the ptexenc library.
163
164
165%prep
166[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
167
168%setup -q -n %{name}-%{texlivesrcver}-source -a 1
169# %setup -q -n %{name}-source-%{texlivesrcver} -a 1
170
171%patch0 -p0 -b .parallel
172%patch1 -p1 -b .vine
173%patch2 -p1 -b .vine
174%patch3 -p1 -b .vine
175
176## Applying tlptexlive that provides pxdvi(k) and pmpost
177echo "applying patches"
178cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
179    echo $p | grep '^#' >/dev/null  || \
180    patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
181done
182
183## Avoid pollution from internal libraries.
184%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,paper,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
185# ./reautoconf || exit 1
186
187
188%build
189set -x
190unset TEXINPUTS || :
191unset HOME || :
192
193export CFLAGS="$RPM_OPT_FLAGS" \
194       CXXFLAGS="$RPM_OPT_FLAGS" \
195       LANG=C
196
197PREFIX=$(pwd)/work
198
199TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
200TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
201
202TL_CONFIGURE_ARGS=" \
203    --disable-multiplatform \
204    --disable-native-texlive-build \
205    --with-banner-add=\"/Vine Linux\" \
206    --enable-shared --disable-static \
207    --enable-compiler-warnings=max \
208    --without-cxx-runtime-hack \
209    \
210    --with-system-xpdf \
211    --with-system-gd \
212    --with-system-t1lib \
213    --with-system-libpng \
214    --with-system-zlib \
215    --with-system-freetype2 \
216    --with-system-pixman \
217    --with-system-poppler \
218    --with-system-cairo \
219    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
220    --with-pic \
221    \
222    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
223    --disable-dvi2tty \
224    --disable-t1utils --disable-psutils --disable-detex \
225    --disable-dvipng --disable-lcdf-typetools \
226"
227
228export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
229TL_MAKE=%__make ./Build || exit 1
230
231
232%install
233## prepare %%install session
234[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
235
236## copy inst directory to /usr
237%__mkdir_p %{buildroot}
238%__cp -a inst %{buildroot}%{_prefix} || exit 1
239%ifarch x86_64
240%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
241%endif
242
243## make some fundamental texmf trees
244%__mkdir_p %{buildroot}%{_tl_texmfvine}
245%__mkdir_p %{buildroot}%{_tl_texmfdist}
246%__mkdir_p %{buildroot}%{_tl_texmflocal}
247%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
248%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
249%__mkdir_p %{buildroot}%{_tl_vartexfonts}
250%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
251%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
252
253cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
254The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
255distribution wide.
256You must not do any changes in this directory.
257EOF
258
259cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
260The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
261You should not use this directory to manage any other packages because
262we Project Vine use this directory to manage non-CTAN packages, some
263enhancement packages and so on.
264EOF
265
266cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
267The directory %{_tl_texmflocal} is the texmf tree of the system wide.
268If you are a privileged user of this system,
269you can use this directory to manage your local packages.
270EOF
271
272## our texmf-dist/web2c/updmap{,-hdr}.cfg
273%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
274%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
275%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
276
277## our map files for dvipdfmx
278%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
279%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
280for x in ptex uptex otf otf-up; do
281    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
282done
283for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
284    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
285done
286
287## desktop things
288%__mkdir_p %{buildroot}%{_datadir}/applications
289# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
290%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
291
292# for created fonts
293%__mkdir_p %{buildroot}%{_tl_vartexfonts}
294# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
295# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
296
297## set executable bit for the library
298%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
299%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
300
301# configure ConTeXt
302for x in context luatools texexec texmfstart; do
303  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
304done
305
306# touch ghosts
307touch %{buildroot}%{_tl_texmfvine}/ls-R
308touch %{buildroot}%{_tl_texmfdist}/ls-R
309touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
310touch %{buildroot}%{_tl_texmfsysvar}/ls-R
311
312%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
313%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
314%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
315%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
316touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
317touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
318touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
319touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
320touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
321touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
322touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
323touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
324touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
325touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
326touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
327
328
329## remove unpackaging files
330find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
331find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
332%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
333find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
334find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
335%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
336%__rm -f %{buildroot}%{_infodir}/*
337
338## use external packages
339%__rm %{buildroot}/usr/bin/latexmk || exit 1
340
341
342### Files list
343find %{buildroot} -type f -or -type l | \
344    %__sed -e "s|%{buildroot}||g" | \
345    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
346    %__grep -v "%{_includedir}" | \
347    %__grep -v "%{_libdir}" | \
348    %__grep -v "%{_infodir}" | \
349    %__sed -e "s|.*ls-R$|%ghost &|" \
350           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
351           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
352           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
353           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
354           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
355           -e "s|.*\.cnf$|%config(noreplace) &|" \
356           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
357           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
358           -e "s|^.*/updmap/$|%config &|" \
359           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
360           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
361           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
362           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
363           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
364           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
365           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
366           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
367           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
368           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
369           -e "s|%{_mandir}/.*|&*|" \
370        > %{_builddir}/filelist.full
371
372find %{buildroot}%{_tl_texmfvine}* -type d | \
373    %__sed -e "s|^%{buildroot}|%dir |" \
374           -e "s|$|/|" >> %{_builddir}/filelist.full
375
376## subpackages
377%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
378cat %{_builddir}/filelist.doc \
379    %{_builddir}/filelist.full | \
380    sort | uniq -u > %{_builddir}/filelist.tmp
381%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
382
383
384%clean
385%__rm -rf %{buildroot}
386
387
388%pretrans
389rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013
390[ $? -eq 1 ] && exit 0
391_trans_time=$(date +%Y%m%d)
392echo "Running some transitional processes on your TeX system ... "
393x=(
394    /usr/share/texmf-local
395    /usr/share/texmf-var
396    /usr/share/texmf-config
397)
398for dir in ${x[@]}; do
399    _trans_dir=${dir}.${_trans_time}.rpmorig
400    [ -d ${_trans_dir}.old ] && \
401        echo -n "  " && \
402        echo "Found ${_trans_dir}.old: " && \
403        echo -n "    " && \
404        %__rm -rvf ${_trans_dir}.old
405    [ -d ${_trans_dir} ] && \
406        echo -n "  " && \
407        echo "Found ${_trans_dir}: " && \
408        echo -n "    " && \
409        %__mv -v ${_trans_dir} ${_trans_dir}.old
410    [ -d ${dir} ] && \
411        echo -n "  " && \
412        echo "Found ${dir}: " && \
413        echo -n "    " && \
414        %__mv -v ${dir} ${_trans_dir}
415done
416echo "done."
417
418%postun
419if [ "$1" = 0 ]; then
420    %__rm -rf %{_tl_vartexfonts}
421fi
422exit 0
423
424%post
425%_tl_touch_run texhash
426%_tl_touch_run updmap
427%_tl_touch_run mtxrun
428%_tl_touch_run fmtutil
429exit 0
430
431%posttrans
432%__mkdir_p %{_tl_vartexfonts}
433%__chmod 1777 %{_tl_vartexfonts}
434
435## create our map files {ptex,uptex,otf,otf-up}-vine.map
436( %{_tl_exec_upddeffont} ) ||:
437
438%{_tl_exec_texhash}
439%{_tl_exec_mtxrun}
440%{_tl_exec_updmap}
441%{_tl_exec_fmtutil}
442exit 0
443
444%post -n libkpathsea
445/sbin/ldconfig
446# for x in kpathsea tds web2c; do
447#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
448# done
449
450# %preun -n libkpathsea
451# if [ "$1" = 0 ]; then
452#     for x in kpathsea tds web2c; do
453#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
454#     done
455# fi
456
457%postun -n libkpathsea
458/sbin/ldconfig
459
460%post -n libptexenc
461/sbin/ldconfig
462
463%postun -n libptexenc
464/sbin/ldconfig
465
466%triggerin -- ghostscript
467%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
468if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
469    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
470elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
471    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
472fi
473%_tl_touch_run texhash
474exit 0
475
476
477%files -f %{_builddir}/filelist.full
478%defattr(-,root,root)
479%dir %{_tl_aliasttfdir}
480%attr(1777,root,root) %dir %{_tl_vartexfonts}
481# %config %{_sysconfdir}/cron.daily/texlive.cron
482
483%files doc -f %{_builddir}/filelist.doc
484%defattr(-,root,root)
485
486%files -n libkpathsea
487%defattr(-,root,root)
488%{_libdir}/libkpathsea.so.*
489# %{_infodir}/kpathsea.info*
490
491%files -n libkpathsea-devel
492%defattr(-,root,root)
493%{_libdir}/libkpathsea.so
494%dir %{_includedir}/kpathsea
495%{_includedir}/kpathsea/*
496
497%files -n libptexenc
498%defattr(-,root,root)
499%{_libdir}/libptexenc.so.*
500
501%files -n libptexenc-devel
502%defattr(-,root,root)
503%{_libdir}/libptexenc.so
504%dir %{_includedir}/ptexenc
505%{_includedir}/ptexenc/*
506
507
508%changelog
509* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
510- upgrade to TeX Live 2014
511  - texlive-source-20140524 + tlptexlive 20140507
512
513* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
514- rebuild with poppler-0.24.5
515
516* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
517- rebuilt
518
519* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
520- texlive-source-20131101 2014/dev + tlptexlive 20130815
521- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
522
523* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
524- updated texlive-20131002-texmfcnf-vine.patch:
525  texmf.cnf (shell_escape_commands): added some programs
526
527* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
528- texlive-source-20131002 2014/dev + tlptexlive 20130815
529- defined %%global __find_requires find-requires-texlive.sh
530  - dropped unused dependencies of Requires
531
532* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
533- texlive-source-20130919 2014/dev + tlptexlive 20130815
534- correct some scripts of README.vine for each texmf trees
535
536* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
537- upgrade to TeX Live 2013
538  - texlive-source-20130823 2014/dev + tlptexlive 20130815
539- dropped Requires: jvf
540
541* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
542- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
543- fixed duplicated lw35 for updmap.pl
544- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
545
546* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
547- touch the map files generated by updmap-sys
548
549* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
550- fixed Source7: updmap.cfg.texlive-20120701
551  (upto /etc/texmf/web2c/updmap.cfg)
552- fixex %%triggerin -- ghostscript
553  - replaced %%exec_texhash with %%touch_run texhash
554
555* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
556- TeX Live 2012 + tlptexlive 20121107
557
558* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
559- drop BR: poppler-devel temporaly
560  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
561
562* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
563- build with poppler-0.18.4
564- remove tlmgr
565
566* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
567- updated to tl11supp-120120
568- run %%{exec_fmtutil} at %%post when upgrading
569
570* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
571- updated to tl11supp-111214
572
573* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
574- added BuildRequires: texlive-common
575  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
576  - check japanese.ldf
577- updated tl11supp-111120-vine.patch
578  - added the following options to $$TL_CONFIGURE_ARGS:
579    --disable-detex
580    --disable-dvipng
581    --disable-lcdf-typetools
582- remove some files of asymptote
583- remove a man file of latexmk
584- remove man files of lcdf-typetools
585- remove man files of dvipng
586- remove a man file of detex
587
588* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
589- added find-provides-texlive.sh and set it to %%__find_provides
590  - use to find library sonames for libkpathsea and libptexenc
591- added cmex.enc (%%{SOURCE110})
592  - do not install cmex.enc in our TDS, yet
593- removed some unused directories in texmf/fonts/map
594- removed man files of lcdf-typetools
595- moved texdoc{,tk} and its related files to texlive-doc
596
597* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
598- TeX Live 2011 + tl11supp-111120
599
600* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
601- make the directory VARTEXFONTS (%%posttrans)
602  - dropped %%triggerpostun -- texlive < 2009-17vl6
603
604* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
605- fixed ptexlive-20100711-dvipdfmx-vine.patch
606  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
607
608* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
609- added %%pre to avoid conflictions of texmf-{config,var}
610
611* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
612- dropped Requires: texlive-common
613- added perl-Tk-TableMatrix
614  - supported texdoctk
615- removed broken symbolic links in /usr/bin
616  - for each these symbolic links, the package of its real file/path
617    should be its owner.
618
619* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
620- added %%triggerpostun -- texlive < 2009-17vl6
621  - make the directory VARTEXFONTS
622
623* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
624- fixed %%dir VARTEXFONTS around in %%files
625- dropped BuildRequires: t1utils
626
627* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
628- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
629  - changed VARTEXFONTS to /var/lib/texmf/fonts
630
631* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
632- fixed updmap.cfg
633
634* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
635- dropped Requires: texlive-macros
636
637* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
638- updated ptexlive-20100711-pxdvik-vine.patch
639  and added texlive-20091107-xdvik-vine.patch
640  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
641
642* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
643- supported Vine Linux 5
644  - for vl5, changed a requirement of Japanese VF package
645    - added Requires: texlive-jvf = 2009 (vl5)
646- dropped dependencies of Provides:/Obsoletes: tags
647  - merged these dependencies in texlive-common-vl.spec
648
649* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
650- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
651
652* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
653- applied some security patches from Debian
654  - texlive-2009-CVE-2010-0827.patch
655  - texlive-2009-CVE-2010-1440.patch
656- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
657- applied texlive-2009-luatexdir-libpoppler-0.12.patch
658  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
659- fixed some dependencies
660
661* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
662- added BuildArch: noarch in %%package doc
663- removed some comment-out sentences
664
665* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
666- separeted texmf-dist to texlive-common package
667
668* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
669- unpacked texlive-20091107-source.tar.xz
670- babel is available now
671- applied eptex-100420 and some patches:
672  - eptex-100420-vine.patch
673  - eptex-100420-patch1.diff
674
675* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
676- updated ptexlive-20100711
677
678* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
679- customized updmap.cfg to correspond installed fonts
680
681* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
682- fixed insttexfont()
683
684* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
685- added jvf of MORISAWA basic 5 fonts
686- added cm-super, mathdesign in fntlst
687
688* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
689- define insttexfont() in %%install
690  - copy almost compatible tetex-3.0
691
692* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
693- ptexlive-20090322 + TeXLive 2009
694- added BuildRequires: openssl-devel
695
696* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
697- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.