source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 7881

Revision 7881, 24.3 KB checked in by munepi, 11 years ago (diff)

updated texlive-20131002-texmfcnf-vine.patch: texmf.cnf (shell_escape_commands): added some programs

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20131002
9
10Summary: The TeX text formatting system
11Summary(ja): TeX 文書整形システム
12Name: texlive
13Version: 2013
14Release: 4%{?_dist_release}
15License: distributable
16Group: Applications/Publishing
17URL: http://www.tug.org/texlive/
18
19## original TeX Live source
20#Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
21## snapshot
22# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
23# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
24Source: %{name}-source-%{texlivesrcver}.tar.xz
25
26## tlptexlive: pmetapost
27Source1: http://www.preining.info/software/build-tlptexlive-20130815.zip
28Source2: http://www.tug.org/texlive/updmap-kanji.html
29
30## our updmap{,-hdr}.cfg from collection-basic 20130823
31# NOTE:
32# * texmf.cnf: we use the conf file texmf.cnf generated from Source0
33Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
34Source7: updmap.cfg.texlive-%{texlivesrcver}
35
36## desktop files
37# Source10: pxdvi.desktop
38Source11: texdoctk.desktop
39
40# ## pxdvi from tlptexlive 2012
41# Source50: texlive-source-xdvik-20130106.tar.xz
42# Source51: http://www.preining.info/software/build-tlptexlive-20130106.zip
43
44Source98: find-requires-texlive.sh
45## find library sonames for libkpathsea and libptexenc
46Source99:  find-provides-texlive.sh
47
48## etc...
49#Source100: texlive.cron
50
51
52######
53# TeX patches
54######
55
56## vine
57Patch0:         reautoconf-parallel.diff
58Patch1:         texlive-%{texlivesrcver}-vine.patch
59Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
60Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
61#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
62
63## security
64
65Requires:    perl-Tk perl-Tk-TableMatrix
66Requires:    ghostscript >= 8.71
67Requires:    nkf
68Requires(post,postun): fontconfig
69Requires(post): ed mktemp
70Requires(post): vutils >= 7.1
71%{!?with_firstbuild:Requires: texlive-common = %{version}}
72BuildRequires: bison flex
73BuildRequires: bzip2-devel
74BuildRequires: zlib-devel
75BuildRequires: libpng-devel
76BuildRequires: gd-devel
77BuildRequires: ncurses-devel
78BuildRequires: libjpeg-devel
79BuildRequires: XOrg-devel
80BuildRequires: freetype2-devel >= 2.1.10
81BuildRequires: autoconf >= 2.68
82BuildRequires: openMotif-devel
83BuildRequires: poppler-devel >= 0.20
84BuildRequires: openssl-devel
85BuildRequires: libpaper-devel
86BuildRequires: fontconfig-devel
87BuildRequires: nkf
88## needs to build pxdvi
89#BuildRequires: t1lib-devel
90
91BuildRequires: texlive-vtlpkg = %{version}
92
93Buildroot:    %{_tmppath}/%{name}-%{version}-root
94
95Vendor:       Project Vine
96Distribution: Vine Linux
97Packager:     munepi
98
99
100%description
101The TeX Live software distribution offers a complete TeX system for a
102variety of Unix, Macintosh, Windows and other platforms. It
103encompasses programs for editing, typesetting, previewing and printing
104of TeX documents in many different languages, and a large collection
105of TeX macros and font libraries.
106
107The distribution includes extensive general documentation about TeX,
108as well as the documentation for the included software packages.
109
110
111%description -l ja
112TeX Live ソフトウェアディストリビューションは、
113さまざまな Unix, Macintosh, Windows、および
114他のプラットホームに対して完全な TeX システムを提供します。
115多くの異なった言語を含む TeX ドキュメントの
116編集、組版、閲覧、印刷するためのプログラム、
117そして、TeX マクロやフォントライブラリの大きなコレクションを
118同梱しています。
119
120このディストリビューションは
121同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
122TeX に関するたくさんの一般的なドキュメントを含んでいます。
123
124
125%package doc
126Summary: TeX Live: Documentation files of %{name}
127Group: Applications/Publishing
128Requires: %{name} = %{version}-%{release}
129BuildArch: noarch
130
131%description doc
132This package contains documentation files of %{name}.
133
134%package -n libkpathsea
135Summary: path search library for the TeX Live
136Summary(ja): TeX Live 用パス検索ライブラリ
137Group: System Environment/Libraries
138
139%description -n libkpathsea
140This package includes runtime part of the Kpathsea library.
141
142
143%package -n libkpathsea-devel
144Summary: path search libary and header files for the TeX Live
145Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
146Group: Development/Libraries
147Requires: libkpathsea = %{version}-%{release}
148
149%description -n libkpathsea-devel
150This package includes static library and header files of the Kpathsea library.
151
152
153%package -n libptexenc
154Summary: Kanji code convert library for Japanese pTeX
155Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
156Group: System Environment/Libraries
157Requires: libkpathsea = %{version}-%{release}
158
159%description -n libptexenc
160This package includes runtime part of the ptexenc library.
161
162
163%package -n libptexenc-devel
164Summary: Kanji code convert library and header files for Japanese pTeX
165Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
166Group: Development/Libraries
167Requires: libptexenc = %{version}-%{release}
168
169%description -n libptexenc-devel
170This package includes header files of the ptexenc library.
171
172
173%prep
174[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
175
176#%setup -q -n %{name}-%{texlivesrcver}-source
177%setup -q -n %{name}-source-%{texlivesrcver} -a 1
178
179%patch0 -p0 -b .parallel
180%patch1 -p1 -b .vine
181%patch2 -p1 -b .vine
182%patch3 -p1 -b .vine
183
184## Applying tlptexlive that provides pxdvi(k) and pmpost
185echo "applying patches"
186cat "$(pwd)/build-tlptexlive-20130815/patches/series" | while read p r ; do
187    echo $p | grep '^#' >/dev/null  || \
188    patch -p1 $r < "$(pwd)/build-tlptexlive-20130815/patches/$p" || exit 1
189done
190
191# ## pxdvi from tlptexlive 2012
192# echo "creating pxdvi folder"
193# [ -d texk/pxdvik ] && exit 1
194# %__cp -pR texlive-source-20130106/texk/xdvik texk/pxdvik
195# echo "applying patches"
196# cat "$(pwd)/build-tlptexlive-20130106/patches/series" | \
197#     grep -v -e freetype-modules -e pmpost -e reautoconf | while read p r ; do
198#         echo $p | grep '^#' >/dev/null || \
199#       patch -p1 $r < "$(pwd)/build-tlptexlive-20130106/patches/$p" || exit 1
200# done
201#
202# # customize pxdvik for Vine Linux
203# %patch10 -p1 -b .vine
204
205
206## Avoid pollution from internal libraries.
207%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
208# ./reautoconf || exit 1
209
210
211%build
212set -x
213unset TEXINPUTS || :
214unset HOME || :
215
216export CFLAGS="$RPM_OPT_FLAGS" \
217       CXXFLAGS="$RPM_OPT_FLAGS" \
218       LANG=C
219
220PREFIX=$(pwd)/work
221
222TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
223TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
224
225TL_CONFIGURE_ARGS=" \
226    --disable-multiplatform \
227    --disable-native-texlive-build \
228    --with-banner-add=\"/Vine Linux\" \
229    --enable-shared --disable-static \
230    --enable-compiler-warnings=max \
231    --without-cxx-runtime-hack \
232    \
233    --enable-web2c \
234    --enable-web-progs --enable-dvipdfmx --enable-mendexk \
235    --enable-makejvf --enable-pxdvik --enable-dvipsk \
236    --enable-tetex --enable-texlive \
237    \
238    --with-system-xpdf \
239    --with-system-gd \
240    --with-system-t1lib \
241    --with-system-libpng \
242    --with-system-zlib \
243    --with-system-freetype2 \
244    --with-system-pixman \
245    --with-system-poppler \
246    --with-system-cairo \
247    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
248    --with-pic \
249    \
250    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
251    --disable-dvi2tty \
252    --disable-t1utils --disable-psutils --disable-detex \
253    --disable-dvipng --disable-lcdf-typetools \
254"
255
256export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
257TL_MAKE=%__make ./Build || exit 1
258
259
260%install
261## prepare %%install session
262[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
263
264## copy inst directory to /usr
265%__mkdir_p %{buildroot}
266%__cp -a inst %{buildroot}%{_prefix} || exit 1
267%ifarch x86_64
268%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
269%endif
270
271## make some fundamental texmf trees
272%__mkdir_p %{buildroot}%{_tl_texmfvine}
273%__mkdir_p %{buildroot}%{_tl_texmfdist}
274%__mkdir_p %{buildroot}%{_tl_texmflocal}
275%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
276%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
277%__mkdir_p %{buildroot}%{_tl_vartexfonts}
278%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
279%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
280
281cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
282The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
283distribution wide.
284You must not do any changes in this directory.
285EOF
286
287cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
288The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
289You should not use this directory to manage any other packages because
290we Project Vine use this directory to manage non-CTAN packages, some
291enhancement packages and so on.
292EOF
293
294cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
295The directory %{_tl_texmflocal} is the texmf tree of the system wide.
296If you are a privileged user of this system,
297you can use this directory to manage your local packages.
298EOF
299
300## our texmf-dist/web2c/updmap{,-hdr}.cfg
301%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
302%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
303%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
304
305## our map files for dvipdfmx
306%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
307%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
308for x in ptex uptex otf otf-up; do
309    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
310done
311for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
312    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
313done
314
315## desktop things
316%__mkdir_p %{buildroot}%{_datadir}/applications
317# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
318%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
319
320# for created fonts
321%__mkdir_p %{buildroot}%{_tl_vartexfonts}
322# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
323# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
324
325## set executable bit for the library
326%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
327%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
328
329# configure ConTeXt
330for x in context ctxtools luatools texexec texmfstart; do
331  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
332done
333
334# touch ghosts
335touch %{buildroot}%{_tl_texmfvine}/ls-R
336touch %{buildroot}%{_tl_texmfdist}/ls-R
337touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
338touch %{buildroot}%{_tl_texmfsysvar}/ls-R
339
340%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
341%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
342%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
343%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
344touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
345touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
346touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
347touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
348touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
350touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
351touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
352touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
353touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
354touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
355
356
357## remove unpackaging files
358find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
359find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
360%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
361find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
362find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
363%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
364%__rm -f %{buildroot}%{_infodir}/*
365
366## use external packages
367%__rm %{buildroot}/usr/bin/latexmk || exit 1
368
369
370### Files list
371find %{buildroot} -type f -or -type l | \
372    %__sed -e "s|%{buildroot}||g" | \
373    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
374    %__grep -v "%{_includedir}" | \
375    %__grep -v "%{_libdir}" | \
376    %__grep -v "%{_infodir}" | \
377    %__sed -e "s|.*ls-R$|%ghost &|" \
378           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
379           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
380           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
381           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
382           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
383           -e "s|.*\.cnf$|%config(noreplace) &|" \
384           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
385           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
386           -e "s|^.*/updmap/$|%config &|" \
387           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
388           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
389           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
390           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
391           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
392           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
393           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
394           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
395           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
396           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
397           -e "s|%{_mandir}/.*|&*|" \
398        > %{_builddir}/filelist.full
399
400find %{buildroot}%{_tl_texmfvine}* -type d | \
401    %__sed -e "s|^%{buildroot}|%dir |" \
402           -e "s|$|/|" >> %{_builddir}/filelist.full
403
404## subpackages
405%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
406cat %{_builddir}/filelist.doc \
407    %{_builddir}/filelist.full | \
408    sort | uniq -u > %{_builddir}/filelist.tmp
409%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
410
411
412%clean
413%__rm -rf %{buildroot}
414
415
416%pretrans
417rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012
418[ $? -eq 1 ] && exit 0
419_trans_time=$(date +%Y%m%d)
420echo "Running some transitional processes on your TeX system ... "
421x=(
422    #/var/lib/texmf
423    #/etc/texmf
424    /usr/share/texmf-local
425    /usr/share/texmf-var
426    /usr/share/texmf-config
427)
428for dir in ${x[@]}; do
429    _trans_dir=${dir}.${_trans_time}.rpmorig
430    [ -d ${_trans_dir}.old ] && \
431        echo -n "  " && \
432        echo "Found ${_trans_dir}.old: " && \
433        echo -n "    " && \
434        %__rm -rvf ${_trans_dir}.old
435    [ -d ${_trans_dir} ] && \
436        echo -n "  " && \
437        echo "Found ${_trans_dir}: " && \
438        echo -n "    " && \
439        %__mv -v ${_trans_dir} ${_trans_dir}.old
440    [ -d ${dir} ] && \
441        echo -n "  " && \
442        echo "Found ${dir}: " && \
443        echo -n "    " && \
444        %__mv -v ${dir} ${_trans_dir}
445done
446echo "done."
447
448%postun
449if [ "$1" = 0 ]; then
450    %__rm -rf %{_tl_vartexfonts}
451fi
452exit 0
453
454%post
455%_tl_touch_run texhash
456%_tl_touch_run updmap
457%_tl_touch_run mtxrun
458%_tl_touch_run fmtutil
459exit 0
460
461%posttrans
462%__mkdir_p %{_tl_vartexfonts}
463%__chmod 1777 %{_tl_vartexfonts}
464
465## create our map files {ptex,uptex,otf,otf-up}-vine.map
466( %{_tl_exec_upddeffont} ) ||:
467
468%{_tl_exec_texhash}
469%{_tl_exec_mtxrun}
470%{_tl_exec_updmap}
471%{_tl_exec_fmtutil}
472exit 0
473
474%post -n libkpathsea
475/sbin/ldconfig
476# for x in kpathsea tds web2c; do
477#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
478# done
479
480# %preun -n libkpathsea
481# if [ "$1" = 0 ]; then
482#     for x in kpathsea tds web2c; do
483#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
484#     done
485# fi
486
487%postun -n libkpathsea
488/sbin/ldconfig
489
490%post -n libptexenc
491/sbin/ldconfig
492
493%postun -n libptexenc
494/sbin/ldconfig
495
496%triggerin -- ghostscript
497%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
498if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
499    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
500elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
501    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
502fi
503%_tl_touch_run texhash
504exit 0
505
506
507%files -f %{_builddir}/filelist.full
508%defattr(-,root,root)
509%dir %{_tl_aliasttfdir}
510%attr(1777,root,root) %dir %{_tl_vartexfonts}
511# %config %{_sysconfdir}/cron.daily/texlive.cron
512
513%files doc -f %{_builddir}/filelist.doc
514%defattr(-,root,root)
515
516%files -n libkpathsea
517%defattr(-,root,root)
518%{_libdir}/libkpathsea.so.*
519# %{_infodir}/kpathsea.info*
520
521%files -n libkpathsea-devel
522%defattr(-,root,root)
523%{_libdir}/libkpathsea.so
524%dir %{_includedir}/kpathsea
525%{_includedir}/kpathsea/*
526
527%files -n libptexenc
528%defattr(-,root,root)
529%{_libdir}/libptexenc.so.*
530
531%files -n libptexenc-devel
532%defattr(-,root,root)
533%{_libdir}/libptexenc.so
534%dir %{_includedir}/ptexenc
535%{_includedir}/ptexenc/*
536
537
538%changelog
539* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
540- updated texlive-20131002-texmfcnf-vine.patch:
541  texmf.cnf (shell_escape_commands): added some programs
542
543* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
544- texlive-source-20131002 2014/dev + tlptexlive 20130815
545- defined %%global __find_requires find-requires-texlive.sh
546  - dropped unused dependencies of Requires
547
548* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
549- texlive-source-20130919 2014/dev + tlptexlive 20130815
550- correct some scripts of README.vine for each texmf trees
551
552* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
553- upgrade to TeX Live 2013
554  - texlive-source-20130823 2014/dev + tlptexlive 20130815
555- dropped Requires: jvf
556
557* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
558- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
559- fixed duplicated lw35 for updmap.pl
560- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
561
562* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
563- touch the map files generated by updmap-sys
564
565* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
566- fixed Source7: updmap.cfg.texlive-20120701
567  (upto /etc/texmf/web2c/updmap.cfg)
568- fixex %%triggerin -- ghostscript
569  - replaced %%exec_texhash with %%touch_run texhash
570
571* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
572- TeX Live 2012 + tlptexlive 20121107
573
574* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
575- drop BR: poppler-devel temporaly
576  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
577
578* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
579- build with poppler-0.18.4
580- remove tlmgr
581
582* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
583- updated to tl11supp-120120
584- run %%{exec_fmtutil} at %%post when upgrading
585
586* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
587- updated to tl11supp-111214
588
589* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
590- added BuildRequires: texlive-common
591  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
592  - check japanese.ldf
593- updated tl11supp-111120-vine.patch
594  - added the following options to $$TL_CONFIGURE_ARGS:
595    --disable-detex
596    --disable-dvipng
597    --disable-lcdf-typetools
598- remove some files of asymptote
599- remove a man file of latexmk
600- remove man files of lcdf-typetools
601- remove man files of dvipng
602- remove a man file of detex
603
604* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
605- added find-provides-texlive.sh and set it to %%__find_provides
606  - use to find library sonames for libkpathsea and libptexenc
607- added cmex.enc (%%{SOURCE110})
608  - do not install cmex.enc in our TDS, yet
609- removed some unused directories in texmf/fonts/map
610- removed man files of lcdf-typetools
611- moved texdoc{,tk} and its related files to texlive-doc
612
613* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
614- TeX Live 2011 + tl11supp-111120
615
616* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
617- make the directory VARTEXFONTS (%%posttrans)
618  - dropped %%triggerpostun -- texlive < 2009-17vl6
619
620* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
621- fixed ptexlive-20100711-dvipdfmx-vine.patch
622  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
623
624* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
625- added %%pre to avoid conflictions of texmf-{config,var}
626
627* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
628- dropped Requires: texlive-common
629- added perl-Tk-TableMatrix
630  - supported texdoctk
631- removed broken symbolic links in /usr/bin
632  - for each these symbolic links, the package of its real file/path
633    should be its owner.
634
635* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
636- added %%triggerpostun -- texlive < 2009-17vl6
637  - make the directory VARTEXFONTS
638
639* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
640- fixed %%dir VARTEXFONTS around in %%files
641- dropped BuildRequires: t1utils
642
643* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
644- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
645  - changed VARTEXFONTS to /var/lib/texmf/fonts
646
647* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
648- fixed updmap.cfg
649
650* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
651- dropped Requires: texlive-macros
652
653* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
654- updated ptexlive-20100711-pxdvik-vine.patch
655  and added texlive-20091107-xdvik-vine.patch
656  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
657
658* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
659- supported Vine Linux 5
660  - for vl5, changed a requirement of Japanese VF package
661    - added Requires: texlive-jvf = 2009 (vl5)
662- dropped dependencies of Provides:/Obsoletes: tags
663  - merged these dependencies in texlive-common-vl.spec
664
665* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
666- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
667
668* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
669- applied some security patches from Debian
670  - texlive-2009-CVE-2010-0827.patch
671  - texlive-2009-CVE-2010-1440.patch
672- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
673- applied texlive-2009-luatexdir-libpoppler-0.12.patch
674  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
675- fixed some dependencies
676
677* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
678- added BuildArch: noarch in %%package doc
679- removed some comment-out sentences
680
681* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
682- separeted texmf-dist to texlive-common package
683
684* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
685- unpacked texlive-20091107-source.tar.xz
686- babel is available now
687- applied eptex-100420 and some patches:
688  - eptex-100420-vine.patch
689  - eptex-100420-patch1.diff
690
691* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
692- updated ptexlive-20100711
693
694* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
695- customized updmap.cfg to correspond installed fonts
696
697* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
698- fixed insttexfont()
699
700* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
701- added jvf of MORISAWA basic 5 fonts
702- added cm-super, mathdesign in fntlst
703
704* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
705- define insttexfont() in %%install
706  - copy almost compatible tetex-3.0
707
708* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
709- ptexlive-20090322 + TeXLive 2009
710- added BuildRequires: openssl-devel
711
712* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
713- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.