source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 6253

Revision 6253, 31.6 KB checked in by munepi, 12 years ago (diff)

build with poppler

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%define enable_sharedlib 1
5%if %{?_dist_release} == "vl6"
6%define enable_sharedlib 0
7%endif
8
9%global _use_internal_dependency_generator 0
10%global __find_provides %{SOURCE99}
11%global __find_requires %{nil}
12
13%define tl11suppver     120120
14%define texlivesrcver   20110705
15%define texlivever      20110705
16
17%define tl11supp_all_opts               -m -r
18%define tl11supp_source_common_sh       cd ${RPM_BUILD_DIR}/%{name}-%{version}/tl11; . ./common.sh %{tl11supp_all_opts}; set -x;
19
20%define tex_destdir     %{_datadir}
21%define texmf           %{tex_destdir}/texmf
22%define texlive_src     %{tex_destdir}/texlive-sources
23%define build_tex_destdir       %{buildroot}%{tex_destdir}
24%define build_texmf     %{buildroot}%{texmf}
25
26%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
27%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
28%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
29%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
30%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
31%define vartexfonts %{_var}/lib/texmf/fonts
32
33Summary: The TeX text formatting system
34Summary(ja): TeX 文書整形システム
35Name: texlive
36Version: 2011
37Release: 6%{?_dist_release}
38License: distributable
39Group: Applications/Publishing
40URL: http://www.tug.org/texlive/
41
42Source: http://sourceforge.jp/projects/eptex/wiki/TeX_Live_2011/attach/tl11supp-%{tl11suppver}.tar.xz
43
44Source5: updmap-hdr.cfg.texlive-%{texlivesrcver}
45Source6: updmap.cfg.texlive-%{texlivesrcver}
46Source9: __usr_bin_symlink.sh
47
48## desktop files
49Source10: pxdvi.desktop
50Source11: texdoctk.desktop
51
52## find library sonames for libkpathsea and libptexenc
53Source99: find-provides-texlive.sh
54
55## etc...
56Source100: texlive.cron
57Source102: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
58Source110: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
59
60
61######
62# TeX patches
63######
64
65## vine
66Patch0:         tl11supp-%{tl11suppver}-vine.patch
67Patch1:         texlive-%{texlivesrcver}-vine.patch
68Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
69Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
70## pxdvi(k) for Vine Linux
71Patch10:        tl11supp-%{tl11suppver}-pxdvik-vine.patch
72
73## dvipdfmx
74# Patch20:      ptexlive-%{ptexlivever}-dvipdfmx-vine.patch
75
76## others
77
78## security
79
80Requires:    coreutils
81Requires:    ed mktemp
82Requires:    tmpwatch
83Requires:    zlib
84Requires:    libpng
85Requires:    gd
86Requires:    ncurses
87Requires:    libjpeg
88Requires:    t1lib
89Requires:    freetype2
90Requires:    openMotif
91Requires:    poppler >= 0.12
92Requires:    openssl
93Requires:    libpaper
94Requires:    fontconfig
95Requires:    perl-Tk perl-Tk-TableMatrix
96Requires:    nkf
97Requires:    ghostscript >= 8.63
98%if %{?_dist_release} == "vl7"
99Requires:    libkpathsea = %{version}-%{release}
100Requires:    libptexenc = %{version}-%{release}
101%endif
102%if %{?_dist_release} == "vl7"
103%{!?with_firstbuild:Requires: jvf >= 7.0}
104%endif
105%if %{?_dist_release} == "vl6"
106%{!?with_firstbuild:Requires: texlive-jvf >= 7.0}
107%endif
108Requires:    fontconfig >= 2.6.0-2
109Requires(post,postun): fontconfig >= 2.6.0-2
110Requires(post): ed mktemp
111Requires(post): vutils >= 2.0.5
112%{!?with_firstbuild:BuildRequires: texlive-common = %{version}}
113BuildRequires: texlive-sources = %{version}
114BuildRequires: xz
115BuildRequires: unzip
116BuildRequires: bison flex
117BuildRequires: bzip2-devel
118BuildRequires: zlib-devel
119BuildRequires: libpng-devel
120BuildRequires: gd-devel
121BuildRequires: ncurses-devel
122BuildRequires: libjpeg-devel
123BuildRequires: t1lib-devel
124BuildRequires: XOrg-devel
125BuildRequires: freetype2-devel >= 2.1.10
126BuildRequires: autoconf >= 2.68
127BuildRequires: openMotif-devel
128BuildRequires: poppler-devel >= 0.12
129BuildRequires: openssl-devel
130BuildRequires: libpaper-devel
131BuildRequires: fontconfig-devel
132BuildRequires: nkf
133
134Buildroot:    %{_tmppath}/%{name}-%{version}-root
135
136Vendor:       Project Vine
137Distribution: Vine Linux
138Packager:     munepi
139
140
141%description
142The TeX Live software distribution offers a complete TeX system for a
143variety of Unix, Macintosh, Windows and other platforms. It
144encompasses programs for editing, typesetting, previewing and printing
145of TeX documents in many different languages, and a large collection
146of TeX macros and font libraries.
147
148The distribution includes extensive general documentation about TeX,
149as well as the documentation for the included software packages.
150
151
152%description -l ja
153TeX Live ソフトウェアディストリビューションは、
154さまざまな Unix, Macintosh, Windows、および
155他のプラットホームに対して完全な TeX システムを提供します。
156多くの異なった言語を含む TeX ドキュメントの
157編集、組版、閲覧、印刷するためのプログラム、
158そして、TeX マクロやフォントライブラリの大きなコレクションを
159同梱しています。
160
161このディストリビューションは
162同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
163TeX に関するたくさんの一般的なドキュメントを含んでいます。
164
165
166%package doc
167Summary: TeX Live: Documentation files of %{name}
168Group: Applications/Publishing
169Requires: %{name} = %{version}-%{release}
170BuildArch: noarch
171
172%description doc
173This package contains documentation files of %{name}.
174
175%if %{enable_sharedlib}
176%package -n libkpathsea
177Summary: path search library for the TeX Live
178Summary(ja): TeX Live 用パス検索ライブラリ
179Group: System Environment/Libraries
180
181%description -n libkpathsea
182This package includes runtime part of the Kpathsea library.
183
184
185%package -n libkpathsea-devel
186Summary: path search libary and header files for the TeX Live
187Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
188Group: Development/Libraries
189Requires: libkpathsea = %{version}-%{release}
190
191%description -n libkpathsea-devel
192This package includes static library and header files of the Kpathsea library.
193
194
195%package -n libptexenc
196Summary: Kanji code convert library for Japanese pTeX
197Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
198Group: System Environment/Libraries
199Requires: libkpathsea = %{version}-%{release}
200
201%description -n libptexenc
202This package includes runtime part of the ptexenc library.
203
204
205%package -n libptexenc-devel
206Summary: Kanji code convert library and header files for Japanese pTeX
207Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
208Group: Development/Libraries
209Requires: libptexenc = %{version}-%{release}
210
211%description -n libptexenc-devel
212This package includes header files of the ptexenc library.
213%endif
214
215
216%prep
217[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
218
219%setup -q -c %{name}-%{version}
220
221##
222[ -f %{texlive_src}/source/texlive-%{texlivesrcver}-source.tar.xz ] && \
223  %__ln_s -f %{texlive_src}/source/texlive-%{texlivesrcver}-source.tar.xz tl11/
224
225## apply tl11supp
226%patch0 -p1 -b .vine
227%__chmod +x tl11/scripts/build-post.sh || exit 1
228
229## fix $TLSRCDIR
230%__sed -i -e "s,TLSRCDIR=/opt/home-supp/tl11,TLSRCDIR=%{_builddir}/%{name}-%{version}/tl11," %{_builddir}/%{name}-%{version}/tl11/common.sh || exit 1
231
232## exec scripts/unpack.sh
233%{tl11supp_source_common_sh}
234
235scripts/unpack.sh %{tl11supp_all_opts} || exit 1
236
237## some hacks for Vine Linux
238(cd ../
239## vine
240%patch1 -p1 -b .vine
241%patch2 -p1 -b .vine
242%patch3 -p1 -b .vine
243%patch10 -p1 -b .vine
244)
245
246# ## dvipdfmx for Vine Linux
247# %patch20 -p1 -b .orig
248# )
249
250## apply security patches
251
252
253%build
254set -x
255unset TEXINPUTS || :
256unset HOME || :
257%{tl11supp_source_common_sh}
258
259## exec scripts/build.sh
260export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
261       CXXFLAGS="$RPM_OPT_FLAGS" \
262       LANG=C
263
264scripts/build.sh %{tl11supp_all_opts} || exit 1
265
266
267%install
268## prepare %%install session
269[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
270
271set -x
272unset TEXINPUTS || :
273unset HOME || :
274%{tl11supp_source_common_sh}
275
276## The following lines are useful for the call of
277## "rpmbuild -ba --short-circuit ~/rpm/SPECS/texlive-vl.spec"
278%__rm -rf ${SRCDIR}/inst
279(cd ${SRCDIR}/Work
280%__make world
281)
282
283## exec scripts/build-post.sh (Vine Linux only)
284scripts/build-post.sh %{tl11supp_all_opts} || exit 1
285[ -d $SRCDIR/inst/texmf.orig ] && %__rm -rf $SRCDIR/inst/texmf.orig || exit 1
286
287## almostly exec scripts/texmf.sh
288scripts/texmf.sh %{tl11supp_all_opts} || exit 1
289
290## almostly exec scripts/font.sh
291yes N | scripts/font.sh %{tl11supp_all_opts} || exit 1
292
293## replace updmap{,-hdr}.cfg with our updmap{,-hdr}.cfg respectively
294%__cp -af %{SOURCE5} $SRCDIR/inst/texmf/web2c/updmap-hdr.cfg || exit 1
295%__cp -af %{SOURCE6} $SRCDIR/inst/texmf/web2c/updmap.cfg || exit 1
296
297## almostly exec scripts/install.sh
298%__mkdir_p %{build_tex_destdir}
299(cd $SRCDIR/inst && tar cf - *) \
300    | (cd %{build_tex_destdir} && tar xf -) || exit  1
301
302## check japanese.ldf (Babel for Japanese)
303%if %{without firstbuild}
304[ -f %{build_texmf}/tex/platex/japanese/japanese.ldf ] || exit 1
305[ -f %{build_texmf}/tex/platex/japanese/ptex.log ] || exit 1
306[ -f %{build_texmf}/tex/platex/japanese/texput.log ] && exit 1
307%endif
308
309## remove the symbolic link texmf-dist@
310[ -L %{build_tex_destdir}/texmf-dist ] && \
311  %__rm -f %{build_tex_destdir}/texmf-dist || exit 1
312## remove lcdf-typetools-for-tex-live directory
313#%__rm -r %{build_tex_destdir}/lcdf-typetools-for-tex-live || exit 1
314## remove unused directories in texmf/fonts/map
315%__rm -rf %{build_texmf}/fonts/map/dvips/updmap || exit 1
316%__rm -rf %{build_texmf}/fonts/map/pdftex/updmap || exit 1
317
318## move bin, lib include, man, info to /usr, resp.
319%__rm -f %{build_tex_destdir}/bin/man || exit 1
320%__mv %{build_tex_destdir}/bin %{buildroot}%{_bindir} || exit 1
321%__mv %{build_tex_destdir}/lib %{buildroot}%{_libdir} || exit 1
322%__mv %{build_tex_destdir}/include %{buildroot}%{_includedir} || exit 1
323%__cp -ar %{build_texmf}/doc/man %{buildroot}%{_mandir} || exit 1
324#%__mv %{build_texmf}/doc/info %{buildroot}%{_infodir} || exit 1
325
326## move dvipdfmx/newmap/{ptex,otf} to dvipdfmx/{ptex,otf}, resp.
327%__mv %{build_texmf}/fonts/map/dvipdfmx/newmap/* %{build_texmf}/fonts/map/dvipdfmx/ || exit 1
328%__rm -rf %{build_texmf}/fonts/map/dvipdfmx/newmap
329
330## make some fundamental texmf trees
331%__mkdir_p %{build_texmf}-{config,var,local,dist}
332%__mkdir_p %{build_texmf}/fonts/{truetype,opentype}
333
334texmf_local_dirs=(
335  bibtex/bib/local
336  bibtex/bst/local
337  dvips/local
338  fonts/source/local
339  fonts/tfm/local
340  fonts/opentype/local
341  fonts/truetype/local
342  fonts/type1/local
343  fonts/vf/local
344  metapost/local
345  pbibtex/bib/local
346  pbibtex/bst/local
347  tex/latex/local
348  tex/plain/local
349  tex/platex/local
350  web2c
351)
352for i in ${texmf_local_dirs[@]}; do
353    %__mkdir_p %{build_texmf}-local/${i}
354done
355
356## remove tlmgr
357%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
358
359## copy texmf-dist/README
360%__cp -a %{texlive_src}/texmf-dist/README %{build_texmf}-dist/ || exit 1
361
362## customize updmap.cfg
363%__sed -i -e "s,^\(Map\|MixedMap\),#! \1,g" %{build_texmf}/web2c/updmap.cfg
364
365## dvipdfmx: our map file
366%__mkdir_p %{build_texmf}/fonts/map/dvipdfmx
367touch %{build_texmf}/fonts/map/dvipdfmx/vine.map
368
369## install jtygm.sty
370%__mkdir_p %{build_texmf}/tex/platex/base/
371%__install -m0644 %{SOURCE102} %{build_texmf}/tex/platex/base/ || exit 1
372
373## relocate binaries to %{_bindir} and fix relative symlinks
374pushd %{buildroot}%{_bindir}
375for i in `find . -type l`; do
376if [ "`readlink $i | grep '..' | wc -l`" == "1" ]; then
377l=`readlink $i | sed s,../,../share/,`
378%__ln_s -f $l $i
379fi
380done
381## if the real file of a symlink on /usr/bin is contained
382## in texlive-collection-*, remove its symlink
383## See __usr_bin_symlink.sh
384del_symlnks=(
385texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
386texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
387texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
388texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
389texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
390texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
391texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
392texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
393texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
394texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
395texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
396texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
397texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
398texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
399texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
400texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
401texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
402texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
403texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
404texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
405texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
406texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
407texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
408texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
409texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
410texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
411texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
412texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
413texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
414texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
415texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
416texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
417texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
418texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
419texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
420texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
421texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
422texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
423texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
424texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
425texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
426texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
427texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
428texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
429texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
430texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
431texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
432texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
433texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
434texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
435texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
436texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
437texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
438texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
439texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
440texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
441texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
442texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
443texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
444texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
445texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
446texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
447texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
448texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
449texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
450texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
451texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
452texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
453texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
454texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
455texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
456texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
457texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
458texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
459texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
460texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
461texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
462texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
463texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
464texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
465texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
466texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
467)
468for i in ${del_symlnks[@]}; do
469    %__rm -f %{buildroot}$(echo $i | cut -f 2 -d",") || exit 1
470done
471
472## remove man files of psutils
473%__rm \
474  %{buildroot}%{_mandir}/man1/epsffit.1 \
475  %{buildroot}%{_mandir}/man1/extractres.1 \
476  %{buildroot}%{_mandir}/man1/fixdlsrps.1 \
477  %{buildroot}%{_mandir}/man1/fixfmps.1 \
478  %{buildroot}%{_mandir}/man1/fixpsditps.1 \
479  %{buildroot}%{_mandir}/man1/fixpspps.1 \
480  %{buildroot}%{_mandir}/man1/fixscribeps.1 \
481  %{buildroot}%{_mandir}/man1/fixtpps.1 \
482  %{buildroot}%{_mandir}/man1/fixwfwps.1 \
483  %{buildroot}%{_mandir}/man1/fixwpps.1 \
484  %{buildroot}%{_mandir}/man1/fixwwps.1 \
485  %{buildroot}%{_mandir}/man1/getafm.1 \
486  %{buildroot}%{_mandir}/man1/includeres.1 \
487  %{buildroot}%{_mandir}/man1/psbook.1 \
488  %{buildroot}%{_mandir}/man1/psmerge.1 \
489  %{buildroot}%{_mandir}/man1/psnup.1 \
490  %{buildroot}%{_mandir}/man1/psresize.1 \
491  %{buildroot}%{_mandir}/man1/psselect.1 \
492  %{buildroot}%{_mandir}/man1/pstops.1 \
493  || exit 1
494## remove man files of lcdf-typetools
495%__rm \
496  %{buildroot}%{_mandir}/man1/cfftot1.1 \
497  %{buildroot}%{_mandir}/man1/mmafm.1 \
498  %{buildroot}%{_mandir}/man1/mmpfb.1 \
499  %{buildroot}%{_mandir}/man1/otfinfo.1 \
500  %{buildroot}%{_mandir}/man1/otftotfm.1 \
501  %{buildroot}%{_mandir}/man1/t1dotlessj.1 \
502  %{buildroot}%{_mandir}/man1/t1lint.1 \
503  %{buildroot}%{_mandir}/man1/t1rawafm.1 \
504  %{buildroot}%{_mandir}/man1/t1reencode.1 \
505  %{buildroot}%{_mandir}/man1/t1testpage.1 \
506  %{buildroot}%{_mandir}/man1/ttftotype42.1 \
507  || exit 1
508## remove man files of dvipng
509%__rm \
510  %{buildroot}%{_mandir}/man1/dvigif.1 \
511  %{buildroot}%{_mandir}/man1/dvipng.1 \
512  || exit 1
513## remove some files of asymptote
514%__rm \
515  %{buildroot}%{_mandir}/man1/asy.1 \
516  %{buildroot}%{_mandir}/man1/xasy.1 \
517  %{build_texmf}/tex/latex/asymptote/asymptote.sty \
518  %{build_texmf}/tex/latex/asymptote/ocg.sty \
519  || exit 1
520## remove a man file of latexmk
521%__rm \
522  %{buildroot}%{_mandir}/man1/latexmk.1 \
523  || exit 1
524## remove a man file of detex
525%__rm \
526  %{buildroot}%{_mandir}/man1/detex.1 \
527  || exit 1
528
529# remove unpackaged files
530find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
531find %{buildroot}%{_datadir} -name ls-R -exec %__rm -f {} \;
532find %{buildroot}%{_mandir} -name Makefile -exec %__rm -f {} \;
533find %{buildroot}%{_mandir} -name *.pdf -exec %__rm -f {} \;
534
535
536# ## compress info files
537# %__rm -f %{buildroot}%{_infodir}/dir
538# %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
539
540## desktop things
541%__mkdir_p %{buildroot}%{_datadir}/applications
542%__install -m0644 -c %{SOURCE10} %{SOURCE11} \
543    %{buildroot}%{_datadir}/applications/
544
545# for created fonts
546%__mkdir_p %{buildroot}%{vartexfonts}
547%__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
548%__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
549
550## set executable bit for the library
551%if %{enable_sharedlib}
552%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
553%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
554%endif
555
556## remove unpackaging files
557find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f
558find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f
559
560### Files list
561find %{buildroot} -type f -or -type l | \
562    %__sed -e "s|%{buildroot}||g" | \
563    %__grep -v -e "^%{_sysconfdir}" -e ".patch$" -e "\.diff$" -e "\.orig$" | \
564    %__grep -v "%{_includedir}" | \
565    %__grep -v "%{_libdir}" | \
566    %__grep -v "%{_infodir}" | \
567    %__sed -e "s|.*\.\(cnf\|cfg\)$|%config(noreplace) &|" \
568           -e "s|.*ls-R$|%ghost &|" \
569           -e "s|^.*/updmap$|%config &|" \
570           -e "s|%{texmf}*/dvips/config/\(psfonts.*\|ps2pk.*\|pdftex.*\|dvipdfm.*\|.*35\)\.map$|%ghost &|" \
571           -e "s|%{texmf}*/web2c/.*\.\(fmt\|efmt\|log\|base\|mem\|oft\)$|%config &|" \
572           -e "s|%{texmf}*/dvips/config/config\.\(generic\|pdf\|ps\|www\)$|%config &|" \
573           -e "s|%{texmf}*/tex/generic/config/.*|%config &|" \
574           -e "s|%{texmf}*/pdftex/config/pdftex.cfg$|%config &|" \
575           -e "s|%{texmf}*/xdvi/vfontmap$|%config &|" \
576           -e "s|%{texmf}*/xdvi/XDvi|%config &|" \
577           -e "s|%{_mandir}/.*|&*|" \
578        > %{_builddir}/%{name}-%{version}/filelist.full
579
580find %{buildroot}%{texmf}* -type d | \
581    %__sed -e "s|^%{buildroot}|%dir |" \
582           -e "s|$|/|" >> %{_builddir}/%{name}-%{version}/filelist.full
583
584## subpackages
585%__grep -e "/texmf/doc/" -e "/texdoc" %{_builddir}/%{name}-%{version}/filelist.full > %{_builddir}/%{name}-%{version}/filelist.doc
586cat %{_builddir}/%{name}-%{version}/filelist.doc \
587    %{_builddir}/%{name}-%{version}/filelist.full | \
588    sort | uniq -u > %{_builddir}/%{name}-%{version}/filelist.tmp
589%__mv -f %{_builddir}/%{name}-%{version}/filelist.tmp %{_builddir}/%{name}-%{version}/filelist.full
590
591
592%clean
593%__rm -rf %{buildroot}
594
595
596%pretrans
597rpm -q texlive | grep -q 2009
598[ $? -eq 1 ] && exit 0
599## upgrade TeX Live from 2009 to 2011
600_trans_time=$(date +%Y%m%d)
601echo "Running transitional process of your TeX system ... "
602for dir in %{texmf}-var %{texmf}-config; do
603    _trans_dir=${dir}.${_trans_time}.rpmorig
604    [ -d ${_trans_dir}.old ] && \
605        echo -n "  " && \
606        echo "Found ${_trans_dir}.old: " && \
607        echo -n "    " && \
608        %__rm -rvf ${_trans_dir}.old
609    [ -d ${_trans_dir} ] && \
610        echo -n "  " && \
611        echo "Found ${_trans_dir}: " && \
612        echo -n "    " && \
613        %__mv -v ${_trans_dir} ${_trans_dir}.old
614    [ -d ${dir} ] && \
615        echo -n "  " && \
616        echo "Found ${dir}: " && \
617        echo -n "    " && \
618        %__mv -v ${dir} ${_trans_dir}
619done
620echo "done."
621
622
623%post
624## create our own vine.map (cid-x.map) to use dvipdfmx
625( %{exec_upddeffont} ) ||:
626
627%{exec_texhash}
628%{exec_updmap} --syncwithtrees --nomkmap &>/dev/null
629%{exec_updmap} --enable KanjiMap vine.map >/dev/null 2>&1
630if [ "$1" = 2 ]; then
631   %{exec_fmtutil} 2>&1
632fi
633exit 0
634
635%preun
636if [ "$1" = 0 ]; then
637    %__rm -rf %{vartexfonts}
638
639    ## dvipdfmx
640    for i in %{texmf}/fonts/truetype/*; do
641        if [ -L "$i" ]; then
642            %__rm -f "$i"
643        fi
644    done
645fi
646
647
648%if %{enable_sharedlib}
649%post -n libkpathsea
650/sbin/ldconfig
651# /sbin/install-info %{_infodir}/kpathsea.info.* %{_infodir}/dir
652
653%preun -n libkpathsea
654# if [ "$1" = 0 ]; then
655#     /sbin/install-info --delete %{_infodir}/kpathsea.info.* %{_infodir}/dir
656# fi
657
658%postun -n libkpathsea
659/sbin/ldconfig
660
661%post -n libptexenc
662/sbin/ldconfig
663
664%postun -n libptexenc
665/sbin/ldconfig
666%endif
667
668%posttrans
669%__mkdir_p %{vartexfonts}
670%__chmod 1777 %{vartexfonts}
671
672
673%triggerin -- ghostscript
674%__rm -f %{texmf}/fonts/cmap/ghostscript
675if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
676    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{texmf}/fonts/cmap/ghostscript
677elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
678    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{texmf}/fonts/cmap/ghostscript
679fi
680%{exec_texhash}
681
682
683%files -f %{_builddir}/%{name}-%{version}/filelist.full
684%defattr(-,root,root)
685%attr(1777,root,root) %dir %{vartexfonts}
686%config %{_sysconfdir}/cron.daily/texlive.cron
687
688%files doc -f %{_builddir}/%{name}-%{version}/filelist.doc
689%defattr(-,root,root)
690
691%if %{enable_sharedlib}
692%files -n libkpathsea
693%defattr(-,root,root)
694%{_libdir}/libkpathsea.so.*
695# %{_infodir}/kpathsea.info*
696
697%files -n libkpathsea-devel
698%defattr(-,root,root)
699%{_libdir}/libkpathsea.so
700%dir %{_includedir}/kpathsea
701%{_includedir}/kpathsea/*
702
703%files -n libptexenc
704%defattr(-,root,root)
705%{_libdir}/libptexenc.so.*
706
707%files -n libptexenc-devel
708%defattr(-,root,root)
709%{_libdir}/libptexenc.so
710%dir %{_includedir}/ptexenc
711%{_includedir}/ptexenc/*
712%endif
713
714
715%changelog
716* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
717- build with poppler-0.18.4
718- remove tlmgr
719
720* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
721- updated to tl11supp-120120
722- run %%{exec_fmtutil} at %%post when upgrading
723
724* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
725- updated to tl11supp-111214
726
727* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
728- added BuildRequires: texlive-common
729  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
730  - check japanese.ldf
731- updated tl11supp-111120-vine.patch
732  - added the following options to $$TL_CONFIGURE_ARGS:
733    --disable-detex
734    --disable-dvipng
735    --disable-lcdf-typetools
736- remove some files of asymptote
737- remove a man file of latexmk
738- remove man files of lcdf-typetools
739- remove man files of dvipng
740- remove a man file of detex
741
742* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
743- added find-provides-texlive.sh and set it to %%__find_provides
744  - use to find library sonames for libkpathsea and libptexenc
745- added cmex.enc (%%{SOURCE110})
746  - do not install cmex.enc in our TDS, yet
747- removed some unused directories in texmf/fonts/map
748- removed man files of lcdf-typetools
749- moved texdoc{,tk} and its related files to texlive-doc
750
751* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
752- TeX Live 2011 + tl11supp-111120
753
754* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
755- make the directory VARTEXFONTS (%%posttrans)
756  - dropped %%triggerpostun -- texlive < 2009-17vl6
757
758* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
759- fixed ptexlive-20100711-dvipdfmx-vine.patch
760  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
761
762* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
763- added %%pre to avoid conflictions of texmf-{config,var}
764
765* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
766- dropped Requires: texlive-common
767- added perl-Tk-TableMatrix
768  - supported texdoctk
769- removed broken symbolic links in /usr/bin
770  - for each these symbolic links, the package of its real file/path
771    should be its owner.
772
773* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
774- added %%triggerpostun -- texlive < 2009-17vl6
775  - make the directory VARTEXFONTS
776
777* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
778- fixed %%dir VARTEXFONTS around in %%files
779- dropped BuildRequires: t1utils
780
781* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
782- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
783  - changed VARTEXFONTS to /var/lib/texmf/fonts
784
785* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
786- fixed updmap.cfg
787
788* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
789- dropped Requires: texlive-macros
790
791* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
792- updated ptexlive-20100711-pxdvik-vine.patch
793  and added texlive-20091107-xdvik-vine.patch
794  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
795
796* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
797- supported Vine Linux 5
798  - for vl5, changed a requirement of Japanese VF package
799    - added Requires: texlive-jvf = 2009 (vl5)
800- dropped dependencies of Provides:/Obsoletes: tags
801  - merged these dependencies in texlive-common-vl.spec
802
803* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
804- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
805
806* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
807- applied some security patches from Debian
808  - texlive-2009-CVE-2010-0827.patch
809  - texlive-2009-CVE-2010-1440.patch
810- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
811- applied texlive-2009-luatexdir-libpoppler-0.12.patch
812  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
813- fixed some dependencies
814
815* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
816- added BuildArch: noarch in %%package doc
817- removed some comment-out sentences
818
819* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
820- separeted texmf-dist to texlive-common package
821
822* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
823- unpacked texlive-20091107-source.tar.xz
824- babel is available now
825- applied eptex-100420 and some patches:
826  - eptex-100420-vine.patch
827  - eptex-100420-patch1.diff
828
829* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
830- updated ptexlive-20100711
831
832* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
833- customized updmap.cfg to correspond installed fonts
834
835* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
836- fixed insttexfont()
837
838* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
839- added jvf of MORISAWA basic 5 fonts
840- added cm-super, mathdesign in fntlst
841
842* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
843- define insttexfont() in %%install
844  - copy almost compatible tetex-3.0
845
846* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
847- ptexlive-20090322 + TeXLive 2009
848- added BuildRequires: openssl-devel
849
850* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
851- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.