source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 5214

Revision 5214, 29.5 KB checked in by munepi, 13 years ago (diff)

updated texlive-vl.spec

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%define enable_sharedlib 1
5%if %{?_dist_release} == "vl6"
6%define enable_sharedlib 0
7%endif
8
9%global _use_internal_dependency_generator 0
10%global __find_provides %{SOURCE99}
11%global __find_requires %{nil}
12
13%define tl11suppver     111120
14%define texlivesrcver   20110705
15%define texlivever      20110705
16
17%define tl11supp_all_opts               -m -r
18%define tl11supp_source_common_sh       cd ${RPM_BUILD_DIR}/%{name}-%{version}/tl11; . ./common.sh %{tl11supp_all_opts}; set -x;
19
20%define tex_destdir     %{_datadir}
21%define texmf           %{tex_destdir}/texmf
22%define texlive_src     %{tex_destdir}/texlive-sources
23%define build_tex_destdir       %{buildroot}%{tex_destdir}
24%define build_texmf     %{buildroot}%{texmf}
25
26%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
27%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
28%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
29%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
30%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
31%define vartexfonts %{_var}/lib/texmf/fonts
32
33Summary: The TeX text formatting system
34Summary(ja): TeX 文書整形システム
35Name: texlive
36Version: 2011
37Release: 2%{?_dist_release}
38License: distributable
39Group: Applications/Publishing
40URL: http://www.tug.org/texlive/
41
42Source: http://sourceforge.jp/projects/eptex/wiki/TeX_Live_2011/attach/tl11supp-%{tl11suppver}.tar.xz
43
44Source5: updmap-hdr.cfg.texlive-%{texlivesrcver}
45Source6: updmap.cfg.texlive-%{texlivesrcver}
46Source9: __usr_bin_symlink.sh
47
48## desktop files
49Source10: pxdvi.desktop
50Source11: texdoctk.desktop
51
52## find library sonames for libkpathsea and libptexenc
53Source99: find-provides-texlive.sh
54
55## etc...
56Source100: texlive.cron
57Source102: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
58Source110: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
59
60
61######
62# TeX patches
63######
64
65## vine
66Patch0:         tl11supp-%{tl11suppver}-vine.patch
67Patch1:         texlive-%{texlivesrcver}-vine.patch
68Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
69Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
70## pxdvi(k) for Vine Linux
71Patch10:        tl11supp-%{tl11suppver}-pxdvik-vine.patch
72
73## dvipdfmx
74# Patch20:      ptexlive-%{ptexlivever}-dvipdfmx-vine.patch
75
76## others
77
78## security
79
80Requires:    coreutils
81Requires:    ed mktemp
82Requires:    tmpwatch
83Requires:    zlib
84Requires:    libpng
85Requires:    gd
86Requires:    ncurses
87Requires:    libjpeg
88Requires:    t1lib
89Requires:    freetype2
90Requires:    openMotif
91Requires:    poppler >= 0.12
92Requires:    openssl
93Requires:    libpaper
94Requires:    fontconfig
95Requires:    perl-Tk perl-Tk-TableMatrix
96Requires:    nkf
97Requires:    ghostscript >= 8.63
98%if %{?_dist_release} == "vl7"
99Requires:    libkpathsea = %{version}-%{release}
100Requires:    libptexenc = %{version}-%{release}
101%endif
102%if %{?_dist_release} == "vl7"
103%{!?with_firstbuild:Requires: jvf >= 7.0}
104%endif
105%if %{?_dist_release} == "vl6"
106%{!?with_firstbuild:Requires: texlive-jvf >= 7.0}
107%endif
108Requires:    fontconfig >= 2.6.0-2
109Requires(post,postun): fontconfig >= 2.6.0-2
110Requires(post): ed mktemp
111Requires(post): vutils >= 2.0.5
112#%{!?with_firstbuild:BuildRequires: texlive-common = %{version}}
113BuildRequires: texlive-sources = %{version}
114BuildRequires: xz
115BuildRequires: unzip
116BuildRequires: bison flex
117BuildRequires: bzip2-devel
118BuildRequires: zlib-devel
119BuildRequires: libpng-devel
120BuildRequires: gd-devel
121BuildRequires: ncurses-devel
122BuildRequires: libjpeg-devel
123BuildRequires: t1lib-devel
124BuildRequires: XOrg-devel
125BuildRequires: freetype2-devel >= 2.1.10
126BuildRequires: autoconf >= 2.68
127BuildRequires: openMotif-devel
128BuildRequires: poppler-devel >= 0.12
129BuildRequires: openssl-devel
130BuildRequires: libpaper-devel
131BuildRequires: fontconfig-devel
132BuildRequires: nkf
133
134Buildroot:    %{_tmppath}/%{name}-%{version}-root
135
136Vendor:       Project Vine
137Distribution: Vine Linux
138Packager:     munepi
139
140
141%description
142The TeX Live software distribution offers a complete TeX system for a
143variety of Unix, Macintosh, Windows and other platforms. It
144encompasses programs for editing, typesetting, previewing and printing
145of TeX documents in many different languages, and a large collection
146of TeX macros and font libraries.
147
148The distribution includes extensive general documentation about TeX,
149as well as the documentation for the included software packages.
150
151
152%description -l ja
153TeX Live ソフトウェアディストリビューションは、
154さまざまな Unix, Macintosh, Windows、および
155他のプラットホームに対して完全な TeX システムを提供します。
156多くの異なった言語を含む TeX ドキュメントの
157編集、組版、閲覧、印刷するためのプログラム、
158そして、TeX マクロやフォントライブラリの大きなコレクションを
159同梱しています。
160
161このディストリビューションは
162同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
163TeX に関するたくさんの一般的なドキュメントを含んでいます。
164
165
166%package doc
167Summary: TeX Live: Documentation files of %{name}
168Group: Applications/Publishing
169Requires: %{name} = %{version}-%{release}
170BuildArch: noarch
171
172%description doc
173This package contains documentation files of %{name}.
174
175%if %{enable_sharedlib}
176%package -n libkpathsea
177Summary: path search library for the TeX Live
178Summary(ja): TeX Live 用パス検索ライブラリ
179Group: System Environment/Libraries
180
181%description -n libkpathsea
182This package includes runtime part of the Kpathsea library.
183
184
185%package -n libkpathsea-devel
186Summary: path search libary and header files for the TeX Live
187Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
188Group: Development/Libraries
189Requires: libkpathsea = %{version}-%{release}
190
191%description -n libkpathsea-devel
192This package includes static library and header files of the Kpathsea library.
193
194
195%package -n libptexenc
196Summary: Kanji code convert library for Japanese pTeX
197Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
198Group: System Environment/Libraries
199Requires: libkpathsea = %{version}-%{release}
200
201%description -n libptexenc
202This package includes runtime part of the ptexenc library.
203
204
205%package -n libptexenc-devel
206Summary: Kanji code convert library and header files for Japanese pTeX
207Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
208Group: Development/Libraries
209Requires: libptexenc = %{version}-%{release}
210
211%description -n libptexenc-devel
212This package includes header files of the ptexenc library.
213%endif
214
215
216%prep
217[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
218
219%setup -q -c %{name}-%{version}
220
221##
222[ -f %{texlive_src}/source/texlive-%{texlivesrcver}-source.tar.xz ] && \
223  %__ln_s -f %{texlive_src}/source/texlive-%{texlivesrcver}-source.tar.xz tl11/
224
225## apply tl11supp
226%patch0 -p1 -b .vine
227%__chmod +x tl11/scripts/build-post.sh || exit 1
228
229## fix $TLSRCDIR
230%__sed -i -e "s,TLSRCDIR=/opt/home-supp/tl11,TLSRCDIR=%{_builddir}/%{name}-%{version}/tl11," %{_builddir}/%{name}-%{version}/tl11/common.sh || exit 1
231
232## exec scripts/unpack.sh
233%{tl11supp_source_common_sh}
234
235scripts/unpack.sh %{tl11supp_all_opts} || exit 1
236
237## some hacks for Vine Linux
238(cd ../
239## vine
240%patch1 -p1 -b .vine
241%patch2 -p1 -b .vine
242%patch3 -p1 -b .vine
243%patch10 -p1 -b .vine
244)
245
246# ## dvipdfmx for Vine Linux
247# %patch20 -p1 -b .orig
248# )
249
250## apply security patches
251
252
253%build
254set -x
255unset TEXINPUTS || :
256unset HOME || :
257%{tl11supp_source_common_sh}
258
259## exec scripts/build.sh
260export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
261       CXXFLAGS="$RPM_OPT_FLAGS" \
262       LANG=C
263
264scripts/build.sh %{tl11supp_all_opts} || exit 1
265
266
267%install
268## prepare %%install session
269[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
270
271set -x
272unset TEXINPUTS || :
273unset HOME || :
274%{tl11supp_source_common_sh}
275
276## The following lines are useful for the call of
277## "rpmbuild -ba --short-circuit ~/rpm/SPECS/texlive-vl.spec"
278%__rm -rf ${SRCDIR}/inst
279(cd ${SRCDIR}/Work
280%__make world
281)
282
283## exec scripts/build-post.sh (Vine Linux only)
284scripts/build-post.sh %{tl11supp_all_opts} || exit 1
285[ -d $SRCDIR/inst/texmf.orig ] && %__rm -rf $SRCDIR/inst/texmf.orig || exit 1
286
287## almostly exec scripts/texmf.sh
288scripts/texmf.sh %{tl11supp_all_opts} || exit 1
289
290## almostly exec scripts/font.sh
291yes N | scripts/font.sh %{tl11supp_all_opts} || exit 1
292
293## replace updmap{,-hdr}.cfg with our updmap{,-hdr}.cfg respectively
294%__cp -af %{SOURCE5} $SRCDIR/inst/texmf/web2c/updmap-hdr.cfg || exit 1
295%__cp -af %{SOURCE6} $SRCDIR/inst/texmf/web2c/updmap.cfg || exit 1
296
297## almostly exec scripts/install.sh
298%__mkdir_p %{build_tex_destdir}
299(cd $SRCDIR/inst && tar cf - *) \
300    | (cd %{build_tex_destdir} && tar xf -) || exit  1
301
302## remove the symbolic link texmf-dist@
303[ -L %{build_tex_destdir}/texmf-dist ] && \
304  %__rm -f %{build_tex_destdir}/texmf-dist || exit 1
305## remove lcdf-typetools-for-tex-live directory
306%__rm -r %{build_tex_destdir}/lcdf-typetools-for-tex-live || exit 1
307## remove unused directories in texmf/fonts/map
308%__rm -rf %{build_texmf}/fonts/map/dvips/updmap || exit 1
309%__rm -rf %{build_texmf}/fonts/map/pdftex/updmap || exit 1
310
311## move bin, lib include, man, info to /usr, resp.
312%__rm -f %{build_tex_destdir}/bin/man || exit 1
313%__mv %{build_tex_destdir}/bin %{buildroot}%{_bindir} || exit 1
314%__mv %{build_tex_destdir}/lib %{buildroot}%{_libdir} || exit 1
315%__mv %{build_tex_destdir}/include %{buildroot}%{_includedir} || exit 1
316%__cp -ar %{build_texmf}/doc/man %{buildroot}%{_mandir} || exit 1
317#%__mv %{build_texmf}/doc/info %{buildroot}%{_infodir} || exit 1
318
319## move dvipdfmx/newmap/{ptex,otf} to dvipdfmx/{ptex,otf}, resp.
320%__mv %{build_texmf}/fonts/map/dvipdfmx/newmap/* %{build_texmf}/fonts/map/dvipdfmx/ || exit 1
321%__rm -rf %{build_texmf}/fonts/map/dvipdfmx/newmap
322
323## make some fundamental texmf trees
324%__mkdir_p %{build_texmf}-{config,var,local,dist}
325%__mkdir_p %{build_texmf}/fonts/{truetype,opentype}
326
327## copy texmf-dist/README
328%__cp -a %{texlive_src}/texmf-dist/README %{build_texmf}-dist/ || exit 1
329
330## customize updmap.cfg
331%__sed -i -e "s,^\(Map\|MixedMap\),#! \1,g" %{build_texmf}/web2c/updmap.cfg
332
333## dvipdfmx: our map file
334%__mkdir_p %{build_texmf}/fonts/map/dvipdfmx
335touch %{build_texmf}/fonts/map/dvipdfmx/vine.map
336
337## install jtygm.sty
338%__mkdir_p %{build_texmf}/tex/platex/base/
339%__install -m0644 %{SOURCE102} %{build_texmf}/tex/platex/base/ || exit 1
340
341## relocate binaries to %{_bindir} and fix relative symlinks
342pushd %{buildroot}%{_bindir}
343for i in `find . -type l`; do
344if [ "`readlink $i | grep '..' | wc -l`" == "1" ]; then
345l=`readlink $i | sed s,../,../share/,`
346%__ln_s -f $l $i
347fi
348done
349## if the real file of a symlink on /usr/bin is contained
350## in texlive-collection-*, remove its symlink
351## See __usr_bin_symlink.sh
352del_symlnks=(
353texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
354texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
355texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
356texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
357texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
358texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
359texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
360texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
361texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
362texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
363texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
364texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
365texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
366texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
367texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
368texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
369texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
370texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
371texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
372texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
373texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
374texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
375texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
376texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
377texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
378texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
379texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
380texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
381texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
382texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
383texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
384texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
385texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
386texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
387texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
388texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
389texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
390texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
391texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
392texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
393texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
394texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
395texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
396texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
397texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
398texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
399texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
400texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
401texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
402texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
403texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
404texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
405texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
406texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
407texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
408texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
409texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
410texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
411texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
412texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
413texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
414texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
415texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
416texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
417texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
418texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
419texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
420texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
421texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
422texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
423texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
424texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
425texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
426texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
427texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
428texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
429texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
430texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
431texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
432texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
433texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
434texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
435)
436for i in ${del_symlnks[@]}; do
437    %__rm -f %{buildroot}$(echo $i | cut -f 2 -d",") || exit 1
438done
439
440## remove man files of psutils
441%__rm \
442  %{buildroot}%{_mandir}/man1/epsffit.1 \
443  %{buildroot}%{_mandir}/man1/extractres.1 \
444  %{buildroot}%{_mandir}/man1/fixdlsrps.1 \
445  %{buildroot}%{_mandir}/man1/fixfmps.1 \
446  %{buildroot}%{_mandir}/man1/fixpsditps.1 \
447  %{buildroot}%{_mandir}/man1/fixpspps.1 \
448  %{buildroot}%{_mandir}/man1/fixscribeps.1 \
449  %{buildroot}%{_mandir}/man1/fixtpps.1 \
450  %{buildroot}%{_mandir}/man1/fixwfwps.1 \
451  %{buildroot}%{_mandir}/man1/fixwpps.1 \
452  %{buildroot}%{_mandir}/man1/fixwwps.1 \
453  %{buildroot}%{_mandir}/man1/getafm.1 \
454  %{buildroot}%{_mandir}/man1/includeres.1 \
455  %{buildroot}%{_mandir}/man1/psbook.1 \
456  %{buildroot}%{_mandir}/man1/psmerge.1 \
457  %{buildroot}%{_mandir}/man1/psnup.1 \
458  %{buildroot}%{_mandir}/man1/psresize.1 \
459  %{buildroot}%{_mandir}/man1/psselect.1 \
460  %{buildroot}%{_mandir}/man1/pstops.1 \
461  || exit 1
462## remove man files of lcdf-typetools
463%__rm \
464  %{buildroot}%{_mandir}/man1/cfftot1.1 \
465  %{buildroot}%{_mandir}/man1/mmafm.1 \
466  %{buildroot}%{_mandir}/man1/mmpfb.1 \
467  %{buildroot}%{_mandir}/man1/otfinfo.1 \
468  %{buildroot}%{_mandir}/man1/otftotfm.1 \
469  %{buildroot}%{_mandir}/man1/t1dotlessj.1 \
470  %{buildroot}%{_mandir}/man1/t1lint.1 \
471  %{buildroot}%{_mandir}/man1/t1rawafm.1 \
472  %{buildroot}%{_mandir}/man1/t1reencode.1 \
473  %{buildroot}%{_mandir}/man1/t1testpage.1 \
474  %{buildroot}%{_mandir}/man1/ttftotype42.1 \
475  || exit 1
476
477# remove unpackaged files
478find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
479find %{buildroot}%{_datadir} -name ls-R -exec %__rm -f {} \;
480find %{buildroot}%{_mandir} -name Makefile -exec %__rm -f {} \;
481find %{buildroot}%{_mandir} -name *.pdf -exec %__rm -f {} \;
482
483
484# ## compress info files
485# %__rm -f %{buildroot}%{_infodir}/dir
486# %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
487
488## desktop things
489%__mkdir_p %{buildroot}%{_datadir}/applications
490%__install -m0644 -c %{SOURCE10} %{SOURCE11} \
491    %{buildroot}%{_datadir}/applications/
492
493# for created fonts
494%__mkdir_p %{buildroot}%{vartexfonts}
495%__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
496%__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
497
498## set executable bit for the library
499%if %{enable_sharedlib}
500%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
501%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
502%endif
503
504## remove unpackaging files
505find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f
506find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f
507
508### Files list
509find %{buildroot} -type f -or -type l | \
510    %__sed -e "s|%{buildroot}||g" | \
511    %__grep -v -e "^%{_sysconfdir}" -e ".patch$" -e "\.diff$" -e "\.orig$" | \
512    %__grep -v "%{_includedir}" | \
513    %__grep -v "%{_libdir}" | \
514    %__grep -v "%{_infodir}" | \
515    %__sed -e "s|.*\.\(cnf\|cfg\)$|%config(noreplace) &|" \
516           -e "s|.*ls-R$|%ghost &|" \
517           -e "s|^.*/updmap$|%config &|" \
518           -e "s|%{texmf}*/dvips/config/\(psfonts.*\|ps2pk.*\|pdftex.*\|dvipdfm.*\|.*35\)\.map$|%ghost &|" \
519           -e "s|%{texmf}*/web2c/.*\.\(fmt\|efmt\|log\|base\|mem\|oft\)$|%config &|" \
520           -e "s|%{texmf}*/dvips/config/config\.\(generic\|pdf\|ps\|www\)$|%config &|" \
521           -e "s|%{texmf}*/tex/generic/config/.*|%config &|" \
522           -e "s|%{texmf}*/pdftex/config/pdftex.cfg$|%config &|" \
523           -e "s|%{texmf}*/xdvi/vfontmap$|%config &|" \
524           -e "s|%{texmf}*/xdvi/XDvi|%config &|" \
525           -e "s|%{_mandir}/.*|&*|" \
526        > %{_builddir}/%{name}-%{version}/filelist.full
527
528find %{buildroot}%{texmf}* -type d | \
529    %__sed -e "s|^%{buildroot}|%dir |" \
530           -e "s|$|/|" >> %{_builddir}/%{name}-%{version}/filelist.full
531
532## subpackages
533%__grep -e "/texmf/doc/" -e "/texdoc" %{_builddir}/%{name}-%{version}/filelist.full > %{_builddir}/%{name}-%{version}/filelist.doc
534cat %{_builddir}/%{name}-%{version}/filelist.doc \
535    %{_builddir}/%{name}-%{version}/filelist.full | \
536    sort | uniq -u > %{_builddir}/%{name}-%{version}/filelist.tmp
537%__mv -f %{_builddir}/%{name}-%{version}/filelist.tmp %{_builddir}/%{name}-%{version}/filelist.full
538
539
540%clean
541%__rm -rf %{buildroot}
542
543
544%pretrans
545rpm -q texlive | grep -q 2009
546[ $? -eq 1 ] && exit 0
547## upgrade TeX Live from 2009 to 2011
548_trans_time=$(date +%Y%m%d)
549echo "Running transitional process of your TeX system ... "
550for dir in %{texmf}-var %{texmf}-config; do
551    _trans_dir=${dir}.${_trans_time}.rpmorig
552    [ -d ${_trans_dir}.old ] && \
553        echo -n "  " && \
554        echo "Found ${_trans_dir}.old: " && \
555        echo -n "    " && \
556        %__rm -rvf ${_trans_dir}.old
557    [ -d ${_trans_dir} ] && \
558        echo -n "  " && \
559        echo "Found ${_trans_dir}: " && \
560        echo -n "    " && \
561        %__mv -v ${_trans_dir} ${_trans_dir}.old
562    [ -d ${dir} ] && \
563        echo -n "  " && \
564        echo "Found ${dir}: " && \
565        echo -n "    " && \
566        %__mv -v ${dir} ${_trans_dir}
567done
568echo "done."
569
570
571%post
572## create our own vine.map (cid-x.map) to use dvipdfmx
573( %{exec_upddeffont} ) ||:
574
575%{exec_texhash}
576%{exec_updmap} --syncwithtrees --nomkmap &>/dev/null
577%{exec_updmap} --enable KanjiMap vine.map >/dev/null 2>&1
578exit 0
579
580%preun
581if [ "$1" = 0 ]; then
582    %__rm -rf %{vartexfonts}
583
584    ## dvipdfmx
585    for i in %{texmf}/fonts/truetype/*; do
586        if [ -L "$i" ]; then
587            %__rm -f "$i"
588        fi
589    done
590fi
591
592
593%if %{enable_sharedlib}
594%post -n libkpathsea
595/sbin/ldconfig
596# /sbin/install-info %{_infodir}/kpathsea.info.* %{_infodir}/dir
597
598%preun -n libkpathsea
599# if [ "$1" = 0 ]; then
600#     /sbin/install-info --delete %{_infodir}/kpathsea.info.* %{_infodir}/dir
601# fi
602
603%postun -n libkpathsea
604/sbin/ldconfig
605
606%post -n libptexenc
607/sbin/ldconfig
608
609%postun -n libptexenc
610/sbin/ldconfig
611%endif
612
613%posttrans
614%__mkdir_p %{vartexfonts}
615%__chmod 1777 %{vartexfonts}
616
617
618%triggerin -- ghostscript
619%__rm -f %{texmf}/fonts/cmap/ghostscript
620if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
621    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{texmf}/fonts/cmap/ghostscript
622elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
623    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{texmf}/fonts/cmap/ghostscript
624fi
625%{exec_texhash}
626
627
628%files -f %{_builddir}/%{name}-%{version}/filelist.full
629%defattr(-,root,root)
630%attr(1777,root,root) %dir %{vartexfonts}
631%config %{_sysconfdir}/cron.daily/texlive.cron
632
633%files doc -f %{_builddir}/%{name}-%{version}/filelist.doc
634%defattr(-,root,root)
635
636%if %{enable_sharedlib}
637%files -n libkpathsea
638%defattr(-,root,root)
639%{_libdir}/libkpathsea.so.*
640# %{_infodir}/kpathsea.info*
641
642%files -n libkpathsea-devel
643%defattr(-,root,root)
644%{_libdir}/libkpathsea.so
645%dir %{_includedir}/kpathsea
646%{_includedir}/kpathsea/*
647
648%files -n libptexenc
649%defattr(-,root,root)
650%{_libdir}/libptexenc.so.*
651
652%files -n libptexenc-devel
653%defattr(-,root,root)
654%{_libdir}/libptexenc.so
655%dir %{_includedir}/ptexenc
656%{_includedir}/ptexenc/*
657%endif
658
659
660%changelog
661* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
662- added find-provides-texlive.sh and set it to %%__find_provides
663  - use to find library sonames for libkpathsea and libptexenc
664- added cmex.enc (%%{SOURCE110})
665  - do not install cmex.enc in our TDS, yet
666- removed some unused directories in texmf/fonts/map
667- removed man files of lcdf-typetools
668- moved texdoc{,tk} and its related files to texlive-doc
669
670* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
671- TeX Live 2011 + tl11supp-111120
672
673* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
674- make the directory VARTEXFONTS (%%posttrans)
675  - dropped %%triggerpostun -- texlive < 2009-17vl6
676
677* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
678- fixed ptexlive-20100711-dvipdfmx-vine.patch
679  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
680
681* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
682- added %%pre to avoid conflictions of texmf-{config,var}
683
684* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
685- dropped Requires: texlive-common
686- added perl-Tk-TableMatrix
687  - supported texdoctk
688- removed broken symbolic links in /usr/bin
689  - for each these symbolic links, the package of its real file/path
690    should be its owner.
691
692* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
693- added %%triggerpostun -- texlive < 2009-17vl6
694  - make the directory VARTEXFONTS
695
696* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
697- fixed %%dir VARTEXFONTS around in %%files
698- dropped BuildRequires: t1utils
699
700* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
701- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
702  - changed VARTEXFONTS to /var/lib/texmf/fonts
703
704* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
705- fixed updmap.cfg
706
707* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
708- dropped Requires: texlive-macros
709
710* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
711- updated ptexlive-20100711-pxdvik-vine.patch
712  and added texlive-20091107-xdvik-vine.patch
713  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
714
715* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
716- supported Vine Linux 5
717  - for vl5, changed a requirement of Japanese VF package
718    - added Requires: texlive-jvf = 2009 (vl5)
719- dropped dependencies of Provides:/Obsoletes: tags
720  - merged these dependencies in texlive-common-vl.spec
721
722* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
723- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
724
725* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
726- applied some security patches from Debian
727  - texlive-2009-CVE-2010-0827.patch
728  - texlive-2009-CVE-2010-1440.patch
729- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
730- applied texlive-2009-luatexdir-libpoppler-0.12.patch
731  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
732- fixed some dependencies
733
734* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
735- added BuildArch: noarch in %%package doc
736- removed some comment-out sentences
737
738* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
739- separeted texmf-dist to texlive-common package
740
741* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
742- unpacked texlive-20091107-source.tar.xz
743- babel is available now
744- applied eptex-100420 and some patches:
745  - eptex-100420-vine.patch
746  - eptex-100420-patch1.diff
747
748* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
749- updated ptexlive-20100711
750
751* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
752- customized updmap.cfg to correspond installed fonts
753
754* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
755- fixed insttexfont()
756
757* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
758- added jvf of MORISAWA basic 5 fonts
759- added cm-super, mathdesign in fntlst
760
761* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
762- define insttexfont() in %%install
763  - copy almost compatible tetex-3.0
764
765* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
766- ptexlive-20090322 + TeXLive 2009
767- added BuildRequires: openssl-devel
768
769* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
770- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.