source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 9971

Revision 9971, 26.8 KB checked in by munepi, 8 years ago (diff)

fixed some development files

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20150521
9#% global tlptexlivesrcver   20140507
10
11Summary: The TeX text formatting system
12Summary(ja): TeX 文書整形システム
13Name: texlive
14Version: 2015
15Release: 5%{?_dist_release}
16License: distributable
17Group: Applications/Publishing
18URL: http://www.tug.org/texlive/
19
20## original TeX Live source
21Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
22# Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
23## snapshot
24# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
25# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
26# Source: %{name}-source-%{texlivesrcver}.tar.xz
27
28# ## tlptexlive: pmetapost
29# Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
30Source2: http://www.tug.org/texlive/updmap-kanji.html
31
32## our updmap{,-hdr}.cfg from collection-basic 20140524
33# NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
34Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
35Source7: updmap.cfg.texlive-%{texlivesrcver}
36
37## desktop files
38Source11: texdoctk.desktop
39
40Source98: find-requires-texlive.sh
41## find library sonames for libkpathsea, libptexenc, and libsynctex
42Source99:  find-provides-texlive.sh
43
44######
45# TeX patches
46######
47
48## vine
49Patch0:         reautoconf-parallel.diff
50#Patch1:                texlive-%{texlivesrcver}-vine.patch
51Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
52Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
53#Patch4:                texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
54#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
55
56## security
57
58Requires:    perl-Tk perl-Tk-TableMatrix
59Requires:    ghostscript >= 8.71
60Requires:    nkf
61Requires(post,postun): fontconfig
62Requires(post): ed mktemp
63Requires(post): vutils >= 7.1
64%{!?with_firstbuild:Requires: texlive-common = %{version}}
65BuildRequires: autoconf >= 2.68
66BuildRequires: bison flex
67BuildRequires: bzip2-devel
68BuildRequires: cairo-devel >= 1.12
69BuildRequires: fontconfig-devel
70BuildRequires: freetype2-devel >= 2.1.10
71BuildRequires: gd-devel
72BuildRequires: libjpeg-devel
73BuildRequires: libpng-devel >= 1.6
74BuildRequires: ncurses-devel
75BuildRequires: nkf
76BuildRequires: openssl-devel
77BuildRequires: pixman-devel >= 0.18
78#BuildRequires: poppler-devel >= 0.26
79BuildRequires: xorg-x11-devel
80BuildRequires: zlib-devel
81## use distro's libpaper
82#BuildRequires: libpaper-devel >= 1.1.24-2
83## do not xdvi(k)
84#BuildRequires: XOrg-devel
85#BuildRequires: openMotif-devel
86## needs to build pxdvi
87#BuildRequires: t1lib-devel
88
89BuildRequires: texlive-vtlpkg = %{version}
90
91Buildroot:    %{_tmppath}/%{name}-%{version}-root
92
93Vendor:       Project Vine
94Distribution: Vine Linux
95Packager:     munepi
96
97
98%description
99The TeX Live software distribution offers a complete TeX system for a
100variety of Unix, Macintosh, Windows and other platforms. It
101encompasses programs for editing, typesetting, previewing and printing
102of TeX documents in many different languages, and a large collection
103of TeX macros and font libraries.
104
105The distribution includes extensive general documentation about TeX,
106as well as the documentation for the included software packages.
107
108
109%description -l ja
110TeX Live ソフトウェアディストリビューションは、
111さまざまな Unix, Macintosh, Windows、および
112他のプラットホームに対して完全な TeX システムを提供します。
113多くの異なった言語を含む TeX ドキュメントの
114編集、組版、閲覧、印刷するためのプログラム、
115そして、TeX マクロやフォントライブラリの大きなコレクションを
116同梱しています。
117
118このディストリビューションは
119同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
120TeX に関するたくさんの一般的なドキュメントを含んでいます。
121
122
123%package doc
124Summary: TeX Live: Documentation files of %{name}
125Group: Applications/Publishing
126Requires: %{name} = %{version}-%{release}
127BuildArch: noarch
128
129%description doc
130This package contains documentation files of %{name}.
131
132%package -n libkpathsea
133Summary: path search library for the TeX Live
134Summary(ja): TeX Live 用パス検索ライブラリ
135Group: System Environment/Libraries
136
137%description -n libkpathsea
138This package includes runtime part of the Kpathsea library.
139
140
141%package -n libkpathsea-devel
142Summary: path search libary and header files for the TeX Live
143Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
144Group: Development/Libraries
145Requires: libkpathsea = %{version}-%{release}
146
147%description -n libkpathsea-devel
148This package includes static library and header files of the Kpathsea library.
149
150
151%package -n libptexenc
152Summary: Kanji code convert library for Japanese pTeX
153Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
154Group: System Environment/Libraries
155Requires: libkpathsea = %{version}-%{release}
156
157%description -n libptexenc
158This package includes runtime part of the ptexenc library.
159
160
161%package -n libptexenc-devel
162Summary: Kanji code convert library and header files for Japanese pTeX
163Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
164Group: Development/Libraries
165Requires: libptexenc = %{version}-%{release}
166
167%description -n libptexenc-devel
168This package includes header files of the ptexenc library.
169
170
171%package -n libsynctex
172Summary: SyncTeX library
173Group: System Environment/Libraries
174
175%description -n libsynctex
176This package includes the runtime part of SyncTeX library.
177
178%package -n libsynctex-devel
179Summary: SyncTeX header files
180Group: Development/Libraries
181Requires: libsynctex = %{version}-%{release}
182
183%description -n libsynctex-devel
184This package includes the header files of SyncTeX library.
185
186
187%prep
188[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
189
190%setup -q -n %{name}-%{texlivesrcver}-source
191# %setup -q -n %{name}-source-%{texlivesrcver}
192
193%patch0 -p0 -b .parallel
194# %patch1 -p1 -b .vine
195%patch2 -p1 -b .vine
196%patch3 -p1 -b .vine
197# %patch4 -p1 -b .vine
198
199# ## Applying tlptexlive that provides pxdvi(k) and pmpost
200# echo "applying patches"
201# cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
202#     echo $p | grep '^#' >/dev/null  || \
203#     patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
204# done
205
206## Avoid pollution from internal libraries.
207#,paper,poppler,xpdf
208%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
209./reautoconf || exit 1
210
211
212%build
213set -x
214unset TEXINPUTS || :
215unset HOME || :
216
217export CFLAGS="$RPM_OPT_FLAGS" \
218       CXXFLAGS="$RPM_OPT_FLAGS" \
219       LANG=C
220
221PREFIX=$(pwd)/work
222
223TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
224TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
225
226TL_CONFIGURE_ARGS=" \
227    --disable-multiplatform \
228    --disable-native-texlive-build \
229    --with-banner-add=\"/Vine Linux\" \
230    --enable-shared --disable-static \
231    --enable-compiler-warnings=max \
232    --without-cxx-runtime-hack \
233    \
234    --with-system-xpdf=no --with-system-poppler=no \
235    --with-system-gd \
236    --with-system-t1lib \
237    --with-system-libpng \
238    --with-system-zlib \
239    --with-system-freetype2 \
240    --with-system-pixman \
241    --with-system-cairo \
242    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
243    --with-pic \
244    \
245    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
246    --disable-xdvik \
247    --disable-dvi2tty \
248    --disable-t1utils --disable-psutils --disable-detex \
249    --disable-dvipng --disable-lcdf-typetools \
250"
251
252export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
253TL_MAKE=%__make ./Build || exit 1
254
255
256%install
257## prepare %%install session
258[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
259
260## copy inst directory to /usr
261%__mkdir_p %{buildroot}
262%__cp -a inst %{buildroot}%{_prefix} || exit 1
263%ifarch x86_64
264%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
265%endif
266
267if [ -f %{buildroot}%{_libdir}/kpathsea/c-auto.h ]; then
268   %__mv %{buildroot}%{_libdir}/kpathsea/c-auto.h \
269         %{buildroot}%{_includedir}/kpathsea/c-auto.h || exit 1
270   %__rm -r %{buildroot}%{_libdir}/kpathsea || exit 1
271fi
272
273## make some fundamental texmf trees
274%__mkdir_p %{buildroot}%{_tl_texmfvine}
275%__mkdir_p %{buildroot}%{_tl_texmfdist}
276%__mkdir_p %{buildroot}%{_tl_texmflocal}
277%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
278%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
279%__mkdir_p %{buildroot}%{_tl_vartexfonts}
280%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
281%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
282
283cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
284The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
285distribution wide.
286You must not do any changes in this directory.
287EOF
288
289cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
290The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
291You should not use this directory to manage any other packages because
292we Project Vine use this directory to manage non-CTAN packages, some
293enhancement packages and so on.
294EOF
295
296cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
297The directory %{_tl_texmflocal} is the texmf tree of the system wide.
298If you are a privileged user of this system,
299you can use this directory to manage your local packages.
300EOF
301
302## our texmf-dist/web2c/updmap{,-hdr}.cfg
303%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
304%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
305%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
306
307## our map files for dvipdfmx
308%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
309%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
310for x in ptex uptex otf otf-up; do
311    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
312done
313for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
314    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
315done
316
317## desktop things
318%__mkdir_p %{buildroot}%{_datadir}/applications
319# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
320%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
321
322# for created fonts
323%__mkdir_p %{buildroot}%{_tl_vartexfonts}
324# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
325# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
326
327## set executable bit for the library
328%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
329%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
330
331# configure ConTeXt
332for x in context luatools texexec texmfstart; do
333  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
334done
335for x in contextjit; do
336  %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
337done
338
339# touch ghosts
340touch %{buildroot}%{_tl_texmfvine}/ls-R
341touch %{buildroot}%{_tl_texmfdist}/ls-R
342touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
343touch %{buildroot}%{_tl_texmfsysvar}/ls-R
344
345%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
346%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
347%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
348%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
350touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
351touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
352touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
353touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
354touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
355touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
356#touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
357touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
358touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
359touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
360
361
362## remove unpackaging files
363find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
364find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
365%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
366find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
367find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
368%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
369%__rm -f %{buildroot}%{_infodir}/*
370
371## use external packages
372%__rm %{buildroot}/usr/bin/latexmk || exit 1
373
374
375### Files list
376find %{buildroot} -type f -or -type l | \
377    %__sed -e "s|%{buildroot}||g" | \
378    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
379    %__grep -v "%{_includedir}" | \
380    %__grep -v "%{_libdir}" | \
381    %__grep -v "%{_infodir}" | \
382    %__sed -e "s|.*ls-R$|%ghost &|" \
383           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
384           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
385           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
386           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
387           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
388           -e "s|.*\.cnf$|%config(noreplace) &|" \
389           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
390           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
391           -e "s|^.*/updmap/$|%config &|" \
392           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
393           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
394           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
395           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
396           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
397           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
398           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
399           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
400           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
401           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
402           -e "s|%{_mandir}/.*|&*|" \
403        > %{_builddir}/filelist.full
404
405find %{buildroot}%{_tl_texmfvine}* -type d | \
406    %__sed -e "s|^%{buildroot}|%dir |" \
407           -e "s|$|/|" >> %{_builddir}/filelist.full
408
409## subpackages
410%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
411cat %{_builddir}/filelist.doc \
412    %{_builddir}/filelist.full | \
413    sort | uniq -u > %{_builddir}/filelist.tmp
414%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
415
416
417%clean
418%__rm -rf %{buildroot}
419
420
421%pretrans
422rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
423[ $? -eq 1 ] && exit 0
424_trans_time=$(date +%Y%m%d)
425echo "Running some transitional processes on your TeX system ... "
426x=(
427    /usr/share/texmf-local
428    /usr/share/texmf-var
429    /usr/share/texmf-config
430)
431for dir in ${x[@]}; do
432    _trans_dir=${dir}.${_trans_time}.rpmorig
433    [ -d ${_trans_dir}.old ] && \
434        echo -n "  " && \
435        echo "Found ${_trans_dir}.old: " && \
436        echo -n "    " && \
437        %__rm -rvf ${_trans_dir}.old
438    [ -d ${_trans_dir} ] && \
439        echo -n "  " && \
440        echo "Found ${_trans_dir}: " && \
441        echo -n "    " && \
442        %__mv -v ${_trans_dir} ${_trans_dir}.old
443    [ -d ${dir} ] && \
444        echo -n "  " && \
445        echo "Found ${dir}: " && \
446        echo -n "    " && \
447        %__mv -v ${dir} ${_trans_dir}
448done
449echo "done."
450
451%postun
452if [ "$1" = 0 ]; then
453    %__rm -rf %{_tl_vartexfonts}
454fi
455exit 0
456
457%post
458%_tl_touch_run texhash
459%_tl_touch_run updmap
460%_tl_touch_run mtxrun
461%_tl_touch_run fmtutil
462exit 0
463
464%posttrans
465%__mkdir_p %{_tl_vartexfonts}
466%__chmod 1777 %{_tl_vartexfonts}
467
468## create our map files {ptex,uptex,otf,otf-up}-vine.map
469( %{_tl_exec_upddeffont} ) ||:
470
471%{_tl_exec_texhash}
472%{_tl_exec_mtxrun}
473%{_tl_exec_updmap}
474%{_tl_exec_fmtutil}
475exit 0
476
477%post -n libkpathsea
478/sbin/ldconfig
479# for x in kpathsea tds web2c; do
480#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
481# done
482
483# %preun -n libkpathsea
484# if [ "$1" = 0 ]; then
485#     for x in kpathsea tds web2c; do
486#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
487#     done
488# fi
489
490%postun -n libkpathsea
491/sbin/ldconfig
492
493%post -n libptexenc
494/sbin/ldconfig
495
496%postun -n libptexenc
497/sbin/ldconfig
498
499%triggerin -- ghostscript
500%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
501if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
502    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
503elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
504    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
505fi
506%_tl_touch_run texhash
507exit 0
508
509
510%files -f %{_builddir}/filelist.full
511%defattr(-,root,root)
512%{_libdir}/libtexlua52.so.*
513%{_libdir}/libtexluajit.so.*
514%dir %{_tl_aliasttfdir}
515%attr(1777,root,root) %dir %{_tl_vartexfonts}
516# %config %{_sysconfdir}/cron.daily/texlive.cron
517
518%exclude %{_includedir}/texlua52/*.h
519%exclude %{_includedir}/texlua52/*.hpp
520%exclude %{_includedir}/texluajit/*.h
521%exclude %{_includedir}/texluajit/*.hpp
522%exclude %{_libdir}/libtexlua52.so
523%exclude %{_libdir}/libtexluajit.so
524%exclude %{_libdir}/pkgconfig/texlua52.pc
525%exclude %{_libdir}/pkgconfig/texluajit.pc
526
527%files doc -f %{_builddir}/filelist.doc
528%defattr(-,root,root)
529
530%files -n libkpathsea
531%defattr(-,root,root)
532%{_libdir}/libkpathsea.so.*
533# %{_infodir}/kpathsea.info*
534
535%files -n libkpathsea-devel
536%defattr(-,root,root)
537%{_libdir}/libkpathsea.so
538%dir %{_includedir}/kpathsea
539%{_includedir}/kpathsea/*.h
540%{_libdir}/pkgconfig/kpathsea.pc
541
542%files -n libptexenc
543%defattr(-,root,root)
544%{_libdir}/libptexenc.so.*
545
546%files -n libptexenc-devel
547%defattr(-,root,root)
548%{_libdir}/libptexenc.so
549%dir %{_includedir}/ptexenc
550%{_includedir}/ptexenc/*.h
551%{_libdir}/pkgconfig/ptexenc.pc
552
553%files -n libsynctex
554%defattr(-,root,root)
555%{_libdir}/libsynctex.so.*
556
557%files -n libsynctex-devel
558%defattr(-,root,root)
559%{_libdir}/libsynctex.so
560%dir %{_includedir}/synctex
561%{_includedir}/synctex/*.h
562%{_libdir}/pkgconfig/synctex.pc
563
564
565%changelog
566* Thu Jan 21 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-5
567- fixed some development files
568
569* Tue Jan 12 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-4
570- reverted to texlive-20150521-source (TeX Live 2015)
571
572* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
573- texlive-source-20160110 (TeX Live 2016/dev)
574
575* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
576- texlive-source-20150523 (TeX Live 2015/pretest)
577- configure ConTeXt/LuaTeX+LuaJIT
578
579* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
580- texlive-source-20150426 (TeX Live 2015/pretest)
581
582* Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
583- texlive-source-20141230 (TeX Live 2015/dev)
584
585* Thu Jul  3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
586- texlive-source-20140525 + tlptexlive 20140507
587- dropped texlive-20140524-vine.patch: built with libpng >= 1.6
588
589* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
590- upgrade to TeX Live 2014
591  - texlive-source-20140524 + tlptexlive 20140507
592
593* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
594- rebuild with poppler-0.24.5
595
596* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
597- rebuilt
598
599* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
600- texlive-source-20131101 2014/dev + tlptexlive 20130815
601- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
602
603* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
604- updated texlive-20131002-texmfcnf-vine.patch:
605  texmf.cnf (shell_escape_commands): added some programs
606
607* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
608- texlive-source-20131002 2014/dev + tlptexlive 20130815
609- defined %%global __find_requires find-requires-texlive.sh
610  - dropped unused dependencies of Requires
611
612* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
613- texlive-source-20130919 2014/dev + tlptexlive 20130815
614- correct some scripts of README.vine for each texmf trees
615
616* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
617- upgrade to TeX Live 2013
618  - texlive-source-20130823 2014/dev + tlptexlive 20130815
619- dropped Requires: jvf
620
621* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
622- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
623- fixed duplicated lw35 for updmap.pl
624- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
625
626* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
627- touch the map files generated by updmap-sys
628
629* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
630- fixed Source7: updmap.cfg.texlive-20120701
631  (upto /etc/texmf/web2c/updmap.cfg)
632- fixex %%triggerin -- ghostscript
633  - replaced %%exec_texhash with %%touch_run texhash
634
635* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
636- TeX Live 2012 + tlptexlive 20121107
637
638* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
639- drop BR: poppler-devel temporaly
640  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
641
642* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
643- build with poppler-0.18.4
644- remove tlmgr
645
646* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
647- updated to tl11supp-120120
648- run %%{exec_fmtutil} at %%post when upgrading
649
650* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
651- updated to tl11supp-111214
652
653* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
654- added BuildRequires: texlive-common
655  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
656  - check japanese.ldf
657- updated tl11supp-111120-vine.patch
658  - added the following options to $$TL_CONFIGURE_ARGS:
659    --disable-detex
660    --disable-dvipng
661    --disable-lcdf-typetools
662- remove some files of asymptote
663- remove a man file of latexmk
664- remove man files of lcdf-typetools
665- remove man files of dvipng
666- remove a man file of detex
667
668* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
669- added find-provides-texlive.sh and set it to %%__find_provides
670  - use to find library sonames for libkpathsea and libptexenc
671- added cmex.enc (%%{SOURCE110})
672  - do not install cmex.enc in our TDS, yet
673- removed some unused directories in texmf/fonts/map
674- removed man files of lcdf-typetools
675- moved texdoc{,tk} and its related files to texlive-doc
676
677* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
678- TeX Live 2011 + tl11supp-111120
679
680* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
681- make the directory VARTEXFONTS (%%posttrans)
682  - dropped %%triggerpostun -- texlive < 2009-17vl6
683
684* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
685- fixed ptexlive-20100711-dvipdfmx-vine.patch
686  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
687
688* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
689- added %%pre to avoid conflictions of texmf-{config,var}
690
691* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
692- dropped Requires: texlive-common
693- added perl-Tk-TableMatrix
694  - supported texdoctk
695- removed broken symbolic links in /usr/bin
696  - for each these symbolic links, the package of its real file/path
697    should be its owner.
698
699* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
700- added %%triggerpostun -- texlive < 2009-17vl6
701  - make the directory VARTEXFONTS
702
703* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
704- fixed %%dir VARTEXFONTS around in %%files
705- dropped BuildRequires: t1utils
706
707* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
708- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
709  - changed VARTEXFONTS to /var/lib/texmf/fonts
710
711* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
712- fixed updmap.cfg
713
714* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
715- dropped Requires: texlive-macros
716
717* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
718- updated ptexlive-20100711-pxdvik-vine.patch
719  and added texlive-20091107-xdvik-vine.patch
720  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
721
722* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
723- supported Vine Linux 5
724  - for vl5, changed a requirement of Japanese VF package
725    - added Requires: texlive-jvf = 2009 (vl5)
726- dropped dependencies of Provides:/Obsoletes: tags
727  - merged these dependencies in texlive-common-vl.spec
728
729* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
730- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
731
732* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
733- applied some security patches from Debian
734  - texlive-2009-CVE-2010-0827.patch
735  - texlive-2009-CVE-2010-1440.patch
736- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
737- applied texlive-2009-luatexdir-libpoppler-0.12.patch
738  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
739- fixed some dependencies
740
741* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
742- added BuildArch: noarch in %%package doc
743- removed some comment-out sentences
744
745* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
746- separeted texmf-dist to texlive-common package
747
748* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
749- unpacked texlive-20091107-source.tar.xz
750- babel is available now
751- applied eptex-100420 and some patches:
752  - eptex-100420-vine.patch
753  - eptex-100420-patch1.diff
754
755* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
756- updated ptexlive-20100711
757
758* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
759- customized updmap.cfg to correspond installed fonts
760
761* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
762- fixed insttexfont()
763
764* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
765- added jvf of MORISAWA basic 5 fonts
766- added cm-super, mathdesign in fntlst
767
768* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
769- define insttexfont() in %%install
770  - copy almost compatible tetex-3.0
771
772* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
773- ptexlive-20090322 + TeXLive 2009
774- added BuildRequires: openssl-devel
775
776* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
777- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.