source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 8174

Revision 8174, 24.5 KB checked in by munepi, 10 years ago (diff)

rebuilt

RevLine 
[7769]1# -*- coding: utf-8-unix -*-
[1533]2%bcond_with firstbuild
3
[5207]4%global _use_internal_dependency_generator 0
[5214]5%global __find_provides %{SOURCE99}
[7855]6%global __find_requires %{SOURCE98}
[1533]7
[7951]8%global texlivesrcver   20131101
[1533]9
10Summary: The TeX text formatting system
11Summary(ja): TeX 文書整形システム
12Name: texlive
[7769]13Version: 2013
[8174]14Release: 6%{?_dist_release}
[1533]15License: distributable
16Group: Applications/Publishing
[5207]17URL: http://www.tug.org/texlive/
[1533]18
[7148]19## original TeX Live source
[7769]20#Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
21## snapshot
22# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
23# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
24Source: %{name}-source-%{texlivesrcver}.tar.xz
[1533]25
[7769]26## tlptexlive: pmetapost
27Source1: http://www.preining.info/software/build-tlptexlive-20130815.zip
[7148]28Source2: http://www.tug.org/texlive/updmap-kanji.html
[1533]29
[7769]30## our updmap{,-hdr}.cfg from collection-basic 20130823
31# NOTE:
32# * texmf.cnf: we use the conf file texmf.cnf generated from Source0
33Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
[7148]34Source7: updmap.cfg.texlive-%{texlivesrcver}
35
[5207]36## desktop files
[7769]37# Source10: pxdvi.desktop
[5207]38Source11: texdoctk.desktop
[1533]39
[7769]40# ## pxdvi from tlptexlive 2012
41# Source50: texlive-source-xdvik-20130106.tar.xz
42# Source51: http://www.preining.info/software/build-tlptexlive-20130106.zip
[7678]43
[7855]44Source98: find-requires-texlive.sh
[5214]45## find library sonames for libkpathsea and libptexenc
[7855]46Source99:  find-provides-texlive.sh
[5214]47
[1533]48## etc...
[7148]49#Source100: texlive.cron
[1533]50
51
52######
53# TeX patches
54######
55
56## vine
[7148]57Patch0:         reautoconf-parallel.diff
[5207]58Patch1:         texlive-%{texlivesrcver}-vine.patch
[1533]59Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
[5207]60Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
[7769]61#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
[1533]62
[1973]63## security
[1533]64
[3944]65Requires:    perl-Tk perl-Tk-TableMatrix
[7148]66Requires:    ghostscript >= 8.71
[7855]67Requires:    nkf
68Requires(post,postun): fontconfig
[1533]69Requires(post): ed mktemp
[7148]70Requires(post): vutils >= 7.1
71%{!?with_firstbuild:Requires: texlive-common = %{version}}
[1533]72BuildRequires: bison flex
[5207]73BuildRequires: bzip2-devel
[1973]74BuildRequires: zlib-devel
75BuildRequires: libpng-devel
76BuildRequires: gd-devel
77BuildRequires: ncurses-devel
78BuildRequires: libjpeg-devel
[1533]79BuildRequires: XOrg-devel
80BuildRequires: freetype2-devel >= 2.1.10
[5207]81BuildRequires: autoconf >= 2.68
[1533]82BuildRequires: openMotif-devel
[7154]83BuildRequires: poppler-devel >= 0.20
[1533]84BuildRequires: openssl-devel
85BuildRequires: fontconfig-devel
[7951]86BuildRequires: libpaper-devel >= 1.1.24-2
[1533]87BuildRequires: nkf
[7855]88## needs to build pxdvi
89#BuildRequires: t1lib-devel
[1533]90
[7769]91BuildRequires: texlive-vtlpkg = %{version}
92
[1533]93Buildroot:    %{_tmppath}/%{name}-%{version}-root
94
95Vendor:       Project Vine
96Distribution: Vine Linux
97Packager:     munepi
98
99
100%description
101The TeX Live software distribution offers a complete TeX system for a
102variety of Unix, Macintosh, Windows and other platforms. It
103encompasses programs for editing, typesetting, previewing and printing
104of TeX documents in many different languages, and a large collection
105of TeX macros and font libraries.
106
107The distribution includes extensive general documentation about TeX,
108as well as the documentation for the included software packages.
109
110
111%description -l ja
112TeX Live ソフトウェアディストリビューションは、
113さまざまな Unix, Macintosh, Windows、および
114他のプラットホームに対して完全な TeX システムを提供します。
115多くの異なった言語を含む TeX ドキュメントの
116編集、組版、閲覧、印刷するためのプログラム、
117そして、TeX マクロやフォントライブラリの大きなコレクションを
118同梱しています。
119
120このディストリビューションは
121同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
122TeX に関するたくさんの一般的なドキュメントを含んでいます。
123
124
125%package doc
126Summary: TeX Live: Documentation files of %{name}
127Group: Applications/Publishing
128Requires: %{name} = %{version}-%{release}
[1542]129BuildArch: noarch
[1533]130
131%description doc
132This package contains documentation files of %{name}.
133
134%package -n libkpathsea
135Summary: path search library for the TeX Live
136Summary(ja): TeX Live 用パス検索ライブラリ
137Group: System Environment/Libraries
138
139%description -n libkpathsea
140This package includes runtime part of the Kpathsea library.
141
142
143%package -n libkpathsea-devel
144Summary: path search libary and header files for the TeX Live
145Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
146Group: Development/Libraries
147Requires: libkpathsea = %{version}-%{release}
148
149%description -n libkpathsea-devel
150This package includes static library and header files of the Kpathsea library.
151
152
153%package -n libptexenc
154Summary: Kanji code convert library for Japanese pTeX
155Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
156Group: System Environment/Libraries
157Requires: libkpathsea = %{version}-%{release}
158
159%description -n libptexenc
160This package includes runtime part of the ptexenc library.
161
162
163%package -n libptexenc-devel
164Summary: Kanji code convert library and header files for Japanese pTeX
165Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
166Group: Development/Libraries
167Requires: libptexenc = %{version}-%{release}
168
169%description -n libptexenc-devel
170This package includes header files of the ptexenc library.
171
172
173%prep
174[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
175
[7769]176#%setup -q -n %{name}-%{texlivesrcver}-source
177%setup -q -n %{name}-source-%{texlivesrcver} -a 1
[1533]178
[7148]179%patch0 -p0 -b .parallel
[5207]180%patch1 -p1 -b .vine
181%patch2 -p1 -b .vine
182%patch3 -p1 -b .vine
[7148]183
184## Applying tlptexlive that provides pxdvi(k) and pmpost
[7769]185echo "applying patches"
186cat "$(pwd)/build-tlptexlive-20130815/patches/series" | while read p r ; do
187    echo $p | grep '^#' >/dev/null  || \
188    patch -p1 $r < "$(pwd)/build-tlptexlive-20130815/patches/$p" || exit 1
189done
[7148]190
[7769]191# ## pxdvi from tlptexlive 2012
192# echo "creating pxdvi folder"
193# [ -d texk/pxdvik ] && exit 1
194# %__cp -pR texlive-source-20130106/texk/xdvik texk/pxdvik
195# echo "applying patches"
196# cat "$(pwd)/build-tlptexlive-20130106/patches/series" | \
197#     grep -v -e freetype-modules -e pmpost -e reautoconf | while read p r ; do
198#         echo $p | grep '^#' >/dev/null || \
199#       patch -p1 $r < "$(pwd)/build-tlptexlive-20130106/patches/$p" || exit 1
200# done
201#
202# # customize pxdvik for Vine Linux
203# %patch10 -p1 -b .vine
[7148]204
[1533]205
[7769]206## Avoid pollution from internal libraries.
[7951]207%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,paper,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
[7769]208# ./reautoconf || exit 1
[1533]209
[1973]210
[1533]211%build
212set -x
213unset TEXINPUTS || :
214unset HOME || :
215
[7148]216export CFLAGS="$RPM_OPT_FLAGS" \
[5207]217       CXXFLAGS="$RPM_OPT_FLAGS" \
218       LANG=C
[1533]219
[7148]220PREFIX=$(pwd)/work
[1533]221
[7148]222TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
223TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
[1533]224
[7148]225TL_CONFIGURE_ARGS=" \
226    --disable-multiplatform \
227    --disable-native-texlive-build \
228    --with-banner-add=\"/Vine Linux\" \
229    --enable-shared --disable-static \
230    --enable-compiler-warnings=max \
231    --without-cxx-runtime-hack \
232    \
233    --enable-web2c \
234    --enable-web-progs --enable-dvipdfmx --enable-mendexk \
235    --enable-makejvf --enable-pxdvik --enable-dvipsk \
236    --enable-tetex --enable-texlive \
237    \
238    --with-system-xpdf \
239    --with-system-gd \
240    --with-system-t1lib \
241    --with-system-libpng \
242    --with-system-zlib \
243    --with-system-freetype2 \
[7951]244    --with-system-paper \
[7769]245    --with-system-pixman \
246    --with-system-poppler \
247    --with-system-cairo \
[7148]248    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
249    --with-pic \
250    \
251    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
252    --disable-dvi2tty \
253    --disable-t1utils --disable-psutils --disable-detex \
254    --disable-dvipng --disable-lcdf-typetools \
255"
256
257export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
[7678]258TL_MAKE=%__make ./Build || exit 1
[7148]259
[7678]260
[1533]261%install
[1542]262## prepare %%install session
[1533]263[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
264
[7769]265## copy inst directory to /usr
[7148]266%__mkdir_p %{buildroot}
267%__cp -a inst %{buildroot}%{_prefix} || exit 1
268%ifarch x86_64
[7769]269%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
[5289]270%endif
[5248]271
[5207]272## make some fundamental texmf trees
[7769]273%__mkdir_p %{buildroot}%{_tl_texmfvine}
274%__mkdir_p %{buildroot}%{_tl_texmfdist}
275%__mkdir_p %{buildroot}%{_tl_texmflocal}
276%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
277%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
278%__mkdir_p %{buildroot}%{_tl_vartexfonts}
279%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
280%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
[5248]281
[7769]282cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
[7810]283The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
284distribution wide.
285You must not do any changes in this directory.
[7769]286EOF
[6253]287
[7769]288cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
[7810]289The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
[7769]290You should not use this directory to manage any other packages because
[7810]291we Project Vine use this directory to manage non-CTAN packages, some
292enhancement packages and so on.
[7769]293EOF
[1533]294
[7769]295cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
[7810]296The directory %{_tl_texmflocal} is the texmf tree of the system wide.
[7769]297If you are a privileged user of this system,
298you can use this directory to manage your local packages.
299EOF
[1533]300
[7769]301## our texmf-dist/web2c/updmap{,-hdr}.cfg
302%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
303%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
304%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
305
306## our map files for dvipdfmx
307%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
308%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
[7154]309for x in ptex uptex otf otf-up; do
[7769]310    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
[7154]311done
312for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
[7769]313    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
[7154]314done
[1533]315
316## desktop things
317%__mkdir_p %{buildroot}%{_datadir}/applications
[7769]318# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
319%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
[1533]320
321# for created fonts
[7769]322%__mkdir_p %{buildroot}%{_tl_vartexfonts}
[7148]323# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
324# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
[1533]325
326## set executable bit for the library
327%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
328%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
329
[7148]330# configure ConTeXt
331for x in context ctxtools luatools texexec texmfstart; do
[7769]332  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
[7148]333done
334
335# touch ghosts
[7769]336touch %{buildroot}%{_tl_texmfvine}/ls-R
337touch %{buildroot}%{_tl_texmfdist}/ls-R
338touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
339touch %{buildroot}%{_tl_texmfsysvar}/ls-R
[7148]340
[7769]341%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
342%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
343%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
344%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
345touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
346touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
347touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
348touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
350touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
351touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
352touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
353touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
354touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
355touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
[7530]356
357
[7154]358## remove unpackaging files
359find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
360find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
[7148]361%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
[7769]362find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
[7148]363find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
[7769]364%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
[7154]365%__rm -f %{buildroot}%{_infodir}/*
[7148]366
[7769]367## use external packages
368%__rm %{buildroot}/usr/bin/latexmk || exit 1
[1533]369
[7769]370
[1533]371### Files list
372find %{buildroot} -type f -or -type l | \
373    %__sed -e "s|%{buildroot}||g" | \
[7148]374    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
[1533]375    %__grep -v "%{_includedir}" | \
376    %__grep -v "%{_libdir}" | \
377    %__grep -v "%{_infodir}" | \
[7154]378    %__sed -e "s|.*ls-R$|%ghost &|" \
[7769]379           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
380           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
[7154]381           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
382           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
383           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
384           -e "s|.*\.cnf$|%config(noreplace) &|" \
[7769]385           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
386           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
[7154]387           -e "s|^.*/updmap/$|%config &|" \
[7769]388           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
389           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
390           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
391           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
392           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
393           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
394           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
395           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
396           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
397           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
[1533]398           -e "s|%{_mandir}/.*|&*|" \
[7148]399        > %{_builddir}/filelist.full
[1533]400
[7769]401find %{buildroot}%{_tl_texmfvine}* -type d | \
[1533]402    %__sed -e "s|^%{buildroot}|%dir |" \
[7148]403           -e "s|$|/|" >> %{_builddir}/filelist.full
[1533]404
405## subpackages
[7769]406%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
[7148]407cat %{_builddir}/filelist.doc \
408    %{_builddir}/filelist.full | \
409    sort | uniq -u > %{_builddir}/filelist.tmp
410%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
[1533]411
412
413%clean
414%__rm -rf %{buildroot}
415
416
[5207]417%pretrans
[7769]418rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012
[5207]419[ $? -eq 1 ] && exit 0
420_trans_time=$(date +%Y%m%d)
[7769]421echo "Running some transitional processes on your TeX system ... "
422x=(
423    /usr/share/texmf-local
424    /usr/share/texmf-var
425    /usr/share/texmf-config
426)
427for dir in ${x[@]}; do
[5207]428    _trans_dir=${dir}.${_trans_time}.rpmorig
429    [ -d ${_trans_dir}.old ] && \
430        echo -n "  " && \
431        echo "Found ${_trans_dir}.old: " && \
432        echo -n "    " && \
433        %__rm -rvf ${_trans_dir}.old
434    [ -d ${_trans_dir} ] && \
435        echo -n "  " && \
436        echo "Found ${_trans_dir}: " && \
437        echo -n "    " && \
438        %__mv -v ${_trans_dir} ${_trans_dir}.old
439    [ -d ${dir} ] && \
440        echo -n "  " && \
441        echo "Found ${dir}: " && \
442        echo -n "    " && \
443        %__mv -v ${dir} ${_trans_dir}
444done
445echo "done."
[4152]446
[7769]447%postun
[7148]448if [ "$1" = 0 ]; then
[7769]449    %__rm -rf %{_tl_vartexfonts}
[7148]450fi
451exit 0
[4152]452
[1533]453%post
[7769]454%_tl_touch_run texhash
455%_tl_touch_run updmap
456%_tl_touch_run mtxrun
457%_tl_touch_run fmtutil
[7148]458exit 0
459
460%posttrans
[7769]461%__mkdir_p %{_tl_vartexfonts}
462%__chmod 1777 %{_tl_vartexfonts}
463
[7148]464## create our map files {ptex,uptex,otf,otf-up}-vine.map
[7769]465( %{_tl_exec_upddeffont} ) ||:
[1533]466
[7769]467%{_tl_exec_texhash}
468%{_tl_exec_mtxrun}
469%{_tl_exec_updmap}
470%{_tl_exec_fmtutil}
[5207]471exit 0
[1533]472
473%post -n libkpathsea
474/sbin/ldconfig
[7148]475# for x in kpathsea tds web2c; do
476#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
477# done
[1533]478
[7148]479# %preun -n libkpathsea
[1533]480# if [ "$1" = 0 ]; then
[7148]481#     for x in kpathsea tds web2c; do
482#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
483#     done
[1533]484# fi
485
486%postun -n libkpathsea
487/sbin/ldconfig
488
489%post -n libptexenc
490/sbin/ldconfig
491
492%postun -n libptexenc
493/sbin/ldconfig
494
495%triggerin -- ghostscript
[7769]496%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
[1533]497if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
[7769]498    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
[1533]499elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
[7769]500    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
[1533]501fi
[7769]502%_tl_touch_run texhash
[7154]503exit 0
[1533]504
505
[7148]506%files -f %{_builddir}/filelist.full
[1533]507%defattr(-,root,root)
[7769]508%dir %{_tl_aliasttfdir}
509%attr(1777,root,root) %dir %{_tl_vartexfonts}
[7148]510# %config %{_sysconfdir}/cron.daily/texlive.cron
[1533]511
[7148]512%files doc -f %{_builddir}/filelist.doc
[1533]513%defattr(-,root,root)
514
515%files -n libkpathsea
516%defattr(-,root,root)
517%{_libdir}/libkpathsea.so.*
518# %{_infodir}/kpathsea.info*
519
520%files -n libkpathsea-devel
521%defattr(-,root,root)
522%{_libdir}/libkpathsea.so
523%dir %{_includedir}/kpathsea
524%{_includedir}/kpathsea/*
525
526%files -n libptexenc
527%defattr(-,root,root)
528%{_libdir}/libptexenc.so.*
529
530%files -n libptexenc-devel
531%defattr(-,root,root)
532%{_libdir}/libptexenc.so
533%dir %{_includedir}/ptexenc
534%{_includedir}/ptexenc/*
535
536
537%changelog
[8174]538* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
539- rebuilt
540
[7951]541* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
542- texlive-source-20131101 2014/dev + tlptexlive 20130815
543- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
544
[7881]545* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
546- updated texlive-20131002-texmfcnf-vine.patch:
547  texmf.cnf (shell_escape_commands): added some programs
548
[7855]549* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
550- texlive-source-20131002 2014/dev + tlptexlive 20130815
551- defined %%global __find_requires find-requires-texlive.sh
552  - dropped unused dependencies of Requires
553
[7810]554* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
555- texlive-source-20130919 2014/dev + tlptexlive 20130815
556- correct some scripts of README.vine for each texmf trees
557
[7769]558* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
559- upgrade to TeX Live 2013
560  - texlive-source-20130823 2014/dev + tlptexlive 20130815
561- dropped Requires: jvf
562
[7678]563* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
564- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
565- fixed duplicated lw35 for updmap.pl
566- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
567
[7530]568* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
569- touch the map files generated by updmap-sys
570
[7154]571* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
572- fixed Source7: updmap.cfg.texlive-20120701
573  (upto /etc/texmf/web2c/updmap.cfg)
574- fixex %%triggerin -- ghostscript
575  - replaced %%exec_texhash with %%touch_run texhash
576
[7148]577* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
578- TeX Live 2012 + tlptexlive 20121107
579
[7042]580* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
581- drop BR: poppler-devel temporaly
582  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
583
[6253]584* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
585- build with poppler-0.18.4
586- remove tlmgr
587
[5502]588* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
589- updated to tl11supp-120120
590- run %%{exec_fmtutil} at %%post when upgrading
591
[5289]592* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
593- updated to tl11supp-111214
594
[5248]595* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
596- added BuildRequires: texlive-common
597  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
598  - check japanese.ldf
599- updated tl11supp-111120-vine.patch
600  - added the following options to $$TL_CONFIGURE_ARGS:
601    --disable-detex
602    --disable-dvipng
603    --disable-lcdf-typetools
604- remove some files of asymptote
605- remove a man file of latexmk
606- remove man files of lcdf-typetools
607- remove man files of dvipng
608- remove a man file of detex
609
[5214]610* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
611- added find-provides-texlive.sh and set it to %%__find_provides
612  - use to find library sonames for libkpathsea and libptexenc
613- added cmex.enc (%%{SOURCE110})
614  - do not install cmex.enc in our TDS, yet
615- removed some unused directories in texmf/fonts/map
616- removed man files of lcdf-typetools
617- moved texdoc{,tk} and its related files to texlive-doc
618
[5207]619* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
620- TeX Live 2011 + tl11supp-111120
621
622* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
623- make the directory VARTEXFONTS (%%posttrans)
624  - dropped %%triggerpostun -- texlive < 2009-17vl6
625
[4346]626* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
627- fixed ptexlive-20100711-dvipdfmx-vine.patch
628  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
629
[4152]630* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
631- added %%pre to avoid conflictions of texmf-{config,var}
632
[3944]633* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
634- dropped Requires: texlive-common
635- added perl-Tk-TableMatrix
636  - supported texdoctk
637- removed broken symbolic links in /usr/bin
638  - for each these symbolic links, the package of its real file/path
639    should be its owner.
640
[3910]641* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
642- added %%triggerpostun -- texlive < 2009-17vl6
643  - make the directory VARTEXFONTS
644
[3840]645* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
646- fixed %%dir VARTEXFONTS around in %%files
647- dropped BuildRequires: t1utils
648
[3703]649* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
650- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
651  - changed VARTEXFONTS to /var/lib/texmf/fonts
652
[3688]653* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
654- fixed updmap.cfg
655
[3150]656* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
657- dropped Requires: texlive-macros
658
[2503]659* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
660- updated ptexlive-20100711-pxdvik-vine.patch
661  and added texlive-20091107-xdvik-vine.patch
662  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
663
[2456]664* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
[2421]665- supported Vine Linux 5
[2456]666  - for vl5, changed a requirement of Japanese VF package
667    - added Requires: texlive-jvf = 2009 (vl5)
[2503]668- dropped dependencies of Provides:/Obsoletes: tags
669  - merged these dependencies in texlive-common-vl.spec
[2421]670
[2257]671* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
672- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
673
[1973]674* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
675- applied some security patches from Debian
676  - texlive-2009-CVE-2010-0827.patch
677  - texlive-2009-CVE-2010-1440.patch
678- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
679- applied texlive-2009-luatexdir-libpoppler-0.12.patch
680  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
681- fixed some dependencies
682
[1542]683* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
684- added BuildArch: noarch in %%package doc
685- removed some comment-out sentences
686
[1533]687* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
688- separeted texmf-dist to texlive-common package
689
690* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
691- unpacked texlive-20091107-source.tar.xz
692- babel is available now
693- applied eptex-100420 and some patches:
694  - eptex-100420-vine.patch
695  - eptex-100420-patch1.diff
696
697* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
698- updated ptexlive-20100711
699
700* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
701- customized updmap.cfg to correspond installed fonts
702
703* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
704- fixed insttexfont()
705
706* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
707- added jvf of MORISAWA basic 5 fonts
708- added cm-super, mathdesign in fntlst
709
710* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
711- define insttexfont() in %%install
712  - copy almost compatible tetex-3.0
713
714* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
715- ptexlive-20090322 + TeXLive 2009
716- added BuildRequires: openssl-devel
717
718* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
719- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.