source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 10269

Revision 10269, 26.9 KB checked in by munepi, 8 years ago (diff)

upgrade to TeX Live 2016

RevLine 
[7769]1# -*- coding: utf-8-unix -*-
[1533]2%bcond_with firstbuild
3
[5207]4%global _use_internal_dependency_generator 0
[5214]5%global __find_provides %{SOURCE99}
[7855]6%global __find_requires %{SOURCE98}
[1533]7
[10269]8%global texlivesrcver   20160510
[9529]9#% global tlptexlivesrcver   20140507
[1533]10
11Summary: The TeX text formatting system
12Summary(ja): TeX 文書整形システム
13Name: texlive
[10269]14Version: 2016
15Release: 2%{?_dist_release}
[1533]16License: distributable
17Group: Applications/Publishing
[5207]18URL: http://www.tug.org/texlive/
[1533]19
[7148]20## original TeX Live source
[10269]21# Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
[9529]22# Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
[7769]23## snapshot
24# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
25# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
[10269]26Source: %{name}-source-%{texlivesrcver}.tar.xz
[1533]27
[8744]28## our updmap{,-hdr}.cfg from collection-basic 20140524
29# NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
[7769]30Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
[7148]31Source7: updmap.cfg.texlive-%{texlivesrcver}
32
[5207]33## desktop files
34Source11: texdoctk.desktop
[1533]35
[7855]36Source98: find-requires-texlive.sh
[9529]37## find library sonames for libkpathsea, libptexenc, and libsynctex
[7855]38Source99:  find-provides-texlive.sh
[5214]39
[1533]40######
41# TeX patches
42######
43
44## vine
[9529]45Patch0:         reautoconf-parallel.diff
[8744]46#Patch1:                texlive-%{texlivesrcver}-vine.patch
[1533]47Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
[5207]48Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
[8744]49#Patch4:                texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
[7769]50#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
[1533]51
[1973]52## security
[1533]53
[3944]54Requires:    perl-Tk perl-Tk-TableMatrix
[7148]55Requires:    ghostscript >= 8.71
[7855]56Requires:    nkf
57Requires(post,postun): fontconfig
[1533]58Requires(post): ed mktemp
[7148]59Requires(post): vutils >= 7.1
60%{!?with_firstbuild:Requires: texlive-common = %{version}}
[9529]61BuildRequires: autoconf >= 2.68
[1533]62BuildRequires: bison flex
[5207]63BuildRequires: bzip2-devel
[9529]64BuildRequires: cairo-devel >= 1.12
65BuildRequires: fontconfig-devel
66BuildRequires: freetype2-devel >= 2.1.10
67BuildRequires: gd-devel
68BuildRequires: libjpeg-devel
[8744]69BuildRequires: libpng-devel >= 1.6
[1973]70BuildRequires: ncurses-devel
[9529]71BuildRequires: nkf
[1533]72BuildRequires: openssl-devel
[9529]73BuildRequires: pixman-devel >= 0.18
74#BuildRequires: poppler-devel >= 0.26
75BuildRequires: xorg-x11-devel
76BuildRequires: zlib-devel
77## use distro's libpaper
78#BuildRequires: libpaper-devel >= 1.1.24-2
79## do not xdvi(k)
80#BuildRequires: XOrg-devel
81#BuildRequires: openMotif-devel
[7855]82## needs to build pxdvi
83#BuildRequires: t1lib-devel
[1533]84
[7769]85BuildRequires: texlive-vtlpkg = %{version}
86
[1533]87Buildroot:    %{_tmppath}/%{name}-%{version}-root
88
89Vendor:       Project Vine
90Distribution: Vine Linux
91Packager:     munepi
92
93
94%description
95The TeX Live software distribution offers a complete TeX system for a
96variety of Unix, Macintosh, Windows and other platforms. It
97encompasses programs for editing, typesetting, previewing and printing
98of TeX documents in many different languages, and a large collection
99of TeX macros and font libraries.
100
101The distribution includes extensive general documentation about TeX,
102as well as the documentation for the included software packages.
103
104
105%description -l ja
106TeX Live ソフトウェアディストリビューションは、
107さまざまな Unix, Macintosh, Windows、および
108他のプラットホームに対して完全な TeX システムを提供します。
109多くの異なった言語を含む TeX ドキュメントの
110編集、組版、閲覧、印刷するためのプログラム、
111そして、TeX マクロやフォントライブラリの大きなコレクションを
112同梱しています。
113
114このディストリビューションは
115同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
116TeX に関するたくさんの一般的なドキュメントを含んでいます。
117
118
119%package doc
120Summary: TeX Live: Documentation files of %{name}
121Group: Applications/Publishing
122Requires: %{name} = %{version}-%{release}
[1542]123BuildArch: noarch
[1533]124
125%description doc
126This package contains documentation files of %{name}.
127
128%package -n libkpathsea
129Summary: path search library for the TeX Live
130Summary(ja): TeX Live 用パス検索ライブラリ
131Group: System Environment/Libraries
132
133%description -n libkpathsea
134This package includes runtime part of the Kpathsea library.
135
136
137%package -n libkpathsea-devel
138Summary: path search libary and header files for the TeX Live
139Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
140Group: Development/Libraries
141Requires: libkpathsea = %{version}-%{release}
142
143%description -n libkpathsea-devel
144This package includes static library and header files of the Kpathsea library.
145
146
147%package -n libptexenc
148Summary: Kanji code convert library for Japanese pTeX
149Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
150Group: System Environment/Libraries
151Requires: libkpathsea = %{version}-%{release}
152
153%description -n libptexenc
154This package includes runtime part of the ptexenc library.
155
156
157%package -n libptexenc-devel
158Summary: Kanji code convert library and header files for Japanese pTeX
159Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
160Group: Development/Libraries
161Requires: libptexenc = %{version}-%{release}
162
163%description -n libptexenc-devel
164This package includes header files of the ptexenc library.
165
166
[9529]167%package -n libsynctex
168Summary: SyncTeX library
169Group: System Environment/Libraries
170
171%description -n libsynctex
172This package includes the runtime part of SyncTeX library.
173
174%package -n libsynctex-devel
175Summary: SyncTeX header files
176Group: Development/Libraries
177Requires: libsynctex = %{version}-%{release}
178
179%description -n libsynctex-devel
180This package includes the header files of SyncTeX library.
181
182
[1533]183%prep
184[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
185
[10269]186# %setup -q -n %{name}-%{texlivesrcver}-source
187%setup -q -n %{name}-source-%{texlivesrcver}
[1533]188
[9529]189%patch0 -p0 -b .parallel
[8744]190# %patch1 -p1 -b .vine
[5207]191%patch2 -p1 -b .vine
192%patch3 -p1 -b .vine
[8744]193# %patch4 -p1 -b .vine
[7148]194
[9529]195# ## Applying tlptexlive that provides pxdvi(k) and pmpost
196# echo "applying patches"
197# cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
198#     echo $p | grep '^#' >/dev/null  || \
199#     patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
200# done
[7148]201
[7769]202## Avoid pollution from internal libraries.
[9529]203#,paper,poppler,xpdf
204%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
205./reautoconf || exit 1
[1533]206
[1973]207
[1533]208%build
209set -x
210unset TEXINPUTS || :
211unset HOME || :
212
[7148]213export CFLAGS="$RPM_OPT_FLAGS" \
[5207]214       CXXFLAGS="$RPM_OPT_FLAGS" \
215       LANG=C
[1533]216
[7148]217PREFIX=$(pwd)/work
[1533]218
[7148]219TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
220TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
[1533]221
[7148]222TL_CONFIGURE_ARGS=" \
223    --disable-multiplatform \
224    --disable-native-texlive-build \
225    --with-banner-add=\"/Vine Linux\" \
226    --enable-shared --disable-static \
227    --enable-compiler-warnings=max \
228    --without-cxx-runtime-hack \
229    \
[9529]230    --with-system-xpdf=no --with-system-poppler=no \
[7148]231    --with-system-gd \
232    --with-system-t1lib \
233    --with-system-libpng \
234    --with-system-zlib \
235    --with-system-freetype2 \
[7769]236    --with-system-pixman \
237    --with-system-cairo \
[7148]238    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
239    --with-pic \
240    \
241    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
[9529]242    --disable-xdvik \
[7148]243    --disable-dvi2tty \
244    --disable-t1utils --disable-psutils --disable-detex \
245    --disable-dvipng --disable-lcdf-typetools \
246"
247
248export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
[7678]249TL_MAKE=%__make ./Build || exit 1
[7148]250
[7678]251
[1533]252%install
[1542]253## prepare %%install session
[1533]254[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
255
[7769]256## copy inst directory to /usr
[7148]257%__mkdir_p %{buildroot}
258%__cp -a inst %{buildroot}%{_prefix} || exit 1
259%ifarch x86_64
[7769]260%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
[5289]261%endif
[5248]262
[9971]263if [ -f %{buildroot}%{_libdir}/kpathsea/c-auto.h ]; then
264   %__mv %{buildroot}%{_libdir}/kpathsea/c-auto.h \
265         %{buildroot}%{_includedir}/kpathsea/c-auto.h || exit 1
266   %__rm -r %{buildroot}%{_libdir}/kpathsea || exit 1
267fi
268
[5207]269## make some fundamental texmf trees
[7769]270%__mkdir_p %{buildroot}%{_tl_texmfvine}
271%__mkdir_p %{buildroot}%{_tl_texmfdist}
272%__mkdir_p %{buildroot}%{_tl_texmflocal}
273%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
274%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
275%__mkdir_p %{buildroot}%{_tl_vartexfonts}
276%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
277%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
[5248]278
[7769]279cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
[7810]280The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
281distribution wide.
282You must not do any changes in this directory.
[7769]283EOF
[6253]284
[7769]285cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
[7810]286The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
[7769]287You should not use this directory to manage any other packages because
[7810]288we Project Vine use this directory to manage non-CTAN packages, some
289enhancement packages and so on.
[7769]290EOF
[1533]291
[7769]292cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
[7810]293The directory %{_tl_texmflocal} is the texmf tree of the system wide.
[7769]294If you are a privileged user of this system,
295you can use this directory to manage your local packages.
296EOF
[1533]297
[7769]298## our texmf-dist/web2c/updmap{,-hdr}.cfg
299%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
300%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
301%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
302
303## our map files for dvipdfmx
304%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
305%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
[7154]306for x in ptex uptex otf otf-up; do
[7769]307    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
[7154]308done
309for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
[7769]310    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
[7154]311done
[1533]312
313## desktop things
314%__mkdir_p %{buildroot}%{_datadir}/applications
[7769]315# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
316%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
[1533]317
318# for created fonts
[7769]319%__mkdir_p %{buildroot}%{_tl_vartexfonts}
[7148]320# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
321# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
[1533]322
323## set executable bit for the library
324%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
325%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
326
[7148]327# configure ConTeXt
[8476]328for x in context luatools texexec texmfstart; do
[7769]329  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
[7148]330done
[9576]331for x in contextjit; do
332  %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
333done
[7148]334
335# touch ghosts
[7769]336touch %{buildroot}%{_tl_texmfvine}/ls-R
337touch %{buildroot}%{_tl_texmfdist}/ls-R
338touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
339touch %{buildroot}%{_tl_texmfsysvar}/ls-R
[7148]340
[7769]341%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
342%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
343%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
344%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
345touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
346touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
347touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
348touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
350touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
351touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
[9529]352#touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
[7769]353touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
354touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
355touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
[7530]356
357
[7154]358## remove unpackaging files
359find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
360find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
[7148]361%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
[7769]362find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
[7148]363find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
[7769]364%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
[7154]365%__rm -f %{buildroot}%{_infodir}/*
[7148]366
[7769]367## use external packages
368%__rm %{buildroot}/usr/bin/latexmk || exit 1
[1533]369
[7769]370
[1533]371### Files list
372find %{buildroot} -type f -or -type l | \
373    %__sed -e "s|%{buildroot}||g" | \
[7148]374    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
[1533]375    %__grep -v "%{_includedir}" | \
376    %__grep -v "%{_libdir}" | \
377    %__grep -v "%{_infodir}" | \
[7154]378    %__sed -e "s|.*ls-R$|%ghost &|" \
[7769]379           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
380           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
[7154]381           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
382           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
383           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
384           -e "s|.*\.cnf$|%config(noreplace) &|" \
[7769]385           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
386           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
[7154]387           -e "s|^.*/updmap/$|%config &|" \
[7769]388           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
389           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
390           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
391           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
392           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
393           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
394           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
395           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
396           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
397           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
[1533]398           -e "s|%{_mandir}/.*|&*|" \
[7148]399        > %{_builddir}/filelist.full
[1533]400
[7769]401find %{buildroot}%{_tl_texmfvine}* -type d | \
[1533]402    %__sed -e "s|^%{buildroot}|%dir |" \
[7148]403           -e "s|$|/|" >> %{_builddir}/filelist.full
[1533]404
405## subpackages
[7769]406%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
[7148]407cat %{_builddir}/filelist.doc \
408    %{_builddir}/filelist.full | \
409    sort | uniq -u > %{_builddir}/filelist.tmp
410%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
[1533]411
412
413%clean
414%__rm -rf %{buildroot}
415
416
[5207]417%pretrans
[9529]418rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
[5207]419[ $? -eq 1 ] && exit 0
420_trans_time=$(date +%Y%m%d)
[7769]421echo "Running some transitional processes on your TeX system ... "
422x=(
423    /usr/share/texmf-local
424    /usr/share/texmf-var
425    /usr/share/texmf-config
426)
427for dir in ${x[@]}; do
[5207]428    _trans_dir=${dir}.${_trans_time}.rpmorig
429    [ -d ${_trans_dir}.old ] && \
430        echo -n "  " && \
431        echo "Found ${_trans_dir}.old: " && \
432        echo -n "    " && \
433        %__rm -rvf ${_trans_dir}.old
434    [ -d ${_trans_dir} ] && \
435        echo -n "  " && \
436        echo "Found ${_trans_dir}: " && \
437        echo -n "    " && \
438        %__mv -v ${_trans_dir} ${_trans_dir}.old
439    [ -d ${dir} ] && \
440        echo -n "  " && \
441        echo "Found ${dir}: " && \
442        echo -n "    " && \
443        %__mv -v ${dir} ${_trans_dir}
444done
445echo "done."
[4152]446
[7769]447%postun
[7148]448if [ "$1" = 0 ]; then
[7769]449    %__rm -rf %{_tl_vartexfonts}
[7148]450fi
451exit 0
[4152]452
[1533]453%post
[7769]454%_tl_touch_run texhash
455%_tl_touch_run updmap
456%_tl_touch_run mtxrun
457%_tl_touch_run fmtutil
[7148]458exit 0
459
460%posttrans
[7769]461%__mkdir_p %{_tl_vartexfonts}
462%__chmod 1777 %{_tl_vartexfonts}
463
[7148]464## create our map files {ptex,uptex,otf,otf-up}-vine.map
[7769]465( %{_tl_exec_upddeffont} ) ||:
[1533]466
[7769]467%{_tl_exec_texhash}
468%{_tl_exec_mtxrun}
469%{_tl_exec_updmap}
470%{_tl_exec_fmtutil}
[5207]471exit 0
[1533]472
473%post -n libkpathsea
474/sbin/ldconfig
[7148]475# for x in kpathsea tds web2c; do
476#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
477# done
[1533]478
[7148]479# %preun -n libkpathsea
[1533]480# if [ "$1" = 0 ]; then
[7148]481#     for x in kpathsea tds web2c; do
482#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
483#     done
[1533]484# fi
485
486%postun -n libkpathsea
487/sbin/ldconfig
488
489%post -n libptexenc
490/sbin/ldconfig
491
492%postun -n libptexenc
493/sbin/ldconfig
494
495%triggerin -- ghostscript
[7769]496%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
[1533]497if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
[7769]498    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
[1533]499elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
[7769]500    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
[1533]501fi
[7769]502%_tl_touch_run texhash
[7154]503exit 0
[1533]504
505
[7148]506%files -f %{_builddir}/filelist.full
[1533]507%defattr(-,root,root)
[9529]508%{_libdir}/libtexlua52.so.*
509%{_libdir}/libtexluajit.so.*
[7769]510%dir %{_tl_aliasttfdir}
511%attr(1777,root,root) %dir %{_tl_vartexfonts}
[7148]512# %config %{_sysconfdir}/cron.daily/texlive.cron
[1533]513
[9951]514%exclude %{_includedir}/texlua52/*.h
515%exclude %{_includedir}/texlua52/*.hpp
516%exclude %{_includedir}/texluajit/*.h
517%exclude %{_includedir}/texluajit/*.hpp
518%exclude %{_libdir}/libtexlua52.so
519%exclude %{_libdir}/libtexluajit.so
520%exclude %{_libdir}/pkgconfig/texlua52.pc
521%exclude %{_libdir}/pkgconfig/texluajit.pc
522
[7148]523%files doc -f %{_builddir}/filelist.doc
[1533]524%defattr(-,root,root)
525
526%files -n libkpathsea
527%defattr(-,root,root)
528%{_libdir}/libkpathsea.so.*
529# %{_infodir}/kpathsea.info*
530
531%files -n libkpathsea-devel
532%defattr(-,root,root)
533%{_libdir}/libkpathsea.so
534%dir %{_includedir}/kpathsea
[9529]535%{_includedir}/kpathsea/*.h
536%{_libdir}/pkgconfig/kpathsea.pc
[1533]537
538%files -n libptexenc
539%defattr(-,root,root)
540%{_libdir}/libptexenc.so.*
541
542%files -n libptexenc-devel
543%defattr(-,root,root)
544%{_libdir}/libptexenc.so
545%dir %{_includedir}/ptexenc
[9529]546%{_includedir}/ptexenc/*.h
547%{_libdir}/pkgconfig/ptexenc.pc
[1533]548
[9529]549%files -n libsynctex
550%defattr(-,root,root)
551%{_libdir}/libsynctex.so.*
[1533]552
[9529]553%files -n libsynctex-devel
554%defattr(-,root,root)
555%{_libdir}/libsynctex.so
556%dir %{_includedir}/synctex
557%{_includedir}/synctex/*.h
558%{_libdir}/pkgconfig/synctex.pc
559
560
[1533]561%changelog
[10269]562* Tue May 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-2
563- texlive-20160510-source (TeX Live 2016/pretest)
564
565* Thu Apr 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-1
566- texlive-20160427-source (TeX Live 2016/pretest)
567
[9971]568* Thu Jan 21 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-5
569- fixed some development files
570
[9955]571* Tue Jan 12 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-4
572- reverted to texlive-20150521-source (TeX Live 2015)
573
[9951]574* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
575- texlive-source-20160110 (TeX Live 2016/dev)
576
[9576]577* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
578- texlive-source-20150523 (TeX Live 2015/pretest)
579- configure ConTeXt/LuaTeX+LuaJIT
580
[9529]581* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
582- texlive-source-20150426 (TeX Live 2015/pretest)
[8771]583
[9529]584* Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
585- texlive-source-20141230 (TeX Live 2015/dev)
586
[8744]587* Thu Jul  3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
588- texlive-source-20140525 + tlptexlive 20140507
589- dropped texlive-20140524-vine.patch: built with libpng >= 1.6
590
[8476]591* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
592- upgrade to TeX Live 2014
593  - texlive-source-20140524 + tlptexlive 20140507
594
[8416]595* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
596- rebuild with poppler-0.24.5
597
[8174]598* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
599- rebuilt
600
[7951]601* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
602- texlive-source-20131101 2014/dev + tlptexlive 20130815
603- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
604
[7881]605* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
606- updated texlive-20131002-texmfcnf-vine.patch:
607  texmf.cnf (shell_escape_commands): added some programs
608
[7855]609* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
610- texlive-source-20131002 2014/dev + tlptexlive 20130815
611- defined %%global __find_requires find-requires-texlive.sh
612  - dropped unused dependencies of Requires
613
[7810]614* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
615- texlive-source-20130919 2014/dev + tlptexlive 20130815
616- correct some scripts of README.vine for each texmf trees
617
[7769]618* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
619- upgrade to TeX Live 2013
620  - texlive-source-20130823 2014/dev + tlptexlive 20130815
621- dropped Requires: jvf
622
[7678]623* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
624- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
625- fixed duplicated lw35 for updmap.pl
626- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
627
[7530]628* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
629- touch the map files generated by updmap-sys
630
[7154]631* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
632- fixed Source7: updmap.cfg.texlive-20120701
633  (upto /etc/texmf/web2c/updmap.cfg)
634- fixex %%triggerin -- ghostscript
635  - replaced %%exec_texhash with %%touch_run texhash
636
[7148]637* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
638- TeX Live 2012 + tlptexlive 20121107
639
[7042]640* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
641- drop BR: poppler-devel temporaly
642  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
643
[6253]644* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
645- build with poppler-0.18.4
646- remove tlmgr
647
[5502]648* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
649- updated to tl11supp-120120
650- run %%{exec_fmtutil} at %%post when upgrading
651
[5289]652* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
653- updated to tl11supp-111214
654
[5248]655* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
656- added BuildRequires: texlive-common
657  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
658  - check japanese.ldf
659- updated tl11supp-111120-vine.patch
660  - added the following options to $$TL_CONFIGURE_ARGS:
661    --disable-detex
662    --disable-dvipng
663    --disable-lcdf-typetools
664- remove some files of asymptote
665- remove a man file of latexmk
666- remove man files of lcdf-typetools
667- remove man files of dvipng
668- remove a man file of detex
669
[5214]670* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
671- added find-provides-texlive.sh and set it to %%__find_provides
672  - use to find library sonames for libkpathsea and libptexenc
673- added cmex.enc (%%{SOURCE110})
674  - do not install cmex.enc in our TDS, yet
675- removed some unused directories in texmf/fonts/map
676- removed man files of lcdf-typetools
677- moved texdoc{,tk} and its related files to texlive-doc
678
[5207]679* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
680- TeX Live 2011 + tl11supp-111120
681
682* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
683- make the directory VARTEXFONTS (%%posttrans)
684  - dropped %%triggerpostun -- texlive < 2009-17vl6
685
[4346]686* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
687- fixed ptexlive-20100711-dvipdfmx-vine.patch
688  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
689
[4152]690* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
691- added %%pre to avoid conflictions of texmf-{config,var}
692
[3944]693* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
694- dropped Requires: texlive-common
695- added perl-Tk-TableMatrix
696  - supported texdoctk
697- removed broken symbolic links in /usr/bin
698  - for each these symbolic links, the package of its real file/path
699    should be its owner.
700
[3910]701* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
702- added %%triggerpostun -- texlive < 2009-17vl6
703  - make the directory VARTEXFONTS
704
[3840]705* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
706- fixed %%dir VARTEXFONTS around in %%files
707- dropped BuildRequires: t1utils
708
[3703]709* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
710- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
711  - changed VARTEXFONTS to /var/lib/texmf/fonts
712
[3688]713* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
714- fixed updmap.cfg
715
[3150]716* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
717- dropped Requires: texlive-macros
718
[2503]719* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
720- updated ptexlive-20100711-pxdvik-vine.patch
721  and added texlive-20091107-xdvik-vine.patch
722  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
723
[2456]724* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
[2421]725- supported Vine Linux 5
[2456]726  - for vl5, changed a requirement of Japanese VF package
727    - added Requires: texlive-jvf = 2009 (vl5)
[2503]728- dropped dependencies of Provides:/Obsoletes: tags
729  - merged these dependencies in texlive-common-vl.spec
[2421]730
[2257]731* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
732- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
733
[1973]734* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
735- applied some security patches from Debian
736  - texlive-2009-CVE-2010-0827.patch
737  - texlive-2009-CVE-2010-1440.patch
738- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
739- applied texlive-2009-luatexdir-libpoppler-0.12.patch
740  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
741- fixed some dependencies
742
[1542]743* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
744- added BuildArch: noarch in %%package doc
745- removed some comment-out sentences
746
[1533]747* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
748- separeted texmf-dist to texlive-common package
749
750* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
751- unpacked texlive-20091107-source.tar.xz
752- babel is available now
753- applied eptex-100420 and some patches:
754  - eptex-100420-vine.patch
755  - eptex-100420-patch1.diff
756
757* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
758- updated ptexlive-20100711
759
760* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
761- customized updmap.cfg to correspond installed fonts
762
763* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
764- fixed insttexfont()
765
766* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
767- added jvf of MORISAWA basic 5 fonts
768- added cm-super, mathdesign in fntlst
769
770* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
771- define insttexfont() in %%install
772  - copy almost compatible tetex-3.0
773
774* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
775- ptexlive-20090322 + TeXLive 2009
776- added BuildRequires: openssl-devel
777
778* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
779- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.