source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 1543

Revision 1543, 11.9 KB checked in by munepi, 14 years ago (diff)

updated texlive-macros

Line 
1## -*- coding: utf-8-unix -*-
2%define tex_destdir     %{_datadir}
3%define texmf           %{_prefix}/share/texmf
4%define texlive_src     %{tex_destdir}/texlive-sources
5%define build_tex_destdir       %{buildroot}%{tex_destdir}
6%define build_texmf     %{buildroot}%{texmf}
7%define build_texlive_src       %{buildroot}%{tex_destdir}-sources
8
9%define knjfonts        kanjifonts-3.1
10%define jsclasses_ver   100314
11%define jlisting_ver    0.2
12%define bkmk2uni        convert-bkmk2uni
13
14%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
15%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
16
17%define list_macros \
18        jsclasses-%{jsclasses_ver} \
19        jlisting-%{jlisting_ver}
20
21
22Summary:        A collection of useful macro packages for texlive package
23Summary(ja):    texlive パッケージで使うマクロパッケージ集
24Name:           texlive-macros
25Version:        2009
26Release:        2%{?_dist_release}
27License:        distributable
28Group:          Applications/Publishing
29
30## Vine Linux
31Source0:        %{knjfonts}.tar.bz2
32Source1:        sample.tex
33
34## jsclasses
35Source10:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
36Source11:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
37
38## jlisting
39Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
40
41
42Requires:       perl
43Requires:       texlive = %{version}
44BuildRequires:  texlive = %{version}
45BuildRequires:  jvf nkf unzip
46
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48BuildArch: noarch
49
50Obsoletes:      tetex-macros <= 3.0
51Obsoletes:      pLaTeX2e_Macros
52
53Distribution:   Vine Linux
54Vendor:         Project Vine
55Packager:       munepi
56
57
58%description
59A collection of useful macro packages for texlive package, including
60        kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
61%{list_macros}
62
63# This package contained a perl script
64#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
65
66%description -l ja
67texlive パッケージで使うマクロパッケージ集です。
68以下のマクロを収録しています。
69        kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
70%{list_macros}
71
72# このパッケージには prosper, powerdot 用に
73# PDF ブックマークの文字化けを修正するための perl スクリプト
74#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
75# を同梱しています.
76
77%prep
78[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
79%setup -q -c -n %{name}-%{version}
80
81%__mkdir_p jsclasses
82(cd jsclasses
83    %__mkdir_p jsclasses
84    %__unzip -a -qq %{SOURCE10}
85    %__cp -p %{SOURCE11} ./jsclasses/README.html
86)
87
88# get rid of unwanted files
89find . -type d -name CVS | xargs -r %__rm -frv
90find . -type f -name .cvsignore | xargs -r %__rm -fv
91
92(cd jsclasses
93    %__mkdir_p tmp
94    for i in *.*; do nkf $i > tmp/$i; done
95    %__mv tmp/* .
96    %__rmdir tmp
97)
98
99
100%build
101
102(cd jsclasses
103    for i in jsclasses okumacro okuverb morisawa; do
104        platex ${i}.dtx && platex ${i}.dtx || exit 1
105    done
106    for i in jsclasses okumacro okuverb; do
107        dvipdfmx $i || exit 1
108    done
109    %__cp *.dvi *.pdf jsclasses
110)
111
112%install
113%__rm -rf %{buildroot}
114
115# InstallClass(){
116# target=$1; shift
117# (cd $target
118# bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
119# rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
120
121# if [ -f src/$target.ins ]; then
122#     cp src/* .
123# fi
124# latex $target.ins
125# mkdir -p %{build_texmf}/tex/latex/$target
126# cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
127# if [ ! -z "$*" ]; then
128#     cp -d $* %{build_texmf}/tex/latex/$target || :
129# fi
130# if [ -n "`ls *.bst`" ]; then
131#     mkdir -p %{build_texmf}/bibtex/bst/$target
132#     cp *.bst %{build_texmf}/bibtex/bst/$target || :
133# fi
134# )
135# }
136
137%__mkdir_p %{build_texmf}/packages/
138#InstallClass geometry
139
140## install kanjifonts
141%__mkdir_p %{build_texmf}/ptex/platex/generic
142%__mv %{knjfonts}/*.sty %{build_texmf}/ptex/platex/generic
143%__mv %{knjfonts}/*.def %{build_texmf}/ptex/platex/generic
144
145# nkf --utf8 %{SOURCE25} | \
146#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
147#     %{buildroot}%{_bindir}/%{bkmk2uni}
148# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
149
150## install jsclasses
151(cd jsclasses
152    %__mkdir_p %{build_texmf}/ptex/platex/js
153    %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/ptex/platex/js/
154)
155
156## install jlisting
157%__mkdir_p %{build_texmf}/ptex/platex/jlisting
158%__install -m 644 %{SOURCE20} %{build_texmf}/ptex/platex/jlisting/
159bunzip2 %{build_texmf}/ptex/platex/jlisting/jlisting.sty.bz2
160
161
162# ## install MORISAWA basic 5 fonts
163# #mkdir -p %{build_texmf}/dvips/config/extmap
164# %__mkdir_p %{build_texmf}/fonts/tfm/ptex
165# %__mkdir_p %{build_texmf}/fonts/tfm/dvips
166# %__mkdir_p %{build_texmf}/fonts/vf/ptex
167# #mv morisawa/morisawa.map %{build_texmf}/dvips/config/extmap/
168# %__mv morisawa/tfm/ptex/* %{build_texmf}/fonts/tfm/ptex/
169# %__mv morisawa/tfm/dvips/* %{build_texmf}/fonts/tfm/dvips/
170# %__mv morisawa/vf/* %{build_texmf}/fonts/vf/ptex/
171
172
173%post
174%{exec_texhash}
175# %{exec_updmap}
176exit 0
177
178
179%postun
180if [ "$1" = 0 ]; then
181    %{exec_texhash}
182    # %{exec_updmap}
183fi
184exit 0
185
186
187%clean
188%__rm -rf $RPM_BUILD_ROOT
189
190
191%files
192%defattr(-,root,root)
193%doc %{knjfonts}
194%doc jsclasses/jsclasses
195#%{_bindir}/%{bkmk2uni}
196%{texmf}/ptex/platex/generic/kanjifonts.sty
197%{texmf}/ptex/platex/generic/*.def
198%{texmf}/ptex/platex/js
199%{texmf}/ptex/platex/jlisting
200
201
202%changelog
203* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
204- removed %%{exec_updmap} in %%post and %%postun
205
206* Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
207- ported from tetex-macros-3.0-7
208- TeX Live 2009
209
210* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
211- added BuildRequires: unzip
212- updated jsclasses to 090826
213- updated pict2e to 0.2x
214
215* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
216- dropped epsbox.sty, eclepsf.sty
217  (bacause there style files for platex209 are obsolete)
218
219* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
220- added jlisting v0.2
221- defined list_macros
222  - used %%{list_macros} in %%description and %%description -l ja
223
224* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
225- dropped convert-euc.txt
226
227* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
228- updated prosper
229  - added some contrib themes from CTAN
230  - added prosper.cls v1.6 from CVS HEAD
231  - added a perl script: convert-euc.txt
232- added powerdot v1.3
233  - added xkeyval v2.5d
234- added beamer v3.07
235  - added pgf v2.00
236- added pict2e v0.2w
237
238* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
239- updated jsclasses to 20090222
240- updated jsclasses/index.html to 2009-02-22
241- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
242
243* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
244- applied new versioning policy, spec in utf-8
245
246* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
247- update jsclasses/index.html to 2006-11-06.
248
249* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
250- update jsclasses/index.html to 2006-02-12.
251
252* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
253- update jsclasses/index.html to 2005-10-26.
254
255* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
256- update jsclasses/index.html to 2005-4-30.
257- added breqn
258
259* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
260- update jsclasses/index.html to 2004-12-29.
261
262* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
263- add missing files in kanjifonts-3.0
264
265* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
266- update to kanjifonts.sty-3.0.
267
268* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
269- update jsclasses/index.html to 2004-11-03.
270
271* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
272- update jsclasses/index.html to 2004-09-27.
273
274* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
275- update jsclasses/index.html to 2004-02-25.
276- added eclepsf.sty.
277- removed epsf.sty (symlink to epsbox.sty).
278- removed geometry, which is in tetex-2.0.
279
280* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
281- update jsclasses/index.html to 2003-04-18.
282- added morisawa.dvi.
283
284* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
285- update jsclasses/index.html to 2003-03-06
286
287* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
288- remove natbib, which is in tetex-2.0
289- let version number same as tetex
290- added Requires: tetex
291
292* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
293- update jsclasses/index.html to 2003-01-16
294
295* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
296- update jsclasses to 2003-01-05
297- update index.html to 2003-01-12
298
299* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
300- update jsclasses and index.html to 2002-11-27
301
302* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
303- update jsclasses and index.html to 2002-11-01
304
305* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
306- oops, packager was incorrect
307
308* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
309- update jsclasses to 2002-06-29
310- update index.html to 2002-07-03
311
312* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
313- update jsclasses to 2002-04-21
314- update index.html to 2002-04-09
315
316* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
317- added MORISAWA basic 5 fonts
318
319* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
320- update to kanjifonts-1.1
321
322* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
323- update jsclasses and index.html to 2002-02-07
324
325* Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
326- update jsclasses and index.html to 2002-01-27
327- fix typo in changelog
328
329* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
330- update jsclasses and index.html to 2002-01-18
331
332* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
333- update index.html (jsclasses)
334
335* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
336- update jsclasses to 2001-11-29
337
338* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
339- fixed spec file for Prosper and jsclasses
340- use RPM macro in %files
341- added BuildPrereq: jvf
342
343* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
344- move revtex4 to texmacro-aps package
345
346* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
347- added prosper jsclasses
348
349* Mon Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
350- added revtex4 natbib
351
352* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
353- remove prereq tetex to avoid dependency-loop
354
355* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
356- tetex-macros-1.0-0vl1
357
358* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
359- 2.0-2
360- added kanjifonts-1.0 and removed jisfontsmetric
361
362* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
363- 2.0-1
364- install ldf in babel
365
366* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
367- added jisfontmetric.tex
368
369* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
370- change group.
371
372* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
373- added babel
374
375* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
376- added hoekwater
377
378* Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
379- added psfrag
380
381* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
382- added psnfss
383- Change directory tree according to the suggestion by Dr.Okumura.
384- remove many files from packages directory except documentations
385- disable mktexlsr and erase ls-R
386
387* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
388- added url.sty
389
390* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
391- pLaTeX2e_Macros-1-2
392- added fancyhdr.sty, boxedminipage.sty
393- added graphics.cfg, color.cfg (use dvips as default)
394- symlink from epsbox to epsf
395
396* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
397- pLaTeX2e_Macros-1-1
398  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
399- added def files of graphics
400- added tools and hyperref
401- check the existence of mktexlsr
402
403* Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
404- buildarch: noarch
405- added requires
406
407* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
408- tiny bug fix and add %defattr
409
410* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
411- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.