source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 1533

Revision 1533, 11.8 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2%define tex_destdir     %{_datadir}
3%define texmf           %{_prefix}/share/texmf
4%define texlive_src     %{tex_destdir}/texlive-sources
5%define build_tex_destdir       %{buildroot}%{tex_destdir}
6%define build_texmf     %{buildroot}%{texmf}
7%define build_texlive_src       %{buildroot}%{tex_destdir}-sources
8
9%define knjfonts        kanjifonts-3.1
10%define jsclasses_ver   100314
11%define jlisting_ver    0.2
12%define bkmk2uni        convert-bkmk2uni
13
14%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
15%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
16
17%define list_macros \
18        jsclasses-%{jsclasses_ver} \
19        jlisting-%{jlisting_ver}
20
21
22Summary:        A collection of useful macro packages for texlive package
23Summary(ja):    texlive パッケージで使うマクロパッケージ集
24Name:           texlive-macros
25Version:        2009
26Release:        1%{?_dist_release}
27License:        distributable
28Group:          Applications/Publishing
29
30## Vine Linux
31Source0:        %{knjfonts}.tar.bz2
32Source1:        sample.tex
33
34## jsclasses
35Source10:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
36Source11:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
37
38## jlisting
39Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
40
41
42Requires:       perl
43Requires:       texlive = %{version}
44BuildRequires:  texlive = %{version}
45BuildRequires:  jvf nkf unzip
46
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48BuildArch: noarch
49
50Obsoletes:      tetex-macros <= 3.0
51Obsoletes:      pLaTeX2e_Macros
52
53Distribution:   Vine Linux
54Vendor:         Project Vine
55Packager:       munepi
56
57
58%description
59A collection of useful macro packages for texlive package, including
60        kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
61%{list_macros}
62
63# This package contained a perl script
64#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
65
66%description -l ja
67texlive パッケージで使うマクロパッケージ集です。
68以下のマクロを収録しています。
69        kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
70%{list_macros}
71
72# このパッケージには prosper, powerdot 用に
73# PDF ブックマークの文字化けを修正するための perl スクリプト
74#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
75# を同梱しています.
76
77%prep
78[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
79%setup -q -c -n %{name}-%{version}
80
81%__mkdir_p jsclasses
82(cd jsclasses
83    %__mkdir_p jsclasses
84    %__unzip -a -qq %{SOURCE10}
85    %__cp -p %{SOURCE11} ./jsclasses/README.html
86)
87
88# get rid of unwanted files
89find . -type d -name CVS | xargs -r %__rm -frv
90find . -type f -name .cvsignore | xargs -r %__rm -fv
91
92(cd jsclasses
93    %__mkdir_p tmp
94    for i in *.*; do nkf $i > tmp/$i; done
95    %__mv tmp/* .
96    %__rmdir tmp
97)
98
99
100%build
101
102(cd jsclasses
103    platex jsclasses.dtx
104    platex jsclasses.dtx
105    platex okumacro.dtx
106    platex okumacro.dtx
107    platex okuverb.dtx
108    platex okuverb.dtx
109    platex morisawa.dtx
110    platex morisawa.dtx
111    for i in jsclasses okumacro okuverb; do dvipdfmx $i; done
112    %__cp *.dvi *.pdf jsclasses
113)
114
115%install
116%__rm -rf %{buildroot}
117
118# InstallClass(){
119# target=$1; shift
120# (cd $target
121# bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
122# rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
123
124# if [ -f src/$target.ins ]; then
125#     cp src/* .
126# fi
127# latex $target.ins
128# mkdir -p %{build_texmf}/tex/latex/$target
129# cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
130# if [ ! -z "$*" ]; then
131#     cp -d $* %{build_texmf}/tex/latex/$target || :
132# fi
133# if [ -n "`ls *.bst`" ]; then
134#     mkdir -p %{build_texmf}/bibtex/bst/$target
135#     cp *.bst %{build_texmf}/bibtex/bst/$target || :
136# fi
137# )
138# }
139
140%__mkdir_p %{build_texmf}/packages/
141#InstallClass geometry
142
143## install kanjifonts
144%__mkdir_p %{build_texmf}/ptex/platex/generic
145%__mv %{knjfonts}/*.sty %{build_texmf}/ptex/platex/generic
146%__mv %{knjfonts}/*.def %{build_texmf}/ptex/platex/generic
147
148# nkf --utf8 %{SOURCE25} | \
149#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
150#     %{buildroot}%{_bindir}/%{bkmk2uni}
151# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
152
153## install jsclasses
154(cd jsclasses
155    %__mkdir_p %{build_texmf}/ptex/platex/js
156    %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/ptex/platex/js/
157)
158
159## install jlisting
160%__mkdir_p %{build_texmf}/ptex/platex/jlisting
161%__install -m 644 %{SOURCE20} %{build_texmf}/ptex/platex/jlisting/
162bunzip2 %{build_texmf}/ptex/platex/jlisting/jlisting.sty.bz2
163
164
165# ## install MORISAWA basic 5 fonts
166# #mkdir -p %{build_texmf}/dvips/config/extmap
167# %__mkdir_p %{build_texmf}/fonts/tfm/ptex
168# %__mkdir_p %{build_texmf}/fonts/tfm/dvips
169# %__mkdir_p %{build_texmf}/fonts/vf/ptex
170# #mv morisawa/morisawa.map %{build_texmf}/dvips/config/extmap/
171# %__mv morisawa/tfm/ptex/* %{build_texmf}/fonts/tfm/ptex/
172# %__mv morisawa/tfm/dvips/* %{build_texmf}/fonts/tfm/dvips/
173# %__mv morisawa/vf/* %{build_texmf}/fonts/vf/ptex/
174
175
176%post
177%{exec_texhash}
178%{exec_updmap}
179
180
181%postun
182if [ "$1" = 0 ]; then
183    %{exec_texhash}
184    %{exec_updmap}
185fi
186
187
188%clean
189%__rm -rf $RPM_BUILD_ROOT
190
191
192%files
193%defattr(-,root,root)
194%doc %{knjfonts}
195%doc jsclasses/jsclasses
196#%{_bindir}/%{bkmk2uni}
197%{texmf}/ptex/platex/generic/kanjifonts.sty
198%{texmf}/ptex/platex/generic/*.def
199%{texmf}/ptex/platex/js
200%{texmf}/ptex/platex/jlisting
201
202
203%changelog
204* Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
205- setup for texlive 2009
206
207* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
208- added BuildRequires: unzip
209- updated jsclasses to 090826
210- updated pict2e to 0.2x
211
212* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
213- dropped epsbox.sty, eclepsf.sty
214  (bacause there style files for platex209 are obsolete)
215
216* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
217- added jlisting v0.2
218- defined list_macros
219  - used %%{list_macros} in %%description and %%description -l ja
220
221* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
222- dropped convert-euc.txt
223
224* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
225- updated prosper
226  - added some contrib themes from CTAN
227  - added prosper.cls v1.6 from CVS HEAD
228  - added a perl script: convert-euc.txt
229- added powerdot v1.3
230  - added xkeyval v2.5d
231- added beamer v3.07
232  - added pgf v2.00
233- added pict2e v0.2w
234
235* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
236- updated jsclasses to 20090222
237- updated jsclasses/index.html to 2009-02-22
238- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
239
240* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
241- applied new versioning policy, spec in utf-8
242
243* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
244- update jsclasses/index.html to 2006-11-06.
245
246* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
247- update jsclasses/index.html to 2006-02-12.
248
249* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
250- update jsclasses/index.html to 2005-10-26.
251
252* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
253- update jsclasses/index.html to 2005-4-30.
254- added breqn
255
256* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
257- update jsclasses/index.html to 2004-12-29.
258
259* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
260- add missing files in kanjifonts-3.0
261
262* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
263- update to kanjifonts.sty-3.0.
264
265* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
266- update jsclasses/index.html to 2004-11-03.
267
268* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
269- update jsclasses/index.html to 2004-09-27.
270
271* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
272- update jsclasses/index.html to 2004-02-25.
273- added eclepsf.sty.
274- removed epsf.sty (symlink to epsbox.sty).
275- removed geometry, which is in tetex-2.0.
276
277* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
278- update jsclasses/index.html to 2003-04-18.
279- added morisawa.dvi.
280
281* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
282- update jsclasses/index.html to 2003-03-06
283
284* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
285- remove natbib, which is in tetex-2.0
286- let version number same as tetex
287- added Requires: tetex
288
289* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
290- update jsclasses/index.html to 2003-01-16
291
292* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
293- update jsclasses to 2003-01-05
294- update index.html to 2003-01-12
295
296* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
297- update jsclasses and index.html to 2002-11-27
298
299* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
300- update jsclasses and index.html to 2002-11-01
301
302* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
303- oops, packager was incorrect
304
305* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
306- update jsclasses to 2002-06-29
307- update index.html to 2002-07-03
308
309* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
310- update jsclasses to 2002-04-21
311- update index.html to 2002-04-09
312
313* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
314- added MORISAWA basic 5 fonts
315
316* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
317- update to kanjifonts-1.1
318
319* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
320- update jsclasses and index.html to 2002-02-07
321
322* Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
323- update jsclasses and index.html to 2002-01-27
324- fix typo in changelog
325
326* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
327- update jsclasses and index.html to 2002-01-18
328
329* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
330- update index.html (jsclasses)
331
332* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
333- update jsclasses to 2001-11-29
334
335* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
336- fixed spec file for Prosper and jsclasses
337- use RPM macro in %files
338- added BuildPrereq: jvf
339
340* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
341- move revtex4 to texmacro-aps package
342
343* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
344- added prosper jsclasses
345
346* Mon Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
347- added revtex4 natbib
348
349* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
350- remove prereq tetex to avoid dependency-loop
351
352* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
353- tetex-macros-1.0-0vl1
354
355* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
356- 2.0-2
357- added kanjifonts-1.0 and removed jisfontsmetric
358
359* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
360- 2.0-1
361- install ldf in babel
362
363* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
364- added jisfontmetric.tex
365
366* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
367- change group.
368
369* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
370- added babel
371
372* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
373- added hoekwater
374
375* Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
376- added psfrag
377
378* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
379- added psnfss
380- Change directory tree according to the suggestion by Dr.Okumura.
381- remove many files from packages directory except documentations
382- disable mktexlsr and erase ls-R
383
384* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
385- added url.sty
386
387* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
388- pLaTeX2e_Macros-1-2
389- added fancyhdr.sty, boxedminipage.sty
390- added graphics.cfg, color.cfg (use dvips as default)
391- symlink from epsbox to epsf
392
393* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
394- pLaTeX2e_Macros-1-1
395  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
396- added def files of graphics
397- added tools and hyperref
398- check the existence of mktexlsr
399
400* Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
401- buildarch: noarch
402- added requires
403
404* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
405- tiny bug fix and add %defattr
406
407* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
408- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.