source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 11118

Revision 11118, 10.5 KB checked in by munepi, 7 years ago (diff)

TeX Live 2017

Line 
1## -*- coding: utf-8-unix -*-
2%define jlisting_ver    0.2
3%define bkmk2uni        convert-bkmk2uni
4
5%define list_macros \
6        jlisting-%{jlisting_ver}
7
8Summary:        A collection of useful macro packages for TeX Live
9Summary(ja):    TeX Live の便利なマクロパッケージ集
10Name:           texlive-macros
11Version:        2017
12Release:        1%{?_dist_release}
13License:        distributable
14Group:          Applications/Publishing
15
16## Vine Linux
17
18## jlisting
19Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
20
21## misc
22Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
23Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
24
25#Requires:      perl
26Requires:       texlive-common = %{version}
27BuildRequires:  texlive-vtlpkg = %{version}
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildArch: noarch
31
32Obsoletes:      tetex-macros
33Obsoletes:      pLaTeX2e_Macros
34
35Distribution:   Vine Linux
36Vendor:         Project Vine
37Packager:       munepi
38
39
40%description
41A collection of useful macro packages for texlive package, including
42  jlisting
43  jtygm.sty
44  cmex.enc
45
46# This package contained a perl script
47#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
48
49%description -l ja
50TeX Live の便利なマクロパッケージ集です。
51以下のマクロを収録しています。
52  jlisting
53  jtygm.sty
54  cmex.enc
55
56# このパッケージには prosper, powerdot 用に
57# PDF ブックマークの文字化けを修正するための perl スクリプト
58#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
59# を同梱しています.
60
61%prep
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
63
64%build
65
66%install
67%__rm -rf %{buildroot}
68
69# nkf --utf8 %{SOURCE25} | \
70#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
71#     %{buildroot}%{_bindir}/%{bkmk2uni}
72# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
73
74## install jlisting
75%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
76%__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
77bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
78
79## install jtygm.sty
80%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
81%__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
82## install cmex.enc
83%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
84%__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
85
86%post
87%_tl_touch_run texhash
88exit 0
89
90%postun
91if [ "$1" = 0 ]; then
92   %_tl_touch_run texhash
93fi
94exit 0
95
96%posttrans
97%{_tl_exec_texhash}
98exit 0
99
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106#%{_bindir}/%{bkmk2uni}
107%{_tl_texmfvine}/tex/latex/jlisting
108%{_tl_texmfvine}/tex/platex/base/jtygm.sty
109%{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
110
111%changelog
112* Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 2017-1
113- TeX Live 2017
114
115* Thu Apr 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-1
116- TeX Live 2016
117
118* Tue Apr 28 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
119- TeX Live 2015
120
121* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
122- TeX Live 2014
123
124* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
125- rebuilt
126
127* Sun Nov  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
128- s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
129
130* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
131- TeX Live 2013
132- dropped jsclasses: texlive-collection-langcjk provides jsclasses
133- dropped kanjifonts-3.1: obsolete
134
135* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
136- TeX Live 2012
137
138* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
139- move jlisting package to %%{texmf}/tex/latex/jlisting
140
141* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
142- updated jsclasses to 110510
143  - mistook to change %%jsclasses_ver at 2011-1
144
145* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
146- TeX Live 2011
147- updated jsclasses to 110510
148
149* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
150- dropped BuildRequires: jvf
151- for vl5, added Conflicts: tetex-macros
152
153* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
154- removed %%{exec_updmap} in %%post and %%postun
155
156* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
157- ported from tetex-macros-3.0-7
158- TeX Live 2009
159
160* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
161- added BuildRequires: unzip
162- updated jsclasses to 090826
163- updated pict2e to 0.2x
164
165* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
166- dropped epsbox.sty, eclepsf.sty
167  (bacause there style files for platex209 are obsolete)
168
169* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
170- added jlisting v0.2
171- defined list_macros
172  - used %%{list_macros} in %%description and %%description -l ja
173
174* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
175- dropped convert-euc.txt
176
177* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
178- updated prosper
179  - added some contrib themes from CTAN
180  - added prosper.cls v1.6 from CVS HEAD
181  - added a perl script: convert-euc.txt
182- added powerdot v1.3
183  - added xkeyval v2.5d
184- added beamer v3.07
185  - added pgf v2.00
186- added pict2e v0.2w
187
188* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
189- updated jsclasses to 20090222
190- updated jsclasses/index.html to 2009-02-22
191- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
192
193* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
194- applied new versioning policy, spec in utf-8
195
196* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
197- update jsclasses/index.html to 2006-11-06.
198
199* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
200- update jsclasses/index.html to 2006-02-12.
201
202* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
203- update jsclasses/index.html to 2005-10-26.
204
205* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
206- update jsclasses/index.html to 2005-4-30.
207- added breqn
208
209* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
210- update jsclasses/index.html to 2004-12-29.
211
212* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
213- add missing files in kanjifonts-3.0
214
215* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
216- update to kanjifonts.sty-3.0.
217
218* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
219- update jsclasses/index.html to 2004-11-03.
220
221* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
222- update jsclasses/index.html to 2004-09-27.
223
224* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
225- update jsclasses/index.html to 2004-02-25.
226- added eclepsf.sty.
227- removed epsf.sty (symlink to epsbox.sty).
228- removed geometry, which is in tetex-2.0.
229
230* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
231- update jsclasses/index.html to 2003-04-18.
232- added morisawa.dvi.
233
234* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
235- update jsclasses/index.html to 2003-03-06
236
237* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
238- remove natbib, which is in tetex-2.0
239- let version number same as tetex
240- added Requires: tetex
241
242* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
243- update jsclasses/index.html to 2003-01-16
244
245* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
246- update jsclasses to 2003-01-05
247- update index.html to 2003-01-12
248
249* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
250- update jsclasses and index.html to 2002-11-27
251
252* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
253- update jsclasses and index.html to 2002-11-01
254
255* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
256- oops, packager was incorrect
257
258* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
259- update jsclasses to 2002-06-29
260- update index.html to 2002-07-03
261
262* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
263- update jsclasses to 2002-04-21
264- update index.html to 2002-04-09
265
266* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
267- added MORISAWA basic 5 fonts
268
269* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
270- update to kanjifonts-1.1
271
272* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
273- update jsclasses and index.html to 2002-02-07
274
275* Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
276- update jsclasses and index.html to 2002-01-27
277- fix typo in changelog
278
279* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
280- update jsclasses and index.html to 2002-01-18
281
282* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
283- update index.html (jsclasses)
284
285* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
286- update jsclasses to 2001-11-29
287
288* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
289- fixed spec file for Prosper and jsclasses
290- use RPM macro in %files
291- added BuildPrereq: jvf
292
293* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
294- move revtex4 to texmacro-aps package
295
296* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
297- added prosper jsclasses
298
299* Thu Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
300- added revtex4 natbib
301
302* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
303- remove prereq tetex to avoid dependency-loop
304
305* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
306- tetex-macros-1.0-0vl1
307
308* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
309- 2.0-2
310- added kanjifonts-1.0 and removed jisfontsmetric
311
312* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
313- 2.0-1
314- install ldf in babel
315
316* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
317- added jisfontmetric.tex
318
319* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
320- change group.
321
322* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
323- added babel
324
325* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
326- added hoekwater
327
328* Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
329- added psfrag
330
331* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
332- added psnfss
333- Change directory tree according to the suggestion by Dr.Okumura.
334- remove many files from packages directory except documentations
335- disable mktexlsr and erase ls-R
336
337* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
338- added url.sty
339
340* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
341- pLaTeX2e_Macros-1-2
342- added fancyhdr.sty, boxedminipage.sty
343- added graphics.cfg, color.cfg (use dvips as default)
344- symlink from epsbox to epsf
345
346* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
347- pLaTeX2e_Macros-1-1
348  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
349- added def files of graphics
350- added tools and hyperref
351- check the existence of mktexlsr
352
353* Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
354- buildarch: noarch
355- added requires
356
357* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
358- tiny bug fix and add %defattr
359
360* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
361- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.