source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 10269

Revision 10269, 10.5 KB checked in by munepi, 8 years ago (diff)

upgrade to TeX Live 2016

Line 
1## -*- coding: utf-8-unix -*-
2%define jlisting_ver    0.2
3%define bkmk2uni        convert-bkmk2uni
4
5%define list_macros \
6        jlisting-%{jlisting_ver}
7
8Summary:        A collection of useful macro packages for TeX Live
9Summary(ja):    TeX Live の便利なマクロパッケージ集
10Name:           texlive-macros
11Version:        2016
12Release:        1%{?_dist_release}
13License:        distributable
14Group:          Applications/Publishing
15
16## Vine Linux
17
18## jlisting
19Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
20
21## misc
22Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
23Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
24
25#Requires:      perl
26Requires:       texlive-common = %{version}
27BuildRequires:  texlive-vtlpkg = %{version}
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildArch: noarch
31
32Obsoletes:      tetex-macros
33Obsoletes:      pLaTeX2e_Macros
34
35Distribution:   Vine Linux
36Vendor:         Project Vine
37Packager:       munepi
38
39
40%description
41A collection of useful macro packages for texlive package, including
42  jlisting
43  jtygm.sty
44  cmex.enc
45
46# This package contained a perl script
47#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
48
49%description -l ja
50TeX Live の便利なマクロパッケージ集です。
51以下のマクロを収録しています。
52  jlisting
53  jtygm.sty
54  cmex.enc
55
56# このパッケージには prosper, powerdot 用に
57# PDF ブックマークの文字化けを修正するための perl スクリプト
58#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
59# を同梱しています.
60
61%prep
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
63
64%build
65
66%install
67%__rm -rf %{buildroot}
68
69# nkf --utf8 %{SOURCE25} | \
70#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
71#     %{buildroot}%{_bindir}/%{bkmk2uni}
72# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
73
74## install jlisting
75%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
76%__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
77bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
78
79## install jtygm.sty
80%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
81%__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
82## install cmex.enc
83%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
84%__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
85
86%post
87%_tl_touch_run texhash
88exit 0
89
90%postun
91if [ "$1" = 0 ]; then
92   %_tl_touch_run texhash
93fi
94exit 0
95
96%posttrans
97%{_tl_exec_texhash}
98exit 0
99
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106#%{_bindir}/%{bkmk2uni}
107%{_tl_texmfvine}/tex/latex/jlisting
108%{_tl_texmfvine}/tex/platex/base/jtygm.sty
109%{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
110
111%changelog
112* Thu Apr 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-1
113- TeX Live 2016
114
115* Tue Apr 28 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
116- TeX Live 2015
117
118* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
119- TeX Live 2014
120
121* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
122- rebuilt
123
124* Sun Nov  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
125- s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
126
127* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
128- TeX Live 2013
129- dropped jsclasses: texlive-collection-langcjk provides jsclasses
130- dropped kanjifonts-3.1: obsolete
131
132* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
133- TeX Live 2012
134
135* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
136- move jlisting package to %%{texmf}/tex/latex/jlisting
137
138* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
139- updated jsclasses to 110510
140  - mistook to change %%jsclasses_ver at 2011-1
141
142* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
143- TeX Live 2011
144- updated jsclasses to 110510
145
146* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
147- dropped BuildRequires: jvf
148- for vl5, added Conflicts: tetex-macros
149
150* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
151- removed %%{exec_updmap} in %%post and %%postun
152
153* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
154- ported from tetex-macros-3.0-7
155- TeX Live 2009
156
157* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
158- added BuildRequires: unzip
159- updated jsclasses to 090826
160- updated pict2e to 0.2x
161
162* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
163- dropped epsbox.sty, eclepsf.sty
164  (bacause there style files for platex209 are obsolete)
165
166* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
167- added jlisting v0.2
168- defined list_macros
169  - used %%{list_macros} in %%description and %%description -l ja
170
171* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
172- dropped convert-euc.txt
173
174* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
175- updated prosper
176  - added some contrib themes from CTAN
177  - added prosper.cls v1.6 from CVS HEAD
178  - added a perl script: convert-euc.txt
179- added powerdot v1.3
180  - added xkeyval v2.5d
181- added beamer v3.07
182  - added pgf v2.00
183- added pict2e v0.2w
184
185* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
186- updated jsclasses to 20090222
187- updated jsclasses/index.html to 2009-02-22
188- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
189
190* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
191- applied new versioning policy, spec in utf-8
192
193* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
194- update jsclasses/index.html to 2006-11-06.
195
196* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
197- update jsclasses/index.html to 2006-02-12.
198
199* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
200- update jsclasses/index.html to 2005-10-26.
201
202* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
203- update jsclasses/index.html to 2005-4-30.
204- added breqn
205
206* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
207- update jsclasses/index.html to 2004-12-29.
208
209* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
210- add missing files in kanjifonts-3.0
211
212* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
213- update to kanjifonts.sty-3.0.
214
215* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
216- update jsclasses/index.html to 2004-11-03.
217
218* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
219- update jsclasses/index.html to 2004-09-27.
220
221* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
222- update jsclasses/index.html to 2004-02-25.
223- added eclepsf.sty.
224- removed epsf.sty (symlink to epsbox.sty).
225- removed geometry, which is in tetex-2.0.
226
227* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
228- update jsclasses/index.html to 2003-04-18.
229- added morisawa.dvi.
230
231* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
232- update jsclasses/index.html to 2003-03-06
233
234* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
235- remove natbib, which is in tetex-2.0
236- let version number same as tetex
237- added Requires: tetex
238
239* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
240- update jsclasses/index.html to 2003-01-16
241
242* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
243- update jsclasses to 2003-01-05
244- update index.html to 2003-01-12
245
246* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
247- update jsclasses and index.html to 2002-11-27
248
249* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
250- update jsclasses and index.html to 2002-11-01
251
252* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
253- oops, packager was incorrect
254
255* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
256- update jsclasses to 2002-06-29
257- update index.html to 2002-07-03
258
259* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
260- update jsclasses to 2002-04-21
261- update index.html to 2002-04-09
262
263* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
264- added MORISAWA basic 5 fonts
265
266* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
267- update to kanjifonts-1.1
268
269* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
270- update jsclasses and index.html to 2002-02-07
271
272* Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
273- update jsclasses and index.html to 2002-01-27
274- fix typo in changelog
275
276* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
277- update jsclasses and index.html to 2002-01-18
278
279* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
280- update index.html (jsclasses)
281
282* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
283- update jsclasses to 2001-11-29
284
285* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
286- fixed spec file for Prosper and jsclasses
287- use RPM macro in %files
288- added BuildPrereq: jvf
289
290* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
291- move revtex4 to texmacro-aps package
292
293* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
294- added prosper jsclasses
295
296* Thu Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
297- added revtex4 natbib
298
299* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
300- remove prereq tetex to avoid dependency-loop
301
302* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
303- tetex-macros-1.0-0vl1
304
305* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
306- 2.0-2
307- added kanjifonts-1.0 and removed jisfontsmetric
308
309* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
310- 2.0-1
311- install ldf in babel
312
313* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
314- added jisfontmetric.tex
315
316* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
317- change group.
318
319* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
320- added babel
321
322* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
323- added hoekwater
324
325* Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
326- added psfrag
327
328* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
329- added psnfss
330- Change directory tree according to the suggestion by Dr.Okumura.
331- remove many files from packages directory except documentations
332- disable mktexlsr and erase ls-R
333
334* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
335- added url.sty
336
337* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
338- pLaTeX2e_Macros-1-2
339- added fancyhdr.sty, boxedminipage.sty
340- added graphics.cfg, color.cfg (use dvips as default)
341- symlink from epsbox to epsf
342
343* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
344- pLaTeX2e_Macros-1-1
345  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
346- added def files of graphics
347- added tools and hyperref
348- check the existence of mktexlsr
349
350* Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
351- buildarch: noarch
352- added requires
353
354* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
355- tiny bug fix and add %defattr
356
357* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
358- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.