source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 9529

Revision 9529, 10.4 KB checked in by munepi, 9 years ago (diff)

TeX Live 2015/pretest

Line 
1## -*- coding: utf-8-unix -*-
2%define jlisting_ver    0.2
3%define bkmk2uni        convert-bkmk2uni
4
5%define list_macros \
6        jlisting-%{jlisting_ver}
7
8Summary:        A collection of useful macro packages for TeX Live
9Summary(ja):    TeX Live の便利なマクロパッケージ集
10Name:           texlive-macros
11Version:        2015
12Release:        1%{?_dist_release}
13License:        distributable
14Group:          Applications/Publishing
15
16## Vine Linux
17
18## jlisting
19Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
20
21## misc
22Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
23Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
24
25#Requires:      perl
26Requires:       texlive-common = %{version}
27BuildRequires:  texlive-vtlpkg = %{version}
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildArch: noarch
31
32Obsoletes:      tetex-macros
33Obsoletes:      pLaTeX2e_Macros
34
35Distribution:   Vine Linux
36Vendor:         Project Vine
37Packager:       munepi
38
39
40%description
41A collection of useful macro packages for texlive package, including
42  jlisting
43  jtygm.sty
44  cmex.enc
45
46# This package contained a perl script
47#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
48
49%description -l ja
50TeX Live の便利なマクロパッケージ集です。
51以下のマクロを収録しています。
52  jlisting
53  jtygm.sty
54  cmex.enc
55
56# このパッケージには prosper, powerdot 用に
57# PDF ブックマークの文字化けを修正するための perl スクリプト
58#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
59# を同梱しています.
60
61%prep
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
63
64%build
65
66%install
67%__rm -rf %{buildroot}
68
69# nkf --utf8 %{SOURCE25} | \
70#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
71#     %{buildroot}%{_bindir}/%{bkmk2uni}
72# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
73
74## install jlisting
75%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
76%__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
77bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
78
79## install jtygm.sty
80%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
81%__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
82## install cmex.enc
83%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
84%__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
85
86%post
87%_tl_touch_run texhash
88exit 0
89
90%postun
91if [ "$1" = 0 ]; then
92   %_tl_touch_run texhash
93fi
94exit 0
95
96%posttrans
97%{_tl_exec_texhash}
98exit 0
99
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106#%{_bindir}/%{bkmk2uni}
107%{_tl_texmfvine}/tex/latex/jlisting
108%{_tl_texmfvine}/tex/platex/base/jtygm.sty
109%{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
110
111%changelog
112* Tue Apr 28 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
113- TeX Live 2015
114
115* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
116- TeX Live 2014
117
118* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
119- rebuilt
120
121* Sun Nov  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
122- s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
123
124* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
125- TeX Live 2013
126- dropped jsclasses: texlive-collection-langcjk provides jsclasses
127- dropped kanjifonts-3.1: obsolete
128
129* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
130- TeX Live 2012
131
132* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
133- move jlisting package to %%{texmf}/tex/latex/jlisting
134
135* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
136- updated jsclasses to 110510
137  - mistook to change %%jsclasses_ver at 2011-1
138
139* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
140- TeX Live 2011
141- updated jsclasses to 110510
142
143* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
144- dropped BuildRequires: jvf
145- for vl5, added Conflicts: tetex-macros
146
147* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
148- removed %%{exec_updmap} in %%post and %%postun
149
150* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
151- ported from tetex-macros-3.0-7
152- TeX Live 2009
153
154* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
155- added BuildRequires: unzip
156- updated jsclasses to 090826
157- updated pict2e to 0.2x
158
159* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
160- dropped epsbox.sty, eclepsf.sty
161  (bacause there style files for platex209 are obsolete)
162
163* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
164- added jlisting v0.2
165- defined list_macros
166  - used %%{list_macros} in %%description and %%description -l ja
167
168* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
169- dropped convert-euc.txt
170
171* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
172- updated prosper
173  - added some contrib themes from CTAN
174  - added prosper.cls v1.6 from CVS HEAD
175  - added a perl script: convert-euc.txt
176- added powerdot v1.3
177  - added xkeyval v2.5d
178- added beamer v3.07
179  - added pgf v2.00
180- added pict2e v0.2w
181
182* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
183- updated jsclasses to 20090222
184- updated jsclasses/index.html to 2009-02-22
185- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
186
187* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
188- applied new versioning policy, spec in utf-8
189
190* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
191- update jsclasses/index.html to 2006-11-06.
192
193* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
194- update jsclasses/index.html to 2006-02-12.
195
196* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
197- update jsclasses/index.html to 2005-10-26.
198
199* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
200- update jsclasses/index.html to 2005-4-30.
201- added breqn
202
203* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
204- update jsclasses/index.html to 2004-12-29.
205
206* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
207- add missing files in kanjifonts-3.0
208
209* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
210- update to kanjifonts.sty-3.0.
211
212* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
213- update jsclasses/index.html to 2004-11-03.
214
215* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
216- update jsclasses/index.html to 2004-09-27.
217
218* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
219- update jsclasses/index.html to 2004-02-25.
220- added eclepsf.sty.
221- removed epsf.sty (symlink to epsbox.sty).
222- removed geometry, which is in tetex-2.0.
223
224* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
225- update jsclasses/index.html to 2003-04-18.
226- added morisawa.dvi.
227
228* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
229- update jsclasses/index.html to 2003-03-06
230
231* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
232- remove natbib, which is in tetex-2.0
233- let version number same as tetex
234- added Requires: tetex
235
236* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
237- update jsclasses/index.html to 2003-01-16
238
239* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
240- update jsclasses to 2003-01-05
241- update index.html to 2003-01-12
242
243* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
244- update jsclasses and index.html to 2002-11-27
245
246* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
247- update jsclasses and index.html to 2002-11-01
248
249* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
250- oops, packager was incorrect
251
252* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
253- update jsclasses to 2002-06-29
254- update index.html to 2002-07-03
255
256* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
257- update jsclasses to 2002-04-21
258- update index.html to 2002-04-09
259
260* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
261- added MORISAWA basic 5 fonts
262
263* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
264- update to kanjifonts-1.1
265
266* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
267- update jsclasses and index.html to 2002-02-07
268
269* Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
270- update jsclasses and index.html to 2002-01-27
271- fix typo in changelog
272
273* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
274- update jsclasses and index.html to 2002-01-18
275
276* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
277- update index.html (jsclasses)
278
279* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
280- update jsclasses to 2001-11-29
281
282* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
283- fixed spec file for Prosper and jsclasses
284- use RPM macro in %files
285- added BuildPrereq: jvf
286
287* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
288- move revtex4 to texmacro-aps package
289
290* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
291- added prosper jsclasses
292
293* Thu Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
294- added revtex4 natbib
295
296* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
297- remove prereq tetex to avoid dependency-loop
298
299* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
300- tetex-macros-1.0-0vl1
301
302* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
303- 2.0-2
304- added kanjifonts-1.0 and removed jisfontsmetric
305
306* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
307- 2.0-1
308- install ldf in babel
309
310* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
311- added jisfontmetric.tex
312
313* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
314- change group.
315
316* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
317- added babel
318
319* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
320- added hoekwater
321
322* Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
323- added psfrag
324
325* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
326- added psnfss
327- Change directory tree according to the suggestion by Dr.Okumura.
328- remove many files from packages directory except documentations
329- disable mktexlsr and erase ls-R
330
331* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
332- added url.sty
333
334* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
335- pLaTeX2e_Macros-1-2
336- added fancyhdr.sty, boxedminipage.sty
337- added graphics.cfg, color.cfg (use dvips as default)
338- symlink from epsbox to epsf
339
340* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
341- pLaTeX2e_Macros-1-1
342  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
343- added def files of graphics
344- added tools and hyperref
345- check the existence of mktexlsr
346
347* Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
348- buildarch: noarch
349- added requires
350
351* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
352- tiny bug fix and add %defattr
353
354* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
355- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.